source: projects/specs/trunk/g/gnome-sharp2/gnome-sharp2-vl.spec @ 9472

Revision 9472, 6.2 KB checked in by inagaki, 9 years ago (diff)

2015-03-28 Ryoichi INAGAKI <ryo1@…>

  • dbus-sharp, dbus-sharp-glib, gecko-sharp2, gio-sharp, gnome-desktop-sharp2, kimono, libgpod, mono-debugger, mono-zeroconf, webkit-sharp: rebuilt
  • gnome-sharp2, libgdiplus, mono, mono-addins, mono-basic, nant: updated


Line 
1%define mono_dir %{_prefix}/lib/mono
2%define _name gnome-sharp
3
4Summary: .Net Language Bindings for Gnome
5Summary(ja): Mono 用 GNOME バインディング
6Name: gnome-sharp2
7Version: 2.24.2
8Release: 1%{?_dist_release}
9License: LGPLv2+
10Group: System Environment/Libraries
11URL: http://gtk-sharp.sf.net
12
13Source: %{_name}-%{version}.tar.bz2
14Patch2: gnome-sharp-find_gtkhtml_ver.patch
15Patch3: gnome-sharp-2.24.1-TestXfer.patch
16
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18BuildRequires: gtk-sharp2-devel
19BuildRequires: gtk-sharp2-gapi
20BuildRequires: librsvg2-devel
21BuildRequires: mono-devel monodoc
22#BuildRequires: vte-devel gtkhtml3-devel
23BuildRequires: libSM-devel
24BuildRequires: libgnomeui-devel
25Provides:      gnome-sharp2-devel = %{version}-%{release}
26%define env_options export MONO_SHARED_DIR=/tmp
27
28Vendor: Project Vine
29Distribution: Vine Linux
30
31%description
32This package contains Mono bindings for Gnome.
33
34
35%package -n gnome-sharp2-complete
36Summary: GTK+ and GNOME bindings for Mono (virtual package)
37Group: System Environment/Libraries
38Requires: art-sharp2 = %{version}-%{release}
39Requires: gconf-sharp2 = %{version}-%{release}
40Requires: gnome-sharp2 = %{version}-%{release}
41Requires: gnome-vfs-sharp2 = %{version}-%{release}
42
43%description -n gnome-sharp2-complete
44Gtk# is a library that allows you to build fully native graphical GNOME
45applications using Mono. Gtk# is a binding to GTK+, the cross platform
46user interface toolkit used in GNOME. It includes bindings for Gtk,
47Atk, Pango, Gdk, libgnome, libgnomeui and libgnomecanvas.  (Virtual
48package which depends on all gtk-sharp2 subpackages)
49
50
51%package -n gnome-vfs-sharp2
52Summary: Mono bindings for gnomevfs
53Summary(ja): gnomevfs の Mono バインディング
54Group: System Environment/Libraries
55Requires: gnome-vfs2
56Provides: gnome-vfs-sharp2-devel = %{version}-%{release}
57
58%description -n gnome-vfs-sharp2
59This package contains Mono bindings gnomevfs.
60
61%package -n art-sharp2
62Summary: Mono bindings for libart
63Summary(ja): libart の Mono バインディング
64Group: System Environment/Libraries
65Requires: libart_lgpl
66Provides: art-sharp2-devel = %{version}-%{release}
67
68%description -n art-sharp2
69This package contains Mono bindings for libart.
70
71%package -n gconf-sharp2
72Summary: Mono bindings for gconf
73Summary(ja): GConf の Mono バインディング
74Group: System Environment/Libraries
75Provides: gconf-sharp2-devel = %{version}-%{release}
76
77%description -n gconf-sharp2
78This package contains Mono bindings for gconf and gconf peditors.
79
80
81%prep
82%setup -q -n %{_name}-%{version}
83%patch3 -p1 -b .TestXfer
84autoreconf -f -i
85
86
87%build
88export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
89export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
90%configure \
91        --libexecdir=%{_prefix}/lib \
92        --enable-debug
93make
94
95%install
96export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
97%makeinstall
98
99## remove unuse files
100rm -f $RPM_BUILD_ROOT%{_libdir}/*.*a
101rm -f $RPM_BUILD_ROOT%{_prefix}/lib/debug/%{_libdir}/libgnomesharpglue-2.so.debug
102rm -f $RPM_BUILD_ROOT%{_prefix}/src/debug/gnome-sharp-*/gnome/glue/*.c
103
104%clean
105rm -rf $RPM_BUILD_ROOT
106
107
108%files -n gnome-sharp2-complete
109%defattr(-, root, root)
110## This is the 'base' package so we put the common dirs of all in this package
111# Otherwise, this package doesn't get created!
112%dir %{mono_dir}/gtk-sharp-2.0
113%dir %{_prefix}/lib/gtk-sharp-2.0
114
115%files -n gnome-sharp2
116%defattr(-,root,root)
117%doc COPYING ChangeLog
118%{_libdir}/libgnomesharpglue-2.so
119%{_libdir}/pkgconfig/gnome-sharp-2.0.pc
120%{mono_dir}/gac/*gnome-sharp
121%{mono_dir}/gtk-sharp-2.0/*gnome-sharp.dll
122%{_datadir}/gapi-2.0/gnome-api.xml
123
124%files -n gnome-vfs-sharp2
125%defattr(-,root,root)
126%{_libdir}/pkgconfig/gnome-vfs-sharp-2.0.pc
127%{mono_dir}/gac/*gnome-vfs-sharp
128%{mono_dir}/gtk-sharp-2.0/*gnome-vfs-sharp.dll
129%{_datadir}/gapi-2.0/gnome-vfs-api.xml
130
131%files -n art-sharp2
132%defattr(-,root,root)
133%{_libdir}/pkgconfig/art-sharp-2.0.pc
134%{mono_dir}/gac/*art-sharp
135%{mono_dir}/gtk-sharp-2.0/*art-sharp.dll
136%{_datadir}/gapi-2.0/art-api.xml
137
138%files -n gconf-sharp2
139%defattr(-, root, root)
140%{_bindir}/gconfsharp2-schemagen
141%{_libdir}/pkgconfig/gconf-sharp-2.0.pc
142%{_prefix}/lib/gtk-sharp-2.0/gconfsharp-schemagen.exe
143%{mono_dir}/gac/*gconf-sharp
144%{mono_dir}/gtk-sharp-2.0/*gconf-sharp.dll
145# Other distros place these in gnome-sharp2??
146%{_libdir}/pkgconfig/gconf-sharp-peditors-2.0.pc
147%{mono_dir}/gac/*gconf-sharp-peditors
148%{mono_dir}/gtk-sharp-2.0/*gconf-sharp-peditors.dll
149
150
151%changelog
152* Sat Mar 28 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.24.2-1
153- updated to 2.24.2
154- built with mono 3.12.1
155- remove BR: vte-devel, gtkhtml3-devel
156
157* Sun Dec 29 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.1-8
158- rebuild with VineSeed environment
159- add BuildRequires: libgnomeui-devel
160
161* Tue Dec 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.1-7
162- add BuildRequires: libSM-devel
163
164* Sat Oct 09 2010 Shu KONNO <owa@bg.wakwak.com> 2.24.1-6
165- added gnome-sharp-2.24.1-TestXfer.patch
166- rebuilt with mono-2.8
167
168* Wed Sep 22 2010 IWAI, Masaharu <iwai@alib.jp> 2.24.1-5
169- build with rpm-4.8.1-1 for pkg-config file
170
171* Mon Jul 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.24.1-4
172- rebuilt with new environment
173
174* Wed Jul 08 2009 Shu KONNO <owa@bg.wakwak.com> 2.24.1-3
175- rebuilt with latest rpm to update mono-dependencies
176- dropt BR: libgnomedb-devel
177
178* Sun Apr 19 2009 Shu KONNO <owa@bg.wakwak.com> 2.24.1-2
179- changed Group to Development/Libraries
180
181* Sun Apr 05 2009 Shu KONNO <owa@bg.wakwak.com> 2.24.1-1
182- updated to 2.24.1
183
184* Wed Sep 17 2008 Shu KONNO <owa@bg.wakwak.com> 2.20.0-1
185- initial build for VineSeed
186        - updated gnome-sharp2 to 2.20.0
187        - added japanese summary
188        - applied vine versioning policy
189        - spec in utf-8
190
191* Thu Apr 24 2008 wberrier@suse.de
192- Update to 2.12.1
193  * Bugfix in GLib ref management for Gnome.Program crash in
194  gnome-sharp
195* Thu Apr  3 2008 wberrier@novell.com
196- Can now build 2.16 and 2.20 from the same spec
197- Update to 2.20.0
198  - Updated bindings to coincide with gtk# 2.12
199  - Removed bindings: gtkhtml#, rsvg#, and vte#
200* Wed Mar 26 2008 wberrier@novell.com
201- Update to 2.16.1
202  - Allow storage of empty lists in gconf
203  - Bug fixes:
204  - [GConf] Impossible to set empty list values (bnc#325516)
205  - Comment #8 of bnc#327058 (incorrect p/invoke bindings)
206* Tue Jul  3 2007 wberrier@suse.de
207- Initial package of gnome-sharp2 2.16.0
208  - (Split from gtk-sharp 2.8.3)
Note: See TracBrowser for help on using the repository browser.