source: projects/specs/trunk/g/gnome-sharp2/gnome-sharp2-vl.spec @ 521

Revision 521, 5.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define mono_dir %(/usr/bin/monodir)
2%define _name gnome-sharp
3Summary: .Net Language Bindings for Gnome
4Summary(ja): Mono 用 GNOME バインディング
5Name: gnome-sharp2
6Version: 2.24.1
7Release: 3%{?_dist_release}
8License: GNU General ublic License (GPL), GNU Library General Public License v. 2.0 and 2.1 (LGPL)
9Group: Development/Libraries
10URL: http://gtk-sharp.sf.net
11Source: %{_name}-%{version}.tar.bz2
12Patch2: gnome-sharp-find_gtkhtml_ver.patch
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14BuildRequires: gtk-sharp2 gtk-sharp2-gapi
15#BuildRequires: libgnomedb-devel librsvg2-devel
16BuildRequires: librsvg2-devel
17BuildRequires: mono-devel monodoc
18BuildRequires: vte-devel gtkhtml3-devel
19%define env_options export MONO_SHARED_DIR=/tmp
20
21%description
22This package contains Mono bindings for Gnome.
23
24
25%package -n gnome-sharp2-complete
26Group: Development/Libraries
27Summary: GTK+ and GNOME bindings for Mono (virtual package)
28Requires: art-sharp2 = %{version}-%{release}
29Requires: gconf-sharp2 = %{version}-%{release}
30Requires: gnome-sharp2 = %{version}-%{release}
31Requires: gnome-vfs-sharp2 = %{version}-%{release}
32#Requires: glib-sharp2 >= 2.10.3
33
34%description -n gnome-sharp2-complete
35Gtk# is a library that allows you to build fully native graphical GNOME
36applications using Mono. Gtk# is a binding to GTK+, the cross platform
37user interface toolkit used in GNOME. It includes bindings for Gtk,
38Atk, Pango, Gdk, libgnome, libgnomeui and libgnomecanvas.  (Virtual
39package which depends on all gtk-sharp2 subpackages)
40
41
42%package -n gnome-vfs-sharp2
43Summary: Mono bindings for gnomevfs
44Group: Development/Libraries
45Requires: gnome-vfs2
46
47%description -n gnome-vfs-sharp2
48This package contains Mono bindings gnomevfs.
49
50
51%package -n art-sharp2
52Summary: Mono bindings for libart
53Group: Development/Libraries
54Requires: libart_lgpl
55
56%description -n art-sharp2
57This package contains Mono bindings for libart.
58
59
60%package -n gconf-sharp2
61Summary: Mono bindings for gconf
62Group: Development/Libraries
63
64%description -n gconf-sharp2
65This package contains Mono bindings for gconf and gconf peditors.
66
67
68%prep
69%setup -q -n %{_name}-%{version}
70#%patch2 -p1
71#autoreconf -f -i
72
73
74%build
75export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
76export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
77%configure \
78        --libexecdir=%{_prefix}/lib \
79        --enable-debug
80make
81
82%install
83export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
84%makeinstall
85
86## remove unuse files
87rm -f $RPM_BUILD_ROOT%{_libdir}/*.*a
88rm -f $RPM_BUILD_ROOT%{_prefix}/lib/debug/%{_libdir}/libgnomesharpglue-2.so.debug
89rm -f $RPM_BUILD_ROOT%{_prefix}/src/debug/gnome-sharp-*/gnome/glue/*.c
90
91%clean
92rm -rf $RPM_BUILD_ROOT
93
94
95%files -n gnome-sharp2-complete
96%defattr(-, root, root)
97## This is the 'base' package so we put the common dirs of all in this package
98# Otherwise, this package doesn't get created!
99%dir %{mono_dir}/gtk-sharp-2.0
100%dir %{_prefix}/lib/gtk-sharp-2.0
101
102%files -n gnome-sharp2
103%defattr(-,root,root)
104%{_libdir}/libgnomesharpglue-2.so
105%{_libdir}/pkgconfig/gnome-sharp-2.0.pc
106%{mono_dir}/gac/*gnome-sharp
107%{mono_dir}/gtk-sharp-2.0/*gnome-sharp.dll
108%{_datadir}/gapi-2.0/gnome-api.xml
109
110
111%files -n gnome-vfs-sharp2
112%defattr(-,root,root)
113%{_libdir}/pkgconfig/gnome-vfs-sharp-2.0.pc
114%{mono_dir}/gac/*gnome-vfs-sharp
115%{mono_dir}/gtk-sharp-2.0/*gnome-vfs-sharp.dll
116%{_datadir}/gapi-2.0/gnome-vfs-api.xml
117
118
119%files -n art-sharp2
120%defattr(-,root,root)
121%{_libdir}/pkgconfig/art-sharp-2.0.pc
122%{mono_dir}/gac/*art-sharp
123%{mono_dir}/gtk-sharp-2.0/*art-sharp.dll
124%{_datadir}/gapi-2.0/art-api.xml
125
126
127%files -n gconf-sharp2
128%defattr(-, root, root)
129%{_bindir}/gconfsharp2-schemagen
130%{_libdir}/pkgconfig/gconf-sharp-2.0.pc
131%{_prefix}/lib/gtk-sharp-2.0/gconfsharp-schemagen.exe
132%{mono_dir}/gac/*gconf-sharp
133%{mono_dir}/gtk-sharp-2.0/*gconf-sharp.dll
134# Other distros place these in gnome-sharp2??
135%{_libdir}/pkgconfig/gconf-sharp-peditors-2.0.pc
136%{mono_dir}/gac/*gconf-sharp-peditors
137%{mono_dir}/gtk-sharp-2.0/*gconf-sharp-peditors.dll
138
139
140%changelog
141* Wed Jul 08 2009 Shu KONNO <owa@bg.wakwak.com> 2.24.1-3
142- rebuilt with latest rpm to update mono-dependencies
143- dropt BR: libgnomedb-devel
144
145* Sun Apr 19 2009 Shu KONNO <owa@bg.wakwak.com> 2.24.1-2
146- changed Group to Development/Libraries
147
148* Sun Apr 05 2009 Shu KONNO <owa@bg.wakwak.com> 2.24.1-1
149- updated to 2.24.1
150
151* Wed Sep 17 2008 Shu KONNO <owa@bg.wakwak.com> 2.20.0-1
152- initial build for VineSeed
153        - updated gnome-sharp2 to 2.20.0
154        - added japanese summary
155        - applied vine versioning policy
156        - spec in utf-8
157
158* Thu Apr 24 2008 wberrier@suse.de
159- Update to 2.12.1
160  * Bugfix in GLib ref management for Gnome.Program crash in
161  gnome-sharp
162* Thu Apr  3 2008 wberrier@novell.com
163- Can now build 2.16 and 2.20 from the same spec
164- Update to 2.20.0
165  - Updated bindings to coincide with gtk# 2.12
166  - Removed bindings: gtkhtml#, rsvg#, and vte#
167* Wed Mar 26 2008 wberrier@novell.com
168- Update to 2.16.1
169  - Allow storage of empty lists in gconf
170  - Bug fixes:
171  - [GConf] Impossible to set empty list values (bnc#325516)
172  - Comment #8 of bnc#327058 (incorrect p/invoke bindings)
173* Tue Jul  3 2007 wberrier@suse.de
174- Initial package of gnome-sharp2 2.16.0
175  - (Split from gtk-sharp 2.8.3)
Note: See TracBrowser for help on using the repository browser.