source: projects/specs/trunk/g/gnome-sharp2/gnome-sharp2-vl.spec @ 1449

Revision 1449, 5.1 KB checked in by owa, 14 years ago (diff)

rebuilt

Line 
1%define mono_dir %(/usr/bin/monodir)
2%define _name gnome-sharp
3Summary: .Net Language Bindings for Gnome
4Summary(ja): Mono 用 GNOME バインディング
5Name: gnome-sharp2
6Version: 2.24.1
7Release: 4%{?_dist_release}
8License: GNU General ublic License (GPL), GNU Library General Public License v. 2.0 and 2.1 (LGPL)
9Group: Development/Libraries
10URL: http://gtk-sharp.sf.net
11Source: %{_name}-%{version}.tar.bz2
12Patch2: gnome-sharp-find_gtkhtml_ver.patch
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14BuildRequires: gtk-sharp2 gtk-sharp2-gapi
15BuildRequires: librsvg2-devel
16BuildRequires: mono-devel monodoc
17BuildRequires: vte-devel gtkhtml3-devel
18%define env_options export MONO_SHARED_DIR=/tmp
19
20%description
21This package contains Mono bindings for Gnome.
22
23
24%package -n gnome-sharp2-complete
25Group: Development/Libraries
26Summary: GTK+ and GNOME bindings for Mono (virtual package)
27Requires: art-sharp2 = %{version}-%{release}
28Requires: gconf-sharp2 = %{version}-%{release}
29Requires: gnome-sharp2 = %{version}-%{release}
30Requires: gnome-vfs-sharp2 = %{version}-%{release}
31#Requires: glib-sharp2 >= 2.10.3
32
33%description -n gnome-sharp2-complete
34Gtk# is a library that allows you to build fully native graphical GNOME
35applications using Mono. Gtk# is a binding to GTK+, the cross platform
36user interface toolkit used in GNOME. It includes bindings for Gtk,
37Atk, Pango, Gdk, libgnome, libgnomeui and libgnomecanvas.  (Virtual
38package which depends on all gtk-sharp2 subpackages)
39
40
41%package -n gnome-vfs-sharp2
42Summary: Mono bindings for gnomevfs
43Group: Development/Libraries
44Requires: gnome-vfs2
45
46%description -n gnome-vfs-sharp2
47This package contains Mono bindings gnomevfs.
48
49
50%package -n art-sharp2
51Summary: Mono bindings for libart
52Group: Development/Libraries
53Requires: libart_lgpl
54
55%description -n art-sharp2
56This package contains Mono bindings for libart.
57
58
59%package -n gconf-sharp2
60Summary: Mono bindings for gconf
61Group: Development/Libraries
62
63%description -n gconf-sharp2
64This package contains Mono bindings for gconf and gconf peditors.
65
66
67%prep
68%setup -q -n %{_name}-%{version}
69#%patch2 -p1
70#autoreconf -f -i
71
72
73%build
74export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
75export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
76%configure \
77        --libexecdir=%{_prefix}/lib \
78        --enable-debug
79make
80
81%install
82export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
83%makeinstall
84
85## remove unuse files
86rm -f $RPM_BUILD_ROOT%{_libdir}/*.*a
87rm -f $RPM_BUILD_ROOT%{_prefix}/lib/debug/%{_libdir}/libgnomesharpglue-2.so.debug
88rm -f $RPM_BUILD_ROOT%{_prefix}/src/debug/gnome-sharp-*/gnome/glue/*.c
89
90%clean
91rm -rf $RPM_BUILD_ROOT
92
93
94%files -n gnome-sharp2-complete
95%defattr(-, root, root)
96## This is the 'base' package so we put the common dirs of all in this package
97# Otherwise, this package doesn't get created!
98%dir %{mono_dir}/gtk-sharp-2.0
99%dir %{_prefix}/lib/gtk-sharp-2.0
100
101%files -n gnome-sharp2
102%defattr(-,root,root)
103%{_libdir}/libgnomesharpglue-2.so
104%{_libdir}/pkgconfig/gnome-sharp-2.0.pc
105%{mono_dir}/gac/*gnome-sharp
106%{mono_dir}/gtk-sharp-2.0/*gnome-sharp.dll
107%{_datadir}/gapi-2.0/gnome-api.xml
108
109
110%files -n gnome-vfs-sharp2
111%defattr(-,root,root)
112%{_libdir}/pkgconfig/gnome-vfs-sharp-2.0.pc
113%{mono_dir}/gac/*gnome-vfs-sharp
114%{mono_dir}/gtk-sharp-2.0/*gnome-vfs-sharp.dll
115%{_datadir}/gapi-2.0/gnome-vfs-api.xml
116
117
118%files -n art-sharp2
119%defattr(-,root,root)
120%{_libdir}/pkgconfig/art-sharp-2.0.pc
121%{mono_dir}/gac/*art-sharp
122%{mono_dir}/gtk-sharp-2.0/*art-sharp.dll
123%{_datadir}/gapi-2.0/art-api.xml
124
125
126%files -n gconf-sharp2
127%defattr(-, root, root)
128%{_bindir}/gconfsharp2-schemagen
129%{_libdir}/pkgconfig/gconf-sharp-2.0.pc
130%{_prefix}/lib/gtk-sharp-2.0/gconfsharp-schemagen.exe
131%{mono_dir}/gac/*gconf-sharp
132%{mono_dir}/gtk-sharp-2.0/*gconf-sharp.dll
133# Other distros place these in gnome-sharp2??
134%{_libdir}/pkgconfig/gconf-sharp-peditors-2.0.pc
135%{mono_dir}/gac/*gconf-sharp-peditors
136%{mono_dir}/gtk-sharp-2.0/*gconf-sharp-peditors.dll
137
138
139%changelog
140* Mon Jul 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.24.1-4
141- rebuilt with new environment
142
143* Wed Jul 08 2009 Shu KONNO <owa@bg.wakwak.com> 2.24.1-3
144- rebuilt with latest rpm to update mono-dependencies
145- dropt BR: libgnomedb-devel
146
147* Sun Apr 19 2009 Shu KONNO <owa@bg.wakwak.com> 2.24.1-2
148- changed Group to Development/Libraries
149
150* Sun Apr 05 2009 Shu KONNO <owa@bg.wakwak.com> 2.24.1-1
151- updated to 2.24.1
152
153* Wed Sep 17 2008 Shu KONNO <owa@bg.wakwak.com> 2.20.0-1
154- initial build for VineSeed
155        - updated gnome-sharp2 to 2.20.0
156        - added japanese summary
157        - applied vine versioning policy
158        - spec in utf-8
159
160* Thu Apr 24 2008 wberrier@suse.de
161- Update to 2.12.1
162  * Bugfix in GLib ref management for Gnome.Program crash in
163  gnome-sharp
164* Thu Apr  3 2008 wberrier@novell.com
165- Can now build 2.16 and 2.20 from the same spec
166- Update to 2.20.0
167  - Updated bindings to coincide with gtk# 2.12
168  - Removed bindings: gtkhtml#, rsvg#, and vte#
169* Wed Mar 26 2008 wberrier@novell.com
170- Update to 2.16.1
171  - Allow storage of empty lists in gconf
172  - Bug fixes:
173  - [GConf] Impossible to set empty list values (bnc#325516)
174  - Comment #8 of bnc#327058 (incorrect p/invoke bindings)
175* Tue Jul  3 2007 wberrier@suse.de
176- Initial package of gnome-sharp2 2.16.0
177  - (Split from gtk-sharp 2.8.3)
Note: See TracBrowser for help on using the repository browser.