source: projects/specs/trunk/g/gnome-python/gnome-python-vl.spec @ 779

Revision 779, 8.1 KB checked in by owa, 14 years ago (diff)

new upstream release

Line 
1%define pyver %(python -c 'import sys;print(sys.version[0:3])')
2
3# libzvt is in Extras but not Core
4%define buildzvt 0
5
6Summary: The sources for the PyGNOME Python extension module.
7Name: gnome-python
8Version: 2.28.1
9Release: 1%{?_dist_release}
10Source: ftp://ftp.gnome.org/pub/GNOME/sources/gnome-python/2.28/gnome-python-%{version}.tar.bz2
11License: LGPL
12Group: Development/Libraries
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14
15BuildRequires: pygtk2-devel >= 2.14.0
16BuildRequires: python-devel >= 2.5
17BuildRequires: pyorbit-devel >= 2.24.0
18BuildRequires: pygobject-devel >= 2.17.0
19BuildRequires: libbonobo-devel >= 2.24.1
20BuildRequires: libbonoboui-devel >= 2.24.1
21BuildRequires: libgnome-devel >= 2.26.0
22BuildRequires: gnome-vfs2-devel >= 2.24.0
23BuildRequires: GConf2-devel >= 2.26.0
24%if %{buildzvt}
25BuildRequires: libzvt-devel >= 2.0.2
26%endif
27## needed for automake/autoconf to work right with multilib python
28#BuildRequires: automake >= 1.9.6, libtool, autoconf
29
30#Obsoletes: gnome-python-applet
31Obsoletes: gnome-python-bonobo
32Obsoletes: gnome-python-canvas
33Obsoletes: gnome-python-gconf
34#Obsoletes: gnome-python-gnomeprint
35Obsoletes: gnome-python-gnomevfs
36#Obsoletes: gnome-python-gtkhtml2
37Obsoletes: gnome-python-nautilus
38%if %{buildzvt}
39Obsoletes: gnome-python-zvt
40%endif
41
42Requires: pyorbit >= 2.24.0
43Requires: pygtk2 >= 2.14.1
44
45%description
46The gnome-python package contains the source packages for the Python
47bindings for GNOME called PyGNOME.
48
49PyGNOME is an extension module for Python that provides access to the
50base GNOME libraries, so you have access to more widgets, a simple
51configuration interface, and metadata support.
52
53%package devel
54Summary: Development files for building add-on libraries
55Group: Development/Libraries
56Requires: %{name} = %{version}-%{release}
57Requires: gnome-vfs2-devel >= 2.24.0
58Requires: pkgconfig
59Requires: python-devel >= %{pyver}
60
61%description devel
62This package contains files required to build wrappers for GNOME add-on
63libraries so that they interoperate with gnome-python.
64
65%prep
66%setup -q -n gnome-python-%{version}
67
68%build
69# libtoolize --force
70# aclocal && automake && autoconf
71#export PYTHON=/usr/bin/python%{pyver}
72#CFLAGS="$RPM_OPT_FLAGS -L/usr/lib/python%{pyver}/config" \
73#       ./configure --prefix=%{_prefix}
74%configure
75make
76
77%install
78rm -rf $RPM_BUILD_ROOT
79make install DESTDIR=$RPM_BUILD_ROOT
80find $RPM_BUILD_ROOT -name '*.la' -exec rm {} \;
81
82%clean
83rm -rf $RPM_BUILD_ROOT
84
85%files
86%defattr(-,root,root,-)
87%doc AUTHORS COPYING ChangeLog INSTALL NEWS README examples
88%{_libdir}/gnome-vfs-2.0/modules/libpythonmethod.so
89%{_libdir}/python?.?/site-packages/gtk-2.0/bonobo
90%{_libdir}/python?.?/site-packages/gtk-2.0/gconf.so
91%{_libdir}/python?.?/site-packages/gtk-2.0/gnome
92%{_libdir}/python?.?/site-packages/gtk-2.0/gnomecanvas.so
93%{_libdir}/python?.?/site-packages/gtk-2.0/gnomevfs
94%if %{buildzvt}
95%{_libdir}/python?.?/site-packages/gtk-2.0/zvt.so
96%endif
97%{_datadir}/pygtk/*
98
99%files devel
100%defattr(-,root,root,-)
101%{_includedir}/gnome-python-2.0
102%{_libdir}/pkgconfig/gnome-python-2.0.pc
103%{_datadir}/gtk-doc/html/pygnomevfs
104
105## old versions did not have .pyc and .pyo files in their file list
106## remove them now, or bad things will now happen because of the new
107## paths.  This trigger must remain until upgrading from RHL 8.0 is no
108## longer supported.
109#%triggerun bonobo -- gnome-python-bonobo < 1.99.14-5
110#rm -f /usr/lib/python%{pyver}/site-packages/bonobo/__init__.{pyc,pyo}
111
112%changelog
113* Fri Apr 09 2010 Shu KONNO <owa@bg.wakwak.com> 2.28.1-1
114- new upstream release
115- dropt "Obsoletes: gnome-python-gtkhtml2" (provided by gnome-python-extras)
116
117* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.0-2
118- rebuild for python-2.6
119
120* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.0-1
121- new upstream release
122
123* Sun Apr 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
124- new upstream release
125- add Requires: pygtk2, pyorbit
126
127* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
128- new upstream release
129
130* Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
131- new upstream release
132
133* Sat Jul 19 2008 Shu KONNO <owa@bg.wakwak.com> 2.22.0-2vl5
134- rebuilt with python-2.5
135
136* Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
137- new upstream release
138- split devel package
139
140* Wed Jan  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-0vl1
141- new upstream release
142
143* Sat Jul  7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.2-0vl1
144- new upstream release
145
146* Mon May  8 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.4-0vl1
147- new upstream release 2.12.4
148
149* Thu Oct 13 2005 Shu KONNO <owa@bg.wakwak.com> 2.12.1-0vl1
150- new upstream release 2.12.1
151- obsolete all sub-packages
152
153* Sat Jun 11 2005 Shu KONNO <owa@bg.wakwak.com> 2.10.0-0vl2
154- dropped "Obsoletes: gnome-python-applet, -capplet, -nautilus,
155  -gtkhtml2, -gnomeprint" because they moved to gnome-python-extras srpm
156
157* Mon Apr 04 2005 Shu KONNO <owa@bg.wakwak.com> 2.10.0-0vl1
158- new upstream release 2.10.0
159- rebuilt with python 2.4.1
160- dropped gnome-python-applet
161- dropped gnome-python-capplet
162- dropped gnome-python-nautilus
163- dropped gnome-python-gtkhtml2
164- dropped gnome-python-gnomeprint
165  see also ftp://ftp.gnome.org/pub/GNOME/sources/gnome-python-extras
166
167* Mon Dec 27 2004 Kazuhisa TAKEI <takei@vinelinux.org> 2.6.2-0vl3
168- fixed BuildRequires/Requires for pyorbit's version
169
170* Mon Dec 27 2004 Kazuhisa TAKEI <takei@vinelinux.org> 2.6.2-0vl1
171- new upstream release
172
173* Thu Jun 17 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.2-0vl1
174- new upstream release
175
176* Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 2.0.0-2vl2
177- rebuild with python-2.3.3-0vl1
178
179* Sat Apr 10 2004 Shu KONNO <owa@bg.wakwak.com> 2.0.0-2vl1.1
180- rebuild with python-2.3.3-0vl0.3 (for TestPkg)
181
182* Sat Jan 17 2004 Tomoya TAKA <taka@vinelinux.org> 2.0.0-2vl1
183- sync with Fedora 2.0.0-2
184  * Thu Oct  2 2003 Matt Wilson <msw@redhat.com> 2.0.0-2
185  - fix segv in gnome.ui.About() (#104396)
186- rebuild with new toolchain and pyorbit
187- s/Copyright/License/
188
189* Fri Sep 12 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.0.0-1vl1
190- build for Vine Linux
191
192* Thu Sep  4 2003 Jeremy Katz <katzj@redhat.com> 2.0.0-1
193- 2.0.0
194
195* Wed Aug 20 2003 Jeremy Katz <katzj@redhat.com> 1.99.16-1
196- update to 1.99.16
197- add gnomeprint subpackage
198- don't double include the gnome-vfs module (#102074)
199
200* Tue Aug  5 2003 Elliot Lee <sopwith@redhat.com> 1.99.14-7
201- Fix libtool
202
203* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
204- rebuilt
205
206* Thu Feb  6 2003 Matt Wilson <msw@redhat.com> 1.99.14-5
207- added a trigger to remove left-over bonobo .pyc and .pyo files (#79652)
208
209* Thu Feb  6 2003 Mihai Ibanescu <misa@redhat.com> 1.99.14-4
210- rebuilt against new python
211
212* Tue Jan 28 2003 Jeremy Katz <katzj@redhat.com> 1.99.14-3
213- libdir-ify
214
215* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
216- rebuilt
217
218* Fri Dec 27 2002 Jeremy Katz <katzj@redhat.com> 1.99.14-1
219- update to 1.99.14
220
221* Fri Dec 13 2002 Jeremy Katz <katzj@redhat.com>
222- update to 1.99.13
223- add gnomevfs subpackage
224
225* Thu Oct 31 2002 Matt Wilson <msw@redhat.com>
226- use %%configure
227
228* Wed Oct 30 2002 Matt Wilson <msw@redhat.com>
229- add gnome-python-2.0.pc to file list
230
231* Wed Aug 28 2002 Matt Wilson <msw@redhat.com>
232- bind gnome_client_set_*_command
233
234* Wed Aug 28 2002 Tim Powers <timp@redhat.com>
235- rebuilt
236
237* Tue Aug 20 2002 Matt Wilson <msw@redhat.com>
238- obsolete pygtk-applet (#69830)
239
240* Thu Aug  1 2002 Jonathan Blandford <jrb@redhat.com>
241- make the GnomeDruid's fields accessible from python
242
243* Tue Jul 30 2002 Matt Wilson <msw@redhat.com>
244- official 1.99.11 release
245
246* Thu May 30 2002 Matt Wilson <msw@redhat.com>
247- s/Gconf/GConf/
248
249* Thu May 30 2002 Jeremy Katz <katzj@redhat.com>
250- add gtkhtml2 and gconf subpackages
251
252* Wed May 29 2002 Bill Nottingham <notting@redhat.com>
253- add some defattrs
254
255* Fri May 24 2002 Matt Wilson <msw@redhat.com>
256- added bonobo, nautilus subpackages.  re-enabled applet subpackage
257
258* Mon Nov 26 2001 Matt Wilson <msw@redhat.com>
259- subpackages will need __init__ included in them
260
261* Thu Oct 18 2001 Matt Wilson <msw@redhat.com>
262- doesn't obsolete pygnome - it can be installed side-by-side
263- added _gnomemodule.so to base package filelist
264
265* Mon Oct 15 2001 Matt Wilson <msw@redhat.com>
266- added __init__ files to gnome-python main package
267
268* Mon Oct  8 2001 Matt Wilson <msw@redhat.com>
269- new gnome-python package based on old pygtk package.
Note: See TracBrowser for help on using the repository browser.