source: projects/specs/trunk/g/gnome-python/gnome-python-vl.spec @ 5701

Revision 5701, 8.5 KB checked in by Takemikaduchi, 12 years ago (diff)

python-2.7.2

Line 
1%define pyver %(python -c 'import sys;print(sys.version[0:3])')
2
3# libzvt is in Extras but not Core
4%define buildzvt 0
5
6Summary: The sources for the PyGNOME Python extension module.
7Name: gnome-python
8Version: 2.28.1
9Release: 4%{?_dist_release}
10Source: ftp://ftp.gnome.org/pub/GNOME/sources/gnome-python/2.28/gnome-python-%{version}.tar.bz2
11License: LGPL
12Group: Development/Libraries
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14
15BuildRequires: pygtk2-devel >= 2.14.0
16BuildRequires: python-devel >= 2.5
17BuildRequires: pyorbit-devel >= 2.24.0
18BuildRequires: pygobject-devel >= 2.17.0
19BuildRequires: libbonobo-devel >= 2.24.1
20BuildRequires: libbonoboui-devel >= 2.24.1
21BuildRequires: libgnome-devel >= 2.26.0
22BuildRequires: gnome-vfs2-devel >= 2.24.0
23BuildRequires: GConf2-devel >= 2.26.0
24BuildRequires: libgnomeui-devel >= 2.8.0
25BuildRequires: libSM-devel
26%if %{buildzvt}
27BuildRequires: libzvt-devel >= 2.0.2
28%endif
29## needed for automake/autoconf to work right with multilib python
30#BuildRequires: automake >= 1.9.6, libtool, autoconf
31
32#Obsoletes: gnome-python-applet
33Obsoletes: gnome-python-bonobo
34Obsoletes: gnome-python-canvas
35Obsoletes: gnome-python-gconf
36#Obsoletes: gnome-python-gnomeprint
37Obsoletes: gnome-python-gnomevfs
38#Obsoletes: gnome-python-gtkhtml2
39Obsoletes: gnome-python-nautilus
40%if %{buildzvt}
41Obsoletes: gnome-python-zvt
42%endif
43
44Requires: pyorbit >= 2.24.0
45Requires: pygtk2 >= 2.14.1
46
47%description
48The gnome-python package contains the source packages for the Python
49bindings for GNOME called PyGNOME.
50
51PyGNOME is an extension module for Python that provides access to the
52base GNOME libraries, so you have access to more widgets, a simple
53configuration interface, and metadata support.
54
55%package devel
56Summary: Development files for building add-on libraries
57Group: Development/Libraries
58Requires: %{name} = %{version}-%{release}
59Requires: gnome-vfs2-devel >= 2.24.0
60Requires: pkgconfig
61Requires: python-devel >= %{pyver}
62
63%description devel
64This package contains files required to build wrappers for GNOME add-on
65libraries so that they interoperate with gnome-python.
66
67%prep
68%setup -q -n gnome-python-%{version}
69
70%build
71# libtoolize --force
72# aclocal && automake && autoconf
73#export PYTHON=/usr/bin/python%{pyver}
74#CFLAGS="$RPM_OPT_FLAGS -L/usr/lib/python%{pyver}/config" \
75#       ./configure --prefix=%{_prefix}
76%configure
77make
78
79%install
80rm -rf $RPM_BUILD_ROOT
81make install DESTDIR=$RPM_BUILD_ROOT
82find $RPM_BUILD_ROOT -name '*.la' -exec rm {} \;
83
84%clean
85rm -rf $RPM_BUILD_ROOT
86
87%files
88%defattr(-,root,root,-)
89%doc AUTHORS COPYING ChangeLog INSTALL NEWS README examples
90%{_libdir}/gnome-vfs-2.0/modules/libpythonmethod.so
91%{_libdir}/python?.?/site-packages/gtk-2.0/bonobo
92%{_libdir}/python?.?/site-packages/gtk-2.0/gconf.so
93%{_libdir}/python?.?/site-packages/gtk-2.0/gnome
94%{_libdir}/python?.?/site-packages/gtk-2.0/gnomecanvas.so
95%{_libdir}/python?.?/site-packages/gtk-2.0/gnomevfs
96%if %{buildzvt}
97%{_libdir}/python?.?/site-packages/gtk-2.0/zvt.so
98%endif
99%{_datadir}/pygtk/*
100
101%files devel
102%defattr(-,root,root,-)
103%{_includedir}/gnome-python-2.0
104%{_libdir}/pkgconfig/gnome-python-2.0.pc
105%{_datadir}/gtk-doc/html/pygnomevfs
106
107## old versions did not have .pyc and .pyo files in their file list
108## remove them now, or bad things will now happen because of the new
109## paths.  This trigger must remain until upgrading from RHL 8.0 is no
110## longer supported.
111#%triggerun bonobo -- gnome-python-bonobo < 1.99.14-5
112#rm -f /usr/lib/python%{pyver}/site-packages/bonobo/__init__.{pyc,pyo}
113
114%changelog
115* Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.1-4
116- rebuild with python-2.7.2
117
118* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.1-3
119- rebuild with rpm-4.8.1 for pkg-config file
120- add BuildRequires: libSM-devel
121
122* Sat Jun 05 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 2.28.1-2
123- add BuildRequires: libgnomeui-devel >= 2.8.0
124
125* Fri Apr 09 2010 Shu KONNO <owa@bg.wakwak.com> 2.28.1-1
126- new upstream release
127- dropt "Obsoletes: gnome-python-gtkhtml2" (provided by gnome-python-extras)
128
129* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.0-2
130- rebuild for python-2.6
131
132* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.0-1
133- new upstream release
134
135* Sun Apr 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
136- new upstream release
137- add Requires: pygtk2, pyorbit
138
139* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
140- new upstream release
141
142* Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
143- new upstream release
144
145* Sat Jul 19 2008 Shu KONNO <owa@bg.wakwak.com> 2.22.0-2vl5
146- rebuilt with python-2.5
147
148* Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
149- new upstream release
150- split devel package
151
152* Wed Jan  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-0vl1
153- new upstream release
154
155* Sat Jul  7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.2-0vl1
156- new upstream release
157
158* Mon May  8 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.4-0vl1
159- new upstream release 2.12.4
160
161* Thu Oct 13 2005 Shu KONNO <owa@bg.wakwak.com> 2.12.1-0vl1
162- new upstream release 2.12.1
163- obsolete all sub-packages
164
165* Sat Jun 11 2005 Shu KONNO <owa@bg.wakwak.com> 2.10.0-0vl2
166- dropped "Obsoletes: gnome-python-applet, -capplet, -nautilus,
167  -gtkhtml2, -gnomeprint" because they moved to gnome-python-extras srpm
168
169* Mon Apr 04 2005 Shu KONNO <owa@bg.wakwak.com> 2.10.0-0vl1
170- new upstream release 2.10.0
171- rebuilt with python 2.4.1
172- dropped gnome-python-applet
173- dropped gnome-python-capplet
174- dropped gnome-python-nautilus
175- dropped gnome-python-gtkhtml2
176- dropped gnome-python-gnomeprint
177  see also ftp://ftp.gnome.org/pub/GNOME/sources/gnome-python-extras
178
179* Mon Dec 27 2004 Kazuhisa TAKEI <takei@vinelinux.org> 2.6.2-0vl3
180- fixed BuildRequires/Requires for pyorbit's version
181
182* Mon Dec 27 2004 Kazuhisa TAKEI <takei@vinelinux.org> 2.6.2-0vl1
183- new upstream release
184
185* Thu Jun 17 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.2-0vl1
186- new upstream release
187
188* Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 2.0.0-2vl2
189- rebuild with python-2.3.3-0vl1
190
191* Sat Apr 10 2004 Shu KONNO <owa@bg.wakwak.com> 2.0.0-2vl1.1
192- rebuild with python-2.3.3-0vl0.3 (for TestPkg)
193
194* Sat Jan 17 2004 Tomoya TAKA <taka@vinelinux.org> 2.0.0-2vl1
195- sync with Fedora 2.0.0-2
196  * Thu Oct  2 2003 Matt Wilson <msw@redhat.com> 2.0.0-2
197  - fix segv in gnome.ui.About() (#104396)
198- rebuild with new toolchain and pyorbit
199- s/Copyright/License/
200
201* Fri Sep 12 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.0.0-1vl1
202- build for Vine Linux
203
204* Thu Sep  4 2003 Jeremy Katz <katzj@redhat.com> 2.0.0-1
205- 2.0.0
206
207* Wed Aug 20 2003 Jeremy Katz <katzj@redhat.com> 1.99.16-1
208- update to 1.99.16
209- add gnomeprint subpackage
210- don't double include the gnome-vfs module (#102074)
211
212* Tue Aug  5 2003 Elliot Lee <sopwith@redhat.com> 1.99.14-7
213- Fix libtool
214
215* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
216- rebuilt
217
218* Thu Feb  6 2003 Matt Wilson <msw@redhat.com> 1.99.14-5
219- added a trigger to remove left-over bonobo .pyc and .pyo files (#79652)
220
221* Thu Feb  6 2003 Mihai Ibanescu <misa@redhat.com> 1.99.14-4
222- rebuilt against new python
223
224* Tue Jan 28 2003 Jeremy Katz <katzj@redhat.com> 1.99.14-3
225- libdir-ify
226
227* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
228- rebuilt
229
230* Fri Dec 27 2002 Jeremy Katz <katzj@redhat.com> 1.99.14-1
231- update to 1.99.14
232
233* Fri Dec 13 2002 Jeremy Katz <katzj@redhat.com>
234- update to 1.99.13
235- add gnomevfs subpackage
236
237* Thu Oct 31 2002 Matt Wilson <msw@redhat.com>
238- use %%configure
239
240* Wed Oct 30 2002 Matt Wilson <msw@redhat.com>
241- add gnome-python-2.0.pc to file list
242
243* Wed Aug 28 2002 Matt Wilson <msw@redhat.com>
244- bind gnome_client_set_*_command
245
246* Wed Aug 28 2002 Tim Powers <timp@redhat.com>
247- rebuilt
248
249* Tue Aug 20 2002 Matt Wilson <msw@redhat.com>
250- obsolete pygtk-applet (#69830)
251
252* Thu Aug  1 2002 Jonathan Blandford <jrb@redhat.com>
253- make the GnomeDruid's fields accessible from python
254
255* Tue Jul 30 2002 Matt Wilson <msw@redhat.com>
256- official 1.99.11 release
257
258* Thu May 30 2002 Matt Wilson <msw@redhat.com>
259- s/Gconf/GConf/
260
261* Thu May 30 2002 Jeremy Katz <katzj@redhat.com>
262- add gtkhtml2 and gconf subpackages
263
264* Wed May 29 2002 Bill Nottingham <notting@redhat.com>
265- add some defattrs
266
267* Fri May 24 2002 Matt Wilson <msw@redhat.com>
268- added bonobo, nautilus subpackages.  re-enabled applet subpackage
269
270* Mon Nov 26 2001 Matt Wilson <msw@redhat.com>
271- subpackages will need __init__ included in them
272
273* Thu Oct 18 2001 Matt Wilson <msw@redhat.com>
274- doesn't obsolete pygnome - it can be installed side-by-side
275- added _gnomemodule.so to base package filelist
276
277* Mon Oct 15 2001 Matt Wilson <msw@redhat.com>
278- added __init__ files to gnome-python main package
279
280* Mon Oct  8 2001 Matt Wilson <msw@redhat.com>
281- new gnome-python package based on old pygtk package.
Note: See TracBrowser for help on using the repository browser.