source: projects/specs/trunk/g/gnome-python/gnome-python-vl.spec @ 1143

Revision 1143, 8.3 KB checked in by kazutaka, 14 years ago (diff)

add BuildRequires?: libgnomeui-devel >= 2.8.0

Line 
1%define pyver %(python -c 'import sys;print(sys.version[0:3])')
2
3# libzvt is in Extras but not Core
4%define buildzvt 0
5
6Summary: The sources for the PyGNOME Python extension module.
7Name: gnome-python
8Version: 2.28.1
9Release: 2%{?_dist_release}
10Source: ftp://ftp.gnome.org/pub/GNOME/sources/gnome-python/2.28/gnome-python-%{version}.tar.bz2
11License: LGPL
12Group: Development/Libraries
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14
15BuildRequires: pygtk2-devel >= 2.14.0
16BuildRequires: python-devel >= 2.5
17BuildRequires: pyorbit-devel >= 2.24.0
18BuildRequires: pygobject-devel >= 2.17.0
19BuildRequires: libbonobo-devel >= 2.24.1
20BuildRequires: libbonoboui-devel >= 2.24.1
21BuildRequires: libgnome-devel >= 2.26.0
22BuildRequires: gnome-vfs2-devel >= 2.24.0
23BuildRequires: GConf2-devel >= 2.26.0
24BuildRequires: libgnomeui-devel >= 2.8.0
25%if %{buildzvt}
26BuildRequires: libzvt-devel >= 2.0.2
27%endif
28## needed for automake/autoconf to work right with multilib python
29#BuildRequires: automake >= 1.9.6, libtool, autoconf
30
31#Obsoletes: gnome-python-applet
32Obsoletes: gnome-python-bonobo
33Obsoletes: gnome-python-canvas
34Obsoletes: gnome-python-gconf
35#Obsoletes: gnome-python-gnomeprint
36Obsoletes: gnome-python-gnomevfs
37#Obsoletes: gnome-python-gtkhtml2
38Obsoletes: gnome-python-nautilus
39%if %{buildzvt}
40Obsoletes: gnome-python-zvt
41%endif
42
43Requires: pyorbit >= 2.24.0
44Requires: pygtk2 >= 2.14.1
45
46%description
47The gnome-python package contains the source packages for the Python
48bindings for GNOME called PyGNOME.
49
50PyGNOME is an extension module for Python that provides access to the
51base GNOME libraries, so you have access to more widgets, a simple
52configuration interface, and metadata support.
53
54%package devel
55Summary: Development files for building add-on libraries
56Group: Development/Libraries
57Requires: %{name} = %{version}-%{release}
58Requires: gnome-vfs2-devel >= 2.24.0
59Requires: pkgconfig
60Requires: python-devel >= %{pyver}
61
62%description devel
63This package contains files required to build wrappers for GNOME add-on
64libraries so that they interoperate with gnome-python.
65
66%prep
67%setup -q -n gnome-python-%{version}
68
69%build
70# libtoolize --force
71# aclocal && automake && autoconf
72#export PYTHON=/usr/bin/python%{pyver}
73#CFLAGS="$RPM_OPT_FLAGS -L/usr/lib/python%{pyver}/config" \
74#       ./configure --prefix=%{_prefix}
75%configure
76make
77
78%install
79rm -rf $RPM_BUILD_ROOT
80make install DESTDIR=$RPM_BUILD_ROOT
81find $RPM_BUILD_ROOT -name '*.la' -exec rm {} \;
82
83%clean
84rm -rf $RPM_BUILD_ROOT
85
86%files
87%defattr(-,root,root,-)
88%doc AUTHORS COPYING ChangeLog INSTALL NEWS README examples
89%{_libdir}/gnome-vfs-2.0/modules/libpythonmethod.so
90%{_libdir}/python?.?/site-packages/gtk-2.0/bonobo
91%{_libdir}/python?.?/site-packages/gtk-2.0/gconf.so
92%{_libdir}/python?.?/site-packages/gtk-2.0/gnome
93%{_libdir}/python?.?/site-packages/gtk-2.0/gnomecanvas.so
94%{_libdir}/python?.?/site-packages/gtk-2.0/gnomevfs
95%if %{buildzvt}
96%{_libdir}/python?.?/site-packages/gtk-2.0/zvt.so
97%endif
98%{_datadir}/pygtk/*
99
100%files devel
101%defattr(-,root,root,-)
102%{_includedir}/gnome-python-2.0
103%{_libdir}/pkgconfig/gnome-python-2.0.pc
104%{_datadir}/gtk-doc/html/pygnomevfs
105
106## old versions did not have .pyc and .pyo files in their file list
107## remove them now, or bad things will now happen because of the new
108## paths.  This trigger must remain until upgrading from RHL 8.0 is no
109## longer supported.
110#%triggerun bonobo -- gnome-python-bonobo < 1.99.14-5
111#rm -f /usr/lib/python%{pyver}/site-packages/bonobo/__init__.{pyc,pyo}
112
113%changelog
114* Sat Jun 05 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 2.28.1-2
115- add BuildRequires: libgnomeui-devel >= 2.8.0
116
117* Fri Apr 09 2010 Shu KONNO <owa@bg.wakwak.com> 2.28.1-1
118- new upstream release
119- dropt "Obsoletes: gnome-python-gtkhtml2" (provided by gnome-python-extras)
120
121* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.0-2
122- rebuild for python-2.6
123
124* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.0-1
125- new upstream release
126
127* Sun Apr 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
128- new upstream release
129- add Requires: pygtk2, pyorbit
130
131* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
132- new upstream release
133
134* Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
135- new upstream release
136
137* Sat Jul 19 2008 Shu KONNO <owa@bg.wakwak.com> 2.22.0-2vl5
138- rebuilt with python-2.5
139
140* Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
141- new upstream release
142- split devel package
143
144* Wed Jan  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-0vl1
145- new upstream release
146
147* Sat Jul  7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.2-0vl1
148- new upstream release
149
150* Mon May  8 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.4-0vl1
151- new upstream release 2.12.4
152
153* Thu Oct 13 2005 Shu KONNO <owa@bg.wakwak.com> 2.12.1-0vl1
154- new upstream release 2.12.1
155- obsolete all sub-packages
156
157* Sat Jun 11 2005 Shu KONNO <owa@bg.wakwak.com> 2.10.0-0vl2
158- dropped "Obsoletes: gnome-python-applet, -capplet, -nautilus,
159  -gtkhtml2, -gnomeprint" because they moved to gnome-python-extras srpm
160
161* Mon Apr 04 2005 Shu KONNO <owa@bg.wakwak.com> 2.10.0-0vl1
162- new upstream release 2.10.0
163- rebuilt with python 2.4.1
164- dropped gnome-python-applet
165- dropped gnome-python-capplet
166- dropped gnome-python-nautilus
167- dropped gnome-python-gtkhtml2
168- dropped gnome-python-gnomeprint
169  see also ftp://ftp.gnome.org/pub/GNOME/sources/gnome-python-extras
170
171* Mon Dec 27 2004 Kazuhisa TAKEI <takei@vinelinux.org> 2.6.2-0vl3
172- fixed BuildRequires/Requires for pyorbit's version
173
174* Mon Dec 27 2004 Kazuhisa TAKEI <takei@vinelinux.org> 2.6.2-0vl1
175- new upstream release
176
177* Thu Jun 17 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.2-0vl1
178- new upstream release
179
180* Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 2.0.0-2vl2
181- rebuild with python-2.3.3-0vl1
182
183* Sat Apr 10 2004 Shu KONNO <owa@bg.wakwak.com> 2.0.0-2vl1.1
184- rebuild with python-2.3.3-0vl0.3 (for TestPkg)
185
186* Sat Jan 17 2004 Tomoya TAKA <taka@vinelinux.org> 2.0.0-2vl1
187- sync with Fedora 2.0.0-2
188  * Thu Oct  2 2003 Matt Wilson <msw@redhat.com> 2.0.0-2
189  - fix segv in gnome.ui.About() (#104396)
190- rebuild with new toolchain and pyorbit
191- s/Copyright/License/
192
193* Fri Sep 12 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.0.0-1vl1
194- build for Vine Linux
195
196* Thu Sep  4 2003 Jeremy Katz <katzj@redhat.com> 2.0.0-1
197- 2.0.0
198
199* Wed Aug 20 2003 Jeremy Katz <katzj@redhat.com> 1.99.16-1
200- update to 1.99.16
201- add gnomeprint subpackage
202- don't double include the gnome-vfs module (#102074)
203
204* Tue Aug  5 2003 Elliot Lee <sopwith@redhat.com> 1.99.14-7
205- Fix libtool
206
207* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
208- rebuilt
209
210* Thu Feb  6 2003 Matt Wilson <msw@redhat.com> 1.99.14-5
211- added a trigger to remove left-over bonobo .pyc and .pyo files (#79652)
212
213* Thu Feb  6 2003 Mihai Ibanescu <misa@redhat.com> 1.99.14-4
214- rebuilt against new python
215
216* Tue Jan 28 2003 Jeremy Katz <katzj@redhat.com> 1.99.14-3
217- libdir-ify
218
219* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
220- rebuilt
221
222* Fri Dec 27 2002 Jeremy Katz <katzj@redhat.com> 1.99.14-1
223- update to 1.99.14
224
225* Fri Dec 13 2002 Jeremy Katz <katzj@redhat.com>
226- update to 1.99.13
227- add gnomevfs subpackage
228
229* Thu Oct 31 2002 Matt Wilson <msw@redhat.com>
230- use %%configure
231
232* Wed Oct 30 2002 Matt Wilson <msw@redhat.com>
233- add gnome-python-2.0.pc to file list
234
235* Wed Aug 28 2002 Matt Wilson <msw@redhat.com>
236- bind gnome_client_set_*_command
237
238* Wed Aug 28 2002 Tim Powers <timp@redhat.com>
239- rebuilt
240
241* Tue Aug 20 2002 Matt Wilson <msw@redhat.com>
242- obsolete pygtk-applet (#69830)
243
244* Thu Aug  1 2002 Jonathan Blandford <jrb@redhat.com>
245- make the GnomeDruid's fields accessible from python
246
247* Tue Jul 30 2002 Matt Wilson <msw@redhat.com>
248- official 1.99.11 release
249
250* Thu May 30 2002 Matt Wilson <msw@redhat.com>
251- s/Gconf/GConf/
252
253* Thu May 30 2002 Jeremy Katz <katzj@redhat.com>
254- add gtkhtml2 and gconf subpackages
255
256* Wed May 29 2002 Bill Nottingham <notting@redhat.com>
257- add some defattrs
258
259* Fri May 24 2002 Matt Wilson <msw@redhat.com>
260- added bonobo, nautilus subpackages.  re-enabled applet subpackage
261
262* Mon Nov 26 2001 Matt Wilson <msw@redhat.com>
263- subpackages will need __init__ included in them
264
265* Thu Oct 18 2001 Matt Wilson <msw@redhat.com>
266- doesn't obsolete pygnome - it can be installed side-by-side
267- added _gnomemodule.so to base package filelist
268
269* Mon Oct 15 2001 Matt Wilson <msw@redhat.com>
270- added __init__ files to gnome-python main package
271
272* Mon Oct  8 2001 Matt Wilson <msw@redhat.com>
273- new gnome-python package based on old pygtk package.
Note: See TracBrowser for help on using the repository browser.