source: projects/specs/trunk/g/gnome-python/gnome-python-vl.spec @ 521

Revision 521, 8.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define pyver %(python -c 'import sys;print(sys.version[0:3])')
2
3# libzvt is in Extras but not Core
4%define buildzvt 0
5
6Summary: The sources for the PyGNOME Python extension module.
7Name: gnome-python
8Version: 2.28.0
9Release: 2%{?_dist_release}
10Source: ftp://ftp.gnome.org/pub/GNOME/sources/gnome-python/2.28/gnome-python-%{version}.tar.bz2
11License: LGPL
12Group: Development/Libraries
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14
15BuildRequires: pygtk2-devel >= 2.14.0
16BuildRequires: python-devel >= 2.5
17BuildRequires: pyorbit-devel >= 2.24.0
18BuildRequires: pygobject-devel >= 2.17.0
19BuildRequires: libbonobo-devel >= 2.24.1
20BuildRequires: libbonoboui-devel >= 2.24.1
21BuildRequires: libgnome-devel >= 2.26.0
22BuildRequires: gnome-vfs2-devel >= 2.24.0
23BuildRequires: GConf2-devel >= 2.26.0
24%if %{buildzvt}
25BuildRequires: libzvt-devel >= 2.0.2
26%endif
27## needed for automake/autoconf to work right with multilib python
28#BuildRequires: automake >= 1.9.6, libtool, autoconf
29
30#Obsoletes: gnome-python-applet
31Obsoletes: gnome-python-bonobo
32Obsoletes: gnome-python-canvas
33Obsoletes: gnome-python-gconf
34#Obsoletes: gnome-python-gnomeprint
35Obsoletes: gnome-python-gnomevfs
36Obsoletes: gnome-python-gtkhtml2
37Obsoletes: gnome-python-nautilus
38%if %{buildzvt}
39Obsoletes: gnome-python-zvt
40%endif
41
42Requires: pyorbit >= 2.24.0
43Requires: pygtk2 >= 2.14.1
44
45%description
46The gnome-python package contains the source packages for the Python
47bindings for GNOME called PyGNOME.
48
49PyGNOME is an extension module for Python that provides access to the
50base GNOME libraries, so you have access to more widgets, a simple
51configuration interface, and metadata support.
52
53%package devel
54Summary: Development files for building add-on libraries
55Group: Development/Libraries
56Requires: %{name} = %{version}-%{release}
57Requires: gnome-vfs2-devel >= 2.24.0
58Requires: pkgconfig
59Requires: python-devel >= %{pyver}
60
61%description devel
62This package contains files required to build wrappers for GNOME add-on
63libraries so that they interoperate with gnome-python.
64
65%prep
66%setup -q -n gnome-python-%{version}
67
68%build
69# libtoolize --force
70# aclocal && automake && autoconf
71#export PYTHON=/usr/bin/python%{pyver}
72#CFLAGS="$RPM_OPT_FLAGS -L/usr/lib/python%{pyver}/config" \
73#       ./configure --prefix=%{_prefix}
74%configure
75make
76
77%install
78rm -rf $RPM_BUILD_ROOT
79make install DESTDIR=$RPM_BUILD_ROOT
80find $RPM_BUILD_ROOT -name '*.la' -exec rm {} \;
81
82%clean
83rm -rf $RPM_BUILD_ROOT
84
85%files
86%defattr(-,root,root,-)
87%doc AUTHORS COPYING ChangeLog INSTALL NEWS README examples
88%{_libdir}/gnome-vfs-2.0/modules/libpythonmethod.so
89%{_libdir}/python?.?/site-packages/gtk-2.0/bonobo
90%{_libdir}/python?.?/site-packages/gtk-2.0/gconf.so
91%{_libdir}/python?.?/site-packages/gtk-2.0/gnome
92%{_libdir}/python?.?/site-packages/gtk-2.0/gnomecanvas.so
93%{_libdir}/python?.?/site-packages/gtk-2.0/gnomevfs
94%if %{buildzvt}
95%{_libdir}/python?.?/site-packages/gtk-2.0/zvt.so
96%endif
97%{_datadir}/pygtk/*
98
99%files devel
100%defattr(-,root,root,-)
101%{_includedir}/gnome-python-2.0
102%{_libdir}/pkgconfig/gnome-python-2.0.pc
103%{_datadir}/gtk-doc/html/pygnomevfs
104
105## old versions did not have .pyc and .pyo files in their file list
106## remove them now, or bad things will now happen because of the new
107## paths.  This trigger must remain until upgrading from RHL 8.0 is no
108## longer supported.
109#%triggerun bonobo -- gnome-python-bonobo < 1.99.14-5
110#rm -f /usr/lib/python%{pyver}/site-packages/bonobo/__init__.{pyc,pyo}
111
112%changelog
113* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.0-2
114- rebuild for python-2.6
115
116* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.0-1
117- new upstream release
118
119* Sun Apr 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
120- new upstream release
121- add Requires: pygtk2, pyorbit
122
123* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
124- new upstream release
125
126* Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
127- new upstream release
128
129* Sat Jul 19 2008 Shu KONNO <owa@bg.wakwak.com> 2.22.0-2vl5
130- rebuilt with python-2.5
131
132* Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
133- new upstream release
134- split devel package
135
136* Wed Jan  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-0vl1
137- new upstream release
138
139* Sat Jul  7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.2-0vl1
140- new upstream release
141
142* Mon May  8 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.4-0vl1
143- new upstream release 2.12.4
144
145* Thu Oct 13 2005 Shu KONNO <owa@bg.wakwak.com> 2.12.1-0vl1
146- new upstream release 2.12.1
147- obsolete all sub-packages
148
149* Sat Jun 11 2005 Shu KONNO <owa@bg.wakwak.com> 2.10.0-0vl2
150- dropped "Obsoletes: gnome-python-applet, -capplet, -nautilus,
151  -gtkhtml2, -gnomeprint" because they moved to gnome-python-extras srpm
152
153* Mon Apr 04 2005 Shu KONNO <owa@bg.wakwak.com> 2.10.0-0vl1
154- new upstream release 2.10.0
155- rebuilt with python 2.4.1
156- dropped gnome-python-applet
157- dropped gnome-python-capplet
158- dropped gnome-python-nautilus
159- dropped gnome-python-gtkhtml2
160- dropped gnome-python-gnomeprint
161  see also ftp://ftp.gnome.org/pub/GNOME/sources/gnome-python-extras
162
163* Mon Dec 27 2004 Kazuhisa TAKEI <takei@vinelinux.org> 2.6.2-0vl3
164- fixed BuildRequires/Requires for pyorbit's version
165
166* Mon Dec 27 2004 Kazuhisa TAKEI <takei@vinelinux.org> 2.6.2-0vl1
167- new upstream release
168
169* Thu Jun 17 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.2-0vl1
170- new upstream release
171
172* Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 2.0.0-2vl2
173- rebuild with python-2.3.3-0vl1
174
175* Sat Apr 10 2004 Shu KONNO <owa@bg.wakwak.com> 2.0.0-2vl1.1
176- rebuild with python-2.3.3-0vl0.3 (for TestPkg)
177
178* Sat Jan 17 2004 Tomoya TAKA <taka@vinelinux.org> 2.0.0-2vl1
179- sync with Fedora 2.0.0-2
180  * Thu Oct  2 2003 Matt Wilson <msw@redhat.com> 2.0.0-2
181  - fix segv in gnome.ui.About() (#104396)
182- rebuild with new toolchain and pyorbit
183- s/Copyright/License/
184
185* Fri Sep 12 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.0.0-1vl1
186- build for Vine Linux
187
188* Thu Sep  4 2003 Jeremy Katz <katzj@redhat.com> 2.0.0-1
189- 2.0.0
190
191* Wed Aug 20 2003 Jeremy Katz <katzj@redhat.com> 1.99.16-1
192- update to 1.99.16
193- add gnomeprint subpackage
194- don't double include the gnome-vfs module (#102074)
195
196* Tue Aug  5 2003 Elliot Lee <sopwith@redhat.com> 1.99.14-7
197- Fix libtool
198
199* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
200- rebuilt
201
202* Thu Feb  6 2003 Matt Wilson <msw@redhat.com> 1.99.14-5
203- added a trigger to remove left-over bonobo .pyc and .pyo files (#79652)
204
205* Thu Feb  6 2003 Mihai Ibanescu <misa@redhat.com> 1.99.14-4
206- rebuilt against new python
207
208* Tue Jan 28 2003 Jeremy Katz <katzj@redhat.com> 1.99.14-3
209- libdir-ify
210
211* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
212- rebuilt
213
214* Fri Dec 27 2002 Jeremy Katz <katzj@redhat.com> 1.99.14-1
215- update to 1.99.14
216
217* Fri Dec 13 2002 Jeremy Katz <katzj@redhat.com>
218- update to 1.99.13
219- add gnomevfs subpackage
220
221* Thu Oct 31 2002 Matt Wilson <msw@redhat.com>
222- use %%configure
223
224* Wed Oct 30 2002 Matt Wilson <msw@redhat.com>
225- add gnome-python-2.0.pc to file list
226
227* Wed Aug 28 2002 Matt Wilson <msw@redhat.com>
228- bind gnome_client_set_*_command
229
230* Wed Aug 28 2002 Tim Powers <timp@redhat.com>
231- rebuilt
232
233* Tue Aug 20 2002 Matt Wilson <msw@redhat.com>
234- obsolete pygtk-applet (#69830)
235
236* Thu Aug  1 2002 Jonathan Blandford <jrb@redhat.com>
237- make the GnomeDruid's fields accessible from python
238
239* Tue Jul 30 2002 Matt Wilson <msw@redhat.com>
240- official 1.99.11 release
241
242* Thu May 30 2002 Matt Wilson <msw@redhat.com>
243- s/Gconf/GConf/
244
245* Thu May 30 2002 Jeremy Katz <katzj@redhat.com>
246- add gtkhtml2 and gconf subpackages
247
248* Wed May 29 2002 Bill Nottingham <notting@redhat.com>
249- add some defattrs
250
251* Fri May 24 2002 Matt Wilson <msw@redhat.com>
252- added bonobo, nautilus subpackages.  re-enabled applet subpackage
253
254* Mon Nov 26 2001 Matt Wilson <msw@redhat.com>
255- subpackages will need __init__ included in them
256
257* Thu Oct 18 2001 Matt Wilson <msw@redhat.com>
258- doesn't obsolete pygnome - it can be installed side-by-side
259- added _gnomemodule.so to base package filelist
260
261* Mon Oct 15 2001 Matt Wilson <msw@redhat.com>
262- added __init__ files to gnome-python main package
263
264* Mon Oct  8 2001 Matt Wilson <msw@redhat.com>
265- new gnome-python package based on old pygtk package.
Note: See TracBrowser for help on using the repository browser.