source: projects/specs/trunk/g/gnome-python-desktop/gnome-python-desktop-vl.spec @ 521

Revision 521, 13.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3%define glib_version 2.20.0
4%define gtk_version 2.16.0
5%define pygtk_version 2.14.0
6%define gnome_python_version 2.28.0
7%define gnome_keyring_version 2.26.0
8%define gnome_panel_version 2.26.0
9%define gnome_desktop_version 2.26.0
10%define gtksourceview_version 1.1.90
11%define libgtop_version 2.26.0
12%define gnome_media_version 2.26.0
13%define metacity_version 2.26.0
14%define librsvg2_version 2.26.0
15%define totem_version 2.26.0
16%define libwnck_version 2.26.0
17%define bug_buddy_version 2.16.0
18
19### Abstract ###
20
21Name: gnome-python-desktop
22Version: 2.28.0
23Release: 2%{?_dist_release}
24License: GPL/LGPL
25Group: Development/Libraries
26Summary: The sources for additional PyGNOME Python extension modules
27BuildRoot: %{_tmppath}/%{name}-%{version}-root
28Source: gnome-python-desktop-%{version}.tar.bz2
29
30### Dependencies ###
31
32Requires: gnome-python >= %{gnome_python_version}
33
34### Build Dependencies ###
35
36BuildRequires: glib2-devel >= %{glib_version}
37BuildRequires: gtk2-devel >= %{gtk_version}
38BuildRequires: python >= 2.4
39BuildRequires: pygtk2-devel >= %{pygtk_version}
40BuildRequires: gnome-python-devel >= %{gnome_python_version}
41BuildRequires: gnome-keyring-devel >= %{gnome_keyring_version}
42BuildRequires: gnome-panel-devel >= %{gnome_panel_version}
43BuildRequires: gnome-desktop-devel >= %{gnome_desktop_version}
44BuildRequires: libgnomeprint-devel
45BuildRequires: libgnomeprintui-devel
46BuildRequires: evince-devel
47BuildRequires: evolution-data-server >= 2.22.0
48BuildRequires: gtksourceview-devel >= %{gtksourceview_version}
49BuildRequires: libgtop2-devel >= %{libgtop_version}
50BuildRequires: gnome-media >= %{gnome_media_version}
51BuildRequires: metacity >= %{metacity_version}
52BuildRequires: brasero-devel
53BuildRequires: librsvg2-devel >= %{librsvg2_version}
54BuildRequires: pycairo-devel
55BuildRequires: totem-pl-parser-devel >= %{totem_version}
56BuildRequires: libwnck-devel >= %{libwnck_version}
57BuildRequires: bug-buddy >= %{bug_buddy_version}
58
59%description
60The gnome-python-desktop package contains the source packages for additional
61Python bindings for GNOME. It should be used together with gnome-python.
62
63%package -n gnome-python-applet
64Summary: Python bindings for GNOME Panel applets.
65Group: Development/Libraries
66Requires: %{name} = %{version}-%{release}
67# applets from GNOME 1.4 are no longer supported - we only have 1 panel
68Obsoletes: pygnome-applet
69
70%description -n gnome-python-applet
71This module contains a wrapper that allows GNOME Panel applets to be
72written in Python.
73
74%package -n gnome-python-bugbuddy
75Summary: Python bindings for interacting with bug-buddy
76Group: Development/Libraries
77Requires: %{name} = %{version}-%{release}
78Requires: bug-buddy >= %{bug_buddy_version}
79
80%description -n gnome-python-bugbuddy
81This module contains a wrapper that allows the use of bug-buddy via
82Python.
83
84%package -n gnome-python-evolution
85Summary: Python bindings for interacting with evolution
86Group: Development/Libraries
87Requires: %{name} = %{version}-%{release}
88Requires: evolution-data-server >= 2.22.0
89
90%description -n gnome-python-evolution
91This module contains a wrapper that allows the use of evolution via
92Python.
93
94%package -n gnome-python-gnomeprint
95Summary: Python bindings for interacting with libgnomeprint
96Group: Development/Libraries
97Requires: %{name} = %{version}-%{release}
98Requires: libgnomeprint
99Requires: libgnomeprintui
100
101%description -n gnome-python-gnomeprint
102This module contains a wrapper that allows the use of libgnomeprint via
103Python.
104
105%package -n gnome-python-gtksourceview
106Summary: Python bindings for interacting with the gtksourceview library
107Group: Development/Libraries
108Requires: %{name} = %{version}-%{release}
109Requires: gtksourceview >= %{gtksourceview_version}
110Requires: gnome-python-gnomeprint
111
112%description -n gnome-python-gtksourceview
113This module contains a wrapper that allows the use of gtksourceview via
114Python.
115
116%package -n gnome-python-libwnck
117Summary: Python bindings for interacting with libwnck
118Group: Development/Libraries
119Requires: libwnck >= %{libwnck_version}
120
121%description -n gnome-python-libwnck
122This module contains a wrapper that allows the use of libwnck via
123Python.
124
125%package -n gnome-python-libgtop2
126Summary: Python bindings for interacting with libgtop
127Group: Development/Libraries
128Requires: %{name} = %{version}-%{release}
129Requires: libgtop2 >= %{libgtop_version}
130
131%description -n gnome-python-libgtop2
132This module contains a wrapper that allows the use of libgtop via
133Python.
134
135%package -n gnome-python-brasero
136Summary: Python bindings for interacting with brasero
137Group: Development/Libraries
138Requires: %{name} = %{version}-%{release}
139Requires: brasero-libs
140
141%description -n gnome-python-brasero
142This module contains a wrapper that allows the use of brasero
143via Python.
144
145%package -n gnome-python-metacity
146Summary: Python bindings for interacting with metacity
147Group: Development/Libraries
148Requires: %{name} = %{version}-%{release}
149Requires: metacity >= %{metacity_version}
150
151%description -n gnome-python-metacity
152This module contains a wrapper that allows the use of metacity
153via Python.
154
155%package -n gnome-python-totem
156Summary: Python bindings for interacting with totem
157Group: Development/Libraries
158Requires: %{name} = %{version}-%{release}
159Requires: totem >= %{totem_version}
160
161%description -n gnome-python-totem
162This module contains a wrapper that allows the use of totem
163via Python.
164
165%package -n gnome-python-rsvg
166Summary: Python bindings for interacting with librsvg
167Group: Development/Libraries
168Requires: librsvg2 >= %{librsvg2_version}
169Requires: pycairo
170
171%description -n gnome-python-rsvg
172This module contains a wrapper that allows the use of librsvg
173via Python.
174
175%package -n gnome-python-gnomedesktop
176Summary: Python bindings for interacting with gnome-desktop
177Group: Development/Libraries
178Requires: %{name} = %{version}-%{release}
179Requires: gnome-desktop >= %{gnome_desktop_version}
180
181%description -n gnome-python-gnomedesktop
182This module contains a wrapper that allows the use of gnome-desktop
183via Python.
184
185%package -n gnome-python-gnomekeyring
186Summary: Python bindings for interacting with gnome-keyring
187Group: Development/Libraries
188Requires: %{name} = %{version}-%{release}
189Requires: gnome-keyring >= %{gnome_keyring_version}
190
191%description -n gnome-python-gnomekeyring
192This module contains a wrapper that allows the use of gnome-keyring
193via Python.
194
195%package -n gnome-python-evince
196Summary: Python bindings for interacting with evince
197Group: Development/Libraries
198Requires: %{name} = %{version}-%{release}
199Requires: evince
200
201%description -n gnome-python-evince
202This module contains a wrapper that allows the use of evince
203via Python.
204
205%prep
206%setup -q -n gnome-python-desktop-%{version}
207
208%build
209./waf configure --prefix=%{_prefix} --libdir=%{_libdir} --enable-metacity
210./waf build %{?_smp_mflags}
211
212%install
213rm -rf $RPM_BUILD_ROOT
214./waf install --destdir=$RPM_BUILD_ROOT
215
216find $RPM_BUILD_ROOT -name '*.la' -exec rm {} \;
217
218rm -rf $RPM_BUILD_ROOT/%{_libdir}/python*/site-packages/gtk-2.0/gksu
219
220%clean
221rm -rf $RPM_BUILD_ROOT
222
223%files
224%defattr(-,root,root,-)
225%doc AUTHORS ChangeLog NEWS
226%{_libdir}/pkgconfig/gnome-python-desktop-2.0.pc
227%{_datadir}/pygtk
228
229%files -n gnome-python-applet
230%defattr(-,root,root,-)
231%{python_sitearch}/gtk-2.0/gnomeapplet.so
232%defattr(644,root,root,755)
233%doc ../gnome-python-desktop-%{version}/examples/applet/*
234
235%files -n gnome-python-bugbuddy
236%defattr(-,root,root,-)
237%{python_sitearch}/gtk-2.0/bugbuddy.py*
238
239%files -n gnome-python-evolution
240%defattr(-,root,root,-)
241%dir %{python_sitearch}/gtk-2.0/evolution/
242%{python_sitearch}/gtk-2.0/evolution/*
243
244%files -n gnome-python-gnomeprint
245%defattr(-,root,root,-)
246%{python_sitearch}/gtk-2.0/gnomeprint/
247%{_datadir}/gtk-doc/html/pygnomeprint
248%{_datadir}/gtk-doc/html/pygnomeprintui
249%defattr(644,root,root,755)
250%doc ../gnome-python-desktop-%{version}/examples/gnomeprint/*
251
252%files -n gnome-python-gtksourceview
253%defattr(-,root,root,-)
254%{python_sitearch}/gtk-2.0/gtksourceview.so
255%{_datadir}/gtk-doc/html/pygtksourceview
256%defattr(644,root,root,755)
257%doc ../gnome-python-desktop-%{version}/examples/gtksourceview/*
258
259%files -n gnome-python-libwnck
260%defattr(-,root,root,-)
261%{python_sitearch}/gtk-2.0/wnck.so
262%defattr(644,root,root,755)
263%doc ../gnome-python-desktop-%{version}/examples/wnck_example.py
264
265%files -n gnome-python-libgtop2
266%defattr(-,root,root,-)
267%{python_sitearch}/gtk-2.0/gtop.so
268
269%files -n gnome-python-brasero
270%defattr(-,root,root,-)
271%{python_sitearch}/gtk-2.0/braseroburn.so
272%{python_sitearch}/gtk-2.0/braseromedia.so
273%defattr(644,root,root,755)
274%doc ../gnome-python-desktop-%{version}/examples/braseroburn/*
275%doc ../gnome-python-desktop-%{version}/examples/braseromedia/*
276
277%files -n gnome-python-metacity
278%defattr(-,root,root,-)
279%{python_sitearch}/gtk-2.0/metacity.so
280
281%files -n gnome-python-totem
282%defattr(-,root,root,-)
283%{python_sitearch}/gtk-2.0/mediaprofiles.so
284%{python_sitearch}/gtk-2.0/totem
285
286%files -n gnome-python-rsvg
287%{python_sitearch}/gtk-2.0/rsvg.so
288%defattr(644,root,root,755)
289%doc ../gnome-python-desktop-%{version}/examples/rsvg/*
290
291%files -n gnome-python-gnomedesktop
292%{python_sitearch}/gtk-2.0/gnomedesktop
293
294%files -n gnome-python-gnomekeyring
295%{python_sitearch}/gtk-2.0/gnomekeyring.so
296%defattr(644,root,root,755)
297%doc ../gnome-python-desktop-%{version}/examples/keyring*.py
298
299%files -n gnome-python-evince
300%{python_sitearch}/gtk-2.0/evince.so
301
302%changelog
303* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.0-2
304- rebuild for python-2.6
305
306* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.0-1
307- new upstream release
308- added gnome-python-brasero, gnome-python-evince package
309- remove gnome-python-nautilus-cd-burner package
310- used waf instead of configure script
311
312* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
313- new upstream release
314
315* Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.24.0-1
316- new upstream release
317- added BuildRequires: pycairo-devel
318
319* Wed Jul 23 2008 Shu KONNO <owa@bg.wakwak.com> - 2.20.0-3
320- rebuilt with python-2.5.2
321
322* Wed Apr 16 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.20.0-2
323- re-enable BuildRequires: gnome-python-devel
324
325* Mon Apr  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.22.0-1vl5
326- new upstream release
327- added gnome-python-evolution subpackage
328
329* Wed Jan  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.20.0-0vl1
330- new upstream release
331
332* Sun Jul 08 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.18.0-1vl2
333- add BuildRequires: gnome-media
334
335* Sat Jul  7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.18.0-1vl1
336- initial build for Vine Linux
337
338* Mon Mar 12 2007 Matthew Barnes <mbarnes@redhat.com> - 2.18.0-1.fc7
339- Update to 2.18.0
340
341* Wed Feb 28 2007 Matthias Clasen <mclasen@redhat.com> - 2.17.93-1
342- Update to 2.17.93
343
344* Sun Feb 25 2007 Matthew Barnes <mbarnes@redhat.com> - 2.17.92-1.fc7
345- Update to 2.17.92
346- Remove patch for GNOME bug #401760 (fixed upstream).
347
348* Mon Feb 05 2007 Matthew Barnes <mbarnes@redhat.com> - 2.17.3-3.fc7
349- Add patch for GNOME bug #401760 (plparser fails to build).
350
351* Mon Feb 05 2007 Matthew Barnes <mbarnes@redhat.com> - 2.17.3-2.fc7
352- Rename spec file to gnome-python2-desktop.spec (RH bug #225832).
353
354* Mon Jan 08 2007 Matthew Barnes <mbarnes@redhat.com> - 2.17.3-1
355- Update to 2.17.3
356
357* Sun Jan 07 2007 Matthew Barnes <mbarnes@redhat.com> - 2.17.2-1
358- Update to 2.17.2
359- New gnome-python2-bugbuddy subpackage.
360- Update version requirements to match configure.ac.
361- Use python_sitearch macro for installing libraries.
362
363* Thu Dec  7 2006 Jeremy Katz <katzj@redhat.com> - 2.17.1-2
364- rebuild for python 2.5
365- BR gnome-python2-devel
366
367* Sat Oct 21 2006 Matthias Clasen <mclasen@redhat.com> - 2.17.1-1
368- Update to 2.17.1
369
370* Tue Sep  5 2006 Matthias Clasen <mclasen@redhat.com> - 2.16.0-1.fc6
371- Update to 2.16.0
372
373* Tue Aug 22 2006 Dan Williams <dcbw@redhat.com> - 2.15.90-2.fc6
374- Remove unecessary dependencies on gnome-python2-desktop from
375    -libwnck and -rsvg subpackages (OLPC)
376
377* Fri Aug  4 2006 Matthias Clasen <mclasen@redhat.com> - 2.15.90-1.fc6
378- Update to 2.15.90
379
380* Thu Jul 20 2006 Matthias Clasen <mclasen@redhat.com> - 2.15.4-2
381- Rebuild against dbus
382
383* Thu Jul 13 2006 Matthias Clasen <mclasen@redhat.com> - 2.15.4-1
384- Update to 2.15.4
385
386* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.15.3-4.1
387- rebuild
388
389* Thu Jun 15 2006 Jesse Keating <jkeating@redhat.com> - 2.15.3-4
390- Create gnomekeyring subpackage
391- block out the nautilus-cd stuff
392
393* Thu Jun 15 2006 Jesse Keating <jkeating@redhat.com> - 2.15.3-2
394- Bump for new nautilus-cd-burner
395
396* Tue Jun 13 2006 Matthias Clasen <mclasen@redhat.com> - 2.15.3-1
397- Update to 2.15.3
398
399* Tue May 30 2006 Matthias Clasen <mclasen@redhat.com> - 2.15.2-1
400- Update to 2.15.2
401- Add subpackages gnome-python2-rsvg and gnome-python2-gnomedesktop
402
403* Wed May 24 2006 John (J5) Palmieri <johnp@redhat.com> - 2.14.0-2
404- Add pygtk2 BR
405
406* Mon Mar 13 2006 Ray Strode <rstrode@redhat.de> 2.14.0-1
407- Update to 2.14.0
408
409* Tue Feb 28 2006 Karsten Hopp <karsten@redhat.de> 2.13.3-2
410- Buildrequires: python-devel
411
412* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.13.3-1.1
413- bump again for double-long bug on ppc(64)
414
415* Mon Feb  6 2006 John (J5) Palmieri <johnp@redhat.com> - 2.13.3-1
416- Initial build.
417
Note: See TracBrowser for help on using the repository browser.