source: projects/specs/trunk/g/gnome-python-desktop/gnome-python-desktop-vl.spec @ 5701

Revision 5701, 14.1 KB checked in by Takemikaduchi, 12 years ago (diff)

python-2.7.2

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3%define glib_version 2.26.0
4%define gtk_version 2.22.0
5%define pygtk_version 2.22.0
6%define gnome_python_version 2.28.0
7%define libgnome_keyring_version 2.32.0
8%define gnome_panel_version 2.32.0
9%define gnome_desktop_version 2.32.0
10%define gtksourceview2_version 2.10.5
11%define libgtop_version 2.28.2
12%define gnome_media_version 2.32.0
13%define metacity_version 2.30.3
14%define librsvg2_version 2.32.0
15%define totem_version 2.32.0
16%define libwnck_version 2.30.5
17%define bug_buddy_version 2.32.0
18%define evolution_data_server_version 2.32.0
19
20### Abstract ###
21
22Name: gnome-python-desktop
23Version: 2.32.0
24Release: 2%{?_dist_release}
25License: GPL/LGPL
26Group: Development/Libraries
27Summary: The sources for additional PyGNOME Python extension modules
28BuildRoot: %{_tmppath}/%{name}-%{version}-root
29Source: gnome-python-desktop-%{version}.tar.bz2
30
31### Dependencies ###
32
33Requires: gnome-python >= %{gnome_python_version}
34
35### Build Dependencies ###
36
37BuildRequires: glib2-devel >= %{glib_version}
38BuildRequires: gtk2-devel >= %{gtk_version}
39BuildRequires: python >= 2.6
40BuildRequires: pygtk2-devel >= %{pygtk_version}
41BuildRequires: gnome-python-devel >= %{gnome_python_version}
42BuildRequires: libgnome-keyring-devel >= %{libgnome_keyring_version}
43# BuildRequires: gnome-panel-devel >= %{gnome_panel_version}
44BuildRequires: gnome-desktop-devel >= %{gnome_desktop_version}
45BuildRequires: libgnomeprint-devel
46BuildRequires: libgnomeprintui-devel
47# BuildRequires: evince-devel
48BuildRequires: evolution-data-server >= %{evolution_data_server_version}
49BuildRequires: gtksourceview-devel >= %{gtksourceview_version}
50BuildRequires: libgtop2-devel >= %{libgtop_version}
51BuildRequires: gnome-media-devel >= %{gnome_media_version}
52BuildRequires: metacity-devel >= %{metacity_version}
53# BuildRequires: brasero-devel
54BuildRequires: librsvg2-devel >= %{librsvg2_version}
55BuildRequires: pycairo-devel
56BuildRequires: totem-pl-parser-devel >= %{totem_version}
57BuildRequires: totem >= %{totem_version}
58BuildRequires: libwnck-devel >= %{libwnck_version}
59BuildRequires: bug-buddy >= %{bug_buddy_version}
60BuildRequires: libSM-devel
61
62Obsoletes: gnome-python-applet < 2.32.0-2
63Obsoletes: gnome-python-brasero < 2.32.0-2
64Obsoletes: gnome-python-evince < 2.32.0-2
65
66%description
67The gnome-python-desktop package contains the source packages for additional
68Python bindings for GNOME. It should be used together with gnome-python.
69
70## %package -n gnome-python-applet
71## Summary: Python bindings for GNOME Panel applets.
72## Group: Development/Libraries
73## Requires: %{name} = %{version}-%{release}
74## Obsoletes: pygnome-applet
75
76## %description -n gnome-python-applet
77## This module contains a wrapper that allows GNOME Panel applets to be
78## written in Python.
79
80%package -n gnome-python-bugbuddy
81Summary: Python bindings for interacting with bug-buddy
82Group: Development/Libraries
83Requires: %{name} = %{version}-%{release}
84Requires: bug-buddy >= %{bug_buddy_version}
85
86%description -n gnome-python-bugbuddy
87This module contains a wrapper that allows the use of bug-buddy via
88Python.
89
90%package -n gnome-python-evolution
91Summary: Python bindings for interacting with evolution
92Group: Development/Libraries
93Requires: %{name} = %{version}-%{release}
94Requires: evolution-data-server >= %{evolution_data_server_version}
95
96%description -n gnome-python-evolution
97This module contains a wrapper that allows the use of evolution via
98Python.
99
100%package -n gnome-python-gnomeprint
101Summary: Python bindings for interacting with libgnomeprint
102Group: Development/Libraries
103Requires: %{name} = %{version}-%{release}
104Requires: libgnomeprint
105Requires: libgnomeprintui
106
107%description -n gnome-python-gnomeprint
108This module contains a wrapper that allows the use of libgnomeprint via
109Python.
110
111%package -n gnome-python-gtksourceview
112Summary: Python bindings for interacting with the gtksourceview library
113Group: Development/Libraries
114Requires: %{name} = %{version}-%{release}
115Requires: gtksourceview >= %{gtksourceview_version}
116Requires: gnome-python-gnomeprint
117
118%description -n gnome-python-gtksourceview
119This module contains a wrapper that allows the use of gtksourceview via
120Python.
121
122%package -n gnome-python-libwnck
123Summary: Python bindings for interacting with libwnck
124Group: Development/Libraries
125Requires: libwnck >= %{libwnck_version}
126
127%description -n gnome-python-libwnck
128This module contains a wrapper that allows the use of libwnck via
129Python.
130
131%package -n gnome-python-libgtop2
132Summary: Python bindings for interacting with libgtop
133Group: Development/Libraries
134Requires: %{name} = %{version}-%{release}
135Requires: libgtop2 >= %{libgtop_version}
136
137%description -n gnome-python-libgtop2
138This module contains a wrapper that allows the use of libgtop via
139Python.
140
141## %package -n gnome-python-brasero
142## Summary: Python bindings for interacting with brasero
143## Group: Development/Libraries
144## Requires: %{name} = %{version}-%{release}
145## Requires: brasero-libs
146
147## %description -n gnome-python-brasero
148## This module contains a wrapper that allows the use of brasero
149## via Python.
150
151%package -n gnome-python-metacity
152Summary: Python bindings for interacting with metacity
153Group: Development/Libraries
154Requires: %{name} = %{version}-%{release}
155Requires: metacity >= %{metacity_version}
156
157%description -n gnome-python-metacity
158This module contains a wrapper that allows the use of metacity
159via Python.
160
161%package -n gnome-python-totem
162Summary: Python bindings for interacting with totem
163Group: Development/Libraries
164Requires: %{name} = %{version}-%{release}
165Requires: totem >= %{totem_version}
166
167%description -n gnome-python-totem
168This module contains a wrapper that allows the use of totem
169via Python.
170
171%package -n gnome-python-rsvg
172Summary: Python bindings for interacting with librsvg
173Group: Development/Libraries
174Requires: librsvg2 >= %{librsvg2_version}
175Requires: pycairo
176
177%description -n gnome-python-rsvg
178This module contains a wrapper that allows the use of librsvg
179via Python.
180
181%package -n gnome-python-gnomedesktop
182Summary: Python bindings for interacting with gnome-desktop
183Group: Development/Libraries
184Requires: %{name} = %{version}-%{release}
185Requires: gnome-desktop >= %{gnome_desktop_version}
186
187%description -n gnome-python-gnomedesktop
188This module contains a wrapper that allows the use of gnome-desktop
189via Python.
190
191%package -n gnome-python-gnomekeyring
192Summary: Python bindings for interacting with gnome-keyring
193Group: Development/Libraries
194Requires: %{name} = %{version}-%{release}
195Requires: libgnome-keyring >= %{libgnome_keyring_version}
196
197%description -n gnome-python-gnomekeyring
198This module contains a wrapper that allows the use of gnome-keyring
199via Python.
200
201## %package -n gnome-python-evince
202## Summary: Python bindings for interacting with evince
203## Group: Development/Libraries
204## Requires: %{name} = %{version}-%{release}
205## Requires: evince
206
207## %description -n gnome-python-evince
208## This module contains a wrapper that allows the use of evince
209## via Python.
210
211%prep
212%setup -q -n gnome-python-desktop-%{version}
213
214%build
215./waf configure --prefix=%{_prefix} --libdir=%{_libdir} --enable-metacity
216./waf build %{?_smp_mflags}
217
218%install
219rm -rf $RPM_BUILD_ROOT
220./waf install --destdir=$RPM_BUILD_ROOT
221
222find $RPM_BUILD_ROOT -name '*.la' -exec rm {} \;
223
224rm -rf $RPM_BUILD_ROOT/%{_libdir}/python*/site-packages/gtk-2.0/gksu
225
226%clean
227rm -rf $RPM_BUILD_ROOT
228
229%files
230%defattr(-,root,root,-)
231%doc AUTHORS ChangeLog NEWS
232%{_libdir}/pkgconfig/gnome-python-desktop-2.0.pc
233%{_datadir}/pygtk
234
235## %files -n gnome-python-applet
236## %defattr(-,root,root,-)
237## %{python_sitearch}/gtk-2.0/gnomeapplet.so
238## %defattr(644,root,root,755)
239## %doc ../gnome-python-desktop-%{version}/examples/applet/*
240
241%files -n gnome-python-bugbuddy
242%defattr(-,root,root,-)
243%{python_sitearch}/gtk-2.0/bugbuddy.py*
244
245%files -n gnome-python-evolution
246%defattr(-,root,root,-)
247%dir %{python_sitearch}/gtk-2.0/evolution/
248%{python_sitearch}/gtk-2.0/evolution/*
249
250%files -n gnome-python-gnomeprint
251%defattr(-,root,root,-)
252%{python_sitearch}/gtk-2.0/gnomeprint/
253%{_datadir}/gtk-doc/html/pygnomeprint
254%{_datadir}/gtk-doc/html/pygnomeprintui
255%defattr(644,root,root,755)
256%doc ../gnome-python-desktop-%{version}/examples/gnomeprint/*
257
258%files -n gnome-python-gtksourceview
259%defattr(-,root,root,-)
260%{python_sitearch}/gtk-2.0/gtksourceview.so
261%{_datadir}/gtk-doc/html/pygtksourceview
262%defattr(644,root,root,755)
263%doc ../gnome-python-desktop-%{version}/examples/gtksourceview/*
264
265%files -n gnome-python-libwnck
266%defattr(-,root,root,-)
267%{python_sitearch}/gtk-2.0/wnck.so
268%defattr(644,root,root,755)
269%doc ../gnome-python-desktop-%{version}/examples/wnck_example.py
270
271%files -n gnome-python-libgtop2
272%defattr(-,root,root,-)
273%{python_sitearch}/gtk-2.0/gtop.so
274
275## %files -n gnome-python-brasero
276## %defattr(-,root,root,-)
277#%{python_sitearch}/gtk-2.0/braseroburn.so
278#%{python_sitearch}/gtk-2.0/braseromedia.so
279## %defattr(644,root,root,755)
280## %doc ../gnome-python-desktop-%{version}/examples/braseroburn/*
281## %doc ../gnome-python-desktop-%{version}/examples/braseromedia/*
282
283%files -n gnome-python-metacity
284%defattr(-,root,root,-)
285%{python_sitearch}/gtk-2.0/metacity.so
286
287%files -n gnome-python-totem
288%defattr(-,root,root,-)
289%{python_sitearch}/gtk-2.0/mediaprofiles.so
290%{python_sitearch}/gtk-2.0/totem
291
292%files -n gnome-python-rsvg
293%{python_sitearch}/gtk-2.0/rsvg.so
294%defattr(644,root,root,755)
295%doc ../gnome-python-desktop-%{version}/examples/rsvg/*
296
297%files -n gnome-python-gnomedesktop
298%{python_sitearch}/gtk-2.0/gnomedesktop
299
300%files -n gnome-python-gnomekeyring
301%{python_sitearch}/gtk-2.0/gnomekeyring.so
302%defattr(644,root,root,755)
303%doc ../gnome-python-desktop-%{version}/examples/keyring*.py
304
305## %files -n gnome-python-evince
306## %{python_sitearch}/gtk-2.0/evince.so
307
308%changelog
309* Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-2
310- rebuild with python-2.7.2
311- drop gnome-python-{applets,brasero,evince} sub packages
312
313* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
314- new upstream release
315
316* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-2
317- rebuild with rpm-4.8.1 for pkg-config file
318- change BuildRequires: gnome-panel-devel instead of gnome-panel
319- change BuildRequires: gnome-media-devel instead of gnome-media
320- add BuildRequires: libSM-devel
321
322* Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
323- new upstream release
324
325* Sat Apr 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
326- new upstream release
327- add BuildRequires: totem
328- change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
329
330* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.0-2
331- rebuild for python-2.6
332
333* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.0-1
334- new upstream release
335- added gnome-python-brasero, gnome-python-evince package
336- remove gnome-python-nautilus-cd-burner package
337- used waf instead of configure script
338
339* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
340- new upstream release
341
342* Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.24.0-1
343- new upstream release
344- added BuildRequires: pycairo-devel
345
346* Wed Jul 23 2008 Shu KONNO <owa@bg.wakwak.com> - 2.20.0-3
347- rebuilt with python-2.5.2
348
349* Wed Apr 16 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.20.0-2
350- re-enable BuildRequires: gnome-python-devel
351
352* Mon Apr  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.22.0-1vl5
353- new upstream release
354- added gnome-python-evolution subpackage
355
356* Wed Jan  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.20.0-0vl1
357- new upstream release
358
359* Sun Jul 08 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.18.0-1vl2
360- add BuildRequires: gnome-media
361
362* Sat Jul  7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.18.0-1vl1
363- initial build for Vine Linux
364
365* Mon Mar 12 2007 Matthew Barnes <mbarnes@redhat.com> - 2.18.0-1.fc7
366- Update to 2.18.0
367
368* Wed Feb 28 2007 Matthias Clasen <mclasen@redhat.com> - 2.17.93-1
369- Update to 2.17.93
370
371* Sun Feb 25 2007 Matthew Barnes <mbarnes@redhat.com> - 2.17.92-1.fc7
372- Update to 2.17.92
373- Remove patch for GNOME bug #401760 (fixed upstream).
374
375* Mon Feb 05 2007 Matthew Barnes <mbarnes@redhat.com> - 2.17.3-3.fc7
376- Add patch for GNOME bug #401760 (plparser fails to build).
377
378* Mon Feb 05 2007 Matthew Barnes <mbarnes@redhat.com> - 2.17.3-2.fc7
379- Rename spec file to gnome-python2-desktop.spec (RH bug #225832).
380
381* Mon Jan 08 2007 Matthew Barnes <mbarnes@redhat.com> - 2.17.3-1
382- Update to 2.17.3
383
384* Sun Jan 07 2007 Matthew Barnes <mbarnes@redhat.com> - 2.17.2-1
385- Update to 2.17.2
386- New gnome-python2-bugbuddy subpackage.
387- Update version requirements to match configure.ac.
388- Use python_sitearch macro for installing libraries.
389
390* Thu Dec  7 2006 Jeremy Katz <katzj@redhat.com> - 2.17.1-2
391- rebuild for python 2.5
392- BR gnome-python2-devel
393
394* Sat Oct 21 2006 Matthias Clasen <mclasen@redhat.com> - 2.17.1-1
395- Update to 2.17.1
396
397* Tue Sep  5 2006 Matthias Clasen <mclasen@redhat.com> - 2.16.0-1.fc6
398- Update to 2.16.0
399
400* Tue Aug 22 2006 Dan Williams <dcbw@redhat.com> - 2.15.90-2.fc6
401- Remove unecessary dependencies on gnome-python2-desktop from
402    -libwnck and -rsvg subpackages (OLPC)
403
404* Fri Aug  4 2006 Matthias Clasen <mclasen@redhat.com> - 2.15.90-1.fc6
405- Update to 2.15.90
406
407* Thu Jul 20 2006 Matthias Clasen <mclasen@redhat.com> - 2.15.4-2
408- Rebuild against dbus
409
410* Thu Jul 13 2006 Matthias Clasen <mclasen@redhat.com> - 2.15.4-1
411- Update to 2.15.4
412
413* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.15.3-4.1
414- rebuild
415
416* Thu Jun 15 2006 Jesse Keating <jkeating@redhat.com> - 2.15.3-4
417- Create gnomekeyring subpackage
418- block out the nautilus-cd stuff
419
420* Thu Jun 15 2006 Jesse Keating <jkeating@redhat.com> - 2.15.3-2
421- Bump for new nautilus-cd-burner
422
423* Tue Jun 13 2006 Matthias Clasen <mclasen@redhat.com> - 2.15.3-1
424- Update to 2.15.3
425
426* Tue May 30 2006 Matthias Clasen <mclasen@redhat.com> - 2.15.2-1
427- Update to 2.15.2
428- Add subpackages gnome-python2-rsvg and gnome-python2-gnomedesktop
429
430* Wed May 24 2006 John (J5) Palmieri <johnp@redhat.com> - 2.14.0-2
431- Add pygtk2 BR
432
433* Mon Mar 13 2006 Ray Strode <rstrode@redhat.de> 2.14.0-1
434- Update to 2.14.0
435
436* Tue Feb 28 2006 Karsten Hopp <karsten@redhat.de> 2.13.3-2
437- Buildrequires: python-devel
438
439* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.13.3-1.1
440- bump again for double-long bug on ppc(64)
441
442* Mon Feb  6 2006 John (J5) Palmieri <johnp@redhat.com> - 2.13.3-1
443- Initial build.
444
Note: See TracBrowser for help on using the repository browser.