source: projects/specs/trunk/g/gnome-python-desktop/gnome-python-desktop-vl.spec @ 1231

Revision 1231, 13.4 KB checked in by Takemikaduchi, 14 years ago (diff)

update libchamplain, libgda, anjuta, evolution, ekiga, evolution-data-server, gnome-python-desktop, gmime, glibmm, gtkhtml3, gtksourceview2, gnome-color-manager, gtkmm2, opal, pango, ptlib, tracker, totem-pl-parser

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3%define glib_version 2.24.0
4%define gtk_version 2.20.0
5%define pygtk_version 2.14.0
6%define gnome_python_version 2.28.0
7%define libgnome_keyring_version 2.30.0
8%define gnome_panel_version 2.30.0
9%define gnome_desktop_version 2.30.0
10%define gtksourceview_version 1.1.90
11%define libgtop_version 2.28.0
12%define gnome_media_version 2.30.0
13%define metacity_version 2.30.0
14%define librsvg2_version 2.26.0
15%define totem_version 2.30.0
16%define libwnck_version 2.30.0
17%define bug_buddy_version 2.30.0
18%define evolution_data_server_version 2.30.0
19
20### Abstract ###
21
22Name: gnome-python-desktop
23Version: 2.30.2
24Release: 1%{?_dist_release}
25License: GPL/LGPL
26Group: Development/Libraries
27Summary: The sources for additional PyGNOME Python extension modules
28BuildRoot: %{_tmppath}/%{name}-%{version}-root
29Source: gnome-python-desktop-%{version}.tar.bz2
30
31### Dependencies ###
32
33Requires: gnome-python >= %{gnome_python_version}
34
35### Build Dependencies ###
36
37BuildRequires: glib2-devel >= %{glib_version}
38BuildRequires: gtk2-devel >= %{gtk_version}
39BuildRequires: python >= 2.6
40BuildRequires: pygtk2-devel >= %{pygtk_version}
41BuildRequires: gnome-python-devel >= %{gnome_python_version}
42BuildRequires: libgnome-keyring-devel >= %{libgnome_keyring_version}
43BuildRequires: gnome-panel >= %{gnome_panel_version}
44BuildRequires: gnome-desktop-devel >= %{gnome_desktop_version}
45BuildRequires: libgnomeprint-devel
46BuildRequires: libgnomeprintui-devel
47BuildRequires: evince-devel
48BuildRequires: evolution-data-server >= %{evolution_data_server_version}
49BuildRequires: gtksourceview-devel >= %{gtksourceview_version}
50BuildRequires: libgtop2-devel >= %{libgtop_version}
51BuildRequires: gnome-media >= %{gnome_media_version}
52BuildRequires: metacity-devel >= %{metacity_version}
53BuildRequires: brasero-devel
54BuildRequires: librsvg2-devel >= %{librsvg2_version}
55BuildRequires: pycairo-devel
56BuildRequires: totem-pl-parser-devel >= %{totem_version}
57BuildRequires: totem >= %{totem_version}
58BuildRequires: libwnck-devel >= %{libwnck_version}
59BuildRequires: bug-buddy >= %{bug_buddy_version}
60
61%description
62The gnome-python-desktop package contains the source packages for additional
63Python bindings for GNOME. It should be used together with gnome-python.
64
65%package -n gnome-python-applet
66Summary: Python bindings for GNOME Panel applets.
67Group: Development/Libraries
68Requires: %{name} = %{version}-%{release}
69# applets from GNOME 1.4 are no longer supported - we only have 1 panel
70Obsoletes: pygnome-applet
71
72%description -n gnome-python-applet
73This module contains a wrapper that allows GNOME Panel applets to be
74written in Python.
75
76%package -n gnome-python-bugbuddy
77Summary: Python bindings for interacting with bug-buddy
78Group: Development/Libraries
79Requires: %{name} = %{version}-%{release}
80Requires: bug-buddy >= %{bug_buddy_version}
81
82%description -n gnome-python-bugbuddy
83This module contains a wrapper that allows the use of bug-buddy via
84Python.
85
86%package -n gnome-python-evolution
87Summary: Python bindings for interacting with evolution
88Group: Development/Libraries
89Requires: %{name} = %{version}-%{release}
90Requires: evolution-data-server >= %{evolution_data_server_version}
91
92%description -n gnome-python-evolution
93This module contains a wrapper that allows the use of evolution via
94Python.
95
96%package -n gnome-python-gnomeprint
97Summary: Python bindings for interacting with libgnomeprint
98Group: Development/Libraries
99Requires: %{name} = %{version}-%{release}
100Requires: libgnomeprint
101Requires: libgnomeprintui
102
103%description -n gnome-python-gnomeprint
104This module contains a wrapper that allows the use of libgnomeprint via
105Python.
106
107%package -n gnome-python-gtksourceview
108Summary: Python bindings for interacting with the gtksourceview library
109Group: Development/Libraries
110Requires: %{name} = %{version}-%{release}
111Requires: gtksourceview >= %{gtksourceview_version}
112Requires: gnome-python-gnomeprint
113
114%description -n gnome-python-gtksourceview
115This module contains a wrapper that allows the use of gtksourceview via
116Python.
117
118%package -n gnome-python-libwnck
119Summary: Python bindings for interacting with libwnck
120Group: Development/Libraries
121Requires: libwnck >= %{libwnck_version}
122
123%description -n gnome-python-libwnck
124This module contains a wrapper that allows the use of libwnck via
125Python.
126
127%package -n gnome-python-libgtop2
128Summary: Python bindings for interacting with libgtop
129Group: Development/Libraries
130Requires: %{name} = %{version}-%{release}
131Requires: libgtop2 >= %{libgtop_version}
132
133%description -n gnome-python-libgtop2
134This module contains a wrapper that allows the use of libgtop via
135Python.
136
137%package -n gnome-python-brasero
138Summary: Python bindings for interacting with brasero
139Group: Development/Libraries
140Requires: %{name} = %{version}-%{release}
141Requires: brasero-libs
142
143%description -n gnome-python-brasero
144This module contains a wrapper that allows the use of brasero
145via Python.
146
147%package -n gnome-python-metacity
148Summary: Python bindings for interacting with metacity
149Group: Development/Libraries
150Requires: %{name} = %{version}-%{release}
151Requires: metacity >= %{metacity_version}
152
153%description -n gnome-python-metacity
154This module contains a wrapper that allows the use of metacity
155via Python.
156
157%package -n gnome-python-totem
158Summary: Python bindings for interacting with totem
159Group: Development/Libraries
160Requires: %{name} = %{version}-%{release}
161Requires: totem >= %{totem_version}
162
163%description -n gnome-python-totem
164This module contains a wrapper that allows the use of totem
165via Python.
166
167%package -n gnome-python-rsvg
168Summary: Python bindings for interacting with librsvg
169Group: Development/Libraries
170Requires: librsvg2 >= %{librsvg2_version}
171Requires: pycairo
172
173%description -n gnome-python-rsvg
174This module contains a wrapper that allows the use of librsvg
175via Python.
176
177%package -n gnome-python-gnomedesktop
178Summary: Python bindings for interacting with gnome-desktop
179Group: Development/Libraries
180Requires: %{name} = %{version}-%{release}
181Requires: gnome-desktop >= %{gnome_desktop_version}
182
183%description -n gnome-python-gnomedesktop
184This module contains a wrapper that allows the use of gnome-desktop
185via Python.
186
187%package -n gnome-python-gnomekeyring
188Summary: Python bindings for interacting with gnome-keyring
189Group: Development/Libraries
190Requires: %{name} = %{version}-%{release}
191Requires: libgnome-keyring >= %{libgnome_keyring_version}
192
193%description -n gnome-python-gnomekeyring
194This module contains a wrapper that allows the use of gnome-keyring
195via Python.
196
197%package -n gnome-python-evince
198Summary: Python bindings for interacting with evince
199Group: Development/Libraries
200Requires: %{name} = %{version}-%{release}
201Requires: evince
202
203%description -n gnome-python-evince
204This module contains a wrapper that allows the use of evince
205via Python.
206
207%prep
208%setup -q -n gnome-python-desktop-%{version}
209
210%build
211./waf configure --prefix=%{_prefix} --libdir=%{_libdir} --enable-metacity
212./waf build %{?_smp_mflags}
213
214%install
215rm -rf $RPM_BUILD_ROOT
216./waf install --destdir=$RPM_BUILD_ROOT
217
218find $RPM_BUILD_ROOT -name '*.la' -exec rm {} \;
219
220rm -rf $RPM_BUILD_ROOT/%{_libdir}/python*/site-packages/gtk-2.0/gksu
221
222%clean
223rm -rf $RPM_BUILD_ROOT
224
225%files
226%defattr(-,root,root,-)
227%doc AUTHORS ChangeLog NEWS
228%{_libdir}/pkgconfig/gnome-python-desktop-2.0.pc
229%{_datadir}/pygtk
230
231%files -n gnome-python-applet
232%defattr(-,root,root,-)
233%{python_sitearch}/gtk-2.0/gnomeapplet.so
234%defattr(644,root,root,755)
235%doc ../gnome-python-desktop-%{version}/examples/applet/*
236
237%files -n gnome-python-bugbuddy
238%defattr(-,root,root,-)
239%{python_sitearch}/gtk-2.0/bugbuddy.py*
240
241%files -n gnome-python-evolution
242%defattr(-,root,root,-)
243%dir %{python_sitearch}/gtk-2.0/evolution/
244%{python_sitearch}/gtk-2.0/evolution/*
245
246%files -n gnome-python-gnomeprint
247%defattr(-,root,root,-)
248%{python_sitearch}/gtk-2.0/gnomeprint/
249%{_datadir}/gtk-doc/html/pygnomeprint
250%{_datadir}/gtk-doc/html/pygnomeprintui
251%defattr(644,root,root,755)
252%doc ../gnome-python-desktop-%{version}/examples/gnomeprint/*
253
254%files -n gnome-python-gtksourceview
255%defattr(-,root,root,-)
256%{python_sitearch}/gtk-2.0/gtksourceview.so
257%{_datadir}/gtk-doc/html/pygtksourceview
258%defattr(644,root,root,755)
259%doc ../gnome-python-desktop-%{version}/examples/gtksourceview/*
260
261%files -n gnome-python-libwnck
262%defattr(-,root,root,-)
263%{python_sitearch}/gtk-2.0/wnck.so
264%defattr(644,root,root,755)
265%doc ../gnome-python-desktop-%{version}/examples/wnck_example.py
266
267%files -n gnome-python-libgtop2
268%defattr(-,root,root,-)
269%{python_sitearch}/gtk-2.0/gtop.so
270
271%files -n gnome-python-brasero
272%defattr(-,root,root,-)
273%{python_sitearch}/gtk-2.0/braseroburn.so
274%{python_sitearch}/gtk-2.0/braseromedia.so
275%defattr(644,root,root,755)
276%doc ../gnome-python-desktop-%{version}/examples/braseroburn/*
277%doc ../gnome-python-desktop-%{version}/examples/braseromedia/*
278
279%files -n gnome-python-metacity
280%defattr(-,root,root,-)
281%{python_sitearch}/gtk-2.0/metacity.so
282
283%files -n gnome-python-totem
284%defattr(-,root,root,-)
285%{python_sitearch}/gtk-2.0/mediaprofiles.so
286%{python_sitearch}/gtk-2.0/totem
287
288%files -n gnome-python-rsvg
289%{python_sitearch}/gtk-2.0/rsvg.so
290%defattr(644,root,root,755)
291%doc ../gnome-python-desktop-%{version}/examples/rsvg/*
292
293%files -n gnome-python-gnomedesktop
294%{python_sitearch}/gtk-2.0/gnomedesktop
295
296%files -n gnome-python-gnomekeyring
297%{python_sitearch}/gtk-2.0/gnomekeyring.so
298%defattr(644,root,root,755)
299%doc ../gnome-python-desktop-%{version}/examples/keyring*.py
300
301%files -n gnome-python-evince
302%{python_sitearch}/gtk-2.0/evince.so
303
304%changelog
305* Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
306- new upstream release
307
308* Sat Apr 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
309- new upstream release
310- add BuildRequires: totem
311- change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
312
313* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.0-2
314- rebuild for python-2.6
315
316* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.0-1
317- new upstream release
318- added gnome-python-brasero, gnome-python-evince package
319- remove gnome-python-nautilus-cd-burner package
320- used waf instead of configure script
321
322* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
323- new upstream release
324
325* Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.24.0-1
326- new upstream release
327- added BuildRequires: pycairo-devel
328
329* Wed Jul 23 2008 Shu KONNO <owa@bg.wakwak.com> - 2.20.0-3
330- rebuilt with python-2.5.2
331
332* Wed Apr 16 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.20.0-2
333- re-enable BuildRequires: gnome-python-devel
334
335* Mon Apr  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.22.0-1vl5
336- new upstream release
337- added gnome-python-evolution subpackage
338
339* Wed Jan  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.20.0-0vl1
340- new upstream release
341
342* Sun Jul 08 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.18.0-1vl2
343- add BuildRequires: gnome-media
344
345* Sat Jul  7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.18.0-1vl1
346- initial build for Vine Linux
347
348* Mon Mar 12 2007 Matthew Barnes <mbarnes@redhat.com> - 2.18.0-1.fc7
349- Update to 2.18.0
350
351* Wed Feb 28 2007 Matthias Clasen <mclasen@redhat.com> - 2.17.93-1
352- Update to 2.17.93
353
354* Sun Feb 25 2007 Matthew Barnes <mbarnes@redhat.com> - 2.17.92-1.fc7
355- Update to 2.17.92
356- Remove patch for GNOME bug #401760 (fixed upstream).
357
358* Mon Feb 05 2007 Matthew Barnes <mbarnes@redhat.com> - 2.17.3-3.fc7
359- Add patch for GNOME bug #401760 (plparser fails to build).
360
361* Mon Feb 05 2007 Matthew Barnes <mbarnes@redhat.com> - 2.17.3-2.fc7
362- Rename spec file to gnome-python2-desktop.spec (RH bug #225832).
363
364* Mon Jan 08 2007 Matthew Barnes <mbarnes@redhat.com> - 2.17.3-1
365- Update to 2.17.3
366
367* Sun Jan 07 2007 Matthew Barnes <mbarnes@redhat.com> - 2.17.2-1
368- Update to 2.17.2
369- New gnome-python2-bugbuddy subpackage.
370- Update version requirements to match configure.ac.
371- Use python_sitearch macro for installing libraries.
372
373* Thu Dec  7 2006 Jeremy Katz <katzj@redhat.com> - 2.17.1-2
374- rebuild for python 2.5
375- BR gnome-python2-devel
376
377* Sat Oct 21 2006 Matthias Clasen <mclasen@redhat.com> - 2.17.1-1
378- Update to 2.17.1
379
380* Tue Sep  5 2006 Matthias Clasen <mclasen@redhat.com> - 2.16.0-1.fc6
381- Update to 2.16.0
382
383* Tue Aug 22 2006 Dan Williams <dcbw@redhat.com> - 2.15.90-2.fc6
384- Remove unecessary dependencies on gnome-python2-desktop from
385    -libwnck and -rsvg subpackages (OLPC)
386
387* Fri Aug  4 2006 Matthias Clasen <mclasen@redhat.com> - 2.15.90-1.fc6
388- Update to 2.15.90
389
390* Thu Jul 20 2006 Matthias Clasen <mclasen@redhat.com> - 2.15.4-2
391- Rebuild against dbus
392
393* Thu Jul 13 2006 Matthias Clasen <mclasen@redhat.com> - 2.15.4-1
394- Update to 2.15.4
395
396* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.15.3-4.1
397- rebuild
398
399* Thu Jun 15 2006 Jesse Keating <jkeating@redhat.com> - 2.15.3-4
400- Create gnomekeyring subpackage
401- block out the nautilus-cd stuff
402
403* Thu Jun 15 2006 Jesse Keating <jkeating@redhat.com> - 2.15.3-2
404- Bump for new nautilus-cd-burner
405
406* Tue Jun 13 2006 Matthias Clasen <mclasen@redhat.com> - 2.15.3-1
407- Update to 2.15.3
408
409* Tue May 30 2006 Matthias Clasen <mclasen@redhat.com> - 2.15.2-1
410- Update to 2.15.2
411- Add subpackages gnome-python2-rsvg and gnome-python2-gnomedesktop
412
413* Wed May 24 2006 John (J5) Palmieri <johnp@redhat.com> - 2.14.0-2
414- Add pygtk2 BR
415
416* Mon Mar 13 2006 Ray Strode <rstrode@redhat.de> 2.14.0-1
417- Update to 2.14.0
418
419* Tue Feb 28 2006 Karsten Hopp <karsten@redhat.de> 2.13.3-2
420- Buildrequires: python-devel
421
422* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.13.3-1.1
423- bump again for double-long bug on ppc(64)
424
425* Mon Feb  6 2006 John (J5) Palmieri <johnp@redhat.com> - 2.13.3-1
426- Initial build.
427
Note: See TracBrowser for help on using the repository browser.