source: projects/specs/trunk/g/gnome-power-manager/gnome-power-manager-vl.spec @ 805

Revision 805, 11.5 KB checked in by Takemikaduchi, 14 years ago (diff)

change spec file of gnome-2.30

Line 
1%define dbus_version 1.2.24
2%define dbus_glib_version 0.82
3%define gnome_panel_version 2.30.0
4
5Summary: GNOME power management service
6Summary(ja): GNOME 電源管理ツール
7Name: gnome-power-manager
8Version: 2.30.0
9Release: 1%{?_dist_release}
10License: GPLv2+ and GFDL
11Group: Applications/System
12URL: http://projects.gnome.org/gnome-power-manager/
13
14Source: http://download.gnome.org/sources/gnome-power-manager/2.28/gnome-power-manager-%{version}.tar.bz2
15
16# for Vine Linux
17Patch10: gnome-power-manager-2.28.2-warningflags.patch
18Patch11: gnome-power-manager-2.28.2-math.patch
19
20BuildRoot: %{_tmppath}/%{name}-%{version}-root
21BuildRequires: autoconf >= 2.65
22BuildRequires: libgnomeui-devel
23BuildRequires: libglade2-devel
24BuildRequires: libwnck-devel
25BuildRequires: dbus-devel >= %{dbus_version}
26BuildRequires: libnotify-devel
27BuildRequires: gnome-panel >= %{gnome_panel_version}
28BuildRequires: scrollkeeper
29BuildRequires: gnome-doc-utils >= 0.3.2
30BuildRequires: desktop-file-utils
31BuildRequires: gettext
32BuildRequires: libtool
33BuildRequires: cairo-devel
34BuildRequires: libcanberra-devel >= 0.10
35BuildRequires: unique-devel >= 1.1.6
36## BuildRequires: DeviceKit-power-devel >= 008
37BuildRequires: upower-devel >= 0.9.0
38BuildRequires: intltool
39BuildRequires: docbook-utils
40Requires: gtk2 >= 2.10.0
41Requires: gnome-mime-data
42Requires: gnome-icon-theme
43Requires: libnotify >= 0.4.3
44Requires: dbus-glib >= %{dbus_glib_version}
45Requires: dbus-x11 >= %{dbus_version}
46Requires: libcanberra-gtk2 >= 0.10
47Requires: unique >= 1.1.6
48Requires: upower >= 0.9.0
49Requires(post,postun): scrollkeeper
50Requires(post,pre,preun): GConf2
51
52Vendor:       Project Vine
53Distribution: Vine Linux
54Packager:     daisuke, Takemikaduchi
55
56%description
57GNOME Power Manager uses the information and facilities provided by HAL
58displaying icons and handling user callbacks in an interactive GNOME session.
59GNOME Power Preferences allows authorised users to set policy and
60change preferences.
61
62%package extra
63Summary: GNOME Power Manager extra utility programs
64Group: Applications/System
65Requires: %{name} = %{version}-%{release}
66
67%description extra
68Extra GNOME power management applications that are not normally needed.
69
70%prep
71%setup -q
72#%setup -q -n %{?name}-%{?version}-%{?alphatag}
73## %patch10 -p1 -b .warnings
74## %patch11 -p1 -b .math
75autoreconf -i
76
77%build
78%configure \
79        --disable-scrollkeeper
80make
81
82# strip unneeded translations from .mo files
83# ideally intltool (ha!) would do that for us
84# http://bugzilla.gnome.org/show_bug.cgi?id=474987
85cd po
86grep -v ".*[.]desktop[.]in[.]in$\|.*[.]server[.]in[.]in$" POTFILES.in > POTFILES.keep
87mv POTFILES.keep POTFILES.in
88intltool-update --pot
89for p in *.po; do
90  msgmerge $p %{name}.pot > $p.out
91  msgfmt -o `basename $p .po`.gmo $p.out
92done
93
94%install
95rm -rf $RPM_BUILD_ROOT
96export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
97make install DESTDIR=$RPM_BUILD_ROOT
98unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
99
100desktop-file-install --vendor gnome --delete-original                   \
101  --dir $RPM_BUILD_ROOT%{_sysconfdir}/xdg/autostart                     \
102  $RPM_BUILD_ROOT%{_sysconfdir}/xdg/autostart/gnome-power-manager.desktop
103
104# save space by linking identical images in translated docs
105helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
106for f in $helpdir/C/figures/*.png; do
107  b="$(basename $f)"
108  for d in $helpdir/*; do
109    if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
110      g="$d/figures/$b"
111      if [ -f "$g" ]; then
112        if cmp -s $f $g; then
113          rm "$g"; ln -s "../../C/figures/$b" "$g"
114        fi
115      fi
116    fi
117  done
118done
119
120%find_lang %name --with-gnome
121
122%clean
123rm -rf $RPM_BUILD_ROOT
124
125%post
126export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
127gconftool-2 --makefile-install-rule \
128        %{_sysconfdir}/gconf/schemas/gnome-power-manager.schemas >/dev/null || :
129scrollkeeper-update -q &> /dev/null || :
130touch --no-create %{_datadir}/icons/hicolor
131if [ -x /usr/bin/gtk-update-icon-cache ]; then
132    gtk-update-icon-cache -q %{_datadir}/icons/hicolor
133fi
134
135%pre
136if [ "$1" -gt 1 ]; then
137    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
138    gconftool-2 --makefile-uninstall-rule \
139      %{_sysconfdir}/gconf/schemas/gnome-power-manager.schemas > /dev/null || :
140fi
141
142%preun
143if [ "$1" -eq 0 ]; then
144    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
145    gconftool-2 --makefile-uninstall-rule \
146      %{_sysconfdir}/gconf/schemas/gnome-power-manager.schemas > /dev/null || :
147fi
148
149%postun
150scrollkeeper-update -q &> /dev/null || :
151touch --no-create %{_datadir}/icons/hicolor
152if [ -x /usr/bin/gtk-update-icon-cache ]; then
153    gtk-update-icon-cache -q %{_datadir}/icons/hicolor &> /dev/null || :
154fi
155
156%files -f %{name}.lang
157%defattr(-,root,root)
158%doc AUTHORS COPYING README
159%{_bindir}/gnome-power-bugreport.sh
160%{_bindir}/gnome-power-manager
161%{_bindir}/gnome-power-preferences
162%dir %{_datadir}/gnome-power-manager
163%{_datadir}/gnome-power-manager/acme.ui
164%{_datadir}/gnome-power-manager/gpm-prefs.ui
165%{_datadir}/gnome-power-manager/gpm-feedback-widget.ui
166%{_mandir}/man1/gnome-power-manager.1.gz
167%{_mandir}/man1/gnome-power-preferences.1.gz
168%{_sysconfdir}/gconf/schemas/*.schemas
169%{_datadir}/dbus-1/services/gnome-power-manager.service
170#%{_datadir}/omf/gnome-power-manager
171%{_sysconfdir}/xdg/autostart/*.desktop
172%{_datadir}/gnome-power-manager/icons/hicolor/*/*/*.*
173%{_datadir}/icons/hicolor/*/apps/gnome-power-manager.*
174%{_datadir}/applications/gnome-power-preferences.desktop
175%{_libexecdir}/gnome-brightness-applet
176%{_libdir}/bonobo/servers/GNOME_BrightnessApplet.server
177%{_datadir}/gnome-2.0/ui/GNOME_BrightnessApplet.xml
178%{_datadir}/icons/hicolor/*/apps/gnome-brightness-applet.*
179
180%files extra
181%defattr(-,root,root,-)
182%doc AUTHORS COPYING NEWS README
183%{_bindir}/gnome-power-statistics
184%{_mandir}/man1/gnome-power-statistics.1.gz
185%{_datadir}/gnome-power-manager/gpm-statistics.ui
186%{_datadir}/applications/gnome-power-statistics.desktop
187%{_datadir}/icons/hicolor/*/apps/gnome-power-statistics.*
188%{_libexecdir}/gnome-inhibit-applet
189%{_libdir}/bonobo/servers/GNOME_InhibitApplet.server
190%{_datadir}/gnome-2.0/ui/GNOME_InhibitApplet.xml
191%{_datadir}/icons/hicolor/*/apps/gnome-inhibit-applet.*
192
193%changelog
194* Sat Apr 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
195- new upstream release
196- remove Patch1, Patch2, Patch3
197- change BuildRequires: DeviceKit-power-devel -> upower-devel
198- change Requires: DeviceKit-power -> upower
199
200* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.3-1
201- new upstream release
202- change BuildRequires: xmlto -> docbook-utils
203- remove BuildReuiqres: hal-devel
204
205* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.3-1
206- new upstream release
207
208* Tue Dec 29 2009 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
209- merge spec file from FC package
210- add Patch1, Patch2 and Patch3 from FC package
211- add Patch10 and Patch11 for Vine Linux
212- remove configure option --enable-policykit
213- add new package (extra)
214
215* Sun Apr 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.4-1
216- new upstream release
217
218* Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
219- new upstream release
220
221* Thu Sep 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
222- new upstream release
223
224* Sun Apr 13 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
225- new upstream release
226
227* Sun Jan 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.2-0vl1
228- new upstream release
229
230* Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.2-0vl2
231- rebuild with new environment/toolchain
232
233* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.2-0vl1
234- new upstream release
235- drop Patch10 to enable suspend-to-ram.
236
237* Thu Sep 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-0vl1
238- new upstream release
239
240* Tue Aug 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.91-0vl1
241- new upstream release
242
243* Mon Jul 24 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.90-0vl1
244- new upstream release
245
246* Wed Jun 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.3-0vl1
247- new upstream release
248
249* Wed May 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.2-0vl1
250- new upstream release
251
252* Wed Apr 26 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.1-0vl1
253- new upstream release
254
255* Mon Apr 17 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-0vl1
256- new upstream release
257
258* Mon Apr 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
259- new upstream release
260
261* Thu Mar 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl3
262- add Patch10 to disable suspend-to-ram by default.
263
264* Thu Mar 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
265- update ja.po from CVS head.
266
267* Thu Mar 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
268- new upstream release
269
270* Sun Mar 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.93-0vl1
271- initial build for Vine Linux based on FC package
272
273* Mon Mar  6 2006 Ray Strode <rstrode@redhat.com> - 2.13.93-4
274- fix the fix in -2 and -3
275
276* Mon Mar  6 2006 Ray Strode <rstrode@redhat.com> - 2.13.93-3
277- fix the fix in -2
278
279* Mon Mar  6 2006 Ray Strode <rstrode@redhat.com> - 2.13.93-2
280- fix icon in bubbles (bug 184192).
281
282* Fri Mar  3 2006 Ray Strode <rstrode@redhat.com> - 2.13.93-1
283- Update to 2.13.93
284- ignore d-bus timeout errors
285
286* Thu Mar  2 2006 Ray Strode <rstrode@redhat.com> - 2.13.92-3
287- Add patch from Richard Hughes to potentially fix a
288  crasher bug (bug 183127)
289
290* Tue Feb 28 2006 Karsten Hopp <karsten@redhat.de> 2.13.92-2
291- Buildrequires: gnome-doc-utils
292
293* Sun Feb 26 2006 Ray Strode <rstrode@redhat.com> - 2.13.92-1
294- Update to 2.13.92
295
296* Tue Feb 21 2006 Matthias Clasen <mclasen@redhat.com> - 2.13.91-1
297- Update to 2.13.91
298- Drop upstreamed patch
299
300* Wed Feb 15 2006 Matthias Clasen <mclasen@redhat.com> - 2.13.90-1
301- Update to 2.13.90
302- Require dbus-x11 (#176656)
303
304* Sun Feb 13 2006 Ray Strode <rstrode@redhat.com> - 2.13.5.0.20060207-2
305- remove Hibernate and Suspend from menus as part of
306  panel/g-p-m integration effort
307
308* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.13.5.0.20060207-1.1
309- bump again for double-long bug on ppc(64)
310
311* Tue Feb  7 2006 Ray Strode <rstrode@redhat.com> - 2.13.5.0.20060207-1
312- pull cvs snapshot from HEAD and drop the patches caillon
313  just added
314
315* Tue Feb  7 2006 Christopher Aillon <caillon@redhat.com> - 2.13.5-3
316- Install into the autostart directory
317- Don't suspend on lid close while on AC power
318
319* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.13.5-2.1
320- rebuilt for new gcc4.1 snapshot and glibc changes
321
322* Tue Jan 31 2006 Matthias Clasen <mclasen@redhat.com> - 2.13.5-2
323- rebuild
324
325* Thu Jan 26 2006 Ray Strode <rstrode@redhat.com> - 2.13.5-1
326- packaging tweaks
327
328* Thu Jan 26 2006 Christopher Aillon <caillon@redhat.com> 2.13.5-1
329- Update to 2.13.5
330
331* Tue Jan 24 2006 Christopher Aillon <caillon@redhat.com> - 0.3.4-2
332- Left clicking on the applet should bring up the menu
333
334* Tue Jan 17 2006 Ray Strode <rstrode@redhat.com> - 0.3.4-1
335- update to 0.3.4
336- disable updating scrollkeeper database in buildroot
337  (move to %%post)
338
339* Fri Jan  6 2006 Jeremy Katz <katzj@redhat.com> - 0.3.3-0.cvs.20060106
340- update to a cvs snap so that it works with hal cvs snap
341- make sure we use libnotify
342
343* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com> - 0.3.1-2.1
344- rebuilt
345
346* Thu Dec 01 2005 John (J5) Palmieri <johnp@redhat.com> - 0.3.1-2
347- rebuild for new dbus
348
349* Mon Nov 28 2005 Christopher Aillon <caillon@redhat.com> 0.3.1-1
350- Update to 0.3.1
351
352* Fri Nov 25 2005 Christopher Aillon <caillon@redhat.com> 0.3.0-1
353- Update to 0.3.0
354
355* Wed Oct 19 2005 Ray Strode <rstrode@redhat.com> 0.2.8-1
356- update to 0.2.8
357
358* Wed Oct  3 2005 Ray Strode <rstrode@redhat.com> 0.2.6-1
359- update to 0.2.6
360
361* Wed Sep 28 2005 Ray Strode <rstrode@redhat.com> 0.2.4-1
362- update to 0.2.4
363
364* Fri Sep 02 2005 David Zeuthen <davidz@redhat.com> 0.2.3.1-1
365- Initial import based on an SRPM from Richard Hughes
366
Note: See TracBrowser for help on using the repository browser.