source: projects/specs/trunk/g/gnome-power-manager/gnome-power-manager-vl.spec @ 521

Revision 521, 11.6 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define hal_version  0.5.13
2%define dbus_version 1.2
3%define dbus_glib_version 0.82
4
5Summary: GNOME power management service
6Summary(ja): GNOME 電源管理ツール
7Name: gnome-power-manager
8Version: 2.28.3
9Release: 1%{?_dist_release}
10License: GPLv2+ and GFDL
11Group: Applications/System
12URL: http://projects.gnome.org/gnome-power-manager/
13
14Source: http://download.gnome.org/sources/gnome-power-manager/2.28/gnome-power-manager-%{version}.tar.bz2
15
16# Fedora-specific backport, already same UI in git master
17Patch1: 0001-Do-not-show-About-and-Help-menu-items-on-the-panel-i.patch
18
19# Fedora-specific backport, already same UI in git master
20Patch2: 0002-Make-the-left-and-right-buttons-on-the-status-icon-b.patch
21
22# https://bugzilla.gnome.org/show_bug.cgi?id=594664
23%define         _default_patch_fuzz 2
24BuildRequires: autoconf automake libtool
25Patch3: 0001-Use-gnome-settings-daemon-popup-code.patch
26
27# for Vine Linux
28Patch10: gnome-power-manager-2.28.2-warningflags.patch
29Patch11: gnome-power-manager-2.28.2-math.patch
30
31BuildRoot: %{_tmppath}/%{name}-%{version}-root
32BuildRequires: libgnomeui-devel
33BuildRequires: libglade2-devel
34BuildRequires: libwnck-devel
35BuildRequires: hal-devel >= %{hal_version}
36BuildRequires: dbus-devel >= %{dbus_version}
37BuildRequires: libnotify-devel
38BuildRequires: gnome-panel-devel
39BuildRequires: scrollkeeper
40BuildRequires: gnome-doc-utils >= 0.3.2
41BuildRequires: desktop-file-utils
42BuildRequires: gettext
43BuildRequires: libtool
44BuildRequires: cairo-devel
45BuildRequires: libcanberra-devel >= 0.10
46BuildRequires: unique-devel >= 1.0.0
47BuildRequires: DeviceKit-power-devel >= 008
48BuildRequires: intltool
49BuildRequires: xmlto
50Requires: gtk2 >= 2.10.0
51Requires: gnome-mime-data
52Requires: gnome-icon-theme
53Requires: libnotify >= 0.4.3
54Requires: hal >= %{hal_version}
55Requires: dbus-glib >= %{dbus_glib_version}
56Requires: dbus-x11 >= %{dbus_version}
57Requires: libcanberra-gtk2 >= 0.10
58Requires: unique >= 1.0.0
59Requires: DeviceKit-power >= 008
60Requires(post,postun): scrollkeeper
61Requires(post,pre,preun): GConf2
62
63Vendor:       Project Vine
64Distribution: Vine Linux
65Packager:     daisuke, Takemikaduchi
66
67%description
68GNOME Power Manager uses the information and facilities provided by HAL
69displaying icons and handling user callbacks in an interactive GNOME session.
70GNOME Power Preferences allows authorised users to set policy and
71change preferences.
72
73%package extra
74Summary: GNOME Power Manager extra utility programs
75Group: Applications/System
76Requires: %{name} = %{version}-%{release}
77
78%description extra
79Extra GNOME power management applications that are not normally needed.
80
81%prep
82%setup -q
83#%setup -q -n %{?name}-%{?version}-%{?alphatag}
84%patch1 -p1 -b .remove-help
85%patch2 -p1 -b .uni-menu
86%patch3 -p1 -b .osd
87%patch10 -p1 -b .warnings
88%patch11 -p1 -b .math
89autoreconf -i
90
91%build
92%configure \
93        --disable-scrollkeeper
94make
95
96# strip unneeded translations from .mo files
97# ideally intltool (ha!) would do that for us
98# http://bugzilla.gnome.org/show_bug.cgi?id=474987
99cd po
100grep -v ".*[.]desktop[.]in[.]in$\|.*[.]server[.]in[.]in$" POTFILES.in > POTFILES.keep
101mv POTFILES.keep POTFILES.in
102intltool-update --pot
103for p in *.po; do
104  msgmerge $p %{name}.pot > $p.out
105  msgfmt -o `basename $p .po`.gmo $p.out
106done
107
108%install
109rm -rf $RPM_BUILD_ROOT
110export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
111make install DESTDIR=$RPM_BUILD_ROOT
112unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
113
114desktop-file-install --vendor gnome --delete-original                   \
115  --dir $RPM_BUILD_ROOT%{_sysconfdir}/xdg/autostart                     \
116  $RPM_BUILD_ROOT%{_sysconfdir}/xdg/autostart/gnome-power-manager.desktop
117
118# save space by linking identical images in translated docs
119helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
120for f in $helpdir/C/figures/*.png; do
121  b="$(basename $f)"
122  for d in $helpdir/*; do
123    if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
124      g="$d/figures/$b"
125      if [ -f "$g" ]; then
126        if cmp -s $f $g; then
127          rm "$g"; ln -s "../../C/figures/$b" "$g"
128        fi
129      fi
130    fi
131  done
132done
133
134%find_lang %name --with-gnome
135
136%clean
137rm -rf $RPM_BUILD_ROOT
138
139%post
140export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
141gconftool-2 --makefile-install-rule \
142        %{_sysconfdir}/gconf/schemas/gnome-power-manager.schemas >/dev/null || :
143scrollkeeper-update -q &> /dev/null || :
144touch --no-create %{_datadir}/icons/hicolor
145if [ -x /usr/bin/gtk-update-icon-cache ]; then
146    gtk-update-icon-cache -q %{_datadir}/icons/hicolor
147fi
148
149%pre
150if [ "$1" -gt 1 ]; then
151    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
152    gconftool-2 --makefile-uninstall-rule \
153      %{_sysconfdir}/gconf/schemas/gnome-power-manager.schemas > /dev/null || :
154fi
155
156%preun
157if [ "$1" -eq 0 ]; then
158    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
159    gconftool-2 --makefile-uninstall-rule \
160      %{_sysconfdir}/gconf/schemas/gnome-power-manager.schemas > /dev/null || :
161fi
162
163%postun
164scrollkeeper-update -q &> /dev/null || :
165touch --no-create %{_datadir}/icons/hicolor
166if [ -x /usr/bin/gtk-update-icon-cache ]; then
167    gtk-update-icon-cache -q %{_datadir}/icons/hicolor &> /dev/null || :
168fi
169
170%files -f %{name}.lang
171%defattr(-,root,root)
172%doc AUTHORS COPYING README
173%{_bindir}/gnome-power-bugreport.sh
174%{_bindir}/gnome-power-manager
175%{_bindir}/gnome-power-preferences
176%dir %{_datadir}/gnome-power-manager
177%{_datadir}/gnome-power-manager/acme.ui
178%{_datadir}/gnome-power-manager/gpm-prefs.ui
179%{_datadir}/gnome-power-manager/gpm-feedback-widget.ui
180%{_mandir}/man1/gnome-power-manager.1.gz
181%{_mandir}/man1/gnome-power-preferences.1.gz
182%{_sysconfdir}/gconf/schemas/*.schemas
183%{_datadir}/dbus-1/services/gnome-power-manager.service
184#%{_datadir}/omf/gnome-power-manager
185%{_sysconfdir}/xdg/autostart/*.desktop
186%{_datadir}/gnome-power-manager/icons/hicolor/*/*/*.*
187%{_datadir}/icons/hicolor/*/apps/gnome-power-manager.*
188%{_datadir}/applications/gnome-power-preferences.desktop
189%{_libexecdir}/gnome-brightness-applet
190%{_libdir}/bonobo/servers/GNOME_BrightnessApplet.server
191%{_datadir}/gnome-2.0/ui/GNOME_BrightnessApplet.xml
192%{_datadir}/icons/hicolor/*/apps/gnome-brightness-applet.*
193
194%files extra
195%defattr(-,root,root,-)
196%doc AUTHORS COPYING NEWS README
197%{_bindir}/gnome-power-statistics
198%{_mandir}/man1/gnome-power-statistics.1.gz
199%{_datadir}/gnome-power-manager/gpm-statistics.ui
200%{_datadir}/applications/gnome-power-statistics.desktop
201%{_datadir}/icons/hicolor/*/apps/gnome-power-statistics.*
202%{_libexecdir}/gnome-inhibit-applet
203%{_libdir}/bonobo/servers/GNOME_InhibitApplet.server
204%{_datadir}/gnome-2.0/ui/GNOME_InhibitApplet.xml
205%{_datadir}/icons/hicolor/*/apps/gnome-inhibit-applet.*
206
207%changelog
208* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.3-1
209- new upstream release
210
211* Tue Dec 29 2009 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
212- merge spec file from FC package
213- add Patch1, Patch2 and Patch3 from FC package
214- add Patch10 and Patch11 for Vine Linux
215- remove configure option --enable-policykit
216- add new package (extra)
217
218* Sun Apr 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.4-1
219- new upstream release
220
221* Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
222- new upstream release
223
224* Thu Sep 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
225- new upstream release
226
227* Sun Apr 13 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
228- new upstream release
229
230* Sun Jan 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.2-0vl1
231- new upstream release
232
233* Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.2-0vl2
234- rebuild with new environment/toolchain
235
236* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.2-0vl1
237- new upstream release
238- drop Patch10 to enable suspend-to-ram.
239
240* Thu Sep 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-0vl1
241- new upstream release
242
243* Tue Aug 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.91-0vl1
244- new upstream release
245
246* Mon Jul 24 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.90-0vl1
247- new upstream release
248
249* Wed Jun 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.3-0vl1
250- new upstream release
251
252* Wed May 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.2-0vl1
253- new upstream release
254
255* Wed Apr 26 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.1-0vl1
256- new upstream release
257
258* Mon Apr 17 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-0vl1
259- new upstream release
260
261* Mon Apr 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
262- new upstream release
263
264* Thu Mar 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl3
265- add Patch10 to disable suspend-to-ram by default.
266
267* Thu Mar 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
268- update ja.po from CVS head.
269
270* Thu Mar 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
271- new upstream release
272
273* Sun Mar 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.93-0vl1
274- initial build for Vine Linux based on FC package
275
276* Mon Mar  6 2006 Ray Strode <rstrode@redhat.com> - 2.13.93-4
277- fix the fix in -2 and -3
278
279* Mon Mar  6 2006 Ray Strode <rstrode@redhat.com> - 2.13.93-3
280- fix the fix in -2
281
282* Mon Mar  6 2006 Ray Strode <rstrode@redhat.com> - 2.13.93-2
283- fix icon in bubbles (bug 184192).
284
285* Fri Mar  3 2006 Ray Strode <rstrode@redhat.com> - 2.13.93-1
286- Update to 2.13.93
287- ignore d-bus timeout errors
288
289* Thu Mar  2 2006 Ray Strode <rstrode@redhat.com> - 2.13.92-3
290- Add patch from Richard Hughes to potentially fix a
291  crasher bug (bug 183127)
292
293* Tue Feb 28 2006 Karsten Hopp <karsten@redhat.de> 2.13.92-2
294- Buildrequires: gnome-doc-utils
295
296* Sun Feb 26 2006 Ray Strode <rstrode@redhat.com> - 2.13.92-1
297- Update to 2.13.92
298
299* Tue Feb 21 2006 Matthias Clasen <mclasen@redhat.com> - 2.13.91-1
300- Update to 2.13.91
301- Drop upstreamed patch
302
303* Wed Feb 15 2006 Matthias Clasen <mclasen@redhat.com> - 2.13.90-1
304- Update to 2.13.90
305- Require dbus-x11 (#176656)
306
307* Sun Feb 13 2006 Ray Strode <rstrode@redhat.com> - 2.13.5.0.20060207-2
308- remove Hibernate and Suspend from menus as part of
309  panel/g-p-m integration effort
310
311* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.13.5.0.20060207-1.1
312- bump again for double-long bug on ppc(64)
313
314* Tue Feb  7 2006 Ray Strode <rstrode@redhat.com> - 2.13.5.0.20060207-1
315- pull cvs snapshot from HEAD and drop the patches caillon
316  just added
317
318* Tue Feb  7 2006 Christopher Aillon <caillon@redhat.com> - 2.13.5-3
319- Install into the autostart directory
320- Don't suspend on lid close while on AC power
321
322* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.13.5-2.1
323- rebuilt for new gcc4.1 snapshot and glibc changes
324
325* Tue Jan 31 2006 Matthias Clasen <mclasen@redhat.com> - 2.13.5-2
326- rebuild
327
328* Thu Jan 26 2006 Ray Strode <rstrode@redhat.com> - 2.13.5-1
329- packaging tweaks
330
331* Thu Jan 26 2006 Christopher Aillon <caillon@redhat.com> 2.13.5-1
332- Update to 2.13.5
333
334* Tue Jan 24 2006 Christopher Aillon <caillon@redhat.com> - 0.3.4-2
335- Left clicking on the applet should bring up the menu
336
337* Tue Jan 17 2006 Ray Strode <rstrode@redhat.com> - 0.3.4-1
338- update to 0.3.4
339- disable updating scrollkeeper database in buildroot
340  (move to %%post)
341
342* Fri Jan  6 2006 Jeremy Katz <katzj@redhat.com> - 0.3.3-0.cvs.20060106
343- update to a cvs snap so that it works with hal cvs snap
344- make sure we use libnotify
345
346* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com> - 0.3.1-2.1
347- rebuilt
348
349* Thu Dec 01 2005 John (J5) Palmieri <johnp@redhat.com> - 0.3.1-2
350- rebuild for new dbus
351
352* Mon Nov 28 2005 Christopher Aillon <caillon@redhat.com> 0.3.1-1
353- Update to 0.3.1
354
355* Fri Nov 25 2005 Christopher Aillon <caillon@redhat.com> 0.3.0-1
356- Update to 0.3.0
357
358* Wed Oct 19 2005 Ray Strode <rstrode@redhat.com> 0.2.8-1
359- update to 0.2.8
360
361* Wed Oct  3 2005 Ray Strode <rstrode@redhat.com> 0.2.6-1
362- update to 0.2.6
363
364* Wed Sep 28 2005 Ray Strode <rstrode@redhat.com> 0.2.4-1
365- update to 0.2.4
366
367* Fri Sep 02 2005 David Zeuthen <davidz@redhat.com> 0.2.3.1-1
368- Initial import based on an SRPM from Richard Hughes
369
Note: See TracBrowser for help on using the repository browser.