source: projects/specs/trunk/g/gnome-panel/gnome-panel-vl.spec @ 4625

Revision 4625, 25.5 KB checked in by Takemikaduchi, 13 years ago (diff)

xserver: update to 1.10.4, others: fix spec file

Line 
1%define use_eds 1
2
3%define gettext_package gnome-panel-2.0
4
5%define gnome_desktop3_version 3.0.0
6%define glib2_version 2.26.0
7%define gtk2_version 2.22.0
8%define libgnome_version 2.32.0
9%define libbonoboui_version 2.24.4
10%define orbit_version 2.14.19
11%define libwnck3_version 3.0.0
12%define gconf_version 2.32.0
13%define gnome_menus_version 2.30.4
14%define evolution_data_server_version 2.32.0
15%define cairo_version 1.10.0
16%define dbus_version 1.4.0
17%define dbus_glib_version 0.88
18%define gnome_doc_utils_version 0.3.2
19%define libgweather_version 2.30.3
20%define libcanberra_version 0.25
21%define gobject_introspection_version 0.9.8
22
23Summary: GNOME panel
24Summary(ja): GNOME パネル
25Name: gnome-panel
26Version: 3.0.2
27Release: 1%{_dist_release}
28URL: http://www.gnome.org/
29License: GPL
30Group: User Interface/Desktops
31
32Source0: http://ftp.gnome.org/pub/gnome/sources/gnome-panel/3.0/%{name}-%{version}.tar.bz2
33# Remove this line and next line when upstream adopt Source1
34Source1: clock.gnome-2-32.ja.po
35Source2: vine6-panel-default-setup.entries
36Source5: vine-panel-backwards-compat-config.schemas
37Source10: add-translations.sh
38Source12: gnome-compiler-flags.m4
39
40Patch0: gnome-panel-3.0.2-configure.patch
41
42BuildRoot: %{_tmppath}/%{name}-%{version}-root
43
44Requires: %{name}-libs = %{version}-%{release}
45Requires: gnome-desktop3 >= %{gnome_desktop3_version}
46Requires: libwnck3 >= %{libwnck3_version}
47Requires: gnome-menus >= %{gnome_menus_version}
48Requires: vine-menus >= 1.1
49Requires(post,postun): scrollkeeper, gtk2
50Requires(post,pre,preun): GConf2
51
52%if %{use_eds}
53Requires: evolution-data-server >= 2.30.2
54%endif
55Requires: libSM
56
57BuildRequires: libxml2-python
58BuildRequires: intltool
59BuildRequires: gettext
60BuildRequires: automake
61BuildRequires: autoconf
62BuildRequires: libtool
63BuildRequires: scrollkeeper
64BuildRequires: libxslt
65BuildRequires: gnome-desktop3-devel >= %{gnome_desktop3_version}
66BuildRequires: gtk3-devel >= %{gtk3_version}
67BuildRequires: libgnome-devel >= %{libgnome_version}
68BuildRequires: libbonoboui-devel >= %{libbonoboui_version}
69BuildRequires: libwnck3-devel >= %{libwnck3_version}
70BuildRequires: GConf2-devel >= %{gconf_version}
71BuildRequires: gnome-menus-devel >= %{gnome_menus_version}
72BuildRequires: cairo-devel >= %{cairo_version}
73BuildRequires: gnome-doc-utils >= %{gnome_doc_utils_version}
74BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
75BuildRequires: gtk-doc
76BuildRequires: pango-devel
77BuildRequires: libbonobo-devel
78BuildRequires: libX11-devel
79BuildRequires: libXau-devel
80%if %{use_eds}
81BuildRequires: evolution-data-server-devel >= %{evolution_data_server_version}
82BuildRequires: ORBit2-devel >= %{orbit_version}
83BuildRequires: dbus-devel >= %{dbus_version}
84%endif
85BuildRequires: libgweather-devel >= %{libgweather_version}
86BuildRequires: libcanberra-devel >= %{libcanberra_versino}
87BuildRequires: librsvg2-devel
88BuildRequires: polkit-gnome-devel
89BuildRequires: NetworkManager-devel
90BuildRequires: libSM-devel
91BuildRequires: gobject-introspection-devel >= %{gobject_introspection_version}
92BuildRequires: dconf-devel
93BuildRequires: telepathy-glib-devel
94BuildRequires(install): desktop-file-utils
95
96Obsoletes: gnome-netstatus < 2.29
97
98%description
99
100The GNOME panel provides the window list, workspace switcher, menus, and other
101features for the GNOME desktop.
102
103%description -l ja
104
105GNOME パネルは、ウィンドウ一覧・ワークスペース切り換え器・メニューその他の
106特徴を GNOME デスクトップに提供します。
107
108%package libs
109Summary: Libraries for use in panel applets of GNOME
110Summary(ja): GNOME のパネルアップレットで使用するライブラリ
111Group: System Environment/Libraries
112
113%description libs
114Libraries for use in panel applets of GNOME.
115
116%description libs -l ja
117GNOME のパネルアップレットで使用するライブラリ
118
119%package devel
120Summary: Development environment for panel applets of GNOME
121Summary(ja): GNOME のパネルアップレット用開発環境
122Group: Development/Libraries
123Requires: %{name}-libs = %{version}-%{release}
124Requires: pkgconfig
125Requires: gtk2-devel >= %{gtk2_version}
126Requires: libbonoboui-devel >= %{libbonoboui_version}
127Requires: GConf2-devel >= %{gconf_version}
128
129%description devel
130Header files and libraries for building a panel applets of GNOME.
131
132%description devel -l ja
133GNOME のパネルアップレットをビルドするためのヘッダファイル及びライブラリ集
134
135
136%prep
137%setup -q
138%patch0 -p1
139
140# Remove this line and next line when upstream adopt Source1
141cp -f %{SOURCE1} help/clock/ja/ja.po
142
143cp -f %{SOURCE2} gnome-panel/panel-default-setup.entries
144cp -f %{SOURCE12} m4
145cp -f %{SOURCE5} gnome-panel/panel-compatibility.schemas
146
147. %{SOURCE10}
148
149%build
150# gpm-integration patches Makefile.am and configure.in
151#aclocal -I m4
152#automake --add-missing
153#autoheader
154#autoconf
155%configure --disable-scrollkeeper \
156           --disable-schemas-install \
157           --disable-gtk-doc \
158           --with-in-process-applets=clock:fish \
159           --enable-introspection=yes \
160           --enable-telepathy-glib=yes \
161%if %{use_eds}
162           --enable-eds=yes
163%else
164           --enable-eds=no
165%endif
166make
167
168%install
169rm -rf $RPM_BUILD_ROOT
170
171export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
172make install DESTDIR=$RPM_BUILD_ROOT
173unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
174
175#
176# Create pager and tasklist schemas for compatibility with older
177# configurations which reference the old schema names
178#
179#sed -e 's|/schemas/apps/window_list_applet/prefs/|/schemas/apps/tasklist_applet/prefs/|' $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/window-list.schemas > $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/tasklist.schemas
180#sed -e 's|/schemas/apps/workspace_switcher_applet/prefs/|/schemas/apps/pager_applet/prefs/|; s|<default>1</default>|<default>2</default>|' $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/workspace-switcher.schemas > $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/pager.schemas
181
182
183## blow away stuff we don't want
184/bin/rm -rf $RPM_BUILD_ROOT%{_localstatedir}/scrollkeeper
185#rmdir --ignore-fail-on-non-empty $RPM_BUILD_ROOT/var
186/bin/rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
187
188/bin/rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
189
190sed -i -e "s/NoDisplay=True/NoDisplay=true/" $RPM_BUILD_ROOT%{_datadir}/applications/gnome-panel.desktop
191
192desktop-file-install --delete-original \
193  --dir $RPM_BUILD_ROOT%{_datadir}/applications \
194  $RPM_BUILD_ROOT%{_datadir}/applications/gnome-panel.desktop
195
196%find_lang %{gettext_package} --all-name --with-gnome
197#grep -q '/usr/share/locale' %{gettext_package}.lang || exit 1
198
199%clean
200rm -rf $RPM_BUILD_ROOT
201
202%post
203touch --no-create %{_datadir}/icons/hicolor
204if [ -x /usr/bin/gtk-update-icon-cache ]; then
205  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
206fi
207
208export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
209
210#
211# Clear out the old defaults
212#
213gconftool-2 --direct --config-source=$GCONF_CONFIG_SOURCE --recursive-unset /apps/panel > /dev/null || :
214gconftool-2 --direct --config-source=$GCONF_CONFIG_SOURCE --recursive-unset /schemas/apps/panel > /dev/null || :
215
216# install schemas
217SCHEMAS="clock.schemas"
218for S in $SCHEMAS; do
219    echo %{_sysconfdir}/gconf/schemas/$S ; done \
220    | xargs gconftool-2 --makefile-install-rule >& /dev/null 2>&1 ||:
221
222#
223# Install the default setup into /apps/panel and /apps/panel/default_setup
224#
225gconftool-2 --direct --config-source=$GCONF_CONFIG_SOURCE --load %{_sysconfdir}/gconf/schemas/clock.schemas > /dev/null 2>&1 || :
226
227/sbin/ldconfig
228scrollkeeper-update > /dev/null 2>&1 || :
229
230%pre
231if [ "$1" -gt 1 ]; then
232  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
233  SCHEMAS="clock.schemas"
234  for S in $SCHEMAS; do
235      echo %{_sysconfdir}/gconf/schemas/$S ; done \
236      | xargs gconftool-2 --makefile-uninstall-rule >& /dev/null 2>&1 ||:
237fi
238
239%preun
240if [ "$1" -eq 0 ]; then
241  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
242  SCHEMAS="clock.schemas"
243  for S in $SCHEMAS; do
244      echo %{_sysconfdir}/gconf/schemas/$S ; done \
245      | xargs gconftool-2 --makefile-uninstall-rule >& /dev/null 2>&1 ||:
246fi
247
248%postun
249/sbin/ldconfig
250scrollkeeper-update > /dev/null 2>&1 || :
251touch --no-create %{_datadir}/icons/hicolor
252if [ -x /usr/bin/gtk-update-icon-cache ]; then
253  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
254fi
255 
256%files -f %{gettext_package}.lang
257%defattr(-,root,root)
258%doc AUTHORS COPYING COPYING.LIB COPYING-DOCS NEWS README
259%{_bindir}/*
260%exclude %{_bindir}/panel-test-applets
261%{_libexecdir}/*
262%{_sysconfdir}/gconf/schemas/*.schemas
263%{_datadir}/applications/*.desktop
264%{_datadir}/icons/hicolor/*/*/*
265%{_datadir}/glib-2.0/schemas/*.xml
266%{_datadir}/gnome-panel
267%{_datadir}/dbus-1/services/org.gnome.panel.applet.ClockAppletFactory.service
268%{_datadir}/dbus-1/services/org.gnome.panel.applet.FishAppletFactory.service
269%{_datadir}/dbus-1/services/org.gnome.panel.applet.NotificationAreaAppletFactory.service
270%{_datadir}/dbus-1/services/org.gnome.panel.applet.WnckletFactory.service
271%{_mandir}/man*/*
272
273%files libs
274%{_libdir}/*.so.*
275%{_libdir}/girepository-1.0/*.typelib
276
277%files devel
278%{_bindir}/panel-test-applets
279%{_libdir}/pkgconfig/*.pc
280%{_includedir}/gnome-panel*
281%{_libdir}/*.so
282%{_datadir}/gtk-doc
283%{_datadir}/gir-1.0/*.gir
284
285
286%changelog
287* Sat Aug 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.2-1
288- new upstream release
289- drop old Patches
290- change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
291- change BuildRequires: libwnck3-devel instead of libwnck-devel
292- add BuildRequires: dconf-devel, telepathy-glib-devel
293- add Obsoletes: gnome-netstatus
294- add Patch0 (gnome-panel-3.0.2-configure.patch)
295
296* Thu Jun 02 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.32.1-4
297- update SOURCE2(vine6-panel-default-setup.entries)
298  - remove bottom panel
299  - move window_list and workspace_switcher applet to top panel
300
301* Sat Dec 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-3
302- update Source1 (clock.gnome-2.32.ja.po)
303
304* Sat Dec 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-2
305- remove Provides: gnome-panel-devel
306
307* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
308- new upstream release
309
310* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0.2-1
311- new upstream release
312- add BuildRequires: gobject-introspection-devel
313- remove BuildRequires: libgnomeui-devel
314- remove SOURCE3 and SOURCE4
315- drop Patch11
316- add configure option (--enable-introspection=yes)
317
318* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-3
319- rebuild with rpm-4.8.1 for pkg-config file
320
321* Sun Aug 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-2
322- create -libs and -devel package
323
324* Tue Jun 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
325- new upstream release
326
327* Tue Jun 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-2
328- rebuild with evolution-data-server-2.30.2
329
330* Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
331- new upstream release
332- update Patch8, Patch9 (from FC package)
333- add BuildRequires: libcanberra-devel
334
335* Sat Mar 27 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.28.0-4
336- update translation of clock applet manual
337- add translation of fish applet manual
338
339* Fri Mar 26 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.28.0-3
340- add libSM(-devel) to (Build)Requires
341- add desktop-file-utils to BuildRequires
342
343* Thu Mar 25 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.28.0-2
344- update translation of clock applet manual
345
346* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.0-1
347- new upstream release
348- updated Patch0 and 2
349
350* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
351- new upstream release
352
353* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-3
354- rebuild with gtk2-2.16.3
355
356* Thu Jun 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
357- add empty gconf entries to vine-panel-default-setup.entries
358
359* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
360- new upstream release
361
362* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
363- new upstream release
364
365* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-4
366- update vine-panel-default-setup.entries again..
367
368* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-3
369- update vine-panel-default-setup.entries
370
371* Tue Mar 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-2
372- remove mixer applets from default panel setup
373
374* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
375- new upstream release
376
377* Mon Jan 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.3-1
378- new upstream release
379- added BuildRequires: PolicyKit-gnome-devel
380
381* Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
382- new upstream release
383
384* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
385- new upstream release
386
387* Tue Jun  3 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1
388- new upstream release
389
390* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.3-1
391- new upstream release
392
393* Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.2-1vl5
394- new upstream release
395- removed Patch25,26,27,29 and 30 (merged into upstream)
396
397* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-2vl5
398- added Patches from FC
399  * Fri Mar 28 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-8
400  - Fix editing of locations in the clock applet
401  * Fri Mar 28 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-7
402  - Convert the edit and find location windows to dialogs
403  * Thu Mar 27 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-6
404  - Improve the time settings window
405  * Thu Mar 27 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-5
406  - Make the find-location window of the clock larger
407  * Sat Mar 15 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-4
408  - Only save the session when the users wants it
409  * Fri Mar 14 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-3
410  - Populate the location list before showing the preference window
411  * Sat Mar  8 2008 Will Woods <wwoods@redhat.com> - 2.21.92-6
412  - Add "About This Computer" item to System menu if it exists
413  * Wed Feb 20 2008 Matthias Clasen <mclasen@redhat.com> - 2.21.91-6
414  - Try harder to avoid resizing the popup
415- updated BuildRequires
416
417* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
418- new upstream release
419- added BuildRequires: libgweather-devel
420
421* Tue Jan  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.2-0vl1
422- new upstream release
423- updated %post and %postun section
424- added %pre and %preun section
425- added Patches from Fedora
426  * Fri Oct 12 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0.1-4
427  - Sharper icons
428  * Wed Oct  3 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0.1-3
429  - Make it possible to start s-c-d from the clock menu again (#316921)
430  * Fri Sep 21 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0.1-2
431  - Don't pop up an error if an applet from the default
432    configuration is missing 
433  * Mon Sep 17 2007 Matthias Clasen <mclasen@redhat.com> - 2.19.92-6
434  - Turns out we need requires for applets in the default config (#293261)
435  * Mon Sep 17 2007 Matthias Clasen <mclasen@redhat.com> - 2.19.92-5
436  - Drop the requires for fast-user-switch-applet (#253831)
437
438* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.3-0vl1
439- new upstream release
440- dropped Patch22 (merged into upstream)
441
442* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
443- new upstream release
444
445* Mon Oct 30 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.3-0vl2
446- add missing BuildRequires to gnome-menus-devel (<BTS:319>)
447
448* Thu Oct 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl1
449- new upstream release
450- fix panel-default-setup.entries to change the name of
451  firefox desktopfile (<BTS:229>)
452
453* Thu Jul 20 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.14.2-0vl2
454- add patch 11 to fix disappearing of recent documents list.
455  <BTS:VineLinux:81>, http://bugzilla.gnome.org/show_bug.cgi?id=343812
456
457* Sat Jun  3 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.2-0vl1
458- new upstream release
459
460* Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
461- new upstream release
462
463* Sat Apr 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
464- run gtk-update-icon-cache in %%post script.
465
466* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
467- new upstream release
468
469* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.91-0vl2
470- update vine-panel-default-setup.entries
471  - replace mozilla by firefox
472  - remove nautilus
473  - add notification area applet on top panel
474  - add trashbox applet on bottom panel
475- cleanup %%post script
476
477* Thu Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.91-0vl1
478- new upstream release
479
480* Sun Feb 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.3-0vl1
481- new upstream release
482- added Prereq: scroolkeeper, GConf2
483
484* Wed Oct 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
485- new upstream release
486
487* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
488- new upstream release
489
490* Sun Aug 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.91-0vl1
491- new upstream release
492
493* Wed Aug 03 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
494- new upstream release
495
496* Thu Jul 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.2-0vl1
497- new upstream release
498
499* Sat Apr 16 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl2
500- disable evolution-data-server
501
502* Thu Apr 14 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
503- new upstream release
504
505* Thu Mar 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl2
506- add Patch10 to fix hard-coded desktop file name.
507
508* Thu Mar 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
509- new upstream version
510
511* Fri Feb 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.3-0vl1
512- new upstream release
513- run scrollkeeper at %post, %postun
514
515* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
516- new upstream release
517
518* Fri Oct 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl3
519- add Patch10 to fix egg-recent-model.c.
520  save old umask value before create ".recently-used" file.
521 
522* Sun Oct 24 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.4.2-0vl2
523- fix location of nautilus launcher in panel-default-setup.entries.
524- do not add wireless monitor in %%post when no interfaces are available.
525- add Japanese summary and description
526- add BuildRequires: startup-notification-devel, gcc-c++.
527- disable libtoolize: version mismatch is bad
528
529* Sat Jan 31 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
530- new upstream release
531
532* Sat Dec 27 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
533- new upstream release
534
535* Sat Dec 27 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.0-0vl3
536- rebuilt against new toolchain
537
538* Fri Sep 12 2003 Tomoya TAKA <taka@vinelinux.org> 2.4.0-0vl2
539- add --disable-schemas-install option to %%configure
540
541* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
542- new upstream release
543
544* Mon Sep 08 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.91-0vl2
545- add missing files
546- add vine default panel entries
547
548* Sat Sep 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.91-0vl1
549- new upstream release
550
551* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
552- new upstream release
553
554* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.7-0vl1
555- new upstream release
556
557* Wed Jun 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2.1-0vl2
558- remove vine's panel-per-panel-config.schemas
559  This should be added again in a future version.
560
561* Tue Jun 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2.1-0vl1
562- new upstream release
563
564* Tue Apr 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
565- new upstream release
566- remove old ja.po
567
568* Sat Feb 15 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
569- new upstream release
570
571* Wed Jan 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl2
572- remove clockaddon, system-tray-applet
573
574* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
575- new upstream release
576
577* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.90.1-0vl2
578- add patch1 from rawhide package.
579
580* Fri Jan 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.90.1-0vl1
581- new upstream release
582
583* Sat Dec 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
584- add system-tray-applet
585- modify default panel menu.
586- update ja.po
587
588* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
589- add Requires: vine-menus
590
591* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
592- new upstream release
593
594* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl2
595- remove redhatize patch.
596
597* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
598- build for Vine Linux
599- new upstream release from gnome-2.1.4
600
601* Mon Oct 14 2002 Florian La Roche <Florian.LaRoche@redhat.de>
602- fix postun script
603
604* Tue Oct  8 2002 Havoc Pennington <hp@redhat.com>
605- 2.0.9 with menu edit stuff
606- system-tray-applet 0.15 that doesn't crash all the time
607- merge/remove patches as appropriate
608
609* Wed Aug 28 2002 Owen Taylor <otaylor@redhat.com>
610- Fix problem with "hold down print screen" (71432)
611
612* Tue Aug 27 2002 Jonathan Blandford <jrb@redhat.com>
613- panel-properties OnlyShowIn=GNOME;
614- somehow the po file got screwed up.  Works now
615- update po files
616
617* Sun Aug 25 2002 Havoc Pennington <hp@redhat.com>
618- fix from #71762 for clock applet popdown key
619- no WIN_POS_MOUSE fixes #72167
620- fix for #72540 from George
621
622* Wed Aug 21 2002 Havoc Pennington <hp@redhat.com>
623- system tray applet 0.11 with a small memleak fix and a couple translations
624
625* Thu Aug 15 2002 Jonathan Blandford <jrb@redhat.com>
626- menu tweaks
627
628* Wed Aug 14 2002 Tim Powers <timp@redhat.com>
629- bump release
630
631* Wed Aug 14 2002 Preston Brown <pbrown@redhat.com>
632- put battery applet on panel for laptops (#67296)
633
634* Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
635- 2.0.6 final from gnome 2.0.1
636- remove gnome-panel-screenshot patch now upstream
637
638* Thu Aug  8 2002 Jonathan Blandford <jrb@redhat.com>
639- new system-tray-applet version
640- Fix gnome-panel-screenshot
641
642* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
643- 2.0.4
644- replace gnome-logo-icon-transparent.png with redhat-main-menu.png
645  for the foot menu
646
647* Fri Aug  2 2002 Havoc Pennington <hp@redhat.com>
648- fix desktop (logout/lock) menu item location
649  in Alt+F1 and in new menu applets
650- remove Screenshot... menu item
651
652* Fri Aug  2 2002 Havoc Pennington <hp@redhat.com>
653- move around default applets, remove some of them
654- system tray 0.9
655- change default menu flags
656- blow unpackaged files out of build root
657
658* Wed Jul 31 2002 Havoc Pennington <hp@redhat.com>
659- 2.0.3
660- own libexecdir stuff
661
662* Thu Jul 25 2002 Havoc Pennington <hp@redhat.com>
663- new system tray that's prettier and doesn't clip the icon
664
665* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
666- system tray 0.7 that doesn't crash on startup
667- get Mozilla desktop file right so we get web browser launcher
668
669* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
670- system tray 0.6 with server file fixed (work dammit)
671
672* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
673- tweak applet positions but I think it's just broken
674- system tray 0.5 moved back to libdir not libexecdir
675
676* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
677- remove ltmain.sh hack
678- new system-tray-applet that works
679
680* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
681- put office suite stuff on the panel
682
683* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
684- 2.0.2.90 cvs snap
685
686* Wed Jul 10 2002 Havoc Pennington <hp@redhat.com>
687- update the clock patch to be a little smarter in a couple ways
688
689* Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
690- Fix problem where system tray applet was being looked for in /unst
691- Fix a crash in the system tray applet
692
693* Wed Jun 26 2002 Owen Taylor <otaylor@redhat.com>
694- Fix typo in the pt_BR translation that was causing GConf problems
695
696* Mon Jun 24 2002 Havoc Pennington <hp@redhat.com>
697- add the system tray applet
698- add system tray applet by default
699- add more launcher by default
700
701* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
702- automated rebuild
703
704* Thu Jun 20 2002 Havoc Pennington <hp@redhat.com>
705- use correct gettext package name, and add check for missing translations
706
707* Mon Jun 17 2002 Havoc Pennington <hp@redhat.com>
708- add the calendar and configuration patch
709
710* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
711- 2.0.0
712- add control center desktop file to file list
713- add gnome-panelrc to file list
714- try fixing panel size (blind, no text box at home)
715
716* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
717- rebuild in different environment
718
719* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
720- updates to default configuration
721
722* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
723- fix schemas installation
724
725* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
726- unset old panel schemas when installing new ones
727- put in a broken panel config to see errors about
728- add a patch to give some decent error messages about what's wrong
729  with the default panel config
730
731* Sun Jun 09 2002 Havoc Pennington <hp@redhat.com>
732- rebuild in different environment
733
734* Sun Jun  9 2002 Havoc Pennington <hp@redhat.com>
735- don't provide/obsolete gnome-core
736
737* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
738- rebuild in different environment
739
740* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
741- 1.5.24
742- ldconfig
743
744* Mon Jun 03 2002 Havoc Pennington <hp@redhat.com>
745- rebuild in different environment
746
747* Fri May 31 2002 Havoc Pennington <hp@redhat.com>
748- 1.5.23
749
750* Sun May 26 2002 Tim Powers <timp@redhat.com>
751- automated rebuild
752
753* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
754- rebuild in different environment
755
756* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
757- 1.5.22
758- provide gnome-core
759- add a bunch of extra build requires so build system
760  won't get confused
761
762* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
763- 1.5.19
764
765* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
766- add the keep-libtool-from-relinking hack so
767  we get the gen util applet
768
769* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
770- obsoletes gnome-core-devel
771- include libdir/*.so
772
773* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
774- get libpanel-applet in the package
775
776* Tue Apr 16 2002 Havoc Pennington <hp@redhat.com>
777- Initial build.
778
779
Note: See TracBrowser for help on using the repository browser.