source: projects/specs/trunk/g/gnome-panel/gnome-panel-vl.spec @ 2274

Revision 2274, 26.4 KB checked in by Takemikaduchi, 13 years ago (diff)

pidgin:new upstream release, gnome-panel:remove Provides

Line 
1%define use_eds 1
2
3%define gettext_package gnome-panel-2.0
4
5%define gnome_desktop_version 2.32.1
6%define glib2_version 2.26.1
7%define gtk2_version 2.22.1
8%define libgnome_version 2.32.0
9%define libbonoboui_version 2.24.4
10%define orbit_version 2.14.19
11%define libwnck_version 2.30.5
12%define gconf_version 2.32.0
13%define gnome_menus_version 2.30.4
14%define evolution_data_server_version 2.32.0
15%define cairo_version 1.10.0
16%define dbus_version 1.4.0
17%define dbus_glib_version 0.88
18%define gnome_doc_utils_version 0.3.2
19%define libgweather_version 2.30.3
20%define libcanberra_version 0.25
21%define gobject_introspection_version 0.9.8
22
23Summary: GNOME panel
24Summary(ja): GNOME パネル
25Name: gnome-panel
26Version: 2.32.1
27Release: 2%{_dist_release}
28URL: http://www.gnome.org/
29License: GPL
30Group: User Interface/Desktops
31
32Source0: http://ftp.gnome.org/pub/gnome/sources/gnome-panel/2.32/%{name}-%{version}.tar.bz2
33# Remove this line and next line when upstream adopt Source1
34Source1: clock.gnome-2-28.ja.po
35Source2: vine-panel-default-setup.entries
36Source5: vine-panel-backwards-compat-config.schemas
37Source10: add-translations.sh
38Source12: gnome-compiler-flags.m4
39
40Patch0: gnome-panel-2.28.0-vendor.patch
41Patch1: gnome-panel-2.10.1-speak-to-us-ye-old-wise-fish.patch
42Patch2: gnome-panel-2.28.0-about-vine.patch
43
44# the next three patches belong together
45# http://bugzilla.gnome.org/show_bug.cgi?id=470966
46Patch8: launcher-desktop-files.patch
47Patch9: desktop-file-monitoring.patch
48Patch10: preferred-apps.patch
49
50# don't pop up an error dialog if an applet from the
51# default configuration is missing; we don't want to
52# add a hard dependency on e.g. tomboy
53Patch11: applet-error.patch
54
55BuildRoot: %{_tmppath}/%{name}-%{version}-root
56
57Requires: %{name}-libs = %{version}-%{release}
58Requires: gnome-desktop >= %{gnome_desktop_version}
59Requires: libwnck >= %{libwnck_version}
60Requires: gnome-menus >= %{gnome_menus_version}
61Requires: vine-menus >= 1.1
62Requires(post,postun): scrollkeeper, gtk2
63Requires(post,pre,preun): GConf2
64
65%if %{use_eds}
66Requires: evolution-data-server >= 2.30.2
67%endif
68Requires: libSM
69
70BuildRequires: libxml2-python
71BuildRequires: intltool
72BuildRequires: gettext
73BuildRequires: automake
74BuildRequires: autoconf
75BuildRequires: libtool
76BuildRequires: scrollkeeper
77BuildRequires: libxslt
78BuildRequires: gnome-desktop-devel >= %{gnome_desktop_version}
79BuildRequires: gtk2-devel >= %{gtk2_version}
80BuildRequires: libgnome-devel >= %{libgnome_version}
81BuildRequires: libbonoboui-devel >= %{libbonoboui_version}
82BuildRequires: libwnck-devel >= %{libwnck_version}
83BuildRequires: GConf2-devel >= %{gconf_version}
84BuildRequires: gnome-menus-devel >= %{gnome_menus_version}
85BuildRequires: cairo-devel >= %{cairo_version}
86BuildRequires: gnome-doc-utils >= %{gnome_doc_utils_version}
87BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
88BuildRequires: gtk-doc
89BuildRequires: pango-devel
90BuildRequires: libbonobo-devel
91BuildRequires: libX11-devel
92BuildRequires: libXau-devel
93%if %{use_eds}
94BuildRequires: evolution-data-server-devel >= %{evolution_data_server_version}
95BuildRequires: ORBit2-devel >= %{orbit_version}
96BuildRequires: dbus-devel >= %{dbus_version}
97%endif
98BuildRequires: libgweather-devel >= %{libgweather_version}
99BuildRequires: libcanberra-devel >= %{libcanberra_versino}
100BuildRequires: librsvg2-devel
101BuildRequires: polkit-gnome-devel
102BuildRequires: NetworkManager-devel
103BuildRequires: libSM-devel
104BuildRequires: gobject-introspection-devel >= %{gobject_introspection_version}
105BuildRequires(install): desktop-file-utils
106
107%description
108
109The GNOME panel provides the window list, workspace switcher, menus, and other
110features for the GNOME desktop.
111
112%description -l ja
113
114GNOME パネルは、ウィンドウ一覧・ワークスペース切り換え器・メニューその他の
115特徴を GNOME デスクトップに提供します。
116
117%package libs
118Summary: Libraries for use in panel applets of GNOME
119Summary(ja): GNOME のパネルアップレットで使用するライブラリ
120Group: System Environment/Libraries
121
122%description libs
123Libraries for use in panel applets of GNOME.
124
125%description libs -l ja
126GNOME のパネルアップレットで使用するライブラリ
127
128%package devel
129Summary: Development environment for panel applets of GNOME
130Summary(ja): GNOME のパネルアップレット用開発環境
131Group: Development/Libraries
132Requires: %{name}-libs = %{version}-%{release}
133Requires: pkgconfig
134Requires: gtk2-devel >= %{gtk2_version}
135Requires: libbonoboui-devel >= %{libbonoboui_version}
136Requires: GConf2-devel >= %{gconf_version}
137
138%description devel
139Header files and libraries for building a panel applets of GNOME.
140
141%description devel -l ja
142GNOME のパネルアップレットをビルドするためのヘッダファイル及びライブラリ集
143
144
145%prep
146%setup -q
147
148# Remove this line and next line when upstream adopt Source1
149cp -f %{SOURCE1} help/clock/ja/ja.po
150
151cp -f %{SOURCE2} gnome-panel/panel-default-setup.entries
152cp -f %{SOURCE12} m4
153cp -f %{SOURCE5} gnome-panel/panel-compatibility.schemas
154
155%patch0 -p1 -b .vendor
156%patch1 -p1 -b .speak-to-us-ye-old-wise-fish
157%patch2 -p1 -b .about-vine
158%patch8 -p1 -b .launcher-desktop-files
159%patch9 -p1 -b .desktop-file-monitoring
160%patch10 -p1 -b .preferred-apps
161## %patch11 -p1 -b .applet-error
162
163libtoolize --force --copy
164
165. %{SOURCE10}
166
167%build
168# gpm-integration patches Makefile.am and configure.in
169aclocal -I m4
170automake --add-missing
171autoheader
172autoconf
173%configure --disable-scrollkeeper \
174           --disable-schemas-install \
175           --disable-gtk-doc \
176           --with-in-process-applets=clock:fish \
177           --enable-introspection=yes \
178%if %{use_eds}
179           --enable-eds=yes
180%else
181           --enable-eds=no
182%endif
183make
184
185%install
186rm -rf $RPM_BUILD_ROOT
187
188export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
189make install DESTDIR=$RPM_BUILD_ROOT
190unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
191
192#
193# Create pager and tasklist schemas for compatibility with older
194# configurations which reference the old schema names
195#
196sed -e 's|/schemas/apps/window_list_applet/prefs/|/schemas/apps/tasklist_applet/prefs/|' $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/window-list.schemas > $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/tasklist.schemas
197sed -e 's|/schemas/apps/workspace_switcher_applet/prefs/|/schemas/apps/pager_applet/prefs/|; s|<default>1</default>|<default>2</default>|' $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/workspace-switcher.schemas > $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/pager.schemas
198
199
200## blow away stuff we don't want
201/bin/rm -rf $RPM_BUILD_ROOT%{_localstatedir}/scrollkeeper
202#rmdir --ignore-fail-on-non-empty $RPM_BUILD_ROOT/var
203/bin/rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
204
205/bin/rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
206
207sed -i -e "s/NoDisplay=True/NoDisplay=true/" $RPM_BUILD_ROOT%{_datadir}/applications/gnome-panel.desktop
208
209desktop-file-install --delete-original \
210  --dir $RPM_BUILD_ROOT%{_datadir}/applications \
211  $RPM_BUILD_ROOT%{_datadir}/applications/gnome-panel.desktop
212
213%find_lang %{gettext_package} --all-name --with-gnome
214#grep -q '/usr/share/locale' %{gettext_package}.lang || exit 1
215
216%clean
217rm -rf $RPM_BUILD_ROOT
218
219%post
220touch --no-create %{_datadir}/icons/hicolor
221if [ -x /usr/bin/gtk-update-icon-cache ]; then
222  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
223fi
224
225export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
226
227#
228# Clear out the old defaults
229#
230gconftool-2 --direct --config-source=$GCONF_CONFIG_SOURCE --recursive-unset /apps/panel > /dev/null || :
231gconftool-2 --direct --config-source=$GCONF_CONFIG_SOURCE --recursive-unset /schemas/apps/panel > /dev/null || :
232
233# install schemas
234SCHEMAS="clock.schemas fish.schemas pager.schemas \
235        panel-compatibility.schemas panel-general.schemas \
236        panel-global.schemas panel-object.schemas panel-toplevel.schemas \
237        tasklist.schemas window-list.schemas workspace-switcher.schemas"
238for S in $SCHEMAS; do
239    echo %{_sysconfdir}/gconf/schemas/$S ; done \
240    | xargs gconftool-2 --makefile-install-rule >& /dev/null ||:
241
242#
243# Install the default setup into /apps/panel and /apps/panel/default_setup
244#
245gconftool-2 --direct --config-source=$GCONF_CONFIG_SOURCE --load %{_sysconfdir}/gconf/schemas/panel-default-setup.entries > /dev/null || :
246gconftool-2 --direct --config-source=$GCONF_CONFIG_SOURCE --load %{_sysconfdir}/gconf/schemas/panel-default-setup.entries /apps/panel > /dev/null || :
247
248/sbin/ldconfig
249scrollkeeper-update > /dev/null 2>&1 || :
250
251%pre
252if [ "$1" -gt 1 ]; then
253  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
254  SCHEMAS="clock.schemas fish.schemas pager.schemas \
255          panel-compatibility.schemas panel-general.schemas \
256          panel-global.schemas panel-object.schemas panel-toplevel.schemas \
257          tasklist.schemas window-list.schemas workspace-switcher.schemas"
258  for S in $SCHEMAS; do
259      echo %{_sysconfdir}/gconf/schemas/$S ; done \
260      | xargs gconftool-2 --makefile-uninstall-rule >& /dev/null ||:
261fi
262
263%preun
264if [ "$1" -eq 0 ]; then
265  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
266  SCHEMAS="clock.schemas fish.schemas pager.schemas \
267          panel-compatibility.schemas panel-general.schemas \
268          panel-global.schemas panel-object.schemas panel-toplevel.schemas \
269          tasklist.schemas window-list.schemas workspace-switcher.schemas"
270  for S in $SCHEMAS; do
271      echo %{_sysconfdir}/gconf/schemas/$S ; done \
272      | xargs gconftool-2 --makefile-uninstall-rule >& /dev/null ||:
273fi
274
275%postun
276/sbin/ldconfig
277scrollkeeper-update > /dev/null 2>&1 || :
278touch --no-create %{_datadir}/icons/hicolor
279if [ -x /usr/bin/gtk-update-icon-cache ]; then
280  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
281fi
282 
283%files -f %{gettext_package}.lang
284%defattr(-,root,root)
285%doc AUTHORS COPYING COPYING.LIB COPYING-DOCS NEWS README
286%{_datadir}/applications/*.desktop
287%{_datadir}/icons/*
288%{_datadir}/gnome-panel
289%exclude %{_datadir}/gnome-panelrc
290%{_datadir}/idl/gnome-panel-2.0
291%{_datadir}/gnome-2.0/ui/*
292%{_mandir}/man*/*
293%{_bindir}/*
294%exclude %{_bindir}/panel-test-applets
295%{_libexecdir}/*
296%{_libdir}/gnome-panel/modules/libpanel-applets-bonobo.*
297%{_sysconfdir}/gconf/schemas/*.schemas
298%{_sysconfdir}/gconf/schemas/*.entries
299%{_datadir}/dbus-1/services/org.gnome.panel.applet.ClockAppletFactory.service
300%{_datadir}/dbus-1/services/org.gnome.panel.applet.FishAppletFactory.service
301%{_datadir}/dbus-1/services/org.gnome.panel.applet.NotificationAreaAppletFactory.service
302%{_datadir}/dbus-1/services/org.gnome.panel.applet.WnckletFactory.service
303
304%files libs
305%{_libdir}/*.so.*
306%{_libdir}/girepository-1.0
307
308%files devel
309%{_bindir}/panel-test-applets
310%{_libdir}/pkgconfig/*.pc
311%{_includedir}/gnome-panel-3.0
312%{_includedir}/panel-2.0
313%{_libdir}/*.so
314%{_datadir}/gtk-doc
315%{_datadir}/gir-1.0
316
317
318%changelog
319* Sat Dec 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-2
320- remove Provides: gnome-panel-devel
321
322* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
323- new upstream release
324
325* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0.2-1
326- new upstream release
327- add BuildRequires: gobject-introspection-devel
328- remove BuildRequires: libgnomeui-devel
329- remove SOURCE3 and SOURCE4
330- drop Patch11
331- add configure option (--enable-introspection=yes)
332
333* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-3
334- rebuild with rpm-4.8.1 for pkg-config file
335
336* Sun Aug 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-2
337- create -libs and -devel package
338
339* Tue Jun 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
340- new upstream release
341
342* Tue Jun 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-2
343- rebuild with evolution-data-server-2.30.2
344
345* Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
346- new upstream release
347- update Patch8, Patch9 (from FC package)
348- add BuildRequires: libcanberra-devel
349
350* Sat Mar 27 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.28.0-4
351- update translation of clock applet manual
352- add translation of fish applet manual
353
354* Fri Mar 26 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.28.0-3
355- add libSM(-devel) to (Build)Requires
356- add desktop-file-utils to BuildRequires
357
358* Thu Mar 25 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.28.0-2
359- update translation of clock applet manual
360
361* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.0-1
362- new upstream release
363- updated Patch0 and 2
364
365* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
366- new upstream release
367
368* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-3
369- rebuild with gtk2-2.16.3
370
371* Thu Jun 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
372- add empty gconf entries to vine-panel-default-setup.entries
373
374* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
375- new upstream release
376
377* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
378- new upstream release
379
380* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-4
381- update vine-panel-default-setup.entries again..
382
383* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-3
384- update vine-panel-default-setup.entries
385
386* Tue Mar 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-2
387- remove mixer applets from default panel setup
388
389* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
390- new upstream release
391
392* Mon Jan 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.3-1
393- new upstream release
394- added BuildRequires: PolicyKit-gnome-devel
395
396* Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
397- new upstream release
398
399* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
400- new upstream release
401
402* Tue Jun  3 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1
403- new upstream release
404
405* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.3-1
406- new upstream release
407
408* Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.2-1vl5
409- new upstream release
410- removed Patch25,26,27,29 and 30 (merged into upstream)
411
412* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-2vl5
413- added Patches from FC
414  * Fri Mar 28 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-8
415  - Fix editing of locations in the clock applet
416  * Fri Mar 28 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-7
417  - Convert the edit and find location windows to dialogs
418  * Thu Mar 27 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-6
419  - Improve the time settings window
420  * Thu Mar 27 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-5
421  - Make the find-location window of the clock larger
422  * Sat Mar 15 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-4
423  - Only save the session when the users wants it
424  * Fri Mar 14 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-3
425  - Populate the location list before showing the preference window
426  * Sat Mar  8 2008 Will Woods <wwoods@redhat.com> - 2.21.92-6
427  - Add "About This Computer" item to System menu if it exists
428  * Wed Feb 20 2008 Matthias Clasen <mclasen@redhat.com> - 2.21.91-6
429  - Try harder to avoid resizing the popup
430- updated BuildRequires
431
432* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
433- new upstream release
434- added BuildRequires: libgweather-devel
435
436* Tue Jan  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.2-0vl1
437- new upstream release
438- updated %post and %postun section
439- added %pre and %preun section
440- added Patches from Fedora
441  * Fri Oct 12 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0.1-4
442  - Sharper icons
443  * Wed Oct  3 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0.1-3
444  - Make it possible to start s-c-d from the clock menu again (#316921)
445  * Fri Sep 21 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0.1-2
446  - Don't pop up an error if an applet from the default
447    configuration is missing 
448  * Mon Sep 17 2007 Matthias Clasen <mclasen@redhat.com> - 2.19.92-6
449  - Turns out we need requires for applets in the default config (#293261)
450  * Mon Sep 17 2007 Matthias Clasen <mclasen@redhat.com> - 2.19.92-5
451  - Drop the requires for fast-user-switch-applet (#253831)
452
453* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.3-0vl1
454- new upstream release
455- dropped Patch22 (merged into upstream)
456
457* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
458- new upstream release
459
460* Mon Oct 30 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.3-0vl2
461- add missing BuildRequires to gnome-menus-devel (<BTS:319>)
462
463* Thu Oct 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl1
464- new upstream release
465- fix panel-default-setup.entries to change the name of
466  firefox desktopfile (<BTS:229>)
467
468* Thu Jul 20 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.14.2-0vl2
469- add patch 11 to fix disappearing of recent documents list.
470  <BTS:VineLinux:81>, http://bugzilla.gnome.org/show_bug.cgi?id=343812
471
472* Sat Jun  3 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.2-0vl1
473- new upstream release
474
475* Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
476- new upstream release
477
478* Sat Apr 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
479- run gtk-update-icon-cache in %%post script.
480
481* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
482- new upstream release
483
484* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.91-0vl2
485- update vine-panel-default-setup.entries
486  - replace mozilla by firefox
487  - remove nautilus
488  - add notification area applet on top panel
489  - add trashbox applet on bottom panel
490- cleanup %%post script
491
492* Thu Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.91-0vl1
493- new upstream release
494
495* Sun Feb 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.3-0vl1
496- new upstream release
497- added Prereq: scroolkeeper, GConf2
498
499* Wed Oct 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
500- new upstream release
501
502* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
503- new upstream release
504
505* Sun Aug 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.91-0vl1
506- new upstream release
507
508* Wed Aug 03 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
509- new upstream release
510
511* Thu Jul 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.2-0vl1
512- new upstream release
513
514* Sat Apr 16 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl2
515- disable evolution-data-server
516
517* Thu Apr 14 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
518- new upstream release
519
520* Thu Mar 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl2
521- add Patch10 to fix hard-coded desktop file name.
522
523* Thu Mar 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
524- new upstream version
525
526* Fri Feb 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.3-0vl1
527- new upstream release
528- run scrollkeeper at %post, %postun
529
530* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
531- new upstream release
532
533* Fri Oct 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl3
534- add Patch10 to fix egg-recent-model.c.
535  save old umask value before create ".recently-used" file.
536 
537* Sun Oct 24 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.4.2-0vl2
538- fix location of nautilus launcher in panel-default-setup.entries.
539- do not add wireless monitor in %%post when no interfaces are available.
540- add Japanese summary and description
541- add BuildRequires: startup-notification-devel, gcc-c++.
542- disable libtoolize: version mismatch is bad
543
544* Sat Jan 31 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
545- new upstream release
546
547* Sat Dec 27 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
548- new upstream release
549
550* Sat Dec 27 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.0-0vl3
551- rebuilt against new toolchain
552
553* Fri Sep 12 2003 Tomoya TAKA <taka@vinelinux.org> 2.4.0-0vl2
554- add --disable-schemas-install option to %%configure
555
556* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
557- new upstream release
558
559* Mon Sep 08 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.91-0vl2
560- add missing files
561- add vine default panel entries
562
563* Sat Sep 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.91-0vl1
564- new upstream release
565
566* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
567- new upstream release
568
569* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.7-0vl1
570- new upstream release
571
572* Wed Jun 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2.1-0vl2
573- remove vine's panel-per-panel-config.schemas
574  This should be added again in a future version.
575
576* Tue Jun 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2.1-0vl1
577- new upstream release
578
579* Tue Apr 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
580- new upstream release
581- remove old ja.po
582
583* Sat Feb 15 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
584- new upstream release
585
586* Wed Jan 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl2
587- remove clockaddon, system-tray-applet
588
589* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
590- new upstream release
591
592* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.90.1-0vl2
593- add patch1 from rawhide package.
594
595* Fri Jan 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.90.1-0vl1
596- new upstream release
597
598* Sat Dec 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
599- add system-tray-applet
600- modify default panel menu.
601- update ja.po
602
603* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
604- add Requires: vine-menus
605
606* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
607- new upstream release
608
609* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl2
610- remove redhatize patch.
611
612* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
613- build for Vine Linux
614- new upstream release from gnome-2.1.4
615
616* Mon Oct 14 2002 Florian La Roche <Florian.LaRoche@redhat.de>
617- fix postun script
618
619* Tue Oct  8 2002 Havoc Pennington <hp@redhat.com>
620- 2.0.9 with menu edit stuff
621- system-tray-applet 0.15 that doesn't crash all the time
622- merge/remove patches as appropriate
623
624* Wed Aug 28 2002 Owen Taylor <otaylor@redhat.com>
625- Fix problem with "hold down print screen" (71432)
626
627* Tue Aug 27 2002 Jonathan Blandford <jrb@redhat.com>
628- panel-properties OnlyShowIn=GNOME;
629- somehow the po file got screwed up.  Works now
630- update po files
631
632* Sun Aug 25 2002 Havoc Pennington <hp@redhat.com>
633- fix from #71762 for clock applet popdown key
634- no WIN_POS_MOUSE fixes #72167
635- fix for #72540 from George
636
637* Wed Aug 21 2002 Havoc Pennington <hp@redhat.com>
638- system tray applet 0.11 with a small memleak fix and a couple translations
639
640* Thu Aug 15 2002 Jonathan Blandford <jrb@redhat.com>
641- menu tweaks
642
643* Wed Aug 14 2002 Tim Powers <timp@redhat.com>
644- bump release
645
646* Wed Aug 14 2002 Preston Brown <pbrown@redhat.com>
647- put battery applet on panel for laptops (#67296)
648
649* Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
650- 2.0.6 final from gnome 2.0.1
651- remove gnome-panel-screenshot patch now upstream
652
653* Thu Aug  8 2002 Jonathan Blandford <jrb@redhat.com>
654- new system-tray-applet version
655- Fix gnome-panel-screenshot
656
657* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
658- 2.0.4
659- replace gnome-logo-icon-transparent.png with redhat-main-menu.png
660  for the foot menu
661
662* Fri Aug  2 2002 Havoc Pennington <hp@redhat.com>
663- fix desktop (logout/lock) menu item location
664  in Alt+F1 and in new menu applets
665- remove Screenshot... menu item
666
667* Fri Aug  2 2002 Havoc Pennington <hp@redhat.com>
668- move around default applets, remove some of them
669- system tray 0.9
670- change default menu flags
671- blow unpackaged files out of build root
672
673* Wed Jul 31 2002 Havoc Pennington <hp@redhat.com>
674- 2.0.3
675- own libexecdir stuff
676
677* Thu Jul 25 2002 Havoc Pennington <hp@redhat.com>
678- new system tray that's prettier and doesn't clip the icon
679
680* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
681- system tray 0.7 that doesn't crash on startup
682- get Mozilla desktop file right so we get web browser launcher
683
684* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
685- system tray 0.6 with server file fixed (work dammit)
686
687* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
688- tweak applet positions but I think it's just broken
689- system tray 0.5 moved back to libdir not libexecdir
690
691* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
692- remove ltmain.sh hack
693- new system-tray-applet that works
694
695* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
696- put office suite stuff on the panel
697
698* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
699- 2.0.2.90 cvs snap
700
701* Wed Jul 10 2002 Havoc Pennington <hp@redhat.com>
702- update the clock patch to be a little smarter in a couple ways
703
704* Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
705- Fix problem where system tray applet was being looked for in /unst
706- Fix a crash in the system tray applet
707
708* Wed Jun 26 2002 Owen Taylor <otaylor@redhat.com>
709- Fix typo in the pt_BR translation that was causing GConf problems
710
711* Mon Jun 24 2002 Havoc Pennington <hp@redhat.com>
712- add the system tray applet
713- add system tray applet by default
714- add more launcher by default
715
716* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
717- automated rebuild
718
719* Thu Jun 20 2002 Havoc Pennington <hp@redhat.com>
720- use correct gettext package name, and add check for missing translations
721
722* Mon Jun 17 2002 Havoc Pennington <hp@redhat.com>
723- add the calendar and configuration patch
724
725* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
726- 2.0.0
727- add control center desktop file to file list
728- add gnome-panelrc to file list
729- try fixing panel size (blind, no text box at home)
730
731* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
732- rebuild in different environment
733
734* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
735- updates to default configuration
736
737* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
738- fix schemas installation
739
740* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
741- unset old panel schemas when installing new ones
742- put in a broken panel config to see errors about
743- add a patch to give some decent error messages about what's wrong
744  with the default panel config
745
746* Sun Jun 09 2002 Havoc Pennington <hp@redhat.com>
747- rebuild in different environment
748
749* Sun Jun  9 2002 Havoc Pennington <hp@redhat.com>
750- don't provide/obsolete gnome-core
751
752* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
753- rebuild in different environment
754
755* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
756- 1.5.24
757- ldconfig
758
759* Mon Jun 03 2002 Havoc Pennington <hp@redhat.com>
760- rebuild in different environment
761
762* Fri May 31 2002 Havoc Pennington <hp@redhat.com>
763- 1.5.23
764
765* Sun May 26 2002 Tim Powers <timp@redhat.com>
766- automated rebuild
767
768* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
769- rebuild in different environment
770
771* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
772- 1.5.22
773- provide gnome-core
774- add a bunch of extra build requires so build system
775  won't get confused
776
777* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
778- 1.5.19
779
780* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
781- add the keep-libtool-from-relinking hack so
782  we get the gen util applet
783
784* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
785- obsoletes gnome-core-devel
786- include libdir/*.so
787
788* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
789- get libpanel-applet in the package
790
791* Tue Apr 16 2002 Havoc Pennington <hp@redhat.com>
792- Initial build.
793
794
Note: See TracBrowser for help on using the repository browser.