source: projects/specs/trunk/g/gnome-panel/gnome-panel-vl.spec @ 2219

Revision 2219, 26.3 KB checked in by Takemikaduchi, 14 years ago (diff)

new upstream release

Line 
1%define use_eds 1
2
3%define gettext_package gnome-panel-2.0
4
5%define gnome_desktop_version 2.32.1
6%define glib2_version 2.26.1
7%define gtk2_version 2.22.1
8%define libgnome_version 2.32.0
9%define libbonoboui_version 2.24.4
10%define orbit_version 2.14.19
11%define libwnck_version 2.30.5
12%define gconf_version 2.32.0
13%define gnome_menus_version 2.30.4
14%define evolution_data_server_version 2.32.0
15%define cairo_version 1.10.0
16%define dbus_version 1.4.0
17%define dbus_glib_version 0.88
18%define gnome_doc_utils_version 0.3.2
19%define libgweather_version 2.30.3
20%define libcanberra_version 0.25
21%define gobject_introspection_version 0.9.8
22
23Summary: GNOME panel
24Summary(ja): GNOME パネル
25Name: gnome-panel
26Version: 2.32.1
27Release: 1%{_dist_release}
28URL: http://www.gnome.org/
29License: GPL
30Group: User Interface/Desktops
31
32Source0: http://ftp.gnome.org/pub/gnome/sources/gnome-panel/2.32/%{name}-%{version}.tar.bz2
33# Remove this line and next line when upstream adopt Source1
34Source1: clock.gnome-2-28.ja.po
35Source2: vine-panel-default-setup.entries
36Source5: vine-panel-backwards-compat-config.schemas
37Source10: add-translations.sh
38Source12: gnome-compiler-flags.m4
39
40Patch0: gnome-panel-2.28.0-vendor.patch
41Patch1: gnome-panel-2.10.1-speak-to-us-ye-old-wise-fish.patch
42Patch2: gnome-panel-2.28.0-about-vine.patch
43
44# the next three patches belong together
45# http://bugzilla.gnome.org/show_bug.cgi?id=470966
46Patch8: launcher-desktop-files.patch
47Patch9: desktop-file-monitoring.patch
48Patch10: preferred-apps.patch
49
50# don't pop up an error dialog if an applet from the
51# default configuration is missing; we don't want to
52# add a hard dependency on e.g. tomboy
53Patch11: applet-error.patch
54
55BuildRoot: %{_tmppath}/%{name}-%{version}-root
56
57Requires: %{name}-libs = %{version}-%{release}
58Requires: gnome-desktop >= %{gnome_desktop_version}
59Requires: libwnck >= %{libwnck_version}
60Requires: gnome-menus >= %{gnome_menus_version}
61Requires: vine-menus >= 1.1
62Requires(post,postun): scrollkeeper, gtk2
63Requires(post,pre,preun): GConf2
64
65Provides: %{name}-devel = %{version}-%{release}
66
67%if %{use_eds}
68Requires: evolution-data-server >= 2.30.2
69%endif
70Requires: libSM
71
72BuildRequires: libxml2-python
73BuildRequires: intltool
74BuildRequires: gettext
75BuildRequires: automake
76BuildRequires: autoconf
77BuildRequires: libtool
78BuildRequires: scrollkeeper
79BuildRequires: libxslt
80BuildRequires: gnome-desktop-devel >= %{gnome_desktop_version}
81BuildRequires: gtk2-devel >= %{gtk2_version}
82BuildRequires: libgnome-devel >= %{libgnome_version}
83BuildRequires: libbonoboui-devel >= %{libbonoboui_version}
84BuildRequires: libwnck-devel >= %{libwnck_version}
85BuildRequires: GConf2-devel >= %{gconf_version}
86BuildRequires: gnome-menus-devel >= %{gnome_menus_version}
87BuildRequires: cairo-devel >= %{cairo_version}
88BuildRequires: gnome-doc-utils >= %{gnome_doc_utils_version}
89BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
90BuildRequires: gtk-doc
91BuildRequires: pango-devel
92BuildRequires: libbonobo-devel
93BuildRequires: libX11-devel
94BuildRequires: libXau-devel
95%if %{use_eds}
96BuildRequires: evolution-data-server-devel >= %{evolution_data_server_version}
97BuildRequires: ORBit2-devel >= %{orbit_version}
98BuildRequires: dbus-devel >= %{dbus_version}
99%endif
100BuildRequires: libgweather-devel >= %{libgweather_version}
101BuildRequires: libcanberra-devel >= %{libcanberra_versino}
102BuildRequires: librsvg2-devel
103BuildRequires: polkit-gnome-devel
104BuildRequires: NetworkManager-devel
105BuildRequires: libSM-devel
106BuildRequires: gobject-introspection-devel >= %{gobject_introspection_version}
107BuildRequires(install): desktop-file-utils
108
109%description
110
111The GNOME panel provides the window list, workspace switcher, menus, and other
112features for the GNOME desktop.
113
114%description -l ja
115
116GNOME パネルは、ウィンドウ一覧・ワークスペース切り換え器・メニューその他の
117特徴を GNOME デスクトップに提供します。
118
119%package libs
120Summary: Libraries for use in panel applets of GNOME
121Summary(ja): GNOME のパネルアップレットで使用するライブラリ
122Group: System Environment/Libraries
123
124%description libs
125Libraries for use in panel applets of GNOME.
126
127%description libs -l ja
128GNOME のパネルアップレットで使用するライブラリ
129
130%package devel
131Summary: Development environment for panel applets of GNOME
132Summary(ja): GNOME のパネルアップレット用開発環境
133Group: Development/Libraries
134Requires: %{name}-libs = %{version}-%{release}
135Requires: pkgconfig
136Requires: gtk2-devel >= %{gtk2_version}
137Requires: libbonoboui-devel >= %{libbonoboui_version}
138Requires: GConf2-devel >= %{gconf_version}
139
140%description devel
141Header files and libraries for building a panel applets of GNOME.
142
143%description devel -l ja
144GNOME のパネルアップレットをビルドするためのヘッダファイル及びライブラリ集
145
146
147%prep
148%setup -q
149
150# Remove this line and next line when upstream adopt Source1
151cp -f %{SOURCE1} help/clock/ja/ja.po
152
153cp -f %{SOURCE2} gnome-panel/panel-default-setup.entries
154cp -f %{SOURCE12} m4
155cp -f %{SOURCE5} gnome-panel/panel-compatibility.schemas
156
157%patch0 -p1 -b .vendor
158%patch1 -p1 -b .speak-to-us-ye-old-wise-fish
159%patch2 -p1 -b .about-vine
160%patch8 -p1 -b .launcher-desktop-files
161%patch9 -p1 -b .desktop-file-monitoring
162%patch10 -p1 -b .preferred-apps
163## %patch11 -p1 -b .applet-error
164
165libtoolize --force --copy
166
167. %{SOURCE10}
168
169%build
170# gpm-integration patches Makefile.am and configure.in
171aclocal -I m4
172automake --add-missing
173autoheader
174autoconf
175%configure --disable-scrollkeeper \
176           --disable-schemas-install \
177           --disable-gtk-doc \
178           --with-in-process-applets=clock:fish \
179           --enable-introspection=yes \
180%if %{use_eds}
181           --enable-eds=yes
182%else
183           --enable-eds=no
184%endif
185make
186
187%install
188rm -rf $RPM_BUILD_ROOT
189
190export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
191make install DESTDIR=$RPM_BUILD_ROOT
192unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
193
194#
195# Create pager and tasklist schemas for compatibility with older
196# configurations which reference the old schema names
197#
198sed -e 's|/schemas/apps/window_list_applet/prefs/|/schemas/apps/tasklist_applet/prefs/|' $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/window-list.schemas > $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/tasklist.schemas
199sed -e 's|/schemas/apps/workspace_switcher_applet/prefs/|/schemas/apps/pager_applet/prefs/|; s|<default>1</default>|<default>2</default>|' $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/workspace-switcher.schemas > $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/pager.schemas
200
201
202## blow away stuff we don't want
203/bin/rm -rf $RPM_BUILD_ROOT%{_localstatedir}/scrollkeeper
204#rmdir --ignore-fail-on-non-empty $RPM_BUILD_ROOT/var
205/bin/rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
206
207/bin/rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
208
209sed -i -e "s/NoDisplay=True/NoDisplay=true/" $RPM_BUILD_ROOT%{_datadir}/applications/gnome-panel.desktop
210
211desktop-file-install --delete-original \
212  --dir $RPM_BUILD_ROOT%{_datadir}/applications \
213  $RPM_BUILD_ROOT%{_datadir}/applications/gnome-panel.desktop
214
215%find_lang %{gettext_package} --all-name --with-gnome
216#grep -q '/usr/share/locale' %{gettext_package}.lang || exit 1
217
218%clean
219rm -rf $RPM_BUILD_ROOT
220
221%post
222touch --no-create %{_datadir}/icons/hicolor
223if [ -x /usr/bin/gtk-update-icon-cache ]; then
224  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
225fi
226
227export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
228
229#
230# Clear out the old defaults
231#
232gconftool-2 --direct --config-source=$GCONF_CONFIG_SOURCE --recursive-unset /apps/panel > /dev/null || :
233gconftool-2 --direct --config-source=$GCONF_CONFIG_SOURCE --recursive-unset /schemas/apps/panel > /dev/null || :
234
235# install schemas
236SCHEMAS="clock.schemas fish.schemas pager.schemas \
237        panel-compatibility.schemas panel-general.schemas \
238        panel-global.schemas panel-object.schemas panel-toplevel.schemas \
239        tasklist.schemas window-list.schemas workspace-switcher.schemas"
240for S in $SCHEMAS; do
241    echo %{_sysconfdir}/gconf/schemas/$S ; done \
242    | xargs gconftool-2 --makefile-install-rule >& /dev/null ||:
243
244#
245# Install the default setup into /apps/panel and /apps/panel/default_setup
246#
247gconftool-2 --direct --config-source=$GCONF_CONFIG_SOURCE --load %{_sysconfdir}/gconf/schemas/panel-default-setup.entries > /dev/null || :
248gconftool-2 --direct --config-source=$GCONF_CONFIG_SOURCE --load %{_sysconfdir}/gconf/schemas/panel-default-setup.entries /apps/panel > /dev/null || :
249
250/sbin/ldconfig
251scrollkeeper-update > /dev/null 2>&1 || :
252
253%pre
254if [ "$1" -gt 1 ]; then
255  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
256  SCHEMAS="clock.schemas fish.schemas pager.schemas \
257          panel-compatibility.schemas panel-general.schemas \
258          panel-global.schemas panel-object.schemas panel-toplevel.schemas \
259          tasklist.schemas window-list.schemas workspace-switcher.schemas"
260  for S in $SCHEMAS; do
261      echo %{_sysconfdir}/gconf/schemas/$S ; done \
262      | xargs gconftool-2 --makefile-uninstall-rule >& /dev/null ||:
263fi
264
265%preun
266if [ "$1" -eq 0 ]; then
267  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
268  SCHEMAS="clock.schemas fish.schemas pager.schemas \
269          panel-compatibility.schemas panel-general.schemas \
270          panel-global.schemas panel-object.schemas panel-toplevel.schemas \
271          tasklist.schemas window-list.schemas workspace-switcher.schemas"
272  for S in $SCHEMAS; do
273      echo %{_sysconfdir}/gconf/schemas/$S ; done \
274      | xargs gconftool-2 --makefile-uninstall-rule >& /dev/null ||:
275fi
276
277%postun
278/sbin/ldconfig
279scrollkeeper-update > /dev/null 2>&1 || :
280touch --no-create %{_datadir}/icons/hicolor
281if [ -x /usr/bin/gtk-update-icon-cache ]; then
282  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
283fi
284 
285%files -f %{gettext_package}.lang
286%defattr(-,root,root)
287%doc AUTHORS COPYING COPYING.LIB COPYING-DOCS NEWS README
288%{_datadir}/applications/*.desktop
289%{_datadir}/icons/*
290%{_datadir}/gnome-panel
291%exclude %{_datadir}/gnome-panelrc
292%{_datadir}/idl/gnome-panel-2.0
293%{_datadir}/gnome-2.0/ui/*
294%{_mandir}/man*/*
295%{_bindir}/*
296%exclude %{_bindir}/panel-test-applets
297%{_libexecdir}/*
298%{_libdir}/gnome-panel/modules/libpanel-applets-bonobo.*
299%{_sysconfdir}/gconf/schemas/*.schemas
300%{_sysconfdir}/gconf/schemas/*.entries
301%{_datadir}/dbus-1/services/org.gnome.panel.applet.ClockAppletFactory.service
302%{_datadir}/dbus-1/services/org.gnome.panel.applet.FishAppletFactory.service
303%{_datadir}/dbus-1/services/org.gnome.panel.applet.NotificationAreaAppletFactory.service
304%{_datadir}/dbus-1/services/org.gnome.panel.applet.WnckletFactory.service
305
306%files libs
307%{_libdir}/*.so.*
308%{_libdir}/girepository-1.0
309
310%files devel
311%{_bindir}/panel-test-applets
312%{_libdir}/pkgconfig/*.pc
313%{_includedir}/gnome-panel-3.0
314%{_includedir}/panel-2.0
315%{_libdir}/*.so
316%{_datadir}/gtk-doc
317%{_datadir}/gir-1.0
318
319
320%changelog
321* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
322- new upstream release
323
324* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0.2-1
325- new upstream release
326- add BuildRequires: gobject-introspection-devel
327- remove BuildRequires: libgnomeui-devel
328- remove SOURCE3 and SOURCE4
329- drop Patch11
330- add configure option (--enable-introspection=yes)
331
332* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-3
333- rebuild with rpm-4.8.1 for pkg-config file
334
335* Sun Aug 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-2
336- create -libs and -devel package
337
338* Tue Jun 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
339- new upstream release
340
341* Tue Jun 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-2
342- rebuild with evolution-data-server-2.30.2
343
344* Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
345- new upstream release
346- update Patch8, Patch9 (from FC package)
347- add BuildRequires: libcanberra-devel
348
349* Sat Mar 27 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.28.0-4
350- update translation of clock applet manual
351- add translation of fish applet manual
352
353* Fri Mar 26 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.28.0-3
354- add libSM(-devel) to (Build)Requires
355- add desktop-file-utils to BuildRequires
356
357* Thu Mar 25 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.28.0-2
358- update translation of clock applet manual
359
360* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.0-1
361- new upstream release
362- updated Patch0 and 2
363
364* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
365- new upstream release
366
367* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-3
368- rebuild with gtk2-2.16.3
369
370* Thu Jun 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
371- add empty gconf entries to vine-panel-default-setup.entries
372
373* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
374- new upstream release
375
376* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
377- new upstream release
378
379* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-4
380- update vine-panel-default-setup.entries again..
381
382* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-3
383- update vine-panel-default-setup.entries
384
385* Tue Mar 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-2
386- remove mixer applets from default panel setup
387
388* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
389- new upstream release
390
391* Mon Jan 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.3-1
392- new upstream release
393- added BuildRequires: PolicyKit-gnome-devel
394
395* Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
396- new upstream release
397
398* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
399- new upstream release
400
401* Tue Jun  3 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1
402- new upstream release
403
404* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.3-1
405- new upstream release
406
407* Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.2-1vl5
408- new upstream release
409- removed Patch25,26,27,29 and 30 (merged into upstream)
410
411* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-2vl5
412- added Patches from FC
413  * Fri Mar 28 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-8
414  - Fix editing of locations in the clock applet
415  * Fri Mar 28 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-7
416  - Convert the edit and find location windows to dialogs
417  * Thu Mar 27 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-6
418  - Improve the time settings window
419  * Thu Mar 27 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-5
420  - Make the find-location window of the clock larger
421  * Sat Mar 15 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-4
422  - Only save the session when the users wants it
423  * Fri Mar 14 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-3
424  - Populate the location list before showing the preference window
425  * Sat Mar  8 2008 Will Woods <wwoods@redhat.com> - 2.21.92-6
426  - Add "About This Computer" item to System menu if it exists
427  * Wed Feb 20 2008 Matthias Clasen <mclasen@redhat.com> - 2.21.91-6
428  - Try harder to avoid resizing the popup
429- updated BuildRequires
430
431* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
432- new upstream release
433- added BuildRequires: libgweather-devel
434
435* Tue Jan  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.2-0vl1
436- new upstream release
437- updated %post and %postun section
438- added %pre and %preun section
439- added Patches from Fedora
440  * Fri Oct 12 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0.1-4
441  - Sharper icons
442  * Wed Oct  3 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0.1-3
443  - Make it possible to start s-c-d from the clock menu again (#316921)
444  * Fri Sep 21 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0.1-2
445  - Don't pop up an error if an applet from the default
446    configuration is missing 
447  * Mon Sep 17 2007 Matthias Clasen <mclasen@redhat.com> - 2.19.92-6
448  - Turns out we need requires for applets in the default config (#293261)
449  * Mon Sep 17 2007 Matthias Clasen <mclasen@redhat.com> - 2.19.92-5
450  - Drop the requires for fast-user-switch-applet (#253831)
451
452* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.3-0vl1
453- new upstream release
454- dropped Patch22 (merged into upstream)
455
456* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
457- new upstream release
458
459* Mon Oct 30 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.3-0vl2
460- add missing BuildRequires to gnome-menus-devel (<BTS:319>)
461
462* Thu Oct 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl1
463- new upstream release
464- fix panel-default-setup.entries to change the name of
465  firefox desktopfile (<BTS:229>)
466
467* Thu Jul 20 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.14.2-0vl2
468- add patch 11 to fix disappearing of recent documents list.
469  <BTS:VineLinux:81>, http://bugzilla.gnome.org/show_bug.cgi?id=343812
470
471* Sat Jun  3 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.2-0vl1
472- new upstream release
473
474* Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
475- new upstream release
476
477* Sat Apr 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
478- run gtk-update-icon-cache in %%post script.
479
480* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
481- new upstream release
482
483* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.91-0vl2
484- update vine-panel-default-setup.entries
485  - replace mozilla by firefox
486  - remove nautilus
487  - add notification area applet on top panel
488  - add trashbox applet on bottom panel
489- cleanup %%post script
490
491* Thu Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.91-0vl1
492- new upstream release
493
494* Sun Feb 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.3-0vl1
495- new upstream release
496- added Prereq: scroolkeeper, GConf2
497
498* Wed Oct 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
499- new upstream release
500
501* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
502- new upstream release
503
504* Sun Aug 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.91-0vl1
505- new upstream release
506
507* Wed Aug 03 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
508- new upstream release
509
510* Thu Jul 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.2-0vl1
511- new upstream release
512
513* Sat Apr 16 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl2
514- disable evolution-data-server
515
516* Thu Apr 14 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
517- new upstream release
518
519* Thu Mar 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl2
520- add Patch10 to fix hard-coded desktop file name.
521
522* Thu Mar 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
523- new upstream version
524
525* Fri Feb 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.3-0vl1
526- new upstream release
527- run scrollkeeper at %post, %postun
528
529* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
530- new upstream release
531
532* Fri Oct 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl3
533- add Patch10 to fix egg-recent-model.c.
534  save old umask value before create ".recently-used" file.
535 
536* Sun Oct 24 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.4.2-0vl2
537- fix location of nautilus launcher in panel-default-setup.entries.
538- do not add wireless monitor in %%post when no interfaces are available.
539- add Japanese summary and description
540- add BuildRequires: startup-notification-devel, gcc-c++.
541- disable libtoolize: version mismatch is bad
542
543* Sat Jan 31 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
544- new upstream release
545
546* Sat Dec 27 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
547- new upstream release
548
549* Sat Dec 27 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.0-0vl3
550- rebuilt against new toolchain
551
552* Fri Sep 12 2003 Tomoya TAKA <taka@vinelinux.org> 2.4.0-0vl2
553- add --disable-schemas-install option to %%configure
554
555* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
556- new upstream release
557
558* Mon Sep 08 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.91-0vl2
559- add missing files
560- add vine default panel entries
561
562* Sat Sep 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.91-0vl1
563- new upstream release
564
565* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
566- new upstream release
567
568* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.7-0vl1
569- new upstream release
570
571* Wed Jun 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2.1-0vl2
572- remove vine's panel-per-panel-config.schemas
573  This should be added again in a future version.
574
575* Tue Jun 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2.1-0vl1
576- new upstream release
577
578* Tue Apr 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
579- new upstream release
580- remove old ja.po
581
582* Sat Feb 15 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
583- new upstream release
584
585* Wed Jan 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl2
586- remove clockaddon, system-tray-applet
587
588* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
589- new upstream release
590
591* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.90.1-0vl2
592- add patch1 from rawhide package.
593
594* Fri Jan 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.90.1-0vl1
595- new upstream release
596
597* Sat Dec 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
598- add system-tray-applet
599- modify default panel menu.
600- update ja.po
601
602* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
603- add Requires: vine-menus
604
605* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
606- new upstream release
607
608* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl2
609- remove redhatize patch.
610
611* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
612- build for Vine Linux
613- new upstream release from gnome-2.1.4
614
615* Mon Oct 14 2002 Florian La Roche <Florian.LaRoche@redhat.de>
616- fix postun script
617
618* Tue Oct  8 2002 Havoc Pennington <hp@redhat.com>
619- 2.0.9 with menu edit stuff
620- system-tray-applet 0.15 that doesn't crash all the time
621- merge/remove patches as appropriate
622
623* Wed Aug 28 2002 Owen Taylor <otaylor@redhat.com>
624- Fix problem with "hold down print screen" (71432)
625
626* Tue Aug 27 2002 Jonathan Blandford <jrb@redhat.com>
627- panel-properties OnlyShowIn=GNOME;
628- somehow the po file got screwed up.  Works now
629- update po files
630
631* Sun Aug 25 2002 Havoc Pennington <hp@redhat.com>
632- fix from #71762 for clock applet popdown key
633- no WIN_POS_MOUSE fixes #72167
634- fix for #72540 from George
635
636* Wed Aug 21 2002 Havoc Pennington <hp@redhat.com>
637- system tray applet 0.11 with a small memleak fix and a couple translations
638
639* Thu Aug 15 2002 Jonathan Blandford <jrb@redhat.com>
640- menu tweaks
641
642* Wed Aug 14 2002 Tim Powers <timp@redhat.com>
643- bump release
644
645* Wed Aug 14 2002 Preston Brown <pbrown@redhat.com>
646- put battery applet on panel for laptops (#67296)
647
648* Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
649- 2.0.6 final from gnome 2.0.1
650- remove gnome-panel-screenshot patch now upstream
651
652* Thu Aug  8 2002 Jonathan Blandford <jrb@redhat.com>
653- new system-tray-applet version
654- Fix gnome-panel-screenshot
655
656* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
657- 2.0.4
658- replace gnome-logo-icon-transparent.png with redhat-main-menu.png
659  for the foot menu
660
661* Fri Aug  2 2002 Havoc Pennington <hp@redhat.com>
662- fix desktop (logout/lock) menu item location
663  in Alt+F1 and in new menu applets
664- remove Screenshot... menu item
665
666* Fri Aug  2 2002 Havoc Pennington <hp@redhat.com>
667- move around default applets, remove some of them
668- system tray 0.9
669- change default menu flags
670- blow unpackaged files out of build root
671
672* Wed Jul 31 2002 Havoc Pennington <hp@redhat.com>
673- 2.0.3
674- own libexecdir stuff
675
676* Thu Jul 25 2002 Havoc Pennington <hp@redhat.com>
677- new system tray that's prettier and doesn't clip the icon
678
679* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
680- system tray 0.7 that doesn't crash on startup
681- get Mozilla desktop file right so we get web browser launcher
682
683* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
684- system tray 0.6 with server file fixed (work dammit)
685
686* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
687- tweak applet positions but I think it's just broken
688- system tray 0.5 moved back to libdir not libexecdir
689
690* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
691- remove ltmain.sh hack
692- new system-tray-applet that works
693
694* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
695- put office suite stuff on the panel
696
697* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
698- 2.0.2.90 cvs snap
699
700* Wed Jul 10 2002 Havoc Pennington <hp@redhat.com>
701- update the clock patch to be a little smarter in a couple ways
702
703* Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
704- Fix problem where system tray applet was being looked for in /unst
705- Fix a crash in the system tray applet
706
707* Wed Jun 26 2002 Owen Taylor <otaylor@redhat.com>
708- Fix typo in the pt_BR translation that was causing GConf problems
709
710* Mon Jun 24 2002 Havoc Pennington <hp@redhat.com>
711- add the system tray applet
712- add system tray applet by default
713- add more launcher by default
714
715* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
716- automated rebuild
717
718* Thu Jun 20 2002 Havoc Pennington <hp@redhat.com>
719- use correct gettext package name, and add check for missing translations
720
721* Mon Jun 17 2002 Havoc Pennington <hp@redhat.com>
722- add the calendar and configuration patch
723
724* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
725- 2.0.0
726- add control center desktop file to file list
727- add gnome-panelrc to file list
728- try fixing panel size (blind, no text box at home)
729
730* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
731- rebuild in different environment
732
733* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
734- updates to default configuration
735
736* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
737- fix schemas installation
738
739* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
740- unset old panel schemas when installing new ones
741- put in a broken panel config to see errors about
742- add a patch to give some decent error messages about what's wrong
743  with the default panel config
744
745* Sun Jun 09 2002 Havoc Pennington <hp@redhat.com>
746- rebuild in different environment
747
748* Sun Jun  9 2002 Havoc Pennington <hp@redhat.com>
749- don't provide/obsolete gnome-core
750
751* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
752- rebuild in different environment
753
754* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
755- 1.5.24
756- ldconfig
757
758* Mon Jun 03 2002 Havoc Pennington <hp@redhat.com>
759- rebuild in different environment
760
761* Fri May 31 2002 Havoc Pennington <hp@redhat.com>
762- 1.5.23
763
764* Sun May 26 2002 Tim Powers <timp@redhat.com>
765- automated rebuild
766
767* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
768- rebuild in different environment
769
770* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
771- 1.5.22
772- provide gnome-core
773- add a bunch of extra build requires so build system
774  won't get confused
775
776* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
777- 1.5.19
778
779* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
780- add the keep-libtool-from-relinking hack so
781  we get the gen util applet
782
783* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
784- obsoletes gnome-core-devel
785- include libdir/*.so
786
787* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
788- get libpanel-applet in the package
789
790* Tue Apr 16 2002 Havoc Pennington <hp@redhat.com>
791- Initial build.
792
793
Note: See TracBrowser for help on using the repository browser.