source: projects/specs/trunk/g/gnome-panel/gnome-panel-vl.spec @ 1491

Revision 1491, 26.0 KB checked in by Takemikaduchi, 14 years ago (diff)

net-snmp:new upstream release, gnome-panel:create libs and devel package

Line 
1%define use_eds 1
2
3%define gettext_package gnome-panel-2.0
4
5%define gnome_desktop_version 2.30.0
6%define glib2_version 2.24.0
7%define gtk2_version 2.20.0
8%define libgnome_version 2.30.0
9%define libgnomeui_version 2.24.3
10%define libbonoboui_version 2.24.3
11%define orbit_version 2.14.17
12%define libwnck_version 2.30.0
13%define gconf_version 2.28.0
14%define gnome_menus_version 2.30.0
15%define evolution_data_server_version 2.30.0
16%define cairo_version 1.8.10
17%define dbus_version 1.2.24
18%define dbus_glib_version 0.82
19%define gnome_doc_utils_version 0.3.2
20%define libgweather_version 2.30.0
21%define libcanberra_version 0.22
22
23Summary: GNOME panel
24Summary(ja): GNOME パネル
25Name: gnome-panel
26Version: 2.30.2
27Release: 2%{_dist_release}
28URL: http://www.gnome.org/
29License: GPL
30Group: User Interface/Desktops
31
32Source0: http://ftp.gnome.org/pub/gnome/sources/gnome-panel/2.30/%{name}-%{version}.tar.bz2
33# Remove this line and next line when upstream adopt Source1
34Source1: clock.gnome-2-28.ja.po
35Source2: vine-panel-default-setup.entries
36# Remove this line and next line when upstream adopt Source3
37Source3: fish.help.Makefile.am
38# Remove this line and next line when upstream adopt Source4
39Source4: gnome-panel.fish.gnome-2-28.ja.po
40Source5: vine-panel-backwards-compat-config.schemas
41Source10: add-translations.sh
42Source12: gnome-compiler-flags.m4
43
44Patch0: gnome-panel-2.28.0-vendor.patch
45Patch1: gnome-panel-2.10.1-speak-to-us-ye-old-wise-fish.patch
46Patch2: gnome-panel-2.28.0-about-vine.patch
47
48# the next three patches belong together
49# http://bugzilla.gnome.org/show_bug.cgi?id=470966
50Patch8: launcher-desktop-files.patch
51Patch9: desktop-file-monitoring.patch
52Patch10: preferred-apps.patch
53
54# don't pop up an error dialog if an applet from the
55# default configuration is missing; we don't want to
56# add a hard dependency on e.g. tomboy
57Patch11: applet-error.patch
58
59BuildRoot: %{_tmppath}/%{name}-%{version}-root
60
61Requires: %{name}-libs = %{version}-%{release}
62Requires: gnome-desktop >= %{gnome_desktop_version}
63Requires: libwnck >= %{libwnck_version}
64Requires: gnome-menus >= %{gnome_menus_version}
65Requires: vine-menus >= 1.1
66Requires(post,postun): scrollkeeper, gtk2
67Requires(post,pre,preun): GConf2
68
69Provides: %{name}-devel = %{version}-%{release}
70
71%if %{use_eds}
72Requires: evolution-data-server >= 2.30.2
73%endif
74Requires: libSM
75
76BuildRequires: libxml2-python
77BuildRequires: intltool
78BuildRequires: gettext
79BuildRequires: automake
80BuildRequires: autoconf
81BuildRequires: libtool
82BuildRequires: scrollkeeper
83BuildRequires: libxslt
84BuildRequires: gnome-desktop-devel >= %{gnome_desktop_version}
85BuildRequires: gtk2-devel >= %{gtk2_version}
86BuildRequires: libgnome-devel >= %{libgnome_version}
87BuildRequires: libgnomeui-devel >= %{libgnomeui_version}
88BuildRequires: libbonoboui-devel >= %{libbonoboui_version}
89BuildRequires: libwnck-devel >= %{libwnck_version}
90BuildRequires: GConf2-devel >= %{gconf_version}
91BuildRequires: gnome-menus-devel >= %{gnome_menus_version}
92BuildRequires: cairo-devel >= %{cairo_version}
93BuildRequires: gnome-doc-utils >= %{gnome_doc_utils_version}
94BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
95BuildRequires: gtk-doc
96BuildRequires: pango-devel
97BuildRequires: libbonobo-devel
98BuildRequires: libX11-devel
99BuildRequires: libXau-devel
100%if %{use_eds}
101BuildRequires: evolution-data-server-devel >= %{evolution_data_server_version}
102BuildRequires: ORBit2-devel >= %{orbit_version}
103BuildRequires: dbus-devel >= %{dbus_version}
104%endif
105BuildRequires: libgweather-devel >= %{libgweather_version}
106BuildRequires: libcanberra-devel >= %{libcanberra_versino}
107BuildRequires: librsvg2-devel
108BuildRequires: polkit-gnome-devel
109BuildRequires: NetworkManager-devel
110BuildRequires: libSM-devel
111BuildRequires(install): desktop-file-utils
112
113%description
114
115The GNOME panel provides the window list, workspace switcher, menus, and other
116features for the GNOME desktop.
117
118%description -l ja
119
120GNOME パネルは、ウィンドウ一覧・ワークスペース切り換え器・メニューその他の
121特徴を GNOME デスクトップに提供します。
122
123%package libs
124Summary: Libraries for use in panel applets of GNOME
125Summary(ja): GNOME のパネルアップレットで使用するライブラリ
126Group: System Environment/Libraries
127
128%description libs
129Libraries for use in panel applets of GNOME.
130
131%description libs -l ja
132GNOME のパネルアップレットで使用するライブラリ
133
134%package devel
135Summary: Development environment for panel applets of GNOME
136Summary(ja): GNOME のパネルアップレット用開発環境
137Group: Development/Libraries
138Requires: %{name}-libs = %{version}-%{release}
139Requires: pkgconfig
140Requires: gtk2-devel >= %{gtk2_version}
141Requires: libbonoboui-devel >= %{libbonoboui_version}
142Requires: GConf2-devel >= %{gconf_version}
143
144%description devel
145Header files and libraries for building a panel applets of GNOME.
146
147%description devel -l ja
148GNOME のパネルアップレットをビルドするためのヘッダファイル及びライブラリ集
149
150
151%prep
152%setup -q
153
154# Remove this line and next line when upstream adopt Source1
155cp -f %{SOURCE1} help/clock/ja/ja.po
156# Remove next line when upstream adopt Source3
157cp -f %{SOURCE3} help/fish/Makefile.am
158# Remove next line when upstream adopt Source4
159mkdir help/fish/ja
160# Remove next line when upstream adopt Source4
161cp -f %{SOURCE4} help/fish/ja/ja.po
162
163cp -f %{SOURCE2} gnome-panel/panel-default-setup.entries
164cp -f %{SOURCE12} m4
165cp -f %{SOURCE5} gnome-panel/panel-compatibility.schemas
166
167%patch0 -p1 -b .vendor
168%patch1 -p1 -b .speak-to-us-ye-old-wise-fish
169%patch2 -p1 -b .about-vine
170%patch8 -p1 -b .launcher-desktop-files
171%patch9 -p1 -b .desktop-file-monitoring
172%patch10 -p1 -b .preferred-apps
173%patch11 -p1 -b .applet-error
174
175libtoolize --force --copy
176
177. %{SOURCE10}
178
179%build
180# gpm-integration patches Makefile.am and configure.in
181aclocal -I m4
182automake --add-missing
183autoheader
184autoconf
185%configure --disable-scrollkeeper \
186           --disable-schemas-install \
187           --disable-gtk-doc \
188           --with-in-process-applets=clock:fish \
189%if %{use_eds}
190           --enable-eds=yes
191%else
192           --enable-eds=no
193%endif
194make
195
196%install
197rm -rf $RPM_BUILD_ROOT
198
199export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
200%makeinstall
201unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
202
203#
204# Create pager and tasklist schemas for compatibility with older
205# configurations which reference the old schema names
206#
207sed -e 's|/schemas/apps/window_list_applet/prefs/|/schemas/apps/tasklist_applet/prefs/|' $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/window-list.schemas > $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/tasklist.schemas
208sed -e 's|/schemas/apps/workspace_switcher_applet/prefs/|/schemas/apps/pager_applet/prefs/|; s|<default>1</default>|<default>2</default>|' $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/workspace-switcher.schemas > $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/pager.schemas
209
210
211## blow away stuff we don't want
212/bin/rm -rf $RPM_BUILD_ROOT%{_localstatedir}/scrollkeeper
213#rmdir --ignore-fail-on-non-empty $RPM_BUILD_ROOT/var
214/bin/rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
215
216/bin/rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
217
218sed -i -e "s/NoDisplay=True/NoDisplay=true/" $RPM_BUILD_ROOT%{_datadir}/applications/gnome-panel.desktop
219
220desktop-file-install --delete-original \
221  --dir $RPM_BUILD_ROOT%{_datadir}/applications \
222  $RPM_BUILD_ROOT%{_datadir}/applications/gnome-panel.desktop
223
224%find_lang %{gettext_package} --all-name --with-gnome
225#grep -q '/usr/share/locale' %{gettext_package}.lang || exit 1
226
227%clean
228rm -rf $RPM_BUILD_ROOT
229
230%post
231touch --no-create %{_datadir}/icons/hicolor
232if [ -x /usr/bin/gtk-update-icon-cache ]; then
233  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
234fi
235
236export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
237
238#
239# Clear out the old defaults
240#
241gconftool-2 --direct --config-source=$GCONF_CONFIG_SOURCE --recursive-unset /apps/panel > /dev/null || :
242gconftool-2 --direct --config-source=$GCONF_CONFIG_SOURCE --recursive-unset /schemas/apps/panel > /dev/null || :
243
244# install schemas
245SCHEMAS="clock.schemas fish.schemas pager.schemas \
246        panel-compatibility.schemas panel-general.schemas \
247        panel-global.schemas panel-object.schemas panel-toplevel.schemas \
248        tasklist.schemas window-list.schemas workspace-switcher.schemas"
249for S in $SCHEMAS; do
250    echo %{_sysconfdir}/gconf/schemas/$S ; done \
251    | xargs gconftool-2 --makefile-install-rule >& /dev/null ||:
252
253#
254# Install the default setup into /apps/panel and /apps/panel/default_setup
255#
256gconftool-2 --direct --config-source=$GCONF_CONFIG_SOURCE --load %{_sysconfdir}/gconf/schemas/panel-default-setup.entries > /dev/null || :
257gconftool-2 --direct --config-source=$GCONF_CONFIG_SOURCE --load %{_sysconfdir}/gconf/schemas/panel-default-setup.entries /apps/panel > /dev/null || :
258
259/sbin/ldconfig
260scrollkeeper-update > /dev/null 2>&1 || :
261
262%pre
263if [ "$1" -gt 1 ]; then
264  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
265  SCHEMAS="clock.schemas fish.schemas pager.schemas \
266          panel-compatibility.schemas panel-general.schemas \
267          panel-global.schemas panel-object.schemas panel-toplevel.schemas \
268          tasklist.schemas window-list.schemas workspace-switcher.schemas"
269  for S in $SCHEMAS; do
270      echo %{_sysconfdir}/gconf/schemas/$S ; done \
271      | xargs gconftool-2 --makefile-uninstall-rule >& /dev/null ||:
272fi
273
274%preun
275if [ "$1" -eq 0 ]; then
276  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
277  SCHEMAS="clock.schemas fish.schemas pager.schemas \
278          panel-compatibility.schemas panel-general.schemas \
279          panel-global.schemas panel-object.schemas panel-toplevel.schemas \
280          tasklist.schemas window-list.schemas workspace-switcher.schemas"
281  for S in $SCHEMAS; do
282      echo %{_sysconfdir}/gconf/schemas/$S ; done \
283      | xargs gconftool-2 --makefile-uninstall-rule >& /dev/null ||:
284fi
285
286%postun
287/sbin/ldconfig
288scrollkeeper-update > /dev/null 2>&1 || :
289touch --no-create %{_datadir}/icons/hicolor
290if [ -x /usr/bin/gtk-update-icon-cache ]; then
291  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
292fi
293 
294%files -f %{gettext_package}.lang
295%defattr(-,root,root)
296%doc AUTHORS COPYING COPYING.LIB COPYING-DOCS NEWS README
297%{_datadir}/applications/*.desktop
298%{_datadir}/icons/*
299%{_datadir}/gnome-panel
300%exclude %{_datadir}/gnome-panelrc
301%{_datadir}/idl/gnome-panel-2.0
302%{_datadir}/gnome-2.0/ui/*
303%{_mandir}/man*/*
304%{_bindir}/*
305%exclude %{_bindir}/panel-test-applets
306%{_libexecdir}/*
307%{_libdir}/bonobo/servers/*.server
308%{_sysconfdir}/gconf/schemas/*.schemas
309%{_sysconfdir}/gconf/schemas/*.entries
310%{_sysconfdir}/dbus-1/system.d/org.gnome.ClockApplet.Mechanism.conf
311%{_datadir}/dbus-1/system-services/org.gnome.ClockApplet.Mechanism.service
312%{_datadir}/polkit-1/actions/org.gnome.clockapplet.mechanism.policy
313
314%files libs
315%{_libdir}/*.so.*
316
317%files devel
318%{_bindir}/panel-test-applets
319%{_libdir}/pkgconfig/*.pc
320%{_includedir}/panel-2.0
321%{_libdir}/*.so
322%{_datadir}/gtk-doc
323
324
325%changelog
326* Sun Aug 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-2
327- create -libs and -devel package
328
329* Tue Jun 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
330- new upstream release
331
332* Tue Jun 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-2
333- rebuild with evolution-data-server-2.30.2
334
335* Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
336- new upstream release
337- update Patch8, Patch9 (from FC package)
338- add BuildRequires: libcanberra-devel
339
340* Sat Mar 27 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.28.0-4
341- update translation of clock applet manual
342- add translation of fish applet manual
343
344* Fri Mar 26 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.28.0-3
345- add libSM(-devel) to (Build)Requires
346- add desktop-file-utils to BuildRequires
347
348* Thu Mar 25 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.28.0-2
349- update translation of clock applet manual
350
351* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.0-1
352- new upstream release
353- updated Patch0 and 2
354
355* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
356- new upstream release
357
358* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-3
359- rebuild with gtk2-2.16.3
360
361* Thu Jun 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
362- add empty gconf entries to vine-panel-default-setup.entries
363
364* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
365- new upstream release
366
367* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
368- new upstream release
369
370* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-4
371- update vine-panel-default-setup.entries again..
372
373* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-3
374- update vine-panel-default-setup.entries
375
376* Tue Mar 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-2
377- remove mixer applets from default panel setup
378
379* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
380- new upstream release
381
382* Mon Jan 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.3-1
383- new upstream release
384- added BuildRequires: PolicyKit-gnome-devel
385
386* Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
387- new upstream release
388
389* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
390- new upstream release
391
392* Tue Jun  3 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1
393- new upstream release
394
395* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.3-1
396- new upstream release
397
398* Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.2-1vl5
399- new upstream release
400- removed Patch25,26,27,29 and 30 (merged into upstream)
401
402* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-2vl5
403- added Patches from FC
404  * Fri Mar 28 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-8
405  - Fix editing of locations in the clock applet
406  * Fri Mar 28 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-7
407  - Convert the edit and find location windows to dialogs
408  * Thu Mar 27 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-6
409  - Improve the time settings window
410  * Thu Mar 27 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-5
411  - Make the find-location window of the clock larger
412  * Sat Mar 15 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-4
413  - Only save the session when the users wants it
414  * Fri Mar 14 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-3
415  - Populate the location list before showing the preference window
416  * Sat Mar  8 2008 Will Woods <wwoods@redhat.com> - 2.21.92-6
417  - Add "About This Computer" item to System menu if it exists
418  * Wed Feb 20 2008 Matthias Clasen <mclasen@redhat.com> - 2.21.91-6
419  - Try harder to avoid resizing the popup
420- updated BuildRequires
421
422* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
423- new upstream release
424- added BuildRequires: libgweather-devel
425
426* Tue Jan  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.2-0vl1
427- new upstream release
428- updated %post and %postun section
429- added %pre and %preun section
430- added Patches from Fedora
431  * Fri Oct 12 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0.1-4
432  - Sharper icons
433  * Wed Oct  3 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0.1-3
434  - Make it possible to start s-c-d from the clock menu again (#316921)
435  * Fri Sep 21 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0.1-2
436  - Don't pop up an error if an applet from the default
437    configuration is missing 
438  * Mon Sep 17 2007 Matthias Clasen <mclasen@redhat.com> - 2.19.92-6
439  - Turns out we need requires for applets in the default config (#293261)
440  * Mon Sep 17 2007 Matthias Clasen <mclasen@redhat.com> - 2.19.92-5
441  - Drop the requires for fast-user-switch-applet (#253831)
442
443* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.3-0vl1
444- new upstream release
445- dropped Patch22 (merged into upstream)
446
447* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
448- new upstream release
449
450* Mon Oct 30 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.3-0vl2
451- add missing BuildRequires to gnome-menus-devel (<BTS:319>)
452
453* Thu Oct 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl1
454- new upstream release
455- fix panel-default-setup.entries to change the name of
456  firefox desktopfile (<BTS:229>)
457
458* Thu Jul 20 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.14.2-0vl2
459- add patch 11 to fix disappearing of recent documents list.
460  <BTS:VineLinux:81>, http://bugzilla.gnome.org/show_bug.cgi?id=343812
461
462* Sat Jun  3 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.2-0vl1
463- new upstream release
464
465* Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
466- new upstream release
467
468* Sat Apr 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
469- run gtk-update-icon-cache in %%post script.
470
471* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
472- new upstream release
473
474* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.91-0vl2
475- update vine-panel-default-setup.entries
476  - replace mozilla by firefox
477  - remove nautilus
478  - add notification area applet on top panel
479  - add trashbox applet on bottom panel
480- cleanup %%post script
481
482* Thu Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.91-0vl1
483- new upstream release
484
485* Sun Feb 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.3-0vl1
486- new upstream release
487- added Prereq: scroolkeeper, GConf2
488
489* Wed Oct 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
490- new upstream release
491
492* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
493- new upstream release
494
495* Sun Aug 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.91-0vl1
496- new upstream release
497
498* Wed Aug 03 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
499- new upstream release
500
501* Thu Jul 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.2-0vl1
502- new upstream release
503
504* Sat Apr 16 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl2
505- disable evolution-data-server
506
507* Thu Apr 14 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
508- new upstream release
509
510* Thu Mar 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl2
511- add Patch10 to fix hard-coded desktop file name.
512
513* Thu Mar 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
514- new upstream version
515
516* Fri Feb 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.3-0vl1
517- new upstream release
518- run scrollkeeper at %post, %postun
519
520* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
521- new upstream release
522
523* Fri Oct 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl3
524- add Patch10 to fix egg-recent-model.c.
525  save old umask value before create ".recently-used" file.
526 
527* Sun Oct 24 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.4.2-0vl2
528- fix location of nautilus launcher in panel-default-setup.entries.
529- do not add wireless monitor in %%post when no interfaces are available.
530- add Japanese summary and description
531- add BuildRequires: startup-notification-devel, gcc-c++.
532- disable libtoolize: version mismatch is bad
533
534* Sat Jan 31 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
535- new upstream release
536
537* Sat Dec 27 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
538- new upstream release
539
540* Sat Dec 27 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.0-0vl3
541- rebuilt against new toolchain
542
543* Fri Sep 12 2003 Tomoya TAKA <taka@vinelinux.org> 2.4.0-0vl2
544- add --disable-schemas-install option to %%configure
545
546* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
547- new upstream release
548
549* Mon Sep 08 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.91-0vl2
550- add missing files
551- add vine default panel entries
552
553* Sat Sep 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.91-0vl1
554- new upstream release
555
556* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
557- new upstream release
558
559* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.7-0vl1
560- new upstream release
561
562* Wed Jun 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2.1-0vl2
563- remove vine's panel-per-panel-config.schemas
564  This should be added again in a future version.
565
566* Tue Jun 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2.1-0vl1
567- new upstream release
568
569* Tue Apr 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
570- new upstream release
571- remove old ja.po
572
573* Sat Feb 15 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
574- new upstream release
575
576* Wed Jan 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl2
577- remove clockaddon, system-tray-applet
578
579* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
580- new upstream release
581
582* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.90.1-0vl2
583- add patch1 from rawhide package.
584
585* Fri Jan 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.90.1-0vl1
586- new upstream release
587
588* Sat Dec 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
589- add system-tray-applet
590- modify default panel menu.
591- update ja.po
592
593* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
594- add Requires: vine-menus
595
596* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
597- new upstream release
598
599* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl2
600- remove redhatize patch.
601
602* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
603- build for Vine Linux
604- new upstream release from gnome-2.1.4
605
606* Mon Oct 14 2002 Florian La Roche <Florian.LaRoche@redhat.de>
607- fix postun script
608
609* Tue Oct  8 2002 Havoc Pennington <hp@redhat.com>
610- 2.0.9 with menu edit stuff
611- system-tray-applet 0.15 that doesn't crash all the time
612- merge/remove patches as appropriate
613
614* Wed Aug 28 2002 Owen Taylor <otaylor@redhat.com>
615- Fix problem with "hold down print screen" (71432)
616
617* Tue Aug 27 2002 Jonathan Blandford <jrb@redhat.com>
618- panel-properties OnlyShowIn=GNOME;
619- somehow the po file got screwed up.  Works now
620- update po files
621
622* Sun Aug 25 2002 Havoc Pennington <hp@redhat.com>
623- fix from #71762 for clock applet popdown key
624- no WIN_POS_MOUSE fixes #72167
625- fix for #72540 from George
626
627* Wed Aug 21 2002 Havoc Pennington <hp@redhat.com>
628- system tray applet 0.11 with a small memleak fix and a couple translations
629
630* Thu Aug 15 2002 Jonathan Blandford <jrb@redhat.com>
631- menu tweaks
632
633* Wed Aug 14 2002 Tim Powers <timp@redhat.com>
634- bump release
635
636* Wed Aug 14 2002 Preston Brown <pbrown@redhat.com>
637- put battery applet on panel for laptops (#67296)
638
639* Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
640- 2.0.6 final from gnome 2.0.1
641- remove gnome-panel-screenshot patch now upstream
642
643* Thu Aug  8 2002 Jonathan Blandford <jrb@redhat.com>
644- new system-tray-applet version
645- Fix gnome-panel-screenshot
646
647* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
648- 2.0.4
649- replace gnome-logo-icon-transparent.png with redhat-main-menu.png
650  for the foot menu
651
652* Fri Aug  2 2002 Havoc Pennington <hp@redhat.com>
653- fix desktop (logout/lock) menu item location
654  in Alt+F1 and in new menu applets
655- remove Screenshot... menu item
656
657* Fri Aug  2 2002 Havoc Pennington <hp@redhat.com>
658- move around default applets, remove some of them
659- system tray 0.9
660- change default menu flags
661- blow unpackaged files out of build root
662
663* Wed Jul 31 2002 Havoc Pennington <hp@redhat.com>
664- 2.0.3
665- own libexecdir stuff
666
667* Thu Jul 25 2002 Havoc Pennington <hp@redhat.com>
668- new system tray that's prettier and doesn't clip the icon
669
670* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
671- system tray 0.7 that doesn't crash on startup
672- get Mozilla desktop file right so we get web browser launcher
673
674* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
675- system tray 0.6 with server file fixed (work dammit)
676
677* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
678- tweak applet positions but I think it's just broken
679- system tray 0.5 moved back to libdir not libexecdir
680
681* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
682- remove ltmain.sh hack
683- new system-tray-applet that works
684
685* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
686- put office suite stuff on the panel
687
688* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
689- 2.0.2.90 cvs snap
690
691* Wed Jul 10 2002 Havoc Pennington <hp@redhat.com>
692- update the clock patch to be a little smarter in a couple ways
693
694* Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
695- Fix problem where system tray applet was being looked for in /unst
696- Fix a crash in the system tray applet
697
698* Wed Jun 26 2002 Owen Taylor <otaylor@redhat.com>
699- Fix typo in the pt_BR translation that was causing GConf problems
700
701* Mon Jun 24 2002 Havoc Pennington <hp@redhat.com>
702- add the system tray applet
703- add system tray applet by default
704- add more launcher by default
705
706* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
707- automated rebuild
708
709* Thu Jun 20 2002 Havoc Pennington <hp@redhat.com>
710- use correct gettext package name, and add check for missing translations
711
712* Mon Jun 17 2002 Havoc Pennington <hp@redhat.com>
713- add the calendar and configuration patch
714
715* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
716- 2.0.0
717- add control center desktop file to file list
718- add gnome-panelrc to file list
719- try fixing panel size (blind, no text box at home)
720
721* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
722- rebuild in different environment
723
724* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
725- updates to default configuration
726
727* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
728- fix schemas installation
729
730* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
731- unset old panel schemas when installing new ones
732- put in a broken panel config to see errors about
733- add a patch to give some decent error messages about what's wrong
734  with the default panel config
735
736* Sun Jun 09 2002 Havoc Pennington <hp@redhat.com>
737- rebuild in different environment
738
739* Sun Jun  9 2002 Havoc Pennington <hp@redhat.com>
740- don't provide/obsolete gnome-core
741
742* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
743- rebuild in different environment
744
745* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
746- 1.5.24
747- ldconfig
748
749* Mon Jun 03 2002 Havoc Pennington <hp@redhat.com>
750- rebuild in different environment
751
752* Fri May 31 2002 Havoc Pennington <hp@redhat.com>
753- 1.5.23
754
755* Sun May 26 2002 Tim Powers <timp@redhat.com>
756- automated rebuild
757
758* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
759- rebuild in different environment
760
761* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
762- 1.5.22
763- provide gnome-core
764- add a bunch of extra build requires so build system
765  won't get confused
766
767* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
768- 1.5.19
769
770* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
771- add the keep-libtool-from-relinking hack so
772  we get the gen util applet
773
774* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
775- obsoletes gnome-core-devel
776- include libdir/*.so
777
778* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
779- get libpanel-applet in the package
780
781* Tue Apr 16 2002 Havoc Pennington <hp@redhat.com>
782- Initial build.
783
784
Note: See TracBrowser for help on using the repository browser.