source: projects/specs/trunk/g/gnome-panel/gnome-panel-vl.spec @ 1260

Revision 1260, 24.9 KB checked in by Takemikaduchi, 14 years ago (diff)

update gnome (2.30.2)

Line 
1%define use_eds 1
2
3%define gettext_package gnome-panel-2.0
4
5%define gnome_desktop_version 2.30.0
6%define glib2_version 2.24.0
7%define gtk2_version 2.20.0
8%define libgnome_version 2.30.0
9%define libgnomeui_version 2.24.3
10%define orbit_version 2.14.17
11%define libwnck_version 2.30.0
12%define gconf_version 2.28.0
13%define gnome_menus_version 2.30.0
14%define evolution_data_server_version 2.30.0
15%define cairo_version 1.8.10
16%define dbus_version 1.2.24
17%define dbus_glib_version 0.82
18%define gnome_doc_utils_version 0.3.2
19%define libgweather_version 2.30.0
20%define libcanberra_version 0.22
21
22Summary: GNOME panel
23Summary(ja): GNOME パネル
24Name: gnome-panel
25Version: 2.30.2
26Release: 1%{_dist_release}
27URL: http://www.gnome.org/
28License: GPL
29Group: User Interface/Desktops
30
31Source0: http://ftp.gnome.org/pub/gnome/sources/gnome-panel/2.30/%{name}-%{version}.tar.bz2
32# Remove this line and next line when upstream adopt Source1
33Source1: clock.gnome-2-28.ja.po
34Source2: vine-panel-default-setup.entries
35# Remove this line and next line when upstream adopt Source3
36Source3: fish.help.Makefile.am
37# Remove this line and next line when upstream adopt Source4
38Source4: gnome-panel.fish.gnome-2-28.ja.po
39Source5: vine-panel-backwards-compat-config.schemas
40Source10: add-translations.sh
41Source12: gnome-compiler-flags.m4
42
43Patch0: gnome-panel-2.28.0-vendor.patch
44Patch1: gnome-panel-2.10.1-speak-to-us-ye-old-wise-fish.patch
45Patch2: gnome-panel-2.28.0-about-vine.patch
46
47# the next three patches belong together
48# http://bugzilla.gnome.org/show_bug.cgi?id=470966
49Patch8: launcher-desktop-files.patch
50Patch9: desktop-file-monitoring.patch
51Patch10: preferred-apps.patch
52
53# don't pop up an error dialog if an applet from the
54# default configuration is missing; we don't want to
55# add a hard dependency on e.g. tomboy
56Patch11: applet-error.patch
57
58BuildRoot: %{_tmppath}/%{name}-%{version}-root
59
60Requires: gnome-desktop >= %{gnome_desktop_version}
61Requires: libwnck >= %{libwnck_version}
62Requires: gnome-menus >= %{gnome_menus_version}
63Requires: vine-menus >= 1.1
64Requires(post,postun): scrollkeeper, gtk2
65Requires(post,pre,preun): GConf2
66
67Provides: %{name}-devel = %{version}-%{release}
68
69%if %{use_eds}
70Requires: evolution-data-server >= 2.30.2
71%endif
72Requires: libSM
73
74BuildRequires: libxml2-python
75BuildRequires: intltool
76BuildRequires: gettext
77BuildRequires: automake
78BuildRequires: autoconf
79BuildRequires: libtool
80BuildRequires: scrollkeeper
81BuildRequires: libxslt
82BuildRequires: gnome-desktop-devel >= %{gnome_desktop_version}
83BuildRequires: gtk2-devel >= %{gtk2_version}
84BuildRequires: libgnome-devel >= %{libgnome_version}
85BuildRequires: libgnomeui-devel >= %{libgnomeui_version}
86BuildRequires: libbonoboui-devel >= %{libbonoboui_version}
87BuildRequires: libwnck-devel >= %{libwnck_version}
88BuildRequires: GConf2-devel >= %{gconf_version}
89BuildRequires: gnome-menus-devel >= %{gnome_menus_version}
90BuildRequires: cairo-devel >= %{cairo_version}
91BuildRequires: gnome-doc-utils >= %{gnome_doc_utils_version}
92BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
93BuildRequires: gtk-doc
94BuildRequires: pango-devel
95BuildRequires: libbonobo-devel
96BuildRequires: libX11-devel
97BuildRequires: libXau-devel
98%if %{use_eds}
99BuildRequires: evolution-data-server-devel >= %{evolution_data_server_version}
100BuildRequires: ORBit2-devel >= %{orbit_version}
101BuildRequires: dbus-devel >= %{dbus_version}
102%endif
103BuildRequires: libgweather-devel >= %{libgweather_version}
104BuildRequires: libcanberra-devel >= %{libcanberra_versino}
105BuildRequires: librsvg2-devel
106BuildRequires: polkit-gnome-devel
107BuildRequires: NetworkManager-devel
108BuildRequires: libSM-devel
109BuildRequires(install): desktop-file-utils
110
111%description
112
113The GNOME panel provides the window list, workspace switcher, menus, and other
114features for the GNOME desktop.
115
116%description -l ja
117
118GNOME パネルは、ウィンドウ一覧・ワークスペース切り換え器・メニューその他の
119特徴を GNOME デスクトップに提供します。
120
121%prep
122%setup -q
123
124# Remove this line and next line when upstream adopt Source1
125cp -f %{SOURCE1} help/clock/ja/ja.po
126# Remove next line when upstream adopt Source3
127cp -f %{SOURCE3} help/fish/Makefile.am
128# Remove next line when upstream adopt Source4
129mkdir help/fish/ja
130# Remove next line when upstream adopt Source4
131cp -f %{SOURCE4} help/fish/ja/ja.po
132
133cp -f %{SOURCE2} gnome-panel/panel-default-setup.entries
134cp -f %{SOURCE12} m4
135cp -f %{SOURCE5} gnome-panel/panel-compatibility.schemas
136
137%patch0 -p1 -b .vendor
138%patch1 -p1 -b .speak-to-us-ye-old-wise-fish
139%patch2 -p1 -b .about-vine
140%patch8 -p1 -b .launcher-desktop-files
141%patch9 -p1 -b .desktop-file-monitoring
142%patch10 -p1 -b .preferred-apps
143%patch11 -p1 -b .applet-error
144
145libtoolize --force --copy
146
147. %{SOURCE10}
148
149%build
150# gpm-integration patches Makefile.am and configure.in
151aclocal -I m4
152automake --add-missing
153autoheader
154autoconf
155%configure --disable-scrollkeeper \
156           --disable-schemas-install \
157           --disable-gtk-doc \
158           --with-in-process-applets=clock:fish \
159%if %{use_eds}
160           --enable-eds=yes
161%else
162           --enable-eds=no
163%endif
164make
165
166%install
167rm -rf $RPM_BUILD_ROOT
168
169export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
170%makeinstall
171unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
172
173#
174# Create pager and tasklist schemas for compatibility with older
175# configurations which reference the old schema names
176#
177sed -e 's|/schemas/apps/window_list_applet/prefs/|/schemas/apps/tasklist_applet/prefs/|' $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/window-list.schemas > $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/tasklist.schemas
178sed -e 's|/schemas/apps/workspace_switcher_applet/prefs/|/schemas/apps/pager_applet/prefs/|; s|<default>1</default>|<default>2</default>|' $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/workspace-switcher.schemas > $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/pager.schemas
179
180
181## blow away stuff we don't want
182/bin/rm -rf $RPM_BUILD_ROOT%{_localstatedir}/scrollkeeper
183#rmdir --ignore-fail-on-non-empty $RPM_BUILD_ROOT/var
184/bin/rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
185
186/bin/rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
187
188sed -i -e "s/NoDisplay=True/NoDisplay=true/" $RPM_BUILD_ROOT%{_datadir}/applications/gnome-panel.desktop
189
190desktop-file-install --delete-original \
191  --dir $RPM_BUILD_ROOT%{_datadir}/applications \
192  $RPM_BUILD_ROOT%{_datadir}/applications/gnome-panel.desktop
193
194%find_lang %{gettext_package} --all-name --with-gnome
195#grep -q '/usr/share/locale' %{gettext_package}.lang || exit 1
196
197%clean
198rm -rf $RPM_BUILD_ROOT
199
200%post
201touch --no-create %{_datadir}/icons/hicolor
202if [ -x /usr/bin/gtk-update-icon-cache ]; then
203  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
204fi
205
206export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
207
208#
209# Clear out the old defaults
210#
211gconftool-2 --direct --config-source=$GCONF_CONFIG_SOURCE --recursive-unset /apps/panel > /dev/null || :
212gconftool-2 --direct --config-source=$GCONF_CONFIG_SOURCE --recursive-unset /schemas/apps/panel > /dev/null || :
213
214# install schemas
215SCHEMAS="clock.schemas fish.schemas pager.schemas \
216        panel-compatibility.schemas panel-general.schemas \
217        panel-global.schemas panel-object.schemas panel-toplevel.schemas \
218        tasklist.schemas window-list.schemas workspace-switcher.schemas"
219for S in $SCHEMAS; do
220    echo %{_sysconfdir}/gconf/schemas/$S ; done \
221    | xargs gconftool-2 --makefile-install-rule >& /dev/null ||:
222
223#
224# Install the default setup into /apps/panel and /apps/panel/default_setup
225#
226gconftool-2 --direct --config-source=$GCONF_CONFIG_SOURCE --load %{_sysconfdir}/gconf/schemas/panel-default-setup.entries > /dev/null || :
227gconftool-2 --direct --config-source=$GCONF_CONFIG_SOURCE --load %{_sysconfdir}/gconf/schemas/panel-default-setup.entries /apps/panel > /dev/null || :
228
229/sbin/ldconfig
230scrollkeeper-update > /dev/null 2>&1 || :
231
232%pre
233if [ "$1" -gt 1 ]; then
234  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
235  SCHEMAS="clock.schemas fish.schemas pager.schemas \
236          panel-compatibility.schemas panel-general.schemas \
237          panel-global.schemas panel-object.schemas panel-toplevel.schemas \
238          tasklist.schemas window-list.schemas workspace-switcher.schemas"
239  for S in $SCHEMAS; do
240      echo %{_sysconfdir}/gconf/schemas/$S ; done \
241      | xargs gconftool-2 --makefile-uninstall-rule >& /dev/null ||:
242fi
243
244%preun
245if [ "$1" -eq 0 ]; then
246  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
247  SCHEMAS="clock.schemas fish.schemas pager.schemas \
248          panel-compatibility.schemas panel-general.schemas \
249          panel-global.schemas panel-object.schemas panel-toplevel.schemas \
250          tasklist.schemas window-list.schemas workspace-switcher.schemas"
251  for S in $SCHEMAS; do
252      echo %{_sysconfdir}/gconf/schemas/$S ; done \
253      | xargs gconftool-2 --makefile-uninstall-rule >& /dev/null ||:
254fi
255
256%postun
257/sbin/ldconfig
258scrollkeeper-update > /dev/null 2>&1 || :
259touch --no-create %{_datadir}/icons/hicolor
260if [ -x /usr/bin/gtk-update-icon-cache ]; then
261  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
262fi
263 
264%files -f %{gettext_package}.lang
265%defattr(-,root,root)
266%doc AUTHORS COPYING COPYING.LIB COPYING-DOCS NEWS README
267%{_datadir}/applications/*.desktop
268%{_datadir}/icons/*
269%{_datadir}/gnome-panel
270%exclude %{_datadir}/gnome-panelrc
271%{_datadir}/idl/gnome-panel-2.0
272%{_datadir}/gnome-2.0/ui/*
273%{_mandir}/man*/*
274%{_bindir}/*
275%{_libexecdir}/*
276%{_libdir}/bonobo/servers/*.server
277%{_libdir}/*.so.*
278%{_sysconfdir}/gconf/schemas/*.schemas
279%{_sysconfdir}/gconf/schemas/*.entries
280
281%{_sysconfdir}/dbus-1/system.d/org.gnome.ClockApplet.Mechanism.conf
282%{_datadir}/dbus-1/system-services/org.gnome.ClockApplet.Mechanism.service
283%{_datadir}/polkit-1/actions/org.gnome.clockapplet.mechanism.policy
284
285# theoretically a devel package, but just doesn't seem worth it
286%{_libdir}/pkgconfig/*.pc
287%{_includedir}/panel-2.0
288%{_libdir}/*.so
289%{_datadir}/gtk-doc
290
291%changelog
292* Tue Jun 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
293- new upstream release
294
295* Tue Jun 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-2
296- rebuild with evolution-data-server-2.30.2
297
298* Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
299- new upstream release
300- update Patch8, Patch9 (from FC package)
301- add BuildRequires: libcanberra-devel
302
303* Sat Mar 27 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.28.0-4
304- update translation of clock applet manual
305- add translation of fish applet manual
306
307* Fri Mar 26 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.28.0-3
308- add libSM(-devel) to (Build)Requires
309- add desktop-file-utils to BuildRequires
310
311* Thu Mar 25 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.28.0-2
312- update translation of clock applet manual
313
314* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.0-1
315- new upstream release
316- updated Patch0 and 2
317
318* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
319- new upstream release
320
321* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-3
322- rebuild with gtk2-2.16.3
323
324* Thu Jun 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
325- add empty gconf entries to vine-panel-default-setup.entries
326
327* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
328- new upstream release
329
330* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
331- new upstream release
332
333* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-4
334- update vine-panel-default-setup.entries again..
335
336* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-3
337- update vine-panel-default-setup.entries
338
339* Tue Mar 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-2
340- remove mixer applets from default panel setup
341
342* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
343- new upstream release
344
345* Mon Jan 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.3-1
346- new upstream release
347- added BuildRequires: PolicyKit-gnome-devel
348
349* Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
350- new upstream release
351
352* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
353- new upstream release
354
355* Tue Jun  3 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1
356- new upstream release
357
358* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.3-1
359- new upstream release
360
361* Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.2-1vl5
362- new upstream release
363- removed Patch25,26,27,29 and 30 (merged into upstream)
364
365* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-2vl5
366- added Patches from FC
367  * Fri Mar 28 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-8
368  - Fix editing of locations in the clock applet
369  * Fri Mar 28 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-7
370  - Convert the edit and find location windows to dialogs
371  * Thu Mar 27 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-6
372  - Improve the time settings window
373  * Thu Mar 27 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-5
374  - Make the find-location window of the clock larger
375  * Sat Mar 15 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-4
376  - Only save the session when the users wants it
377  * Fri Mar 14 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-3
378  - Populate the location list before showing the preference window
379  * Sat Mar  8 2008 Will Woods <wwoods@redhat.com> - 2.21.92-6
380  - Add "About This Computer" item to System menu if it exists
381  * Wed Feb 20 2008 Matthias Clasen <mclasen@redhat.com> - 2.21.91-6
382  - Try harder to avoid resizing the popup
383- updated BuildRequires
384
385* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
386- new upstream release
387- added BuildRequires: libgweather-devel
388
389* Tue Jan  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.2-0vl1
390- new upstream release
391- updated %post and %postun section
392- added %pre and %preun section
393- added Patches from Fedora
394  * Fri Oct 12 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0.1-4
395  - Sharper icons
396  * Wed Oct  3 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0.1-3
397  - Make it possible to start s-c-d from the clock menu again (#316921)
398  * Fri Sep 21 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0.1-2
399  - Don't pop up an error if an applet from the default
400    configuration is missing 
401  * Mon Sep 17 2007 Matthias Clasen <mclasen@redhat.com> - 2.19.92-6
402  - Turns out we need requires for applets in the default config (#293261)
403  * Mon Sep 17 2007 Matthias Clasen <mclasen@redhat.com> - 2.19.92-5
404  - Drop the requires for fast-user-switch-applet (#253831)
405
406* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.3-0vl1
407- new upstream release
408- dropped Patch22 (merged into upstream)
409
410* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
411- new upstream release
412
413* Mon Oct 30 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.3-0vl2
414- add missing BuildRequires to gnome-menus-devel (<BTS:319>)
415
416* Thu Oct 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl1
417- new upstream release
418- fix panel-default-setup.entries to change the name of
419  firefox desktopfile (<BTS:229>)
420
421* Thu Jul 20 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.14.2-0vl2
422- add patch 11 to fix disappearing of recent documents list.
423  <BTS:VineLinux:81>, http://bugzilla.gnome.org/show_bug.cgi?id=343812
424
425* Sat Jun  3 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.2-0vl1
426- new upstream release
427
428* Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
429- new upstream release
430
431* Sat Apr 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
432- run gtk-update-icon-cache in %%post script.
433
434* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
435- new upstream release
436
437* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.91-0vl2
438- update vine-panel-default-setup.entries
439  - replace mozilla by firefox
440  - remove nautilus
441  - add notification area applet on top panel
442  - add trashbox applet on bottom panel
443- cleanup %%post script
444
445* Thu Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.91-0vl1
446- new upstream release
447
448* Sun Feb 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.3-0vl1
449- new upstream release
450- added Prereq: scroolkeeper, GConf2
451
452* Wed Oct 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
453- new upstream release
454
455* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
456- new upstream release
457
458* Sun Aug 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.91-0vl1
459- new upstream release
460
461* Wed Aug 03 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
462- new upstream release
463
464* Thu Jul 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.2-0vl1
465- new upstream release
466
467* Sat Apr 16 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl2
468- disable evolution-data-server
469
470* Thu Apr 14 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
471- new upstream release
472
473* Thu Mar 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl2
474- add Patch10 to fix hard-coded desktop file name.
475
476* Thu Mar 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
477- new upstream version
478
479* Fri Feb 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.3-0vl1
480- new upstream release
481- run scrollkeeper at %post, %postun
482
483* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
484- new upstream release
485
486* Fri Oct 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl3
487- add Patch10 to fix egg-recent-model.c.
488  save old umask value before create ".recently-used" file.
489 
490* Sun Oct 24 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.4.2-0vl2
491- fix location of nautilus launcher in panel-default-setup.entries.
492- do not add wireless monitor in %%post when no interfaces are available.
493- add Japanese summary and description
494- add BuildRequires: startup-notification-devel, gcc-c++.
495- disable libtoolize: version mismatch is bad
496
497* Sat Jan 31 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
498- new upstream release
499
500* Sat Dec 27 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
501- new upstream release
502
503* Sat Dec 27 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.0-0vl3
504- rebuilt against new toolchain
505
506* Fri Sep 12 2003 Tomoya TAKA <taka@vinelinux.org> 2.4.0-0vl2
507- add --disable-schemas-install option to %%configure
508
509* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
510- new upstream release
511
512* Mon Sep 08 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.91-0vl2
513- add missing files
514- add vine default panel entries
515
516* Sat Sep 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.91-0vl1
517- new upstream release
518
519* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
520- new upstream release
521
522* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.7-0vl1
523- new upstream release
524
525* Wed Jun 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2.1-0vl2
526- remove vine's panel-per-panel-config.schemas
527  This should be added again in a future version.
528
529* Tue Jun 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2.1-0vl1
530- new upstream release
531
532* Tue Apr 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
533- new upstream release
534- remove old ja.po
535
536* Sat Feb 15 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
537- new upstream release
538
539* Wed Jan 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl2
540- remove clockaddon, system-tray-applet
541
542* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
543- new upstream release
544
545* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.90.1-0vl2
546- add patch1 from rawhide package.
547
548* Fri Jan 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.90.1-0vl1
549- new upstream release
550
551* Sat Dec 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
552- add system-tray-applet
553- modify default panel menu.
554- update ja.po
555
556* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
557- add Requires: vine-menus
558
559* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
560- new upstream release
561
562* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl2
563- remove redhatize patch.
564
565* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
566- build for Vine Linux
567- new upstream release from gnome-2.1.4
568
569* Mon Oct 14 2002 Florian La Roche <Florian.LaRoche@redhat.de>
570- fix postun script
571
572* Tue Oct  8 2002 Havoc Pennington <hp@redhat.com>
573- 2.0.9 with menu edit stuff
574- system-tray-applet 0.15 that doesn't crash all the time
575- merge/remove patches as appropriate
576
577* Wed Aug 28 2002 Owen Taylor <otaylor@redhat.com>
578- Fix problem with "hold down print screen" (71432)
579
580* Tue Aug 27 2002 Jonathan Blandford <jrb@redhat.com>
581- panel-properties OnlyShowIn=GNOME;
582- somehow the po file got screwed up.  Works now
583- update po files
584
585* Sun Aug 25 2002 Havoc Pennington <hp@redhat.com>
586- fix from #71762 for clock applet popdown key
587- no WIN_POS_MOUSE fixes #72167
588- fix for #72540 from George
589
590* Wed Aug 21 2002 Havoc Pennington <hp@redhat.com>
591- system tray applet 0.11 with a small memleak fix and a couple translations
592
593* Thu Aug 15 2002 Jonathan Blandford <jrb@redhat.com>
594- menu tweaks
595
596* Wed Aug 14 2002 Tim Powers <timp@redhat.com>
597- bump release
598
599* Wed Aug 14 2002 Preston Brown <pbrown@redhat.com>
600- put battery applet on panel for laptops (#67296)
601
602* Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
603- 2.0.6 final from gnome 2.0.1
604- remove gnome-panel-screenshot patch now upstream
605
606* Thu Aug  8 2002 Jonathan Blandford <jrb@redhat.com>
607- new system-tray-applet version
608- Fix gnome-panel-screenshot
609
610* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
611- 2.0.4
612- replace gnome-logo-icon-transparent.png with redhat-main-menu.png
613  for the foot menu
614
615* Fri Aug  2 2002 Havoc Pennington <hp@redhat.com>
616- fix desktop (logout/lock) menu item location
617  in Alt+F1 and in new menu applets
618- remove Screenshot... menu item
619
620* Fri Aug  2 2002 Havoc Pennington <hp@redhat.com>
621- move around default applets, remove some of them
622- system tray 0.9
623- change default menu flags
624- blow unpackaged files out of build root
625
626* Wed Jul 31 2002 Havoc Pennington <hp@redhat.com>
627- 2.0.3
628- own libexecdir stuff
629
630* Thu Jul 25 2002 Havoc Pennington <hp@redhat.com>
631- new system tray that's prettier and doesn't clip the icon
632
633* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
634- system tray 0.7 that doesn't crash on startup
635- get Mozilla desktop file right so we get web browser launcher
636
637* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
638- system tray 0.6 with server file fixed (work dammit)
639
640* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
641- tweak applet positions but I think it's just broken
642- system tray 0.5 moved back to libdir not libexecdir
643
644* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
645- remove ltmain.sh hack
646- new system-tray-applet that works
647
648* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
649- put office suite stuff on the panel
650
651* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
652- 2.0.2.90 cvs snap
653
654* Wed Jul 10 2002 Havoc Pennington <hp@redhat.com>
655- update the clock patch to be a little smarter in a couple ways
656
657* Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
658- Fix problem where system tray applet was being looked for in /unst
659- Fix a crash in the system tray applet
660
661* Wed Jun 26 2002 Owen Taylor <otaylor@redhat.com>
662- Fix typo in the pt_BR translation that was causing GConf problems
663
664* Mon Jun 24 2002 Havoc Pennington <hp@redhat.com>
665- add the system tray applet
666- add system tray applet by default
667- add more launcher by default
668
669* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
670- automated rebuild
671
672* Thu Jun 20 2002 Havoc Pennington <hp@redhat.com>
673- use correct gettext package name, and add check for missing translations
674
675* Mon Jun 17 2002 Havoc Pennington <hp@redhat.com>
676- add the calendar and configuration patch
677
678* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
679- 2.0.0
680- add control center desktop file to file list
681- add gnome-panelrc to file list
682- try fixing panel size (blind, no text box at home)
683
684* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
685- rebuild in different environment
686
687* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
688- updates to default configuration
689
690* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
691- fix schemas installation
692
693* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
694- unset old panel schemas when installing new ones
695- put in a broken panel config to see errors about
696- add a patch to give some decent error messages about what's wrong
697  with the default panel config
698
699* Sun Jun 09 2002 Havoc Pennington <hp@redhat.com>
700- rebuild in different environment
701
702* Sun Jun  9 2002 Havoc Pennington <hp@redhat.com>
703- don't provide/obsolete gnome-core
704
705* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
706- rebuild in different environment
707
708* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
709- 1.5.24
710- ldconfig
711
712* Mon Jun 03 2002 Havoc Pennington <hp@redhat.com>
713- rebuild in different environment
714
715* Fri May 31 2002 Havoc Pennington <hp@redhat.com>
716- 1.5.23
717
718* Sun May 26 2002 Tim Powers <timp@redhat.com>
719- automated rebuild
720
721* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
722- rebuild in different environment
723
724* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
725- 1.5.22
726- provide gnome-core
727- add a bunch of extra build requires so build system
728  won't get confused
729
730* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
731- 1.5.19
732
733* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
734- add the keep-libtool-from-relinking hack so
735  we get the gen util applet
736
737* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
738- obsoletes gnome-core-devel
739- include libdir/*.so
740
741* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
742- get libpanel-applet in the package
743
744* Tue Apr 16 2002 Havoc Pennington <hp@redhat.com>
745- Initial build.
746
747
Note: See TracBrowser for help on using the repository browser.