source: projects/specs/trunk/g/gnome-panel/gnome-panel-vl.spec @ 11448

Revision 11448, 24.3 KB checked in by tomop, 6 years ago (diff)

gnome-panel-3.20.1-1

Line 
1%define use_eds 1
2
3%define gettext_package gnome-panel-2.0
4
5%define gnome_desktop3_version 2.91.0
6%define glib2_version 2.25.2
7%define gtk3_version 3.15.2
8%define libgnome_version 2.32.0
9%define orbit_version 2.14.19
10%define libwnck3_version 3.4.6
11%define gconf_version 2.32.0
12%define gnome_menus_version 3.7.90
13%define evolution_data_server_version 3.5.3
14%define cairo_version 1.0.0
15%define dbus_version 1.4.0
16%define dbus_glib_version 0.88
17%define libgweather_version 3.17.1
18%define libcanberra_version 0.25
19%define gobject_introspection_version 0.9.8
20
21Summary: GNOME panel
22Summary(ja): GNOME パネル
23Name: gnome-panel
24Version: 3.20.1
25Release: 1%{_dist_release}
26URL: http://www.gnome.org/
27License: GPL
28Group: User Interface/Desktops
29
30Source0: http://ftp.gnome.org/pub/gnome/sources/gnome-panel/3.20/%{name}-%{version}.tar.xz
31# Remove this line and next line when upstream adopt Source1
32Source2: vine6-panel-default-setup.entries
33Source5: vine-panel-backwards-compat-config.schemas
34Source10: add-translations.sh
35Source12: gnome-compiler-flags.m4
36Source13: panel-default-layout.layout.vine
37
38BuildRoot: %{_tmppath}/%{name}-%{version}-root
39
40Requires: %{name}-libs = %{version}-%{release}
41Requires: gnome-desktop3 >= %{gnome_desktop3_version}
42Requires: libwnck3 >= %{libwnck3_version}
43Requires: gnome-menus >= %{gnome_menus_version}
44Requires: vine-menus >= 1.1
45Requires(post,postun): gtk3
46
47%if %{use_eds}
48Requires: evolution-data-server >= %{evolution_data_server_version}
49%endif
50Requires: libSM
51
52BuildRequires: libxml2-python
53BuildRequires: intltool
54BuildRequires: gettext
55BuildRequires: automake
56BuildRequires: autoconf
57BuildRequires: libtool
58BuildRequires: libxslt
59BuildRequires: gnome-desktop3-devel >= %{gnome_desktop3_version}
60BuildRequires: gtk3-devel >= %{gtk3_version}
61BuildRequires: libgnome-devel >= %{libgnome_version}
62BuildRequires: libwnck3-devel >= %{libwnck3_version}
63BuildRequires: gnome-menus-devel >= %{gnome_menus_version}
64BuildRequires: cairo-devel >= %{cairo_version}
65BuildRequires: yelp-tools
66BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
67BuildRequires: gtk-doc
68BuildRequires: pango-devel
69BuildRequires: libX11-devel
70BuildRequires: libXau-devel
71%if %{use_eds}
72BuildRequires: evolution-data-server-devel >= %{evolution_data_server_version}
73BuildRequires: ORBit2-devel >= %{orbit_version}
74BuildRequires: dbus-devel >= %{dbus_version}
75%endif
76BuildRequires: libgweather-devel >= %{libgweather_version}
77BuildRequires: libcanberra-devel >= %{libcanberra_versino}
78BuildRequires: librsvg2-devel
79BuildRequires: NetworkManager-devel
80BuildRequires: libSM-devel
81BuildRequires: gobject-introspection-devel >= %{gobject_introspection_version}
82BuildRequires: dconf-devel
83BuildRequires: polkit-devel
84BuildRequires: telepathy-glib-devel
85BuildRequires: desktop-file-utils
86BuildRequires: gdm-devel
87
88Obsoletes: gnome-netstatus < 2.29
89
90%description
91
92The GNOME panel provides the window list, workspace switcher, menus, and other
93features for the GNOME desktop.
94
95%description -l ja
96
97GNOME パネルは、ウィンドウ一覧・ワークスペース切り換え器・メニューその他の
98特徴を GNOME デスクトップに提供します。
99
100%package libs
101Summary: Libraries for use in panel applets of GNOME
102Summary(ja): GNOME のパネルアップレットで使用するライブラリ
103Group: System Environment/Libraries
104
105%description libs
106Libraries for use in panel applets of GNOME.
107
108%description libs -l ja
109GNOME のパネルアップレットで使用するライブラリ
110
111%package devel
112Summary: Development environment for panel applets of GNOME
113Summary(ja): GNOME のパネルアップレット用開発環境
114Group: Development/Libraries
115Requires: %{name}-libs = %{version}-%{release}
116Requires: pkgconfig
117Requires: glib2-devel >= %{glib2_version}
118Requires: gtk3-devel >= %{gtk3_version}
119
120%description devel
121Header files and libraries for building a panel applets of GNOME.
122
123%description devel -l ja
124GNOME のパネルアップレットをビルドするためのヘッダファイル及びライブラリ集
125
126
127%prep
128%setup -q
129
130cp -f %{SOURCE2} gnome-panel/panel-default-setup.entries
131cp -f %{SOURCE12} m4
132cp -f %{SOURCE5} gnome-panel/panel-compatibility.schemas
133cp -f %{SOURCE13} data/panel-default-layout.layout
134
135. %{SOURCE10}
136
137for a in ca cs de el es fr gu hu it lt nb pl pt pt_BR ru sk sr sv th vi zh_TW;
138do
139    sed -i "s|^$a$||" po/LINGUAS
140    rm -f po/$a.po
141done
142
143%build
144%configure \
145           --disable-gtk-doc \
146           --enable-introspection=yes \
147%if %{use_eds}
148           --enable-eds=yes
149%else
150           --enable-eds=no
151%endif
152make
153
154%install
155rm -rf $RPM_BUILD_ROOT
156
157make install DESTDIR=$RPM_BUILD_ROOT
158
159#
160# Create pager and tasklist schemas for compatibility with older
161# configurations which reference the old schema names
162#
163#sed -e 's|/schemas/apps/window_list_applet/prefs/|/schemas/apps/tasklist_applet/prefs/|' $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/window-list.schemas > $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/tasklist.schemas
164#sed -e 's|/schemas/apps/workspace_switcher_applet/prefs/|/schemas/apps/pager_applet/prefs/|; s|<default>1</default>|<default>2</default>|' $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/workspace-switcher.schemas > $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/pager.schemas
165
166
167find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
168
169/bin/rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
170
171%find_lang %{gettext_package} --all-name --with-gnome
172
173%clean
174rm -rf $RPM_BUILD_ROOT
175
176%post
177/sbin/ldconfig
178touch --no-create %{_datadir}/icons/hicolor
179if [ -x /usr/bin/gtk-update-icon-cache ]; then
180  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
181fi
182
183%postun
184/sbin/ldconfig
185touch --no-create %{_datadir}/icons/hicolor
186if [ -x /usr/bin/gtk-update-icon-cache ]; then
187  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
188fi
189update-desktop-database -q &> /dev/null ||:
190
191%posttrans
192update-desktop-database -q &> /dev/null ||:
193 
194%files -f %{gettext_package}.lang
195%defattr(-,root,root)
196%doc AUTHORS COPYING COPYING.LIB COPYING-DOCS NEWS README
197%{_bindir}/*
198%exclude %{_bindir}/panel-test-applets
199%{_libdir}/%{name}/5.0/libclock-applet.so
200%{_libdir}/%{name}/5.0/libfish-applet.so
201%{_libdir}/%{name}/5.0/libnotification-area-applet.so
202%{_libdir}/%{name}/5.0/libwnck-applet.so
203%{_datadir}/applications/*.desktop
204%{_datadir}/icons/hicolor/*/*/*
205%{_datadir}/glib-2.0/schemas/*.xml
206%{_datadir}/gnome-panel
207%{_mandir}/man*/*
208
209%files libs
210%{_libdir}/*.so.*
211%{_libdir}/girepository-1.0/*.typelib
212
213%files devel
214%{_bindir}/panel-test-applets
215%{_libdir}/pkgconfig/*.pc
216%{_includedir}/gnome-panel*
217%{_libdir}/*.so
218%{_datadir}/gtk-doc
219%{_datadir}/gir-1.0/*.gir
220
221
222%changelog
223* Sat Jan 27 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.20.1-1
224- new upstream release.
225
226* Sun Jul 17 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.20.0-1
227- new upstream release
228
229* Fri Nov 06 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.1-1
230- new upstream release
231- add Source13 (panel-default-layout.layout.vine)
232
233* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
234- new upstream release
235
236* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
237- new upstream release
238- remove Patch0 (gnome-panel-3.5.91-configure.patch)
239- change BuildRequires: yelp-tools instead of gnome-doc-utils
240
241* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2.1-1
242- new upstream release
243
244* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
245- new upstream release
246- add BuildRequires: polkit-devel
247
248* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
249- new upstream release
250
251* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
252- new upstream release
253
254* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
255- new upstream release
256- remove BuildRequires: polkit-gnome-devel
257
258* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5-2
259- rebuild with evolution-data-server-3.1.90
260
261* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5-1
262- new upstream release
263
264* Sat Aug 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.2-1
265- new upstream release
266- drop old Patches
267- change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
268- change BuildRequires: libwnck3-devel instead of libwnck-devel
269- add BuildRequires: dconf-devel, telepathy-glib-devel
270- add Obsoletes: gnome-netstatus
271- add Patch0 (gnome-panel-3.0.2-configure.patch)
272
273* Thu Jun 02 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.32.1-4
274- update SOURCE2(vine6-panel-default-setup.entries)
275  - remove bottom panel
276  - move window_list and workspace_switcher applet to top panel
277
278* Sat Dec 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-3
279- update Source1 (clock.gnome-2.32.ja.po)
280
281* Sat Dec 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-2
282- remove Provides: gnome-panel-devel
283
284* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
285- new upstream release
286
287* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0.2-1
288- new upstream release
289- add BuildRequires: gobject-introspection-devel
290- remove BuildRequires: libgnomeui-devel
291- remove SOURCE3 and SOURCE4
292- drop Patch11
293- add configure option (--enable-introspection=yes)
294
295* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-3
296- rebuild with rpm-4.8.1 for pkg-config file
297
298* Sun Aug 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-2
299- create -libs and -devel package
300
301* Tue Jun 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
302- new upstream release
303
304* Tue Jun 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-2
305- rebuild with evolution-data-server-2.30.2
306
307* Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
308- new upstream release
309- update Patch8, Patch9 (from FC package)
310- add BuildRequires: libcanberra-devel
311
312* Sat Mar 27 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.28.0-4
313- update translation of clock applet manual
314- add translation of fish applet manual
315
316* Fri Mar 26 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.28.0-3
317- add libSM(-devel) to (Build)Requires
318- add desktop-file-utils to BuildRequires
319
320* Thu Mar 25 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.28.0-2
321- update translation of clock applet manual
322
323* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.0-1
324- new upstream release
325- updated Patch0 and 2
326
327* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
328- new upstream release
329
330* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-3
331- rebuild with gtk2-2.16.3
332
333* Thu Jun 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
334- add empty gconf entries to vine-panel-default-setup.entries
335
336* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
337- new upstream release
338
339* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
340- new upstream release
341
342* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-4
343- update vine-panel-default-setup.entries again..
344
345* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-3
346- update vine-panel-default-setup.entries
347
348* Tue Mar 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-2
349- remove mixer applets from default panel setup
350
351* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
352- new upstream release
353
354* Mon Jan 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.3-1
355- new upstream release
356- added BuildRequires: PolicyKit-gnome-devel
357
358* Tue Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
359- new upstream release
360
361* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
362- new upstream release
363
364* Tue Jun  3 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1
365- new upstream release
366
367* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.3-1
368- new upstream release
369
370* Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.2-1vl5
371- new upstream release
372- removed Patch25,26,27,29 and 30 (merged into upstream)
373
374* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-2vl5
375- added Patches from FC
376  * Fri Mar 28 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-8
377  - Fix editing of locations in the clock applet
378  * Fri Mar 28 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-7
379  - Convert the edit and find location windows to dialogs
380  * Thu Mar 27 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-6
381  - Improve the time settings window
382  * Thu Mar 27 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-5
383  - Make the find-location window of the clock larger
384  * Sat Mar 15 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-4
385  - Only save the session when the users wants it
386  * Fri Mar 14 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-3
387  - Populate the location list before showing the preference window
388  * Sat Mar  8 2008 Will Woods <wwoods@redhat.com> - 2.21.92-6
389  - Add "About This Computer" item to System menu if it exists
390  * Wed Feb 20 2008 Matthias Clasen <mclasen@redhat.com> - 2.21.91-6
391  - Try harder to avoid resizing the popup
392- updated BuildRequires
393
394* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
395- new upstream release
396- added BuildRequires: libgweather-devel
397
398* Tue Jan  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.2-0vl1
399- new upstream release
400- updated %post and %postun section
401- added %pre and %preun section
402- added Patches from Fedora
403  * Fri Oct 12 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0.1-4
404  - Sharper icons
405  * Wed Oct  3 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0.1-3
406  - Make it possible to start s-c-d from the clock menu again (#316921)
407  * Fri Sep 21 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0.1-2
408  - Don't pop up an error if an applet from the default
409    configuration is missing 
410  * Mon Sep 17 2007 Matthias Clasen <mclasen@redhat.com> - 2.19.92-6
411  - Turns out we need requires for applets in the default config (#293261)
412  * Mon Sep 17 2007 Matthias Clasen <mclasen@redhat.com> - 2.19.92-5
413  - Drop the requires for fast-user-switch-applet (#253831)
414
415* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.3-0vl1
416- new upstream release
417- dropped Patch22 (merged into upstream)
418
419* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
420- new upstream release
421
422* Mon Oct 30 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.3-0vl2
423- add missing BuildRequires to gnome-menus-devel (<BTS:319>)
424
425* Thu Oct 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl1
426- new upstream release
427- fix panel-default-setup.entries to change the name of
428  firefox desktopfile (<BTS:229>)
429
430* Thu Jul 20 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.14.2-0vl2
431- add patch 11 to fix disappearing of recent documents list.
432  <BTS:VineLinux:81>, http://bugzilla.gnome.org/show_bug.cgi?id=343812
433
434* Sat Jun  3 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.2-0vl1
435- new upstream release
436
437* Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
438- new upstream release
439
440* Sat Apr 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
441- run gtk-update-icon-cache in %%post script.
442
443* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
444- new upstream release
445
446* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.91-0vl2
447- update vine-panel-default-setup.entries
448  - replace mozilla by firefox
449  - remove nautilus
450  - add notification area applet on top panel
451  - add trashbox applet on bottom panel
452- cleanup %%post script
453
454* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.91-0vl1
455- new upstream release
456
457* Sun Feb 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.3-0vl1
458- new upstream release
459- added Prereq: scroolkeeper, GConf2
460
461* Wed Oct 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
462- new upstream release
463
464* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
465- new upstream release
466
467* Sun Aug 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.91-0vl1
468- new upstream release
469
470* Wed Aug 03 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
471- new upstream release
472
473* Thu Jul 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.2-0vl1
474- new upstream release
475
476* Sat Apr 16 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl2
477- disable evolution-data-server
478
479* Thu Apr 14 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
480- new upstream release
481
482* Thu Mar 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl2
483- add Patch10 to fix hard-coded desktop file name.
484
485* Thu Mar 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
486- new upstream version
487
488* Fri Feb 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.3-0vl1
489- new upstream release
490- run scrollkeeper at %post, %postun
491
492* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
493- new upstream release
494
495* Fri Oct 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl3
496- add Patch10 to fix egg-recent-model.c.
497  save old umask value before create ".recently-used" file.
498 
499* Sun Oct 24 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.4.2-0vl2
500- fix location of nautilus launcher in panel-default-setup.entries.
501- do not add wireless monitor in %%post when no interfaces are available.
502- add Japanese summary and description
503- add BuildRequires: startup-notification-devel, gcc-c++.
504- disable libtoolize: version mismatch is bad
505
506* Sat Jan 31 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
507- new upstream release
508
509* Sat Dec 27 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
510- new upstream release
511
512* Sat Dec 27 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.0-0vl3
513- rebuilt against new toolchain
514
515* Fri Sep 12 2003 Tomoya TAKA <taka@vinelinux.org> 2.4.0-0vl2
516- add --disable-schemas-install option to %%configure
517
518* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
519- new upstream release
520
521* Mon Sep 08 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.91-0vl2
522- add missing files
523- add vine default panel entries
524
525* Sat Sep 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.91-0vl1
526- new upstream release
527
528* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
529- new upstream release
530
531* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.7-0vl1
532- new upstream release
533
534* Wed Jun 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2.1-0vl2
535- remove vine's panel-per-panel-config.schemas
536  This should be added again in a future version.
537
538* Tue Jun 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2.1-0vl1
539- new upstream release
540
541* Tue Apr 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
542- new upstream release
543- remove old ja.po
544
545* Sat Feb 15 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
546- new upstream release
547
548* Wed Jan 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl2
549- remove clockaddon, system-tray-applet
550
551* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
552- new upstream release
553
554* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.90.1-0vl2
555- add patch1 from rawhide package.
556
557* Fri Jan 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.90.1-0vl1
558- new upstream release
559
560* Sat Dec 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
561- add system-tray-applet
562- modify default panel menu.
563- update ja.po
564
565* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
566- add Requires: vine-menus
567
568* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
569- new upstream release
570
571* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl2
572- remove redhatize patch.
573
574* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
575- build for Vine Linux
576- new upstream release from gnome-2.1.4
577
578* Mon Oct 14 2002 Florian La Roche <Florian.LaRoche@redhat.de>
579- fix postun script
580
581* Tue Oct  8 2002 Havoc Pennington <hp@redhat.com>
582- 2.0.9 with menu edit stuff
583- system-tray-applet 0.15 that doesn't crash all the time
584- merge/remove patches as appropriate
585
586* Wed Aug 28 2002 Owen Taylor <otaylor@redhat.com>
587- Fix problem with "hold down print screen" (71432)
588
589* Tue Aug 27 2002 Jonathan Blandford <jrb@redhat.com>
590- panel-properties OnlyShowIn=GNOME;
591- somehow the po file got screwed up.  Works now
592- update po files
593
594* Sun Aug 25 2002 Havoc Pennington <hp@redhat.com>
595- fix from #71762 for clock applet popdown key
596- no WIN_POS_MOUSE fixes #72167
597- fix for #72540 from George
598
599* Wed Aug 21 2002 Havoc Pennington <hp@redhat.com>
600- system tray applet 0.11 with a small memleak fix and a couple translations
601
602* Thu Aug 15 2002 Jonathan Blandford <jrb@redhat.com>
603- menu tweaks
604
605* Wed Aug 14 2002 Tim Powers <timp@redhat.com>
606- bump release
607
608* Wed Aug 14 2002 Preston Brown <pbrown@redhat.com>
609- put battery applet on panel for laptops (#67296)
610
611* Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
612- 2.0.6 final from gnome 2.0.1
613- remove gnome-panel-screenshot patch now upstream
614
615* Thu Aug  8 2002 Jonathan Blandford <jrb@redhat.com>
616- new system-tray-applet version
617- Fix gnome-panel-screenshot
618
619* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
620- 2.0.4
621- replace gnome-logo-icon-transparent.png with redhat-main-menu.png
622  for the foot menu
623
624* Fri Aug  2 2002 Havoc Pennington <hp@redhat.com>
625- fix desktop (logout/lock) menu item location
626  in Alt+F1 and in new menu applets
627- remove Screenshot... menu item
628
629* Fri Aug  2 2002 Havoc Pennington <hp@redhat.com>
630- move around default applets, remove some of them
631- system tray 0.9
632- change default menu flags
633- blow unpackaged files out of build root
634
635* Wed Jul 31 2002 Havoc Pennington <hp@redhat.com>
636- 2.0.3
637- own libexecdir stuff
638
639* Thu Jul 25 2002 Havoc Pennington <hp@redhat.com>
640- new system tray that's prettier and doesn't clip the icon
641
642* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
643- system tray 0.7 that doesn't crash on startup
644- get Mozilla desktop file right so we get web browser launcher
645
646* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
647- system tray 0.6 with server file fixed (work dammit)
648
649* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
650- tweak applet positions but I think it's just broken
651- system tray 0.5 moved back to libdir not libexecdir
652
653* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
654- remove ltmain.sh hack
655- new system-tray-applet that works
656
657* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
658- put office suite stuff on the panel
659
660* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
661- 2.0.2.90 cvs snap
662
663* Wed Jul 10 2002 Havoc Pennington <hp@redhat.com>
664- update the clock patch to be a little smarter in a couple ways
665
666* Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
667- Fix problem where system tray applet was being looked for in /unst
668- Fix a crash in the system tray applet
669
670* Wed Jun 26 2002 Owen Taylor <otaylor@redhat.com>
671- Fix typo in the pt_BR translation that was causing GConf problems
672
673* Mon Jun 24 2002 Havoc Pennington <hp@redhat.com>
674- add the system tray applet
675- add system tray applet by default
676- add more launcher by default
677
678* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
679- automated rebuild
680
681* Thu Jun 20 2002 Havoc Pennington <hp@redhat.com>
682- use correct gettext package name, and add check for missing translations
683
684* Mon Jun 17 2002 Havoc Pennington <hp@redhat.com>
685- add the calendar and configuration patch
686
687* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
688- 2.0.0
689- add control center desktop file to file list
690- add gnome-panelrc to file list
691- try fixing panel size (blind, no text box at home)
692
693* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
694- rebuild in different environment
695
696* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
697- updates to default configuration
698
699* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
700- fix schemas installation
701
702* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
703- unset old panel schemas when installing new ones
704- put in a broken panel config to see errors about
705- add a patch to give some decent error messages about what's wrong
706  with the default panel config
707
708* Sun Jun 09 2002 Havoc Pennington <hp@redhat.com>
709- rebuild in different environment
710
711* Sun Jun  9 2002 Havoc Pennington <hp@redhat.com>
712- don't provide/obsolete gnome-core
713
714* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
715- rebuild in different environment
716
717* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
718- 1.5.24
719- ldconfig
720
721* Mon Jun 03 2002 Havoc Pennington <hp@redhat.com>
722- rebuild in different environment
723
724* Fri May 31 2002 Havoc Pennington <hp@redhat.com>
725- 1.5.23
726
727* Sun May 26 2002 Tim Powers <timp@redhat.com>
728- automated rebuild
729
730* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
731- rebuild in different environment
732
733* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
734- 1.5.22
735- provide gnome-core
736- add a bunch of extra build requires so build system
737  won't get confused
738
739* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
740- 1.5.19
741
742* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
743- add the keep-libtool-from-relinking hack so
744  we get the gen util applet
745
746* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
747- obsoletes gnome-core-devel
748- include libdir/*.so
749
750* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
751- get libpanel-applet in the package
752
753* Tue Apr 16 2002 Havoc Pennington <hp@redhat.com>
754- Initial build.
755
756
Note: See TracBrowser for help on using the repository browser.