source: projects/specs/trunk/g/gnome-panel/gnome-panel-vl.spec @ 12005

Revision 12005, 24.3 KB checked in by tomop, 5 years ago (diff)

Merge branch 'tomop'

Line 
1%define use_eds 1
2
3%define gettext_package gnome-panel-2.0
4
5%define gnome_desktop3_version 2.91.0
6%define glib2_version 2.25.2
7%define gtk3_version 3.22.0
8%define libgnome_version 2.32.0
9%define orbit_version 2.14.19
10%define libwnck3_version 3.4.6
11%define gconf_version 2.32.0
12%define gnome_menus_version 3.7.90
13%define evolution_data_server_version 3.5.3
14%define cairo_version 1.0.0
15%define dbus_version 1.4.0
16%define dbus_glib_version 0.88
17%define libgweather_version 3.17.1
18%define libcanberra_version 0.25
19%define gobject_introspection_version 0.9.8
20
21Summary: GNOME panel
22Summary(ja): GNOME パネル
23Name: gnome-panel
24Version: 3.30.0
25Release: 1%{_dist_release}
26URL: http://www.gnome.org/
27License: GPL
28Group: User Interface/Desktops
29
30Vendor: Project Vine
31Distribution: Vine Linux
32
33Source0: http://ftp.gnome.org/pub/gnome/sources/gnome-panel/3.20/%{name}-%{version}.tar.xz
34# Remove this line and next line when upstream adopt Source1
35Source2: vine6-panel-default-setup.entries
36Source5: vine-panel-backwards-compat-config.schemas
37Source10: add-translations.sh
38Source12: gnome-compiler-flags.m4
39Source13: panel-default-layout.layout.vine
40
41Patch1000: gnome-panel-3.30.0-elogind.patch
42
43BuildRoot: %{_tmppath}/%{name}-%{version}-root
44
45Requires: %{name}-libs = %{version}-%{release}
46Requires: gnome-desktop3 >= %{gnome_desktop3_version}
47Requires: libwnck3 >= %{libwnck3_version}
48Requires: gnome-menus >= %{gnome_menus_version}
49Requires: vine-menus >= 1.1
50Requires(post,postun): gtk3
51
52%if %{use_eds}
53Requires: evolution-data-server >= %{evolution_data_server_version}
54%endif
55Requires: libSM
56
57BuildRequires: libxml2-python
58BuildRequires: intltool
59BuildRequires: gettext
60BuildRequires: automake
61BuildRequires: autoconf
62BuildRequires: libtool
63BuildRequires: libxslt
64BuildRequires: gnome-desktop3-devel >= %{gnome_desktop3_version}
65BuildRequires: gtk3-devel >= %{gtk3_version}
66BuildRequires: libgnome-devel >= %{libgnome_version}
67BuildRequires: libwnck3-devel >= %{libwnck3_version}
68BuildRequires: gnome-menus-devel >= %{gnome_menus_version}
69BuildRequires: cairo-devel >= %{cairo_version}
70BuildRequires: yelp-tools
71BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
72BuildRequires: gtk-doc
73BuildRequires: pango-devel
74BuildRequires: libX11-devel
75BuildRequires: libXau-devel
76%if %{use_eds}
77BuildRequires: evolution-data-server-devel >= %{evolution_data_server_version}
78BuildRequires: ORBit2-devel >= %{orbit_version}
79BuildRequires: dbus-devel >= %{dbus_version}
80%endif
81BuildRequires: libgweather-devel >= %{libgweather_version}
82BuildRequires: libcanberra-devel >= %{libcanberra_versino}
83BuildRequires: librsvg2-devel
84BuildRequires: NetworkManager-devel
85BuildRequires: libSM-devel
86BuildRequires: gobject-introspection-devel >= %{gobject_introspection_version}
87BuildRequires: dconf-devel
88BuildRequires: polkit-devel
89BuildRequires: telepathy-glib-devel
90BuildRequires: desktop-file-utils
91BuildRequires: gdm-devel
92BuildRequires: elogind-devel
93
94Obsoletes: gnome-netstatus < 2.29
95
96%description
97
98The GNOME panel provides the window list, workspace switcher, menus, and other
99features for the GNOME desktop.
100
101%description -l ja
102
103GNOME パネルは、ウィンドウ一覧・ワークスペース切り換え器・メニューその他の
104特徴を GNOME デスクトップに提供します。
105
106%package libs
107Summary: Libraries for use in panel applets of GNOME
108Summary(ja): GNOME のパネルアップレットで使用するライブラリ
109Group: System Environment/Libraries
110
111%description libs
112Libraries for use in panel applets of GNOME.
113
114%description libs -l ja
115GNOME のパネルアプレットで使用するライブラリ
116
117%package devel
118Summary: Development environment for panel applets of GNOME
119Summary(ja): GNOME のパネルアップレット用開発環境
120Group: Development/Libraries
121Requires: %{name}-libs = %{version}-%{release}
122Requires: pkgconfig
123Requires: glib2-devel >= %{glib2_version}
124Requires: gtk3-devel >= %{gtk3_version}
125
126%description devel
127Header files and libraries for building a panel applets of GNOME.
128
129%description devel -l ja
130GNOME のパネルアプレットをビルドするためのヘッダファイル及びライブラリ集
131
132
133%prep
134%setup -q
135%patch1000 -p1 -b .elogind
136
137cp -f %{SOURCE2} gnome-panel/panel-default-setup.entries
138cp -f %{SOURCE12} m4
139cp -f %{SOURCE5} gnome-panel/panel-compatibility.schemas
140cp -f %{SOURCE13} data/panel-default-layout.layout
141
142. %{SOURCE10}
143
144for a in ca cs de el es fr gu hu it lt nb pl pt pt_BR ru sk sr sv th vi zh_CN zh_TW;
145do
146    sed -i "s|^$a$||" po/LINGUAS
147    rm -f po/$a.po
148done
149
150%build
151autoreconf -vif
152%configure \
153           --disable-gtk-doc \
154           --enable-introspection=yes \
155%if %{use_eds}
156           --enable-eds=yes
157%else
158           --enable-eds=no
159%endif
160%__make %{?_smp_mflags}
161
162%install
163rm -rf $RPM_BUILD_ROOT
164
165make install DESTDIR=$RPM_BUILD_ROOT
166
167#
168# Create pager and tasklist schemas for compatibility with older
169# configurations which reference the old schema names
170#
171#sed -e 's|/schemas/apps/window_list_applet/prefs/|/schemas/apps/tasklist_applet/prefs/|' $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/window-list.schemas > $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/tasklist.schemas
172#sed -e 's|/schemas/apps/workspace_switcher_applet/prefs/|/schemas/apps/pager_applet/prefs/|; s|<default>1</default>|<default>2</default>|' $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/workspace-switcher.schemas > $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/pager.schemas
173
174
175find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
176
177/bin/rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
178
179%find_lang %{gettext_package} --all-name --with-gnome
180
181%clean
182rm -rf $RPM_BUILD_ROOT
183
184%post
185/sbin/ldconfig
186touch --no-create %{_datadir}/icons/hicolor
187if [ -x /usr/bin/gtk-update-icon-cache ]; then
188  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
189fi
190
191%postun
192/sbin/ldconfig
193touch --no-create %{_datadir}/icons/hicolor
194if [ -x /usr/bin/gtk-update-icon-cache ]; then
195  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
196fi
197update-desktop-database -q &> /dev/null ||:
198
199%posttrans
200update-desktop-database -q &> /dev/null ||:
201 
202%files -f %{gettext_package}.lang
203%defattr(-,root,root)
204%license COPYING COPYING.LIB
205%doc AUTHORS COPYING-DOCS NEWS README
206%{_bindir}/*
207%{_libdir}/%{name}/modules/*.so
208%{_datadir}/applications/*.desktop
209%{_datadir}/icons/hicolor/*/*/*
210%{_datadir}/glib-2.0/schemas/*.xml
211%{_datadir}/gnome-panel
212%{_mandir}/man*/*
213
214%files libs
215%{_libdir}/*.so.*
216
217%files devel
218%{_libdir}/pkgconfig/*.pc
219%{_includedir}/gnome-panel*
220%{_libdir}/*.so
221%{_datadir}/gtk-doc
222
223
224%changelog
225* Sun Dec 30 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.30.0-1
226- new upstream release.
227
228* Sat Jan 27 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.20.1-1
229- new upstream release.
230
231* Sun Jul 17 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.20.0-1
232- new upstream release
233
234* Fri Nov 06 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.1-1
235- new upstream release
236- add Source13 (panel-default-layout.layout.vine)
237
238* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
239- new upstream release
240
241* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
242- new upstream release
243- remove Patch0 (gnome-panel-3.5.91-configure.patch)
244- change BuildRequires: yelp-tools instead of gnome-doc-utils
245
246* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2.1-1
247- new upstream release
248
249* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
250- new upstream release
251- add BuildRequires: polkit-devel
252
253* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
254- new upstream release
255
256* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
257- new upstream release
258
259* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
260- new upstream release
261- remove BuildRequires: polkit-gnome-devel
262
263* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5-2
264- rebuild with evolution-data-server-3.1.90
265
266* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5-1
267- new upstream release
268
269* Sat Aug 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.2-1
270- new upstream release
271- drop old Patches
272- change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
273- change BuildRequires: libwnck3-devel instead of libwnck-devel
274- add BuildRequires: dconf-devel, telepathy-glib-devel
275- add Obsoletes: gnome-netstatus
276- add Patch0 (gnome-panel-3.0.2-configure.patch)
277
278* Thu Jun 02 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.32.1-4
279- update SOURCE2(vine6-panel-default-setup.entries)
280  - remove bottom panel
281  - move window_list and workspace_switcher applet to top panel
282
283* Sat Dec 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-3
284- update Source1 (clock.gnome-2.32.ja.po)
285
286* Sat Dec 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-2
287- remove Provides: gnome-panel-devel
288
289* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
290- new upstream release
291
292* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0.2-1
293- new upstream release
294- add BuildRequires: gobject-introspection-devel
295- remove BuildRequires: libgnomeui-devel
296- remove SOURCE3 and SOURCE4
297- drop Patch11
298- add configure option (--enable-introspection=yes)
299
300* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-3
301- rebuild with rpm-4.8.1 for pkg-config file
302
303* Sun Aug 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-2
304- create -libs and -devel package
305
306* Tue Jun 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
307- new upstream release
308
309* Tue Jun 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-2
310- rebuild with evolution-data-server-2.30.2
311
312* Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
313- new upstream release
314- update Patch8, Patch9 (from FC package)
315- add BuildRequires: libcanberra-devel
316
317* Sat Mar 27 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.28.0-4
318- update translation of clock applet manual
319- add translation of fish applet manual
320
321* Fri Mar 26 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.28.0-3
322- add libSM(-devel) to (Build)Requires
323- add desktop-file-utils to BuildRequires
324
325* Thu Mar 25 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.28.0-2
326- update translation of clock applet manual
327
328* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.0-1
329- new upstream release
330- updated Patch0 and 2
331
332* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
333- new upstream release
334
335* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-3
336- rebuild with gtk2-2.16.3
337
338* Thu Jun 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
339- add empty gconf entries to vine-panel-default-setup.entries
340
341* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
342- new upstream release
343
344* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
345- new upstream release
346
347* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-4
348- update vine-panel-default-setup.entries again..
349
350* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-3
351- update vine-panel-default-setup.entries
352
353* Tue Mar 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-2
354- remove mixer applets from default panel setup
355
356* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
357- new upstream release
358
359* Mon Jan 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.3-1
360- new upstream release
361- added BuildRequires: PolicyKit-gnome-devel
362
363* Tue Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
364- new upstream release
365
366* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
367- new upstream release
368
369* Tue Jun  3 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1
370- new upstream release
371
372* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.3-1
373- new upstream release
374
375* Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.2-1vl5
376- new upstream release
377- removed Patch25,26,27,29 and 30 (merged into upstream)
378
379* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-2vl5
380- added Patches from FC
381  * Fri Mar 28 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-8
382  - Fix editing of locations in the clock applet
383  * Fri Mar 28 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-7
384  - Convert the edit and find location windows to dialogs
385  * Thu Mar 27 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-6
386  - Improve the time settings window
387  * Thu Mar 27 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-5
388  - Make the find-location window of the clock larger
389  * Sat Mar 15 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-4
390  - Only save the session when the users wants it
391  * Fri Mar 14 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-3
392  - Populate the location list before showing the preference window
393  * Sat Mar  8 2008 Will Woods <wwoods@redhat.com> - 2.21.92-6
394  - Add "About This Computer" item to System menu if it exists
395  * Wed Feb 20 2008 Matthias Clasen <mclasen@redhat.com> - 2.21.91-6
396  - Try harder to avoid resizing the popup
397- updated BuildRequires
398
399* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
400- new upstream release
401- added BuildRequires: libgweather-devel
402
403* Tue Jan  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.2-0vl1
404- new upstream release
405- updated %post and %postun section
406- added %pre and %preun section
407- added Patches from Fedora
408  * Fri Oct 12 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0.1-4
409  - Sharper icons
410  * Wed Oct  3 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0.1-3
411  - Make it possible to start s-c-d from the clock menu again (#316921)
412  * Fri Sep 21 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0.1-2
413  - Don't pop up an error if an applet from the default
414    configuration is missing 
415  * Mon Sep 17 2007 Matthias Clasen <mclasen@redhat.com> - 2.19.92-6
416  - Turns out we need requires for applets in the default config (#293261)
417  * Mon Sep 17 2007 Matthias Clasen <mclasen@redhat.com> - 2.19.92-5
418  - Drop the requires for fast-user-switch-applet (#253831)
419
420* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.3-0vl1
421- new upstream release
422- dropped Patch22 (merged into upstream)
423
424* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
425- new upstream release
426
427* Mon Oct 30 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.3-0vl2
428- add missing BuildRequires to gnome-menus-devel (<BTS:319>)
429
430* Thu Oct 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl1
431- new upstream release
432- fix panel-default-setup.entries to change the name of
433  firefox desktopfile (<BTS:229>)
434
435* Thu Jul 20 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.14.2-0vl2
436- add patch 11 to fix disappearing of recent documents list.
437  <BTS:VineLinux:81>, http://bugzilla.gnome.org/show_bug.cgi?id=343812
438
439* Sat Jun  3 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.2-0vl1
440- new upstream release
441
442* Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
443- new upstream release
444
445* Sat Apr 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
446- run gtk-update-icon-cache in %%post script.
447
448* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
449- new upstream release
450
451* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.91-0vl2
452- update vine-panel-default-setup.entries
453  - replace mozilla by firefox
454  - remove nautilus
455  - add notification area applet on top panel
456  - add trashbox applet on bottom panel
457- cleanup %%post script
458
459* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.91-0vl1
460- new upstream release
461
462* Sun Feb 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.3-0vl1
463- new upstream release
464- added Prereq: scroolkeeper, GConf2
465
466* Wed Oct 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
467- new upstream release
468
469* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
470- new upstream release
471
472* Sun Aug 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.91-0vl1
473- new upstream release
474
475* Wed Aug 03 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
476- new upstream release
477
478* Thu Jul 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.2-0vl1
479- new upstream release
480
481* Sat Apr 16 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl2
482- disable evolution-data-server
483
484* Thu Apr 14 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
485- new upstream release
486
487* Thu Mar 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl2
488- add Patch10 to fix hard-coded desktop file name.
489
490* Thu Mar 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
491- new upstream version
492
493* Fri Feb 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.3-0vl1
494- new upstream release
495- run scrollkeeper at %post, %postun
496
497* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
498- new upstream release
499
500* Fri Oct 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl3
501- add Patch10 to fix egg-recent-model.c.
502  save old umask value before create ".recently-used" file.
503 
504* Sun Oct 24 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.4.2-0vl2
505- fix location of nautilus launcher in panel-default-setup.entries.
506- do not add wireless monitor in %%post when no interfaces are available.
507- add Japanese summary and description
508- add BuildRequires: startup-notification-devel, gcc-c++.
509- disable libtoolize: version mismatch is bad
510
511* Sat Jan 31 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
512- new upstream release
513
514* Sat Dec 27 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
515- new upstream release
516
517* Sat Dec 27 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.0-0vl3
518- rebuilt against new toolchain
519
520* Fri Sep 12 2003 Tomoya TAKA <taka@vinelinux.org> 2.4.0-0vl2
521- add --disable-schemas-install option to %%configure
522
523* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
524- new upstream release
525
526* Mon Sep 08 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.91-0vl2
527- add missing files
528- add vine default panel entries
529
530* Sat Sep 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.91-0vl1
531- new upstream release
532
533* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
534- new upstream release
535
536* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.7-0vl1
537- new upstream release
538
539* Wed Jun 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2.1-0vl2
540- remove vine's panel-per-panel-config.schemas
541  This should be added again in a future version.
542
543* Tue Jun 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2.1-0vl1
544- new upstream release
545
546* Tue Apr 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
547- new upstream release
548- remove old ja.po
549
550* Sat Feb 15 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
551- new upstream release
552
553* Wed Jan 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl2
554- remove clockaddon, system-tray-applet
555
556* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
557- new upstream release
558
559* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.90.1-0vl2
560- add patch1 from rawhide package.
561
562* Fri Jan 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.90.1-0vl1
563- new upstream release
564
565* Sat Dec 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
566- add system-tray-applet
567- modify default panel menu.
568- update ja.po
569
570* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
571- add Requires: vine-menus
572
573* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
574- new upstream release
575
576* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl2
577- remove redhatize patch.
578
579* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
580- build for Vine Linux
581- new upstream release from gnome-2.1.4
582
583* Mon Oct 14 2002 Florian La Roche <Florian.LaRoche@redhat.de>
584- fix postun script
585
586* Tue Oct  8 2002 Havoc Pennington <hp@redhat.com>
587- 2.0.9 with menu edit stuff
588- system-tray-applet 0.15 that doesn't crash all the time
589- merge/remove patches as appropriate
590
591* Wed Aug 28 2002 Owen Taylor <otaylor@redhat.com>
592- Fix problem with "hold down print screen" (71432)
593
594* Tue Aug 27 2002 Jonathan Blandford <jrb@redhat.com>
595- panel-properties OnlyShowIn=GNOME;
596- somehow the po file got screwed up.  Works now
597- update po files
598
599* Sun Aug 25 2002 Havoc Pennington <hp@redhat.com>
600- fix from #71762 for clock applet popdown key
601- no WIN_POS_MOUSE fixes #72167
602- fix for #72540 from George
603
604* Wed Aug 21 2002 Havoc Pennington <hp@redhat.com>
605- system tray applet 0.11 with a small memleak fix and a couple translations
606
607* Thu Aug 15 2002 Jonathan Blandford <jrb@redhat.com>
608- menu tweaks
609
610* Wed Aug 14 2002 Tim Powers <timp@redhat.com>
611- bump release
612
613* Wed Aug 14 2002 Preston Brown <pbrown@redhat.com>
614- put battery applet on panel for laptops (#67296)
615
616* Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
617- 2.0.6 final from gnome 2.0.1
618- remove gnome-panel-screenshot patch now upstream
619
620* Thu Aug  8 2002 Jonathan Blandford <jrb@redhat.com>
621- new system-tray-applet version
622- Fix gnome-panel-screenshot
623
624* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
625- 2.0.4
626- replace gnome-logo-icon-transparent.png with redhat-main-menu.png
627  for the foot menu
628
629* Fri Aug  2 2002 Havoc Pennington <hp@redhat.com>
630- fix desktop (logout/lock) menu item location
631  in Alt+F1 and in new menu applets
632- remove Screenshot... menu item
633
634* Fri Aug  2 2002 Havoc Pennington <hp@redhat.com>
635- move around default applets, remove some of them
636- system tray 0.9
637- change default menu flags
638- blow unpackaged files out of build root
639
640* Wed Jul 31 2002 Havoc Pennington <hp@redhat.com>
641- 2.0.3
642- own libexecdir stuff
643
644* Thu Jul 25 2002 Havoc Pennington <hp@redhat.com>
645- new system tray that's prettier and doesn't clip the icon
646
647* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
648- system tray 0.7 that doesn't crash on startup
649- get Mozilla desktop file right so we get web browser launcher
650
651* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
652- system tray 0.6 with server file fixed (work dammit)
653
654* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
655- tweak applet positions but I think it's just broken
656- system tray 0.5 moved back to libdir not libexecdir
657
658* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
659- remove ltmain.sh hack
660- new system-tray-applet that works
661
662* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
663- put office suite stuff on the panel
664
665* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
666- 2.0.2.90 cvs snap
667
668* Wed Jul 10 2002 Havoc Pennington <hp@redhat.com>
669- update the clock patch to be a little smarter in a couple ways
670
671* Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
672- Fix problem where system tray applet was being looked for in /unst
673- Fix a crash in the system tray applet
674
675* Wed Jun 26 2002 Owen Taylor <otaylor@redhat.com>
676- Fix typo in the pt_BR translation that was causing GConf problems
677
678* Mon Jun 24 2002 Havoc Pennington <hp@redhat.com>
679- add the system tray applet
680- add system tray applet by default
681- add more launcher by default
682
683* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
684- automated rebuild
685
686* Thu Jun 20 2002 Havoc Pennington <hp@redhat.com>
687- use correct gettext package name, and add check for missing translations
688
689* Mon Jun 17 2002 Havoc Pennington <hp@redhat.com>
690- add the calendar and configuration patch
691
692* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
693- 2.0.0
694- add control center desktop file to file list
695- add gnome-panelrc to file list
696- try fixing panel size (blind, no text box at home)
697
698* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
699- rebuild in different environment
700
701* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
702- updates to default configuration
703
704* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
705- fix schemas installation
706
707* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
708- unset old panel schemas when installing new ones
709- put in a broken panel config to see errors about
710- add a patch to give some decent error messages about what's wrong
711  with the default panel config
712
713* Sun Jun 09 2002 Havoc Pennington <hp@redhat.com>
714- rebuild in different environment
715
716* Sun Jun  9 2002 Havoc Pennington <hp@redhat.com>
717- don't provide/obsolete gnome-core
718
719* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
720- rebuild in different environment
721
722* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
723- 1.5.24
724- ldconfig
725
726* Mon Jun 03 2002 Havoc Pennington <hp@redhat.com>
727- rebuild in different environment
728
729* Fri May 31 2002 Havoc Pennington <hp@redhat.com>
730- 1.5.23
731
732* Sun May 26 2002 Tim Powers <timp@redhat.com>
733- automated rebuild
734
735* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
736- rebuild in different environment
737
738* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
739- 1.5.22
740- provide gnome-core
741- add a bunch of extra build requires so build system
742  won't get confused
743
744* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
745- 1.5.19
746
747* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
748- add the keep-libtool-from-relinking hack so
749  we get the gen util applet
750
751* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
752- obsoletes gnome-core-devel
753- include libdir/*.so
754
755* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
756- get libpanel-applet in the package
757
758* Tue Apr 16 2002 Havoc Pennington <hp@redhat.com>
759- Initial build.
760
761
Note: See TracBrowser for help on using the repository browser.