source: projects/specs/trunk/g/gnome-keyring/gnome-keyring-vl.spec @ 7938

Revision 7938, 8.3 KB checked in by Takemikaduchi, 11 years ago (diff)

GNOME-3.10.1

Line 
1%define gtk3_version 3.10.0
2
3Summary: A framework for managing user passwords and other secrets
4Summary(ja): ユーザのパスワードや秘匿情報を管理するためのフレームワーク
5Name: gnome-keyring
6Version: 3.10.1
7Release: 1%{?_dist_release}
8License: GPL/LGPL
9Group: System Environment/Libraries
10Source: http://ftp.gnome.org/pub/GNOME/sources/%{name}/3.10/%{name}-%{version}.tar.xz
11URL: http://www.gnome.org
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13Requires: gtk3 >= %{gtk3_version}
14BuildRequires: gtk3-devel >= %{gtk3_version}
15BuildRequires: dbus-devel >= 1.0
16BuildRequires: gettext
17BuildRequires: libcap-ng-devel
18BuildRequires: libgcrypt-devel
19BuildRequires: libtasn1-devel
20BuildRequires: openssl-devel
21BuildRequires: gcr-devel
22BuildRequires: pam-devel
23BuildRequires: p11-kit-devel
24BuildRequires: libxslt
25BuildRequires: docbook-style-xsl
26BuildRequires: autoconf, automake, libtool
27BuildRequires: intltool
28BuildRequires: perl(XML::Parser)
29
30Patch2: %{name}-2.31.91-configure-vine.patch
31
32Vendor: Project Vine
33Distribution: Vine Linux
34
35%description
36gnome-keyring manages passwords and other types of secrets
37for the user, storing them encrypted with a main password.
38Applications can use the gnome-keyring library to integrate
39with the keyring.
40
41%package pam
42Summary: A pam module for unlocking keyrings at login time
43License: LGPLv2+
44Group: System Environment/Libraries
45Requires: %{name} = %{version}-%{release}
46# for /lib/security
47Requires: pam
48
49%description pam
50The gnome-keyring-pam package contains a pam module that can
51automatically unlock the "login" keyring when the user logs in
52and start the keyring daemon.
53
54
55%prep
56%setup -q -n gnome-keyring-%{version}
57%patch2 -p1 -b .vine
58
59%build
60%configure \
61        --with-gtk=3.0 \
62        --disable-gtk-doc \
63        --disable-update-mime \
64        --enable-pam \
65        --with-pam-dir=/%{_lib}/security
66
67make %{?_smp_mflags}
68
69%install
70rm -rf $RPM_BUILD_ROOT
71make install install-pam DESTDIR=$RPM_BUILD_ROOT
72
73rm -f $RPM_BUILD_ROOT%{_libdir}/pam_gnome_keyring.so
74
75%find_lang %{name}
76
77rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
78rm -f $RPM_BUILD_ROOT%{_libdir}/gnome-keyring/*.la
79rm -f $RPM_BUILD_ROOT%{_libdir}/gnome-keyring/*/*.la
80rm -f $RPM_BUILD_ROOT%{_libdir}/pkcs11/*.la
81rm -f $RPM_BUILD_ROOT/%{_lib}/security/*.la
82
83%clean
84rm -rf $RPM_BUILD_ROOT
85
86%post
87/sbin/ldconfig
88if [ -x /usr/bin/gtk-update-icon-cache ]; then
89  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
90fi
91update-mime-database %{_datadir}/mime > /dev/null || :
92
93
94%postun
95/sbin/ldconfig
96if [ $1 -eq 0 ]; then
97        glib-compile-schemas %{_datadir}/glib-2.0/schemas
98        gtk-update-icon-cache -q %{_datadir}/icons/hicolor
99        update-mime-database %{_datadir}/mime > /dev/null || :
100fi
101
102%posttrans
103glib-compile-schemas %{_datadir}/glib-2.0/schemas
104
105
106%files -f %{name}.lang
107%defattr(-, root, root)
108%doc AUTHORS NEWS README COPYING COPYING.LIB
109%{_sysconfdir}/xdg/autostart/gnome-keyring-pkcs11.desktop
110%{_sysconfdir}/xdg/autostart/gnome-keyring-secrets.desktop
111%{_sysconfdir}/xdg/autostart/gnome-keyring-ssh.desktop
112%{_sysconfdir}/xdg/autostart/gnome-keyring-gpg.desktop
113%{_datadir}/p11-kit/modules/gnome-keyring.module
114%{_bindir}/*
115%dir %{_libdir}/gnome-keyring
116%{_libdir}/gnome-keyring/devel/*.so
117%{_libdir}/pkcs11/gnome-keyring-pkcs11.so
118%{_datadir}/dbus-1/services/*
119%{_datadir}/GConf/gsettings/*
120%{_datadir}/glib-2.0/schemas/*
121%{_mandir}/man1/gnome-keyring-daemon.1.gz
122
123%files pam
124%defattr(-, root, root)
125/%{_lib}/security/*.so
126
127
128%changelog
129* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
130- new upstream release
131- add BuildRequires: p11-kit-devel, libxslt, docbook-style-xsl
132
133* Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
134- new upstream release
135
136* Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
137- new upstream release
138
139* Sun Mar 03 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
140- new upstream release
141
142* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
143- new upstream release
144
145* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
146- new upstream release
147
148* Fri Sep 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
149- new upstream release
150
151* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
152- new upstream release
153- remove BuildRequires: p11-kit-devel
154- add BuildRequires: gcr-devel
155- remove devel sub package
156- remove compat32 sub packages
157
158* Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
159- new upstream release
160
161* Thu Oct 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
162- new upstream release
163
164* Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
165- new upstream release
166
167* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
168- new upstream release
169
170* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
171- new upstream release
172- remove Patch3
173
174* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
175- new upstream release
176- change BuildRequires: gtk3-devel instead of gtk2-devel
177- add BuildRequires: openssl-devel, p11-kit-devel, libcap-ng-devel
178- add Patch3 (gnome-keyring-3.1.4-git20110729.patch)
179
180* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
181- new upstream release
182
183* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
184- new upstream release
185- add configure option (--enable-pam)
186- remove configure option (--disable-schemas-install)
187- add Patch2 (%{name}-2.31.91-configure-vine.patch)
188
189* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.3-2
190- build with rpm-4.8.1-1 for pkg-config file
191
192* Sat Jun 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.3-1
193- new upstream release
194
195* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
196- new upstream release
197
198* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
199- new upstream release
200- remove BuildRequires: hal-devel
201
202* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
203- new upstream release
204- add BuildRequires: GConf2-devel
205
206* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
207- new upstream release
208
209* Sun Jul 12 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.26.3-2
210- added compat32 package for x86_64 arch support
211
212* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
213- new upstream release
214
215* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
216- new upstream release
217
218* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
219- new upstream release
220
221* Tue Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
222- new upstream release
223
224* Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
225- new upstream release
226
227* Sat May 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1
228- new upstream release
229
230* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
231- new upstream release
232
233* Sat Mar 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
234- new upstream release
235- added BuildRequires: libtasn1-devel
236
237* Tue Dec 11 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.2-0vl1
238- new upstream release
239- added a pam subpackage
240
241* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.1-0vl1
242- new upstream release
243
244* Tue May 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.9-0vl1
245- new upstream release
246
247* Mon Mar 06 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.8-0vl1
248- new upstream release
249
250* Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.5-0vl1
251- new upstream release
252
253* Wed Sep 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.4-0vl1
254- new upstream release
255
256* Fri Mar 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.2-0vl1
257- new upstream version
258
259* Sun Dec 12 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.0-0vl1
260- new upstream release
261
262* Sun Aug 01 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.2-0vl1
263- initial build for Vine Linux based on fedora's spec file.
264
265* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
266- rebuilt
267
268* Thu Apr  1 2004 Alex Larsson <alexl@redhat.com> 0.2.0-1
269- update to 0.2.0
270
271* Wed Mar 10 2004 Alexander Larsson <alexl@redhat.com> 0.1.90-1
272- update to 0.1.90
273
274* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
275- rebuilt
276
277* Tue Feb 24 2004 Alexander Larsson <alexl@redhat.com> 0.1.4-1
278- update to 0.1.4
279
280* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
281- rebuilt
282
283* Fri Jan 30 2004 Alexander Larsson <alexl@redhat.com> 0.1.3-1
284- update to 0.1.3
285
286* Mon Jan 26 2004 Bill Nottingham <notting@redhat.com>
287- tweak summary
288
289* Mon Jan 26 2004 Alexander Larsson <alexl@redhat.com> 0.1.2-2
290- devel package only needs glib2-devel, not gtk2-devel
291
292* Fri Jan 23 2004 Alexander Larsson <alexl@redhat.com> 0.1.2-1
293- First version
Note: See TracBrowser for help on using the repository browser.