source: projects/specs/trunk/g/gnome-keyring/gnome-keyring-vl.spec @ 7681

Revision 7681, 8.0 KB checked in by Takemikaduchi, 11 years ago (diff)

GNOME 3.8.2

Line 
1%define gtk3_version 3.8.0
2
3Summary: A framework for managing user passwords and other secrets
4Summary(ja): ユーザのパスワードや秘匿情報を管理するためのフレームワーク
5Name: gnome-keyring
6Version: 3.8.2
7Release: 1%{?_dist_release}
8License: GPL/LGPL
9Group: System Environment/Libraries
10Source: http://ftp.gnome.org/pub/GNOME/sources/%{name}/3.8/%{name}-%{version}.tar.xz
11URL: http://www.gnome.org
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13Requires: gtk3 >= %{gtk3_version}
14BuildRequires: gtk3-devel >= %{gtk3_version}
15BuildRequires: dbus-devel >= 1.0
16BuildRequires: gettext
17BuildRequires: libcap-ng-devel
18BuildRequires: libgcrypt-devel
19BuildRequires: libtasn1-devel
20BuildRequires: openssl-devel
21BuildRequires: gcr-devel
22BuildRequires: pam-devel
23BuildRequires: autoconf, automake, libtool
24BuildRequires: intltool
25BuildRequires: perl(XML::Parser)
26
27Patch2: %{name}-2.31.91-configure-vine.patch
28
29Vendor: Project Vine
30Distribution: Vine Linux
31
32%description
33gnome-keyring manages passwords and other types of secrets
34for the user, storing them encrypted with a main password.
35Applications can use the gnome-keyring library to integrate
36with the keyring.
37
38%package pam
39Summary: A pam module for unlocking keyrings at login time
40License: LGPLv2+
41Group: System Environment/Libraries
42Requires: %{name} = %{version}-%{release}
43# for /lib/security
44Requires: pam
45
46%description pam
47The gnome-keyring-pam package contains a pam module that can
48automatically unlock the "login" keyring when the user logs in
49and start the keyring daemon.
50
51
52%prep
53%setup -q -n gnome-keyring-%{version}
54%patch2 -p1 -b .vine
55
56%build
57%configure \
58        --with-gtk=3.0 \
59        --disable-gtk-doc \
60        --disable-update-mime \
61        --enable-pam \
62        --with-pam-dir=/%{_lib}/security
63
64make %{?_smp_mflags}
65
66%install
67rm -rf $RPM_BUILD_ROOT
68make install install-pam DESTDIR=$RPM_BUILD_ROOT
69
70rm -f $RPM_BUILD_ROOT%{_libdir}/pam_gnome_keyring.so
71
72%find_lang %{name}
73
74rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
75rm -f $RPM_BUILD_ROOT%{_libdir}/gnome-keyring/*.la
76rm -f $RPM_BUILD_ROOT%{_libdir}/gnome-keyring/*/*.la
77rm -f $RPM_BUILD_ROOT%{_libdir}/pkcs11/*.la
78rm -f $RPM_BUILD_ROOT/%{_lib}/security/*.la
79
80%clean
81rm -rf $RPM_BUILD_ROOT
82
83%post
84/sbin/ldconfig
85if [ -x /usr/bin/gtk-update-icon-cache ]; then
86  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
87fi
88update-mime-database %{_datadir}/mime > /dev/null || :
89
90
91%postun
92/sbin/ldconfig
93if [ $1 -eq 0 ]; then
94        glib-compile-schemas %{_datadir}/glib-2.0/schemas
95        gtk-update-icon-cache -q %{_datadir}/icons/hicolor
96        update-mime-database %{_datadir}/mime > /dev/null || :
97fi
98
99%posttrans
100glib-compile-schemas %{_datadir}/glib-2.0/schemas
101
102
103%files -f %{name}.lang
104%defattr(-, root, root)
105%doc AUTHORS NEWS README COPYING COPYING.LIB
106%{_sysconfdir}/xdg/autostart/gnome-keyring-pkcs11.desktop
107%{_sysconfdir}/xdg/autostart/gnome-keyring-secrets.desktop
108%{_sysconfdir}/xdg/autostart/gnome-keyring-ssh.desktop
109%{_sysconfdir}/xdg/autostart/gnome-keyring-gpg.desktop
110%{_datadir}/p11-kit/modules/gnome-keyring.module
111%{_bindir}/*
112%dir %{_libdir}/gnome-keyring
113%{_libdir}/gnome-keyring/devel/*.so
114%{_libdir}/pkcs11/gnome-keyring-pkcs11.so
115%{_datadir}/dbus-1/services/*
116%{_datadir}/GConf/gsettings/*
117%{_datadir}/glib-2.0/schemas/*
118
119%files pam
120%defattr(-, root, root)
121/%{_lib}/security/*.so
122
123
124%changelog
125* Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
126- new upstream release
127
128* Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
129- new upstream release
130
131* Sun Mar 03 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
132- new upstream release
133
134* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
135- new upstream release
136
137* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
138- new upstream release
139
140* Fri Sep 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
141- new upstream release
142
143* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
144- new upstream release
145- remove BuildRequires: p11-kit-devel
146- add BuildRequires: gcr-devel
147- remove devel sub package
148- remove compat32 sub packages
149
150* Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
151- new upstream release
152
153* Thu Oct 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
154- new upstream release
155
156* Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
157- new upstream release
158
159* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
160- new upstream release
161
162* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
163- new upstream release
164- remove Patch3
165
166* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
167- new upstream release
168- change BuildRequires: gtk3-devel instead of gtk2-devel
169- add BuildRequires: openssl-devel, p11-kit-devel, libcap-ng-devel
170- add Patch3 (gnome-keyring-3.1.4-git20110729.patch)
171
172* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
173- new upstream release
174
175* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
176- new upstream release
177- add configure option (--enable-pam)
178- remove configure option (--disable-schemas-install)
179- add Patch2 (%{name}-2.31.91-configure-vine.patch)
180
181* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.3-2
182- build with rpm-4.8.1-1 for pkg-config file
183
184* Sat Jun 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.3-1
185- new upstream release
186
187* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
188- new upstream release
189
190* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
191- new upstream release
192- remove BuildRequires: hal-devel
193
194* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
195- new upstream release
196- add BuildRequires: GConf2-devel
197
198* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
199- new upstream release
200
201* Sun Jul 12 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.26.3-2
202- added compat32 package for x86_64 arch support
203
204* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
205- new upstream release
206
207* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
208- new upstream release
209
210* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
211- new upstream release
212
213* Tue Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
214- new upstream release
215
216* Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
217- new upstream release
218
219* Sat May 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1
220- new upstream release
221
222* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
223- new upstream release
224
225* Sat Mar 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
226- new upstream release
227- added BuildRequires: libtasn1-devel
228
229* Tue Dec 11 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.2-0vl1
230- new upstream release
231- added a pam subpackage
232
233* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.1-0vl1
234- new upstream release
235
236* Tue May 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.9-0vl1
237- new upstream release
238
239* Mon Mar 06 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.8-0vl1
240- new upstream release
241
242* Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.5-0vl1
243- new upstream release
244
245* Wed Sep 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.4-0vl1
246- new upstream release
247
248* Fri Mar 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.2-0vl1
249- new upstream version
250
251* Sun Dec 12 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.0-0vl1
252- new upstream release
253
254* Sun Aug 01 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.2-0vl1
255- initial build for Vine Linux based on fedora's spec file.
256
257* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
258- rebuilt
259
260* Thu Apr  1 2004 Alex Larsson <alexl@redhat.com> 0.2.0-1
261- update to 0.2.0
262
263* Wed Mar 10 2004 Alexander Larsson <alexl@redhat.com> 0.1.90-1
264- update to 0.1.90
265
266* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
267- rebuilt
268
269* Tue Feb 24 2004 Alexander Larsson <alexl@redhat.com> 0.1.4-1
270- update to 0.1.4
271
272* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
273- rebuilt
274
275* Fri Jan 30 2004 Alexander Larsson <alexl@redhat.com> 0.1.3-1
276- update to 0.1.3
277
278* Mon Jan 26 2004 Bill Nottingham <notting@redhat.com>
279- tweak summary
280
281* Mon Jan 26 2004 Alexander Larsson <alexl@redhat.com> 0.1.2-2
282- devel package only needs glib2-devel, not gtk2-devel
283
284* Fri Jan 23 2004 Alexander Larsson <alexl@redhat.com> 0.1.2-1
285- First version
Note: See TracBrowser for help on using the repository browser.