source: projects/specs/trunk/g/gnome-keyring/gnome-keyring-vl.spec @ 4704

Revision 4704, 9.8 KB checked in by Takemikaduchi, 13 years ago (diff)

GNOME-3.2 beta 1 (3.1.90)

Line 
1%define gtk3_version 3.1.10
2%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
3
4Summary: A framework for managing user passwords and other secrets
5Summary(ja): ユーザのパスワードや秘匿情報を管理するためのフレームワーク
6Name: gnome-keyring
7Version: 3.1.90
8Release: 1%{?_dist_release}
9License: GPL/LGPL
10Group: System Environment/Libraries
11Source: gnome-keyring-%{version}.tar.xz
12URL: http://www.gnome.org
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14Requires: gtk3 >= %{gtk3_version}
15Requires(post,pre,preun): GConf2
16BuildRequires: gtk3-devel >= %{gtk3_version}
17BuildRequires: GConf2-devel >= 1.0
18BuildRequires: dbus-devel >= 1.0
19BuildRequires: gettext
20BuildRequires: libcap-ng-devel
21BuildRequires: libgcrypt-devel
22BuildRequires: libtasn1-devel
23BuildRequires: openssl-devel
24BuildRequires: p11-kit-devel
25BuildRequires: pam-devel
26BuildRequires: autoconf, automake, libtool
27BuildRequires: intltool
28BuildRequires: perl(XML::Parser)
29
30Patch2: %{name}-2.31.91-configure-vine.patch
31
32Vendor: Project Vine
33Distribution: Vine Linux
34
35%description
36gnome-keyring manages passwords and other types of secrets
37for the user, storing them encrypted with a main password.
38Applications can use the gnome-keyring library to integrate
39with the keyring.
40
41%package devel
42Summary: The files needed for gnome-keyring application development.
43Group: Development/Libraries
44Requires: %{name} = %{version}-%{release}
45Requires: glib2-devel
46
47%description devel
48The gnome-keyring-devel package contains the libraries and
49include files that you can use to develop applications that
50use gnome-keyring.
51
52%package pam
53Summary: A pam module for unlocking keyrings at login time
54License: LGPLv2+
55Group: System Environment/Libraries
56Requires: %{name} = %{version}-%{release}
57# for /lib/security
58Requires: pam
59
60%description pam
61The gnome-keyring-pam package contains a pam module that can
62automatically unlock the "login" keyring when the user logs in
63and start the keyring daemon.
64
65# compat32
66%package -n compat32-%{name}
67Summary: A framework for managing user passwords and other secrets
68Summary(ja): ユーザのパスワードや秘匿情報を管理するためのフレームワーク
69Group: System Environment/Libraries
70Requires: %{name} = %{version}-%{release}
71
72%description -n compat32-%{name}
73gnome-keyring manages passwords and other types of secrets
74for the user, storing them encrypted with a main password.
75Applications can use the gnome-keyring library to integrate
76with the keyring.
77
78%package -n compat32-%{name}-devel
79Summary: The files needed for gnome-keyring application development.
80Group: Development/Libraries
81Requires: %{name}-devel = %{version}-%{release}
82Requires: compat32-%{name} = %{version}-%{release}
83Requires: compat32-glib2-devel
84
85%description -n compat32-%{name}-devel
86The gnome-keyring-devel package contains the libraries and
87include files that you can use to develop applications that
88use gnome-keyring.
89
90%package -n compat32-%{name}-pam
91Summary: A pam module for unlocking keyrings at login time
92License: LGPLv2+
93Group: System Environment/Libraries
94Requires: %{name}-pam = %{version}-%{release}
95Requires: compat32-%{name} = %{version}-%{release}
96# for /lib/security
97Requires: compat32-pam
98
99%description -n compat32-%{name}-pam
100The gnome-keyring-pam package contains a pam module that can
101automatically unlock the "login" keyring when the user logs in
102and start the keyring daemon.
103
104%prep
105%setup -q -n gnome-keyring-%{version}
106%patch2 -p1 -b .vine
107
108%build
109%configure \
110        --with-gtk=3.0 \
111        --disable-gtk-doc \
112        --disable-update-mime \
113        --enable-pam \
114        --with-pam-dir=/%{_lib}/security \
115        --with-root-certs=%{_datadir}/ssl/certs
116
117make %{?_smp_mflags}
118
119%install
120rm -rf $RPM_BUILD_ROOT
121make install install-pam DESTDIR=$RPM_BUILD_ROOT
122
123rm -f $RPM_BUILD_ROOT%{_libdir}/pam_gnome_keyring.so
124
125%find_lang %{name}
126
127rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
128rm -f $RPM_BUILD_ROOT%{_libdir}/gnome-keyring/*.la
129rm -f $RPM_BUILD_ROOT%{_libdir}/gnome-keyring/*/*.la
130rm -f $RPM_BUILD_ROOT%{_libdir}/pkcs11/*.la
131rm -f $RPM_BUILD_ROOT/%{_lib}/security/*.la
132
133%clean
134rm -rf $RPM_BUILD_ROOT
135
136%post
137/sbin/ldconfig
138if [ -x /usr/bin/gtk-update-icon-cache ]; then
139  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
140fi
141update-mime-database %{_datadir}/mime > /dev/null || :
142
143
144%postun
145/sbin/ldconfig
146if [ $1 -eq 0 ]; then
147        glib-compile-schemas %{_datadir}/glib-2.0/schemas
148        gtk-update-icon-cache -q %{_datadir}/icons/hicolor
149        update-mime-database %{_datadir}/mime > /dev/null || :
150fi
151
152%posttrans
153glib-compile-schemas %{_datadir}/glib-2.0/schemas
154
155%post -n compat32-%{name} -p /sbin/ldconfig
156
157%postun -n compat32-%{name} -p /sbin/ldconfig
158
159%files -f %{name}.lang
160%defattr(-, root, root)
161%doc AUTHORS NEWS README COPYING COPYING.LIB
162%{_sysconfdir}/pkcs11/modules/gnome-keyring-module
163%{_sysconfdir}/xdg/autostart/gnome-keyring-pkcs11.desktop
164%{_sysconfdir}/xdg/autostart/gnome-keyring-secrets.desktop
165%{_sysconfdir}/xdg/autostart/gnome-keyring-ssh.desktop
166%{_sysconfdir}/xdg/autostart/gnome-keyring-gpg.desktop
167%{_bindir}/*
168%{_libdir}/lib*.so.*
169%dir %{_libdir}/gnome-keyring
170%{_libdir}/gnome-keyring/devel/*.so
171%{_libdir}/pkcs11/gnome-keyring-pkcs11.so
172%{_libexecdir}/*
173%{_datadir}/applications/gcr-viewer.desktop
174%{_datadir}/applications/gnome-keyring-prompt.desktop
175%{_datadir}/dbus-1/services/*
176%{_datadir}/gnome-keyring-3
177%dir %{_datadir}/gcr-3
178%{_datadir}/gcr-3/ui/*.ui
179%{_datadir}/GConf/gsettings/*
180%{_datadir}/glib-2.0/schemas/*
181%{_datadir}/icons/hicolor/*/apps/*.png
182%{_datadir}/mime/packages/gcr-crypto-types.xml
183
184%files devel
185%defattr(-, root, root)
186%{_libdir}/lib*.so
187%{_libdir}/pkgconfig/*
188%{_includedir}/*
189## %{_datadir}/gtk-doc/html/gnome-keyring
190%{_datadir}/gtk-doc/html/gcr-3
191%{_datadir}/gtk-doc/html/gck
192
193%files pam
194%defattr(-, root, root)
195/%{_lib}/security/*.so
196
197# compat32
198%if %{build_compat32}
199%files -n compat32-%{name}
200%defattr(-, root, root)
201%{_libdir}/lib*.so.*
202%dir %{_libdir}/gnome-keyring
203%{_libdir}/gnome-keyring/devel/*.so
204
205%files -n compat32-%{name}-devel
206%defattr(-, root, root)
207%{_libdir}/lib*.so
208%{_libdir}/pkgconfig/*
209
210%files -n compat32-%{name}-pam
211%defattr(-, root, root)
212/%{_lib}/security/*.so
213%endif
214
215%changelog
216* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
217- new upstream release
218- remove Patch3
219
220* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
221- new upstream release
222- change BuildRequires: gtk3-devel instead of gtk2-devel
223- add BuildRequires: openssl-devel, p11-kit-devel, libcap-ng-devel
224- add Patch3 (gnome-keyring-3.1.4-git20110729.patch)
225
226* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
227- new upstream release
228
229* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
230- new upstream release
231- add configure option (--enable-pam)
232- remove configure option (--disable-schemas-install)
233- add Patch2 (%{name}-2.31.91-configure-vine.patch)
234
235* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.3-2
236- build with rpm-4.8.1-1 for pkg-config file
237
238* Sat Jun 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.3-1
239- new upstream release
240
241* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
242- new upstream release
243
244* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
245- new upstream release
246- remove BuildRequires: hal-devel
247
248* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
249- new upstream release
250- add BuildRequires: GConf2-devel
251
252* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
253- new upstream release
254
255* Sun Jul 12 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.26.3-2
256- added compat32 package for x86_64 arch support
257
258* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
259- new upstream release
260
261* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
262- new upstream release
263
264* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
265- new upstream release
266
267* Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
268- new upstream release
269
270* Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
271- new upstream release
272
273* Sat May 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1
274- new upstream release
275
276* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
277- new upstream release
278
279* Sat Mar 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
280- new upstream release
281- added BuildRequires: libtasn1-devel
282
283* Tue Dec 11 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.2-0vl1
284- new upstream release
285- added a pam subpackage
286
287* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.1-0vl1
288- new upstream release
289
290* Tue May 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.9-0vl1
291- new upstream release
292
293* Mon Mar 06 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.8-0vl1
294- new upstream release
295
296* Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.5-0vl1
297- new upstream release
298
299* Wed Sep 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.4-0vl1
300- new upstream release
301
302* Fri Mar 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.2-0vl1
303- new upstream version
304
305* Sun Dec 12 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.0-0vl1
306- new upstream release
307
308* Sun Aug 01 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.2-0vl1
309- initial build for Vine Linux based on fedora's spec file.
310
311* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
312- rebuilt
313
314* Thu Apr  1 2004 Alex Larsson <alexl@redhat.com> 0.2.0-1
315- update to 0.2.0
316
317* Wed Mar 10 2004 Alexander Larsson <alexl@redhat.com> 0.1.90-1
318- update to 0.1.90
319
320* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
321- rebuilt
322
323* Tue Feb 24 2004 Alexander Larsson <alexl@redhat.com> 0.1.4-1
324- update to 0.1.4
325
326* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
327- rebuilt
328
329* Fri Jan 30 2004 Alexander Larsson <alexl@redhat.com> 0.1.3-1
330- update to 0.1.3
331
332* Mon Jan 26 2004 Bill Nottingham <notting@redhat.com>
333- tweak summary
334
335* Mon Jan 26 2004 Alexander Larsson <alexl@redhat.com> 0.1.2-2
336- devel package only needs glib2-devel, not gtk2-devel
337
338* Fri Jan 23 2004 Alexander Larsson <alexl@redhat.com> 0.1.2-1
339- First version
Note: See TracBrowser for help on using the repository browser.