source: projects/specs/trunk/g/gnome-keyring/gnome-keyring-vl.spec @ 4616

Revision 4616, 9.5 KB checked in by Takemikaduchi, 13 years ago (diff)

X.Org, compiz, GNOME3, etc...

Line 
1%define gtk3_version 3.1.10
2%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
3
4Summary: A framework for managing user passwords and other secrets
5Summary(ja): ユーザのパスワードや秘匿情報を管理するためのフレームワーク
6Name: gnome-keyring
7Version: 3.1.4
8Release: 1%{?_dist_release}
9License: GPL/LGPL
10Group: System Environment/Libraries
11Source: gnome-keyring-%{version}.tar.xz
12URL: http://www.gnome.org
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14Requires: gtk3 >= %{gtk3_version}
15Requires(post,pre,preun): GConf2
16BuildRequires: gtk3-devel >= %{gtk3_version}
17BuildRequires: GConf2-devel >= 1.0
18BuildRequires: dbus-devel >= 1.0
19BuildRequires: gettext
20BuildRequires: libcap-ng-devel
21BuildRequires: libgcrypt-devel
22BuildRequires: libtasn1-devel
23BuildRequires: openssl-devel
24BuildRequires: p11-kit-devel
25BuildRequires: pam-devel
26BuildRequires: autoconf, automake, libtool
27BuildRequires: intltool
28BuildRequires: perl(XML::Parser)
29
30Patch2: %{name}-2.31.91-configure-vine.patch
31Patch3: gnome-keyring-3.1.4-git20110729.patch
32
33Vendor: Project Vine
34Distribution: Vine Linux
35
36%description
37gnome-keyring manages passwords and other types of secrets
38for the user, storing them encrypted with a main password.
39Applications can use the gnome-keyring library to integrate
40with the keyring.
41
42%package devel
43Summary: The files needed for gnome-keyring application development.
44Group: Development/Libraries
45Requires: %{name} = %{version}-%{release}
46Requires: glib2-devel
47
48%description devel
49The gnome-keyring-devel package contains the libraries and
50include files that you can use to develop applications that
51use gnome-keyring.
52
53%package pam
54Summary: A pam module for unlocking keyrings at login time
55License: LGPLv2+
56Group: System Environment/Libraries
57Requires: %{name} = %{version}-%{release}
58# for /lib/security
59Requires: pam
60
61%description pam
62The gnome-keyring-pam package contains a pam module that can
63automatically unlock the "login" keyring when the user logs in
64and start the keyring daemon.
65
66# compat32
67%package -n compat32-%{name}
68Summary: A framework for managing user passwords and other secrets
69Summary(ja): ユーザのパスワードや秘匿情報を管理するためのフレームワーク
70Group: System Environment/Libraries
71Requires: %{name} = %{version}-%{release}
72
73%description -n compat32-%{name}
74gnome-keyring manages passwords and other types of secrets
75for the user, storing them encrypted with a main password.
76Applications can use the gnome-keyring library to integrate
77with the keyring.
78
79%package -n compat32-%{name}-devel
80Summary: The files needed for gnome-keyring application development.
81Group: Development/Libraries
82Requires: %{name}-devel = %{version}-%{release}
83Requires: compat32-%{name} = %{version}-%{release}
84Requires: compat32-glib2-devel
85
86%description -n compat32-%{name}-devel
87The gnome-keyring-devel package contains the libraries and
88include files that you can use to develop applications that
89use gnome-keyring.
90
91%package -n compat32-%{name}-pam
92Summary: A pam module for unlocking keyrings at login time
93License: LGPLv2+
94Group: System Environment/Libraries
95Requires: %{name}-pam = %{version}-%{release}
96Requires: compat32-%{name} = %{version}-%{release}
97# for /lib/security
98Requires: compat32-pam
99
100%description -n compat32-%{name}-pam
101The gnome-keyring-pam package contains a pam module that can
102automatically unlock the "login" keyring when the user logs in
103and start the keyring daemon.
104
105%prep
106%setup -q -n gnome-keyring-%{version}
107%patch2 -p1 -b .vine
108%patch3 -p1 -b .git
109
110%build
111%configure \
112        --with-gtk=3.0 \
113        --disable-gtk-doc \
114        --enable-pam \
115        --with-pam-dir=/%{_lib}/security \
116        --with-root-certs=%{_datadir}/ssl/certs
117make %{?_smp_mflags}
118
119%install
120rm -rf $RPM_BUILD_ROOT
121make install install-pam DESTDIR=$RPM_BUILD_ROOT
122
123rm -f $RPM_BUILD_ROOT%{_libdir}/pam_gnome_keyring.so
124
125%find_lang %{name}
126
127rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
128rm -f $RPM_BUILD_ROOT%{_libdir}/gnome-keyring/*.la
129rm -f $RPM_BUILD_ROOT%{_libdir}/gnome-keyring/*/*.la
130rm -f $RPM_BUILD_ROOT%{_libdir}/pkcs11/*.la
131rm -f $RPM_BUILD_ROOT/%{_lib}/security/*.la
132
133%clean
134rm -rf $RPM_BUILD_ROOT
135
136%post
137/sbin/ldconfig
138if [ -x /usr/bin/gtk-update-icon-cache ]; then
139  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
140fi
141
142
143%postun
144/sbin/ldconfig
145if [ $1 -eq 0 ]; then
146        glib-compile-schemas %{_datadir}/glib-2.0/schemas
147        gtk-update-icon-cache -q %{_datadir}/icons/hicolor
148fi
149
150%posttrans
151glib-compile-schemas %{_datadir}/glib-2.0/schemas
152
153%post -n compat32-%{name} -p /sbin/ldconfig
154
155%postun -n compat32-%{name} -p /sbin/ldconfig
156
157%files -f %{name}.lang
158%defattr(-, root, root)
159%doc AUTHORS NEWS README COPYING COPYING.LIB
160%{_sysconfdir}/pkcs11/modules/gnome-keyring-module
161%{_sysconfdir}/xdg/autostart/gnome-keyring-pkcs11.desktop
162%{_sysconfdir}/xdg/autostart/gnome-keyring-secrets.desktop
163%{_sysconfdir}/xdg/autostart/gnome-keyring-ssh.desktop
164%{_sysconfdir}/xdg/autostart/gnome-keyring-gpg.desktop
165%{_bindir}/*
166%{_libdir}/lib*.so.*
167%dir %{_libdir}/gnome-keyring
168%{_libdir}/gnome-keyring/devel/*.so
169%{_libdir}/pkcs11/gnome-keyring-pkcs11.so
170%{_libexecdir}/*
171%{_datadir}/applications/gnome-keyring-prompt.desktop
172%{_datadir}/dbus-1/services/*
173%{_datadir}/gnome-keyring-3
174%dir %{_datadir}/gcr-3
175%{_datadir}/gcr-3/ui/*.ui
176%{_datadir}/GConf/gsettings/*
177%{_datadir}/glib-2.0/schemas/*
178%{_datadir}/icons/hicolor/*/apps/*.png
179
180%files devel
181%defattr(-, root, root)
182%{_libdir}/lib*.so
183%{_libdir}/pkgconfig/*
184%{_includedir}/*
185## %{_datadir}/gtk-doc/html/gnome-keyring
186%{_datadir}/gtk-doc/html/gcr-3
187%{_datadir}/gtk-doc/html/gck
188
189%files pam
190%defattr(-, root, root)
191/%{_lib}/security/*.so
192
193# compat32
194%if %{build_compat32}
195%files -n compat32-%{name}
196%defattr(-, root, root)
197%{_libdir}/lib*.so.*
198%dir %{_libdir}/gnome-keyring
199%{_libdir}/gnome-keyring/devel/*.so
200
201%files -n compat32-%{name}-devel
202%defattr(-, root, root)
203%{_libdir}/lib*.so
204%{_libdir}/pkgconfig/*
205
206%files -n compat32-%{name}-pam
207%defattr(-, root, root)
208/%{_lib}/security/*.so
209%endif
210
211%changelog
212* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
213- new upstream release
214- change BuildRequires: gtk3-devel instead of gtk2-devel
215- add BuildRequires: openssl-devel, p11-kit-devel, libcap-ng-devel
216- add Patch3 (gnome-keyring-3.1.4-git20110729.patch)
217
218* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
219- new upstream release
220
221* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
222- new upstream release
223- add configure option (--enable-pam)
224- remove configure option (--disable-schemas-install)
225- add Patch2 (%{name}-2.31.91-configure-vine.patch)
226
227* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.3-2
228- build with rpm-4.8.1-1 for pkg-config file
229
230* Sat Jun 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.3-1
231- new upstream release
232
233* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
234- new upstream release
235
236* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
237- new upstream release
238- remove BuildRequires: hal-devel
239
240* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
241- new upstream release
242- add BuildRequires: GConf2-devel
243
244* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
245- new upstream release
246
247* Sun Jul 12 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.26.3-2
248- added compat32 package for x86_64 arch support
249
250* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
251- new upstream release
252
253* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
254- new upstream release
255
256* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
257- new upstream release
258
259* Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
260- new upstream release
261
262* Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
263- new upstream release
264
265* Sat May 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1
266- new upstream release
267
268* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
269- new upstream release
270
271* Sat Mar 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
272- new upstream release
273- added BuildRequires: libtasn1-devel
274
275* Tue Dec 11 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.2-0vl1
276- new upstream release
277- added a pam subpackage
278
279* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.1-0vl1
280- new upstream release
281
282* Tue May 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.9-0vl1
283- new upstream release
284
285* Mon Mar 06 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.8-0vl1
286- new upstream release
287
288* Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.5-0vl1
289- new upstream release
290
291* Wed Sep 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.4-0vl1
292- new upstream release
293
294* Fri Mar 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.2-0vl1
295- new upstream version
296
297* Sun Dec 12 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.0-0vl1
298- new upstream release
299
300* Sun Aug 01 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.2-0vl1
301- initial build for Vine Linux based on fedora's spec file.
302
303* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
304- rebuilt
305
306* Thu Apr  1 2004 Alex Larsson <alexl@redhat.com> 0.2.0-1
307- update to 0.2.0
308
309* Wed Mar 10 2004 Alexander Larsson <alexl@redhat.com> 0.1.90-1
310- update to 0.1.90
311
312* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
313- rebuilt
314
315* Tue Feb 24 2004 Alexander Larsson <alexl@redhat.com> 0.1.4-1
316- update to 0.1.4
317
318* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
319- rebuilt
320
321* Fri Jan 30 2004 Alexander Larsson <alexl@redhat.com> 0.1.3-1
322- update to 0.1.3
323
324* Mon Jan 26 2004 Bill Nottingham <notting@redhat.com>
325- tweak summary
326
327* Mon Jan 26 2004 Alexander Larsson <alexl@redhat.com> 0.1.2-2
328- devel package only needs glib2-devel, not gtk2-devel
329
330* Fri Jan 23 2004 Alexander Larsson <alexl@redhat.com> 0.1.2-1
331- First version
Note: See TracBrowser for help on using the repository browser.