source: projects/specs/trunk/g/gnome-do/gnome-do-vl.spec @ 2202

Revision 2202, 8.7 KB checked in by kazutaka, 14 years ago (diff)

mono-2.8 でコンパイルできるように patch を追加

Line 
1%define mainver         0.8.3
2%define build_vine5     %( [ "%{?_dist_release}" == "vl5" ] && echo 1 || echo 0)
3
4Name:                   gnome-do
5Version:                0.8.3.1
6Release:                4%{?_dist_release}
7Summary:                An intelligent launcher tool for Gnome
8Summary(ja):            Gnome 用の高機能ランチャー
9License:                GPLv3+
10Group:                  Applications/Accessories       
11URL:                    http://do.davebsd.com/
12Source0:                http://edge.launchpad.net/do/0.8/%{mainver}/+download/gnome-do-%{version}.tar.gz
13# https://bugs.launchpad.net/do/+bug/634556
14# https://bugs.launchpad.net/do/+bug/634550
15Patch0:                 gnome-do-0.8.3.1-mono-2.8.patch
16Patch1:                 gnome-do-0.8.3.1-gdk-build-fix.patch
17BuildRoot:              %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
18
19# Various Mono dependencies are not available for ppc64; see bug 241850.
20ExcludeArch:            ppc64
21
22BuildRequires:          mono-devel, mono-addins
23BuildRequires:          desktop-file-utils
24BuildRequires:          ndesk-dbus
25BuildRequires:          ndesk-dbus-glib
26BuildRequires:          gtk-sharp2
27BuildRequires:          notify-sharp-devel
28BuildRequires:          gnome-sharp2, gnome-desktop-sharp2 >= 2.26
29BuildRequires:          gnome-keyring-sharp-devel
30BuildRequires:          gettext
31BuildRequires:          perl-XML-Parser
32BuildRequires:          intltool
33BuildRequires:          gtk2-devel
34BuildRequires:          desktop-file-utils
35BuildRequires:          wnck-sharp
36BuildRequires:          gconf-sharp2
37BuildRequires:          rsvg2-sharp
38
39Requires(pre):          GConf2
40Requires(post):         GConf2
41Requires(preun):        GConf2
42
43Requires:               gnome-keyring-sharp, gnome-desktop-sharp2
44Requires:               pkgconfig
45
46Packager:               kazutaka
47
48%description
49GNOME Do (Do) is an intelligent launcher tool that makes performing
50common tasks on your computer simple and efficient. Do not only
51allows you to search for items in your desktop environment
52(e.g. applications, contacts, bookmarks, files, music), it also
53allows you to specify actions to perform on search results
54(e.g. run, open, email, chat, play).
55
56%description -l ja
57GNOME Do (Do) は高機能なランチャーツールです。 PC を使った一
58般的なタスクをシンプルかつ効率的に実行できるようにします。Do
59はデスクトップ環境の様々なアイテム(例えばアプリケーションや
60連絡先、ブックマーク、ファイル、音楽等)の検索だけでなく、検索
61した結果をどう操作するのか(例えば開く、メールに添付、チャット、
62再生する等)を指定することができます。
63
64%package devel
65Summary:                Development files for GNOME Do
66SUmmary(ja):               GNOME Do の開発用ファイル
67Group:                  Development/Libraries
68Requires:               %{name} = %{version}-%{release}
69Requires:               pkgconfig
70
71%description devel
72Development files for GNOME Do
73
74%description devel -l ja
75GNOME Do の開発用ファイルです。
76
77%prep
78%setup -q
79%if !%{build_vine5}
80%patch0 -p0 -b .mono28-fix
81%patch1 -p1 -b .gdkbuild-fix
82%endif
83
84%build
85%configure
86make %{?_smp_mflags}
87
88
89%install
90rm -rf ${RPM_BUILD_ROOT}
91export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
92make install DESTDIR=${RPM_BUILD_ROOT}
93
94desktop-file-install    \
95        --dir ${RPM_BUILD_ROOT}%{_sysconfdir}/xdg/autostart     \
96        --add-only-show-in=GNOME                                \
97        ${RPM_BUILD_ROOT}%{_datadir}/applications/gnome-do.desktop
98desktop-file-install --delete-original  \
99        --dir ${RPM_BUILD_ROOT}%{_datadir}/applications   \
100        --remove-category Application \
101        ${RPM_BUILD_ROOT}%{_datadir}/applications/%{name}.desktop
102
103
104#own this dir:
105mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/%{name}
106
107%find_lang %{name}
108
109%pre
110if [ "$1" -gt 1 ]; then
111    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
112    gconftool-2 --makefile-uninstall-rule \
113      %{_sysconfdir}/gconf/schemas/%{name}.schemas >/dev/null || :
114fi
115
116%post
117export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
118gconftool-2 --makefile-install-rule \
119  %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null || :
120
121touch --no-create %{_datadir}/icons/hicolor
122if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
123  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
124fi
125
126%preun
127if [ "$1" -eq 0 ]; then
128    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
129    gconftool-2 --makefile-uninstall-rule \
130      %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null || :
131fi
132
133%postun
134touch --no-create %{_datadir}/icons/hicolor
135if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
136  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
137fi
138
139%clean
140rm -rf ${RPM_BUILD_ROOT}
141
142%files -f %{name}.lang
143%defattr(-,root,root,-)
144%doc AUTHORS COPYING COPYRIGHT
145%{_bindir}/gnome-do/
146%{_libdir}/gnome-do/
147%{_datadir}/gnome-do/
148%config(noreplace) %{_sysconfdir}/xdg/autostart/gnome-do.desktop
149%config(noreplace) %{_sysconfdir}/gconf/schemas/*
150%{_datadir}/icons/hicolor/*/apps/gnome-do.*
151%{_datadir}/applications/*
152
153%files devel
154%defattr(-,root,root,-)
155%{_libdir}/pkgconfig/*
156
157%changelog
158* Sat Nov 06 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 0.8.3.1-4
159- add Patch0 & 1 to fix compilation error (Seed only)
160
161* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.3.1-3
162- rebuild with rpm-4.8.1 for pkg-config file
163- add BuildRequires: gconf-sharp2, rsvg2-sharp
164
165* Mon Jul 26 2010 Shu KONNO <owa@bg.wakwak.com> 0.8.3.1-2
166- rebuilt with mono-addins-0.5
167
168* Sun Jan 10 2010 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.8.3.1-1
169- new upstream release
170
171* Fri Jul 10 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.8.2-1
172- new upstream release
173- drop Patch0 (merged in upstream)
174
175* Fri Jun 12 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.8.1.3-3
176- change Group to Applications/Accessories
177
178* Fri Jun 12 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.8.1.3-2
179- add BuildRequires: wnck-sharp
180
181* Thu Jun 11 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.8.1.3-1
182- initial build for Vine Linux based on fedora development
183
184* Fri Apr 10 2009 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.8.1.3-5
185- Fix .desktop issue, install in both autostart and applications
186- Rebuild for new gnome-desktop-sharp
187- Add missing gnome-desktop-sharp requires
188- Fix Ndesk-dbus Requires
189
190* Wed Apr 01 2009 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.8.1.3-3
191- Add patch to fix issue where applications wasn't being indexed
192
193* Tue Mar 17 2009 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.8.1.3-2
194- New upstream release
195
196* Tue Mar 3 2009 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.8.0-4
197- Own _datadir/gnome-do
198* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.0-3
199- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
200
201* Sat Feb  7 2009 Michel Salim <salimma@fedoraproject.org> - 0.8.0-2
202- Rebuild against new mono-addins
203
204* Fri Jan 30 2009 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.8.0-1
205- New upstream release
206
207* Thu Jan 29 2009 Michel Salim <salimma@fedoraproject.org> - 0.6.1.0-3
208- Remove Tomboy dependency (bz #481183)
209- Updated description, from Do
210
211* Mon Oct 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.6.1.0-2
212- rebuild against new gnome-sharp
213
214* Wed Oct 08 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.6.1.0-1
215- New Upstream Release
216
217* Fri Oct 03 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.6.0.1-1
218- New upstream release
219
220* Wed Jun 11 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.6.0.0-1
221- New upstream release
222
223* Wed Jun 11 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.5.0.1-4
224- New upstream release
225- Add gnome-desktop-sharp dependency
226
227* Wed Jun 04 2008 Caol叩n McNamara <caolanm@redhat.com> - 0.4.2.0-2
228- rebuild for dependancies
229
230* Tue Apr 22 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.4.2.0-1
231- New upstream release
232
233* Tue Apr 01 2008 David Nielsen <gnomeuser@gmail.com> - 0.4.0.1-2
234- #439793 - correct URL
235
236* Sat Mar 29 2008 David Nielsen <gnomeuser@gmail.com> - 0.4.0.1-1
237- Bump to 0.4.0.1
238- Hopefully bring an end to the endless dups of 432201
239
240* Thu Feb 21 2008 David Nielsen <david@lovesunix.net> - 0.3.1-2
241- Fix 432201
242
243* Thu Feb 21 2008 David Nielsen <david@lovesunix.net> - 0.3.1-1
244- Bump to 0.3.1
245
246* Wed Feb 06 2008 David Nielsen <david@lovesunix.net> - 0.3.0.1-5
247- #431589 - Force runtime dependency on ndesk-dbus(-glib)
248
249* Mon Feb 04 2008 David Nielsen <david@lovesunix.net> - 0.3.0.1-4
250- #431462 - Correctly pull in Tomboy runtime dependency
251
252* Fri Jan 25 2008 David Nielsen <david@lovesunix.net> - 0.3.0.1-3
253- autostart gnome-do in quiet mode with the user session
254- to invoke gnome-do use super+space
255
256* Tue Jan 22 2008 David Nielsen <david@lovesunix.net> - 0.3.0.1-2
257- Fix BuildRequires
258
259* Tue Jan 22 2008 David Nielsen <david@lovesunix.net> - 0.3.0.1-1
260- bump to 0.3.0.1
261- update patches
262
263* Sat Nov 17 2007 David Nielsen <david@lovesunix.net> - 0.0.2-2
264- updated libdir patch
265- cleaned up desktop-file-install invocation
266- correct BuildRequires
267
268* Mon Nov 12 2007 David Nielsen <david@lovesunix.net> - 0.0.2-1
269- Initial package
Note: See TracBrowser for help on using the repository browser.