source: projects/specs/trunk/g/gnome-do/gnome-do-vl.spec @ 2582

Revision 2582, 8.9 KB checked in by kazutaka, 13 years ago (diff)

ソースを更新

Line 
1%define mainver         0.8.4
2%define build_vine5     %( [ "%{?_dist_release}" == "vl5" ] && echo 1 || echo 0)
3
4Name:                   gnome-do
5Version:                0.8.4
6Release:                1%{?_dist_release}
7Summary:                An intelligent launcher tool for Gnome
8Summary(ja):            Gnome 用の高機能ランチャー
9License:                GPLv3+
10Group:                  Applications/Accessories       
11URL:                    http://do.davebsd.com/
12Source0:                http://edge.launchpad.net/do/0.8/%{mainver}/+download/gnome-do-%{version}.tar.gz
13Source1:                gnome-do.desktop
14# https://bugs.launchpad.net/do/+bug/634556
15#Patch0:                        gnome-do-0.8.3.1-mono-2.8.patch
16#Patch1:                        gnome-do-0.8.3.1-gdk-build-fix.patch
17# https://bugs.launchpad.net/do/+bug/634550
18Patch2:                 gnome-do-0.8.4-cs0200.patch
19BuildRoot:              %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
20
21# Various Mono dependencies are not available for ppc64; see bug 241850.
22ExcludeArch:            ppc64
23
24BuildRequires:          mono-devel, mono-addins
25BuildRequires:          desktop-file-utils
26BuildRequires:          ndesk-dbus
27BuildRequires:          ndesk-dbus-glib
28BuildRequires:          gtk-sharp2
29BuildRequires:          notify-sharp-devel
30BuildRequires:          gnome-sharp2, gnome-desktop-sharp2 >= 2.26
31BuildRequires:          gnome-keyring-sharp-devel
32BuildRequires:          gettext
33BuildRequires:          perl-XML-Parser
34BuildRequires:          intltool
35BuildRequires:          gtk2-devel
36BuildRequires:          desktop-file-utils
37BuildRequires:          wnck-sharp
38BuildRequires:          gconf-sharp2
39BuildRequires:          rsvg2-sharp
40
41Requires(pre):          GConf2
42Requires(post):         GConf2
43Requires(preun):        GConf2
44
45Requires:               gnome-keyring-sharp, gnome-desktop-sharp2
46Requires:               pkgconfig
47
48Packager:               kazutaka
49
50%description
51GNOME Do (Do) is an intelligent launcher tool that makes performing
52common tasks on your computer simple and efficient. Do not only
53allows you to search for items in your desktop environment
54(e.g. applications, contacts, bookmarks, files, music), it also
55allows you to specify actions to perform on search results
56(e.g. run, open, email, chat, play).
57
58%description -l ja
59GNOME Do (Do) は高機能なランチャーツールです。 PC を使った一
60般的なタスクをシンプルかつ効率的に実行できるようにします。Do
61はデスクトップ環境の様々なアイテム(例えばアプリケーションや
62連絡先、ブックマーク、ファイル、音楽等)の検索だけでなく、検索
63した結果をどう操作するのか(例えば開く、メールに添付、チャット、
64再生する等)を指定することができます。
65
66%package devel
67Summary:                Development files for GNOME Do
68Summary(ja):               GNOME Do の開発用ファイル
69Group:                  Development/Libraries
70Requires:               %{name} = %{version}-%{release}
71Requires:               pkgconfig
72
73%description devel
74Development files for GNOME Do
75
76%description devel -l ja
77GNOME Do の開発用ファイルです。
78
79%prep
80%setup -q
81#%if !%{build_vine5}
82#%patch0 -p0 -b .mono28-fix
83#%patch1 -p1 -b .gdkbuild-fix
84#%endif
85%patch2 -p0 -b .cs0200
86
87
88%build
89%configure
90make %{?_smp_mflags}
91
92
93%install
94rm -rf ${RPM_BUILD_ROOT}
95export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
96make install DESTDIR=${RPM_BUILD_ROOT}
97
98desktop-file-install \
99        --dir ${RPM_BUILD_ROOT}%{_sysconfdir}/xdg/autostart     \
100        --add-only-show-in=GNOME                                \
101        %{SOURCE1}
102desktop-file-install \
103        --dir ${RPM_BUILD_ROOT}%{_datadir}/applications   \
104        --remove-category Application \
105        %{SOURCE1}
106
107
108#own this dir:
109mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/%{name}
110
111%find_lang %{name}
112
113%pre
114if [ "$1" -gt 1 ]; then
115    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
116    gconftool-2 --makefile-uninstall-rule \
117      %{_sysconfdir}/gconf/schemas/%{name}.schemas >/dev/null || :
118fi
119
120%post
121export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
122gconftool-2 --makefile-install-rule \
123  %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null || :
124
125touch --no-create %{_datadir}/icons/hicolor
126if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
127  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
128fi
129
130%preun
131if [ "$1" -eq 0 ]; then
132    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
133    gconftool-2 --makefile-uninstall-rule \
134      %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null || :
135fi
136
137%postun
138touch --no-create %{_datadir}/icons/hicolor
139if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
140  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
141fi
142
143%clean
144rm -rf ${RPM_BUILD_ROOT}
145
146%files -f %{name}.lang
147%defattr(-,root,root,-)
148%doc AUTHORS COPYING COPYRIGHT
149%{_bindir}/gnome-do/
150%{_libdir}/gnome-do/
151%{_datadir}/gnome-do/
152%config(noreplace) %{_sysconfdir}/xdg/autostart/gnome-do.desktop
153%config(noreplace) %{_sysconfdir}/gconf/schemas/*
154%{_datadir}/icons/hicolor/*/apps/gnome-do.*
155%{_datadir}/applications/*
156
157%files devel
158%defattr(-,root,root,-)
159%{_libdir}/pkgconfig/*
160
161%changelog
162* Thu Jan 13 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 0.8.4-1
163- new upstream release
164- drop Patch0 & 1
165- add Patch2: fix compilation error (cs0200)
166- add Source1: temporary fix for desktop-file-install failure.
167               (Comment[kk] contains a bogus linebreak)
168
169* Sat Nov 06 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 0.8.3.1-4
170- add Patch0 & 1 to fix compilation error (Seed only)
171
172* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.3.1-3
173- rebuild with rpm-4.8.1 for pkg-config file
174- add BuildRequires: gconf-sharp2, rsvg2-sharp
175
176* Mon Jul 26 2010 Shu KONNO <owa@bg.wakwak.com> 0.8.3.1-2
177- rebuilt with mono-addins-0.5
178
179* Sun Jan 10 2010 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.8.3.1-1
180- new upstream release
181
182* Fri Jul 10 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.8.2-1
183- new upstream release
184- drop Patch0 (merged in upstream)
185
186* Fri Jun 12 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.8.1.3-3
187- change Group to Applications/Accessories
188
189* Fri Jun 12 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.8.1.3-2
190- add BuildRequires: wnck-sharp
191
192* Thu Jun 11 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.8.1.3-1
193- initial build for Vine Linux based on fedora development
194
195* Fri Apr 10 2009 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.8.1.3-5
196- Fix .desktop issue, install in both autostart and applications
197- Rebuild for new gnome-desktop-sharp
198- Add missing gnome-desktop-sharp requires
199- Fix Ndesk-dbus Requires
200
201* Wed Apr 01 2009 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.8.1.3-3
202- Add patch to fix issue where applications wasn't being indexed
203
204* Tue Mar 17 2009 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.8.1.3-2
205- New upstream release
206
207* Tue Mar 3 2009 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.8.0-4
208- Own _datadir/gnome-do
209* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.0-3
210- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
211
212* Sat Feb  7 2009 Michel Salim <salimma@fedoraproject.org> - 0.8.0-2
213- Rebuild against new mono-addins
214
215* Fri Jan 30 2009 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.8.0-1
216- New upstream release
217
218* Thu Jan 29 2009 Michel Salim <salimma@fedoraproject.org> - 0.6.1.0-3
219- Remove Tomboy dependency (bz #481183)
220- Updated description, from Do
221
222* Mon Oct 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.6.1.0-2
223- rebuild against new gnome-sharp
224
225* Wed Oct 08 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.6.1.0-1
226- New Upstream Release
227
228* Fri Oct 03 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.6.0.1-1
229- New upstream release
230
231* Wed Jun 11 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.6.0.0-1
232- New upstream release
233
234* Wed Jun 11 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.5.0.1-4
235- New upstream release
236- Add gnome-desktop-sharp dependency
237
238* Wed Jun 04 2008 Caol叩n McNamara <caolanm@redhat.com> - 0.4.2.0-2
239- rebuild for dependancies
240
241* Tue Apr 22 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.4.2.0-1
242- New upstream release
243
244* Tue Apr 01 2008 David Nielsen <gnomeuser@gmail.com> - 0.4.0.1-2
245- #439793 - correct URL
246
247* Sat Mar 29 2008 David Nielsen <gnomeuser@gmail.com> - 0.4.0.1-1
248- Bump to 0.4.0.1
249- Hopefully bring an end to the endless dups of 432201
250
251* Thu Feb 21 2008 David Nielsen <david@lovesunix.net> - 0.3.1-2
252- Fix 432201
253
254* Thu Feb 21 2008 David Nielsen <david@lovesunix.net> - 0.3.1-1
255- Bump to 0.3.1
256
257* Wed Feb 06 2008 David Nielsen <david@lovesunix.net> - 0.3.0.1-5
258- #431589 - Force runtime dependency on ndesk-dbus(-glib)
259
260* Mon Feb 04 2008 David Nielsen <david@lovesunix.net> - 0.3.0.1-4
261- #431462 - Correctly pull in Tomboy runtime dependency
262
263* Fri Jan 25 2008 David Nielsen <david@lovesunix.net> - 0.3.0.1-3
264- autostart gnome-do in quiet mode with the user session
265- to invoke gnome-do use super+space
266
267* Tue Jan 22 2008 David Nielsen <david@lovesunix.net> - 0.3.0.1-2
268- Fix BuildRequires
269
270* Tue Jan 22 2008 David Nielsen <david@lovesunix.net> - 0.3.0.1-1
271- bump to 0.3.0.1
272- update patches
273
274* Sat Nov 17 2007 David Nielsen <david@lovesunix.net> - 0.0.2-2
275- updated libdir patch
276- cleaned up desktop-file-install invocation
277- correct BuildRequires
278
279* Mon Nov 12 2007 David Nielsen <david@lovesunix.net> - 0.0.2-1
280- Initial package
Note: See TracBrowser for help on using the repository browser.