source: projects/specs/trunk/g/gnome-commander/gnome-commander-vl.spec @ 8771

Revision 8771, 10.4 KB checked in by Takemikaduchi, 10 years ago (diff)

poppler-0.26.2

Line 
1%define        python_ver            2.7
2%define        exiv2_ver             0.23
3%define        taglib_ver            1.4
4%define        libgsf_ver            1.12.0
5%define        poppler_ver           0.14.2
6
7Name:          gnome-commander
8Summary:       A nice and fast file manager for the GNOME desktop
9Summary(pl):   Menadżer plików dla GNOME oparty o Norton Commander'a (TM)
10Summary(sv):   GNOME Commander är en snabb och smidig filhanderare för GNOME
11Version:       1.4.3
12Release:       2%{?_dist_release}
13
14Group:         User Interface/Desktops
15License:       GPLv2+
16URL:           http://www.nongnu.org/gcmd/
17Source0:       ftp://ftp.gnome.org/pub/GNOME/sources/%{name}/1.4/%{name}-%{version}.tar.xz
18
19Patch1:        gnome-commander-1.2.8.15-libgsf.patch
20
21BuildRoot:     %{_tmppath}/%{name}-%{version}-root
22
23BuildRequires: automake
24BuildRequires: flex
25BuildRequires: intltool >= 0.35.0
26BuildRequires: libtool
27BuildRequires: gnome-common
28BuildRequires: desktop-file-utils
29BuildRequires: scrollkeeper
30BuildRequires: gettext >= 0.10.36
31BuildRequires: glib2-devel >= 2.6.0
32BuildRequires: gtk2-devel >= 2.8.0
33BuildRequires: gnome-vfs2-devel >= 2.0.0
34BuildRequires: libgnomeui-devel >= 2.4.0
35BuildRequires: gnome-doc-utils >= 0.3.2
36BuildRequires: perl(XML::Parser)
37BuildRequires: libSM-devel
38BuildRequires: fontconfig-devel
39BuildRequires: unique-devel >= 0.9.3
40
41Requires:      glib2 >= 2.6.0
42Requires:      gtk2 >= 2.8.0
43Requires:      gnome-vfs2 >= 2.0.0
44Requires:      gnome-vfs2-smb >= 2.0.0
45Requires:      libgnomeui >= 2.4.0
46
47Requires:         meld
48Requires(post):   scrollkeeper
49Requires(postun): scrollkeeper
50
51BuildRequires:   python-devel >= %{python_ver}
52BuildRequires:   exiv2-devel >= %{exiv2_ver}
53BuildRequires:   taglib-devel >= %{taglib_ver}
54BuildRequires:   libgsf-devel >= %{libgsf_ver}
55BuildRequires:   poppler-devel >= %{poppler_ver}
56
57Requires:        python >= %{python_ver}
58Requires:        exiv2 >= %{exiv2_ver}
59Requires:        taglib >= %{taglib_ver}
60Requires:        libgsf >= %{libgsf_ver}
61Requires:        poppler >= %{poppler_ver}
62
63Vendor: Project Vine
64Distribution: Vine Linux
65
66%description
67GNOME Commander is a nice and fast file manager for the GNOME desktop.
68In addition to performing the basic file manager functions the program is
69also an FTP-client and it can browse SMB-networks.
70
71%prep
72%setup -q
73%patch1 -p1 -b .libgsf
74
75%build
76export CFLAGS="$RPM_OPT_FLAGS -Wno-deprecated-declarations"
77%configure \
78   --disable-scrollkeeper \
79   --enable-python
80%{__make} %{?_smp_mflags}
81
82%install
83%{__rm} -rf %{buildroot}
84%{__make} \
85   INSTALL="%{__install} -c -p" \
86   DESTDIR=%{buildroot} \
87   install
88
89desktop-file-install \
90   --delete-original \
91   --vendor '' \
92   --remove-category Application \
93   --dir %{buildroot}%{_datadir}/applications \
94   %{buildroot}%{_datadir}/applications/%{name}.desktop
95
96%{__rm} -f %{buildroot}%{_libdir}/%{name}/*.{a,la}
97%{__rm} -f %{buildroot}%{_libdir}/%{name}/*/*.{a,la,py}
98
99%find_lang %{name}
100
101%post
102scrollkeeper-update -q -o %{_datadir}/omf/%{name} || :
103
104%postun
105scrollkeeper-update -q || :
106
107%clean
108%{__rm} -rf %{buildroot}
109
110%files -f %{name}.lang
111%defattr(-,root,root,-)
112%doc AUTHORS BUGS ChangeLog COPYING INSTALL NEWS README TODO doc/*.txt
113
114%{_bindir}/*
115%{_libdir}/%{name}/
116%{_mandir}/man1/%{name}.1*
117
118%{_datadir}/appdata/%{name}.appdata.xml
119%{_datadir}/applications/%{name}.desktop
120
121%{_datadir}/gnome/help/%{name}/
122%{_datadir}/omf/%{name}/
123
124%{_datadir}/pixmaps/%{name}.png
125%{_datadir}/pixmaps/%{name}/
126
127%changelog
128* Tue Jul 08 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.3-2
129- rebuild with poppler-0.26.2
130
131* Sat Jun 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.3-1
132- new upstream release
133
134* Sat Jun 07 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.2-1
135- new upstream release
136
137* Sat May 03 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.1-2
138- rebuild with poppler-0.24.5
139
140* Sun Apr 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.1-1
141- new upstream release
142
143* Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
144- new upstream release
145- add BuildRequires: unique-devel
146
147* Sat Jan 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.17-1
148- new upstream release
149
150* Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.16-1
151- new upstream release
152- remove Patch0 (gnome-commander-1.2.8.15-poppler-0.24.x.patch)
153- remove Patch2 (gnome-commander-1.2.8.15-gcc47.patch) from fedora
154
155* Wed Dec 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.15-7
156- rebuild with exiv2-0.24
157
158* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.15-6
159- rebuild with poppler-0.24.2
160- update Patch0 (gnome-commander-1.2.8.15-poppler-0.24.x.patch)
161- add Patch1 (gnome-commander-1.2.8.15-libgsf.patch)
162- add Patch2 (gnome-commander-1.2.8.15-gcc47.patch) from fedora
163
164* Sun Oct 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.15-5
165- rebuild with poppler-0.20.4
166- add Patch0 (gnome-commander-1.2.8.15-poppler-0.20.x.patch)
167
168* Sun Jul 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.15-4
169- rebuild with exiv2-0.23
170
171* Mon May 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.15-3
172- rebuild with exiv2-0.22
173
174* Sun Feb 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.15-2
175- rebuild with python-2.7.2
176
177* Wed Dec 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.15-1
178- new upstream release
179
180* Fri Oct 07 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.14-1
181- new upstream release
182
183* Sat Aug 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.13-1
184- new upstream release
185
186* Sun Aug  7 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.8.11-2
187- rebuilt with exiv2-0.21.1
188- added BR: fontconfig-devel
189
190* Sat May 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.11-1
191- new upstream release
192- change Group: User Interface/Desktops instead of Applications/File
193
194* Sat Mar 12 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.8.9-2
195- rebuilt with poppler-0.16.3
196
197* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.9-1
198- new upstream release
199
200* Wed Oct 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.8-1
201- new upstream release
202
203* Sun Jun 27 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.6-1
204- new upstream release
205
206* Wed May 05 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.8.5-2
207- rebuilt with exiv2-0.19
208
209* Sun Mar 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.5-1
210- Initial build for Vine Linux
211
212* Wed Jan 13 2010 Piotr Eljasiak <epiotr@use.pl>
213- added gnome-vfs2-smb dependency
214- replaced exiv2 with exiv2-libs dependency for FC>=8
215
216* Fri Oct 3 2008 Yuriy Penkin <yuriy.penkin@gmail.com>
217- changed dependencies for intltool to 0.35.0
218
219* Thu Aug 7 2008 Piotr Eljasiak <epiotr@use.pl>
220- added poppler dependencies
221
222* Fri Jul 11 2008 Piotr Eljasiak <epiotr@use.pl>
223 - added build deps
224
225* Fri Oct  5 2007 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.2.4-4
226- Drop yelp dependency
227
228* Wed Aug 22 2007 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.2.4-3.dist.2
229- Mass rebuild (buildID or binutils issue)
230
231* Fri Aug  3 2007 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.2.4-3.dist.1
232- License update
233
234* Wed Jul 18 2007 Piotr Eljasiak <epiotr@use.pl> 1.2.5-1
235 - replaced libexif and libiptcdata with exiv2 library
236
237* Tue Jul 10 2007 Piotr Eljasiak <epiotr@use.pl> 1.2.5-1
238- replaced id3lib with taglib dependencies
239
240* Sat Jun 16 2007 Dušan Hokův <dusan@mirc.cz> 1.2.5-1
241- added cs description
242
243* Mon Jun 11 2007 Piotr Eljasiak <epiotr@use.pl> 1.2.5-1
244- minor tweaking with library versioning
245
246* Sun Feb 4 2007 Piotr Eljasiak <epiotr@use.pl> 1.2.4-1
247- added libgsf dependencies
248
249* Tue Jan 30 2007 Piotr Eljasiak <epiotr@use.pl> 1.2.4-1
250- added build and runtime deps for python and gnome-python2-gnomevfs
251
252* Sat Jan 20 2007 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.2.3-5
253- Require meld (#225324)
254
255* Wed Jan 10 2007 Piotr Eljasiak <epiotr@use.pl> 1.2.4-1
256- removed unneeded .py files
257
258* Thu Dec 21 2006 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.2.3-2
259- Clean up.
260
261* Sun Dec 17 2006 Piotr Eljasiak <epiotr@use.pl> 1.2.4-1
262- use version requirements from configure.in
263- changed dependencies from glib to glib2
264
265* Fri Dec 15 2006 Stephanos Manos <stefmanos AT gmail DOT com> - 1.2.4-1
266- removed not needed .a files
267- added build and runtime deps for libexif id3lib
268
269* Tue Dec 12 2006 Stephanos Manos <stefmanos AT gmail DOT com> - 1.2.4-1
270- minor cleanups/fixes to make rpmlint silent
271       -changelog: entries starting with % (added a second %)
272       -changelog: replaced tabs with spaces
273       -descriptions: splitted in multiple lines
274       -summary: removed ending dot
275       -license: changed license-tag form GPL2 to GPL
276* Tue Nov 14 2006 Piotr Eljasiak <epiotr@use.pl>
277- fixed Source0 address
278
279* Mon Jul 17 2006 Piotr Eljasiak <epiotr@use.pl>
280- added glib dependencies
281
282* Sun May 14 2006 Stephanos Manos <stefmanos@gmail.com>
283- Fixed Scrollkeeper database update
284        -disabled scrollkeeper update from make
285        -added scrollkeeper-database-update in the %%post & %%postun section
286- Added %%post & %%postun entries for the desktop file
287- Added %%post & %%postun entries for the gtk+ icon cache file
288
289* Sun Apr 9 2006 Piotr Eljasiak <epiotr@use.pl>
290- minor cleanups
291
292* Sun Mar 5 2006 Piotr Eljasiak <epiotr@use.pl>
293- added OMF files
294
295* Mon Feb 13 2006 Piotr Eljasiak <epiotr@use.pl>
296- install gnome-commander icon to %%{_datadir}/pixmaps/
297- install gnome-commander.1* to %%{_mandir}/man1/
298
299* Sat Feb 11 2006 Piotr Eljasiak <epiotr@use.pl>
300- set default srcext to .bz2
301
302* Fri Jan 28 2005 Piotr Eljasiak <epiotr@use.pl>
303- fixed typo: rpm --> rpmbuild
304
305* Mon May 03 2004 Piotr Eljasiak <epiotr@use.pl>
306- converted spec file to utf-8
307- used RPM macros a bit more
308
309* Thu Jun 19 2003 Piotr Eljasiak <epiotr@use.pl>
310- added libraries
311
312* Tue Mar 25 2003 Piotr Eljasiak <epiotr@use.pl>
313- updated Sources
314
315* Mon Jan 20 2003 Piotr Eljasiak <epiotr@use.pl>
316- added build dependencies
317
318* Fri Jan 10 2003 Piotr Eljasiak <epiotr@use.pl>
319- added localization
320
321* Thu Jan 09 2003 Piotr Eljasiak <epiotr@use.pl>
322- added dependencies
323
324* Mon Jun 24 2002 Piotr Eljasiak <epiotr@use.pl>
325- more cleanup in install section
326
327* Sat Jun 15 2002 Piotr Eljasiak <epiotr@use.pl>
328- simplified install and files sections
329
330* Mon Jun 10 2002 Piotr Eljasiak <epiotr@use.pl>
331- .spec file is now generated from .spec.in
332
333* Mon Jun 10 2002 Marcus Bjurman <marbj499@student.liu.se>
334- The default icon for this project is now called gnome-commander.png
335  The xpm variant of the same icon is now also renamed in the same manner.
336
337* Sat Mar  9 2002 Marcus Bjurman <marbj499@student.liu.se>
338- Pumped up the version nr
339
340* Sun Nov  4 2001 Marcus Bjurman <marbj499@student.liu.se>
341- Initial build.
Note: See TracBrowser for help on using the repository browser.