source: projects/specs/trunk/g/gnome-commander/gnome-commander-vl.spec @ 10499

Revision 10499, 10.9 KB checked in by Takemikaduchi, 8 years ago (diff)

rebuild with gcc-5.4.0

Line 
1%define        python_ver            2.7
2%define        exiv2_ver             0.23
3%define        taglib_ver            1.4
4%define        libgsf_ver            1.12.0
5%define        poppler_ver           0.14.2
6
7Name:          gnome-commander
8Summary:       A nice and fast file manager for the GNOME desktop
9Summary(pl):   Menadżer plików dla GNOME oparty o Norton Commander'a (TM)
10Summary(sv):   GNOME Commander är en snabb och smidig filhanderare för GNOME
11Version:       1.4.7
12Release:       3%{?_dist_release}
13
14Group:         User Interface/Desktops
15License:       GPLv2+
16URL:           http://www.nongnu.org/gcmd/
17Source0:       ftp://ftp.gnome.org/pub/GNOME/sources/%{name}/1.4/%{name}-%{version}.tar.xz
18
19Patch1:        gnome-commander-1.2.8.15-libgsf.patch
20
21BuildRoot:     %{_tmppath}/%{name}-%{version}-root
22
23BuildRequires: automake
24BuildRequires: flex
25BuildRequires: intltool >= 0.35.0
26BuildRequires: libtool
27BuildRequires: gnome-common
28BuildRequires: desktop-file-utils
29BuildRequires: scrollkeeper
30BuildRequires: gettext >= 0.10.36
31BuildRequires: glib2-devel >= 2.6.0
32BuildRequires: gtk2-devel >= 2.8.0
33BuildRequires: gnome-vfs2-devel >= 2.0.0
34BuildRequires: libgnomeui-devel >= 2.4.0
35BuildRequires: gnome-doc-utils >= 0.3.2
36BuildRequires: perl(XML::Parser)
37BuildRequires: libSM-devel
38BuildRequires: fontconfig-devel
39BuildRequires: unique-devel >= 0.9.3
40
41Requires:      glib2 >= 2.6.0
42Requires:      gtk2 >= 2.8.0
43Requires:      gnome-vfs2 >= 2.0.0
44Requires:      gnome-vfs2-smb >= 2.0.0
45Requires:      libgnomeui >= 2.4.0
46
47Requires:         meld
48Requires(post):   scrollkeeper
49Requires(postun): scrollkeeper
50
51BuildRequires:   python-devel >= %{python_ver}
52BuildRequires:   exiv2-devel >= %{exiv2_ver}
53BuildRequires:   taglib-devel >= %{taglib_ver}
54BuildRequires:   libgsf-devel >= %{libgsf_ver}
55BuildRequires:   poppler-devel >= %{poppler_ver}
56
57Requires:        python >= %{python_ver}
58Requires:        exiv2 >= %{exiv2_ver}
59Requires:        taglib >= %{taglib_ver}
60Requires:        libgsf >= %{libgsf_ver}
61Requires:        poppler >= %{poppler_ver}
62
63Vendor: Project Vine
64Distribution: Vine Linux
65
66%description
67GNOME Commander is a nice and fast file manager for the GNOME desktop.
68In addition to performing the basic file manager functions the program is
69also an FTP-client and it can browse SMB-networks.
70
71%prep
72%setup -q
73%patch1 -p1 -b .libgsf
74
75%build
76export CFLAGS="$RPM_OPT_FLAGS -Wno-deprecated-declarations"
77%configure \
78   --disable-scrollkeeper \
79   --enable-python
80%{__make} %{?_smp_mflags}
81
82%install
83%{__rm} -rf %{buildroot}
84%{__make} \
85   INSTALL="%{__install} -c -p" \
86   DESTDIR=%{buildroot} \
87   install
88
89desktop-file-install \
90   --delete-original \
91   --vendor '' \
92   --remove-category Application \
93   --dir %{buildroot}%{_datadir}/applications \
94   %{buildroot}%{_datadir}/applications/%{name}.desktop
95
96%{__rm} -f %{buildroot}%{_libdir}/%{name}/*.{a,la}
97%{__rm} -f %{buildroot}%{_libdir}/%{name}/*/*.{a,la,py}
98
99%find_lang %{name}
100
101%post
102scrollkeeper-update -q -o %{_datadir}/omf/%{name} || :
103
104%postun
105scrollkeeper-update -q || :
106
107%clean
108%{__rm} -rf %{buildroot}
109
110%files -f %{name}.lang
111%defattr(-,root,root,-)
112%doc AUTHORS BUGS ChangeLog COPYING INSTALL NEWS README TODO doc/*.txt
113%{_bindir}/*
114%{_libdir}/%{name}/
115%{_mandir}/man1/%{name}.1*
116%{_datadir}/appdata/%{name}.appdata.xml
117%{_datadir}/applications/%{name}.desktop
118%{_datadir}/gnome/help/%{name}/
119%{_datadir}/omf/%{name}/
120%{_datadir}/pixmaps/%{name}.png
121%{_datadir}/pixmaps/%{name}/
122%{_datadir}/%{name}/mime/*
123
124%changelog
125* Sat Jul 02 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.7-3
126- rebuild with gcc-5.4.0
127
128* Sun Nov 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.7-2
129- rebuild with poppler-0.37.0
130
131* Sun Jun 07 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.7-1
132- new upstream release
133
134* Sat May 23 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.6-1
135- new upstream release
136
137* Wed Jan 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.5-1
138- new upstream release
139
140* Wed Nov 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.4-1
141- new upstream release
142
143* Tue Jul 08 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.3-2
144- rebuild with poppler-0.26.2
145
146* Sat Jun 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.3-1
147- new upstream release
148
149* Sat Jun 07 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.2-1
150- new upstream release
151
152* Sat May 03 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.1-2
153- rebuild with poppler-0.24.5
154
155* Sun Apr 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.1-1
156- new upstream release
157
158* Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
159- new upstream release
160- add BuildRequires: unique-devel
161
162* Sat Jan 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.17-1
163- new upstream release
164
165* Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.16-1
166- new upstream release
167- remove Patch0 (gnome-commander-1.2.8.15-poppler-0.24.x.patch)
168- remove Patch2 (gnome-commander-1.2.8.15-gcc47.patch) from fedora
169
170* Wed Dec 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.15-7
171- rebuild with exiv2-0.24
172
173* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.15-6
174- rebuild with poppler-0.24.2
175- update Patch0 (gnome-commander-1.2.8.15-poppler-0.24.x.patch)
176- add Patch1 (gnome-commander-1.2.8.15-libgsf.patch)
177- add Patch2 (gnome-commander-1.2.8.15-gcc47.patch) from fedora
178
179* Sun Oct 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.15-5
180- rebuild with poppler-0.20.4
181- add Patch0 (gnome-commander-1.2.8.15-poppler-0.20.x.patch)
182
183* Sun Jul 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.15-4
184- rebuild with exiv2-0.23
185
186* Mon May 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.15-3
187- rebuild with exiv2-0.22
188
189* Sun Feb 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.15-2
190- rebuild with python-2.7.2
191
192* Wed Dec 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.15-1
193- new upstream release
194
195* Fri Oct 07 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.14-1
196- new upstream release
197
198* Sat Aug 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.13-1
199- new upstream release
200
201* Sun Aug  7 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.8.11-2
202- rebuilt with exiv2-0.21.1
203- added BR: fontconfig-devel
204
205* Sat May 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.11-1
206- new upstream release
207- change Group: User Interface/Desktops instead of Applications/File
208
209* Sat Mar 12 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.8.9-2
210- rebuilt with poppler-0.16.3
211
212* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.9-1
213- new upstream release
214
215* Wed Oct 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.8-1
216- new upstream release
217
218* Sun Jun 27 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.6-1
219- new upstream release
220
221* Wed May 05 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.8.5-2
222- rebuilt with exiv2-0.19
223
224* Sun Mar 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.5-1
225- Initial build for Vine Linux
226
227* Wed Jan 13 2010 Piotr Eljasiak <epiotr@use.pl>
228- added gnome-vfs2-smb dependency
229- replaced exiv2 with exiv2-libs dependency for FC>=8
230
231* Fri Oct 3 2008 Yuriy Penkin <yuriy.penkin@gmail.com>
232- changed dependencies for intltool to 0.35.0
233
234* Thu Aug 7 2008 Piotr Eljasiak <epiotr@use.pl>
235- added poppler dependencies
236
237* Fri Jul 11 2008 Piotr Eljasiak <epiotr@use.pl>
238 - added build deps
239
240* Fri Oct  5 2007 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.2.4-4
241- Drop yelp dependency
242
243* Wed Aug 22 2007 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.2.4-3.dist.2
244- Mass rebuild (buildID or binutils issue)
245
246* Fri Aug  3 2007 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.2.4-3.dist.1
247- License update
248
249* Wed Jul 18 2007 Piotr Eljasiak <epiotr@use.pl> 1.2.5-1
250 - replaced libexif and libiptcdata with exiv2 library
251
252* Tue Jul 10 2007 Piotr Eljasiak <epiotr@use.pl> 1.2.5-1
253- replaced id3lib with taglib dependencies
254
255* Sat Jun 16 2007 Dušan Hokův <dusan@mirc.cz> 1.2.5-1
256- added cs description
257
258* Mon Jun 11 2007 Piotr Eljasiak <epiotr@use.pl> 1.2.5-1
259- minor tweaking with library versioning
260
261* Sun Feb 4 2007 Piotr Eljasiak <epiotr@use.pl> 1.2.4-1
262- added libgsf dependencies
263
264* Tue Jan 30 2007 Piotr Eljasiak <epiotr@use.pl> 1.2.4-1
265- added build and runtime deps for python and gnome-python2-gnomevfs
266
267* Sat Jan 20 2007 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.2.3-5
268- Require meld (#225324)
269
270* Wed Jan 10 2007 Piotr Eljasiak <epiotr@use.pl> 1.2.4-1
271- removed unneeded .py files
272
273* Thu Dec 21 2006 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.2.3-2
274- Clean up.
275
276* Sun Dec 17 2006 Piotr Eljasiak <epiotr@use.pl> 1.2.4-1
277- use version requirements from configure.in
278- changed dependencies from glib to glib2
279
280* Fri Dec 15 2006 Stephanos Manos <stefmanos AT gmail DOT com> - 1.2.4-1
281- removed not needed .a files
282- added build and runtime deps for libexif id3lib
283
284* Tue Dec 12 2006 Stephanos Manos <stefmanos AT gmail DOT com> - 1.2.4-1
285- minor cleanups/fixes to make rpmlint silent
286       -changelog: entries starting with % (added a second %)
287       -changelog: replaced tabs with spaces
288       -descriptions: splitted in multiple lines
289       -summary: removed ending dot
290       -license: changed license-tag form GPL2 to GPL
291* Tue Nov 14 2006 Piotr Eljasiak <epiotr@use.pl>
292- fixed Source0 address
293
294* Mon Jul 17 2006 Piotr Eljasiak <epiotr@use.pl>
295- added glib dependencies
296
297* Sun May 14 2006 Stephanos Manos <stefmanos@gmail.com>
298- Fixed Scrollkeeper database update
299        -disabled scrollkeeper update from make
300        -added scrollkeeper-database-update in the %%post & %%postun section
301- Added %%post & %%postun entries for the desktop file
302- Added %%post & %%postun entries for the gtk+ icon cache file
303
304* Sun Apr 9 2006 Piotr Eljasiak <epiotr@use.pl>
305- minor cleanups
306
307* Sun Mar 5 2006 Piotr Eljasiak <epiotr@use.pl>
308- added OMF files
309
310* Mon Feb 13 2006 Piotr Eljasiak <epiotr@use.pl>
311- install gnome-commander icon to %%{_datadir}/pixmaps/
312- install gnome-commander.1* to %%{_mandir}/man1/
313
314* Sat Feb 11 2006 Piotr Eljasiak <epiotr@use.pl>
315- set default srcext to .bz2
316
317* Fri Jan 28 2005 Piotr Eljasiak <epiotr@use.pl>
318- fixed typo: rpm --> rpmbuild
319
320* Mon May 03 2004 Piotr Eljasiak <epiotr@use.pl>
321- converted spec file to utf-8
322- used RPM macros a bit more
323
324* Thu Jun 19 2003 Piotr Eljasiak <epiotr@use.pl>
325- added libraries
326
327* Tue Mar 25 2003 Piotr Eljasiak <epiotr@use.pl>
328- updated Sources
329
330* Mon Jan 20 2003 Piotr Eljasiak <epiotr@use.pl>
331- added build dependencies
332
333* Fri Jan 10 2003 Piotr Eljasiak <epiotr@use.pl>
334- added localization
335
336* Thu Jan 09 2003 Piotr Eljasiak <epiotr@use.pl>
337- added dependencies
338
339* Mon Jun 24 2002 Piotr Eljasiak <epiotr@use.pl>
340- more cleanup in install section
341
342* Sat Jun 15 2002 Piotr Eljasiak <epiotr@use.pl>
343- simplified install and files sections
344
345* Mon Jun 10 2002 Piotr Eljasiak <epiotr@use.pl>
346- .spec file is now generated from .spec.in
347
348* Mon Jun 10 2002 Marcus Bjurman <marbj499@student.liu.se>
349- The default icon for this project is now called gnome-commander.png
350  The xpm variant of the same icon is now also renamed in the same manner.
351
352* Sat Mar  9 2002 Marcus Bjurman <marbj499@student.liu.se>
353- Pumped up the version nr
354
355* Sun Nov  4 2001 Marcus Bjurman <marbj499@student.liu.se>
356- Initial build.
Note: See TracBrowser for help on using the repository browser.