source: projects/specs/trunk/g/gnome-commander/gnome-commander-vl.spec @ 521

Revision 521, 7.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define        python_ver            2.4
2%define        exiv2_ver             0.14
3%define        taglib_ver            1.4
4%define        libgsf_ver            1.12.0
5%define        poppler_ver           0.6
6
7Name:          gnome-commander
8Version:       1.2.8.5
9Release:       1%{?_dist_release}
10Summary:       A nice and fast file manager for the GNOME desktop
11Summary(pl):   Menadżer plików dla GNOME oparty o Norton Commander'a (TM)
12Summary(sv):   GNOME Commander är en snabb och smidig filhanderare för GNOME
13
14Group:         Applications/File
15License:       GPLv2+
16URL:           http://www.nongnu.org/gcmd/
17Source0:       ftp://ftp.gnome.org/pub/GNOME/sources/%{name}/1.2/%{name}-%{version}.tar.bz2
18BuildRoot:     %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
19
20BuildRequires: automake
21BuildRequires: flex
22BuildRequires: intltool >= 0.35.0
23BuildRequires: libtool
24BuildRequires: gnome-common
25BuildRequires: desktop-file-utils
26BuildRequires: scrollkeeper
27BuildRequires: gettext >= 0.10.36
28BuildRequires: glib2-devel >= 2.6.0
29BuildRequires: gtk2-devel >= 2.8.0
30BuildRequires: gnome-vfs2-devel >= 2.0.0
31BuildRequires: libgnomeui-devel >= 2.4.0
32BuildRequires: gnome-doc-utils >= 0.3.2
33BuildRequires: perl(XML::Parser)
34BuildRequires: libSM-devel
35
36Requires:      glib2 >= 2.6.0
37Requires:      gtk2 >= 2.8.0
38Requires:      gnome-vfs2 >= 2.0.0
39Requires:      gnome-vfs2-smb >= 2.0.0
40Requires:      libgnomeui >= 2.4.0
41
42Requires:         meld
43Requires(post):   scrollkeeper
44Requires(postun): scrollkeeper
45
46BuildRequires:   python-devel >= %{python_ver}
47BuildRequires:   exiv2-devel >= %{exiv2_ver}
48BuildRequires:   taglib-devel >= %{taglib_ver}
49BuildRequires:   libgsf-devel >= %{libgsf_ver}
50BuildRequires:   poppler-devel >= %{poppler_ver}
51
52Requires:        python >= %{python_ver}
53Requires:        exiv2 >= %{exiv2_ver}
54Requires:        taglib >= %{taglib_ver}
55Requires:        libgsf >= %{libgsf_ver}
56Requires:        poppler >= %{poppler_ver}
57
58%description
59GNOME Commander is a nice and fast file manager for the GNOME desktop.
60In addition to performing the basic file manager functions the program is
61also an FTP-client and it can browse SMB-networks.
62
63%prep
64%setup -q
65
66%build
67%configure \
68   --disable-scrollkeeper \
69   --enable-python
70%{__make} %{?_smp_mflags}
71
72%install
73%{__rm} -rf %{buildroot}
74%{__make} \
75   INSTALL="%{__install} -c -p" \
76   DESTDIR=%{buildroot} \
77   install
78
79desktop-file-install \
80   --delete-original \
81   --vendor '' \
82   --remove-category Application \
83   --dir %{buildroot}%{_datadir}/applications \
84   %{buildroot}%{_datadir}/applications/%{name}.desktop
85
86%{__rm} -f %{buildroot}%{_libdir}/%{name}/*.{a,la}
87%{__rm} -f %{buildroot}%{_libdir}/%{name}/*/*.{a,la,py}
88
89%find_lang %{name}
90
91%post
92scrollkeeper-update -q -o %{_datadir}/omf/%{name} || :
93
94%postun
95scrollkeeper-update -q || :
96
97%clean
98%{__rm} -rf %{buildroot}
99
100%files -f %{name}.lang
101%defattr(-,root,root,-)
102%doc AUTHORS BUGS ChangeLog COPYING INSTALL NEWS README TODO doc/*.txt
103
104%{_bindir}/*
105%{_libdir}/%{name}/
106%{_mandir}/man1/%{name}.1*
107
108%{_datadir}/applications/%{name}.desktop
109
110%{_datadir}/gnome/help/%{name}/
111%{_datadir}/omf/%{name}/
112
113%{_datadir}/pixmaps/%{name}.png
114%{_datadir}/pixmaps/%{name}/
115
116%changelog
117* Sun Mar 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.5-1
118- Initial build for Vine Linux
119
120
121* Wed Jan 13 2010 Piotr Eljasiak <epiotr@use.pl>
122- added gnome-vfs2-smb dependency
123- replaced exiv2 with exiv2-libs dependency for FC>=8
124
125* Fri Oct 3 2008 Yuriy Penkin <yuriy.penkin@gmail.com>
126- changed dependencies for intltool to 0.35.0
127
128* Thu Aug 7 2008 Piotr Eljasiak <epiotr@use.pl>
129- added poppler dependencies
130
131* Fri Jul 11 2008 Piotr Eljasiak <epiotr@use.pl>
132 - added build deps
133
134* Fri Oct  5 2007 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.2.4-4
135- Drop yelp dependency
136
137* Wed Aug 22 2007 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.2.4-3.dist.2
138- Mass rebuild (buildID or binutils issue)
139
140* Fri Aug  3 2007 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.2.4-3.dist.1
141- License update
142
143* Wed Jul 18 2007 Piotr Eljasiak <epiotr@use.pl> 1.2.5-1
144 - replaced libexif and libiptcdata with exiv2 library
145
146* Tue Jul 10 2007 Piotr Eljasiak <epiotr@use.pl> 1.2.5-1
147- replaced id3lib with taglib dependencies
148
149* Sat Jun 16 2007 Dušan Hokův <dusan@mirc.cz> 1.2.5-1
150- added cs description
151
152* Mon Jun 11 2007 Piotr Eljasiak <epiotr@use.pl> 1.2.5-1
153- minor tweaking with library versioning
154
155* Sun Feb 4 2007 Piotr Eljasiak <epiotr@use.pl> 1.2.4-1
156- added libgsf dependencies
157
158* Wed Jan 30 2007 Piotr Eljasiak <epiotr@use.pl> 1.2.4-1
159- added build and runtime deps for python and gnome-python2-gnomevfs
160
161* Tue Jan 20 2007 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.2.3-5
162- Require meld (#225324)
163
164* Wed Jan 10 2007 Piotr Eljasiak <epiotr@use.pl> 1.2.4-1
165- removed unneeded .py files
166
167* Thu Dec 21 2006 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.2.3-2
168- Clean up.
169
170* Sun Dec 17 2006 Piotr Eljasiak <epiotr@use.pl> 1.2.4-1
171- use version requirements from configure.in
172- changed dependencies from glib to glib2
173
174* Fri Dec 15 2006 Stephanos Manos <stefmanos AT gmail DOT com> - 1.2.4-1
175- removed not needed .a files
176- added build and runtime deps for libexif id3lib
177
178* Tue Dec 12 2006 Stephanos Manos <stefmanos AT gmail DOT com> - 1.2.4-1
179- minor cleanups/fixes to make rpmlint silent
180       -changelog: entries starting with % (added a second %)
181       -changelog: replaced tabs with spaces
182       -descriptions: splitted in multiple lines
183       -summary: removed ending dot
184       -license: changed license-tag form GPL2 to GPL
185* Tue Nov 14 2006 Piotr Eljasiak <epiotr@use.pl>
186- fixed Source0 address
187
188* Mon Jul 17 2006 Piotr Eljasiak <epiotr@use.pl>
189- added glib dependencies
190
191* Sun May 14 2006 Stephanos Manos <stefmanos@gmail.com>
192- Fixed Scrollkeeper database update
193        -disabled scrollkeeper update from make
194        -added scrollkeeper-database-update in the %%post & %%postun section
195- Added %%post & %%postun entries for the desktop file
196- Added %%post & %%postun entries for the gtk+ icon cache file
197
198* Sun Apr 9 2006 Piotr Eljasiak <epiotr@use.pl>
199- minor cleanups
200
201* Thu Mar 5 2006 Piotr Eljasiak <epiotr@use.pl>
202- added OMF files
203
204* Mon Feb 13 2006 Piotr Eljasiak <epiotr@use.pl>
205- install gnome-commander icon to %%{_datadir}/pixmaps/
206- install gnome-commander.1* to %%{_mandir}/man1/
207
208* Sat Feb 11 2006 Piotr Eljasiak <epiotr@use.pl>
209- set default srcext to .bz2
210
211* Fri Jan 28 2005 Piotr Eljasiak <epiotr@use.pl>
212- fixed typo: rpm --> rpmbuild
213
214* Mon May 03 2004 Piotr Eljasiak <epiotr@use.pl>
215- converted spec file to utf-8
216- used RPM macros a bit more
217
218* Thu Jun 19 2003 Piotr Eljasiak <epiotr@use.pl>
219- added libraries
220
221* Tue Mar 25 2003 Piotr Eljasiak <epiotr@use.pl>
222- updated Sources
223
224* Mon Jan 20 2003 Piotr Eljasiak <epiotr@use.pl>
225- added build dependencies
226
227* Fri Jan 10 2003 Piotr Eljasiak <epiotr@use.pl>
228- added localization
229
230* Thu Jan 09 2003 Piotr Eljasiak <epiotr@use.pl>
231- added dependencies
232
233* Mon Jun 24 2002 Piotr Eljasiak <epiotr@use.pl>
234- more cleanup in install section
235
236* Sat Jun 15 2002 Piotr Eljasiak <epiotr@use.pl>
237- simplified install and files sections
238
239* Mon Jun 10 2002 Piotr Eljasiak <epiotr@use.pl>
240- .spec file is now generated from .spec.in
241
242* Mon Jun 10 2002 Marcus Bjurman <marbj499@student.liu.se>
243- The default icon for this project is now called gnome-commander.png
244  The xpm variant of the same icon is now also renamed in the same manner.
245
246* Sat Mar  9 2002 Marcus Bjurman <marbj499@student.liu.se>
247- Pumped up the version nr
248
249* Sun Nov  4 2001 Marcus Bjurman <marbj499@student.liu.se>
250- Initial build.
Note: See TracBrowser for help on using the repository browser.