source: projects/specs/trunk/g/gnome-commander/gnome-commander-vl.spec @ 8355

Revision 8355, 10.0 KB checked in by Takemikaduchi, 10 years ago (diff)

GNOME-3.12.0

Line 
1%define        python_ver            2.7
2%define        exiv2_ver             0.23
3%define        taglib_ver            1.4
4%define        libgsf_ver            1.12.0
5%define        poppler_ver           0.14.2
6
7Name:          gnome-commander
8Summary:       A nice and fast file manager for the GNOME desktop
9Summary(pl):   Menadżer plików dla GNOME oparty o Norton Commander'a (TM)
10Summary(sv):   GNOME Commander är en snabb och smidig filhanderare för GNOME
11Version:       1.4.1
12Release:       1%{?_dist_release}
13
14Group:         User Interface/Desktops
15License:       GPLv2+
16URL:           http://www.nongnu.org/gcmd/
17Source0:       ftp://ftp.gnome.org/pub/GNOME/sources/%{name}/1.4/%{name}-%{version}.tar.xz
18
19Patch1:        gnome-commander-1.2.8.15-libgsf.patch
20
21BuildRoot:     %{_tmppath}/%{name}-%{version}-root
22
23BuildRequires: automake
24BuildRequires: flex
25BuildRequires: intltool >= 0.35.0
26BuildRequires: libtool
27BuildRequires: gnome-common
28BuildRequires: desktop-file-utils
29BuildRequires: scrollkeeper
30BuildRequires: gettext >= 0.10.36
31BuildRequires: glib2-devel >= 2.6.0
32BuildRequires: gtk2-devel >= 2.8.0
33BuildRequires: gnome-vfs2-devel >= 2.0.0
34BuildRequires: libgnomeui-devel >= 2.4.0
35BuildRequires: gnome-doc-utils >= 0.3.2
36BuildRequires: perl(XML::Parser)
37BuildRequires: libSM-devel
38BuildRequires: fontconfig-devel
39BuildRequires: unique-devel >= 0.9.3
40
41Requires:      glib2 >= 2.6.0
42Requires:      gtk2 >= 2.8.0
43Requires:      gnome-vfs2 >= 2.0.0
44Requires:      gnome-vfs2-smb >= 2.0.0
45Requires:      libgnomeui >= 2.4.0
46
47Requires:         meld
48Requires(post):   scrollkeeper
49Requires(postun): scrollkeeper
50
51BuildRequires:   python-devel >= %{python_ver}
52BuildRequires:   exiv2-devel >= %{exiv2_ver}
53BuildRequires:   taglib-devel >= %{taglib_ver}
54BuildRequires:   libgsf-devel >= %{libgsf_ver}
55BuildRequires:   poppler-devel >= %{poppler_ver}
56
57Requires:        python >= %{python_ver}
58Requires:        exiv2 >= %{exiv2_ver}
59Requires:        taglib >= %{taglib_ver}
60Requires:        libgsf >= %{libgsf_ver}
61Requires:        poppler >= %{poppler_ver}
62
63Vendor: Project Vine
64Distribution: Vine Linux
65
66%description
67GNOME Commander is a nice and fast file manager for the GNOME desktop.
68In addition to performing the basic file manager functions the program is
69also an FTP-client and it can browse SMB-networks.
70
71%prep
72%setup -q
73%patch1 -p1 -b .libgsf
74
75%build
76export CFLAGS="$RPM_OPT_FLAGS -Wno-deprecated-declarations"
77%configure \
78   --disable-scrollkeeper \
79   --enable-python
80%{__make} %{?_smp_mflags}
81
82%install
83%{__rm} -rf %{buildroot}
84%{__make} \
85   INSTALL="%{__install} -c -p" \
86   DESTDIR=%{buildroot} \
87   install
88
89desktop-file-install \
90   --delete-original \
91   --vendor '' \
92   --remove-category Application \
93   --dir %{buildroot}%{_datadir}/applications \
94   %{buildroot}%{_datadir}/applications/%{name}.desktop
95
96%{__rm} -f %{buildroot}%{_libdir}/%{name}/*.{a,la}
97%{__rm} -f %{buildroot}%{_libdir}/%{name}/*/*.{a,la,py}
98
99%find_lang %{name}
100
101%post
102scrollkeeper-update -q -o %{_datadir}/omf/%{name} || :
103
104%postun
105scrollkeeper-update -q || :
106
107%clean
108%{__rm} -rf %{buildroot}
109
110%files -f %{name}.lang
111%defattr(-,root,root,-)
112%doc AUTHORS BUGS ChangeLog COPYING INSTALL NEWS README TODO doc/*.txt
113
114%{_bindir}/*
115%{_libdir}/%{name}/
116%{_mandir}/man1/%{name}.1*
117
118%{_datadir}/applications/%{name}.desktop
119
120%{_datadir}/gnome/help/%{name}/
121%{_datadir}/omf/%{name}/
122
123%{_datadir}/pixmaps/%{name}.png
124%{_datadir}/pixmaps/%{name}/
125
126%changelog
127* Sun Apr 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.1-1
128- new upstream release
129
130* Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
131- new upstream release
132- add BuildRequires: unique-devel
133
134* Sat Jan 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.17-1
135- new upstream release
136
137* Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.16-1
138- new upstream release
139- remove Patch0 (gnome-commander-1.2.8.15-poppler-0.24.x.patch)
140- remove Patch2 (gnome-commander-1.2.8.15-gcc47.patch) from fedora
141
142* Wed Dec 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.15-7
143- rebuild with exiv2-0.24
144
145* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.15-6
146- rebuild with poppler-0.24.2
147- update Patch0 (gnome-commander-1.2.8.15-poppler-0.24.x.patch)
148- add Patch1 (gnome-commander-1.2.8.15-libgsf.patch)
149- add Patch2 (gnome-commander-1.2.8.15-gcc47.patch) from fedora
150
151* Sun Oct 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.15-5
152- rebuild with poppler-0.20.4
153- add Patch0 (gnome-commander-1.2.8.15-poppler-0.20.x.patch)
154
155* Sun Jul 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.15-4
156- rebuild with exiv2-0.23
157
158* Mon May 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.15-3
159- rebuild with exiv2-0.22
160
161* Sun Feb 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.15-2
162- rebuild with python-2.7.2
163
164* Wed Dec 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.15-1
165- new upstream release
166
167* Fri Oct 07 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.14-1
168- new upstream release
169
170* Sat Aug 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.13-1
171- new upstream release
172
173* Sun Aug  7 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.8.11-2
174- rebuilt with exiv2-0.21.1
175- added BR: fontconfig-devel
176
177* Sat May 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.11-1
178- new upstream release
179- change Group: User Interface/Desktops instead of Applications/File
180
181* Sat Mar 12 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.8.9-2
182- rebuilt with poppler-0.16.3
183
184* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.9-1
185- new upstream release
186
187* Wed Oct 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.8-1
188- new upstream release
189
190* Sun Jun 27 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.6-1
191- new upstream release
192
193* Wed May 05 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.8.5-2
194- rebuilt with exiv2-0.19
195
196* Sun Mar 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.5-1
197- Initial build for Vine Linux
198
199* Wed Jan 13 2010 Piotr Eljasiak <epiotr@use.pl>
200- added gnome-vfs2-smb dependency
201- replaced exiv2 with exiv2-libs dependency for FC>=8
202
203* Fri Oct 3 2008 Yuriy Penkin <yuriy.penkin@gmail.com>
204- changed dependencies for intltool to 0.35.0
205
206* Thu Aug 7 2008 Piotr Eljasiak <epiotr@use.pl>
207- added poppler dependencies
208
209* Fri Jul 11 2008 Piotr Eljasiak <epiotr@use.pl>
210 - added build deps
211
212* Fri Oct  5 2007 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.2.4-4
213- Drop yelp dependency
214
215* Wed Aug 22 2007 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.2.4-3.dist.2
216- Mass rebuild (buildID or binutils issue)
217
218* Fri Aug  3 2007 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.2.4-3.dist.1
219- License update
220
221* Wed Jul 18 2007 Piotr Eljasiak <epiotr@use.pl> 1.2.5-1
222 - replaced libexif and libiptcdata with exiv2 library
223
224* Tue Jul 10 2007 Piotr Eljasiak <epiotr@use.pl> 1.2.5-1
225- replaced id3lib with taglib dependencies
226
227* Sat Jun 16 2007 Dušan Hokův <dusan@mirc.cz> 1.2.5-1
228- added cs description
229
230* Mon Jun 11 2007 Piotr Eljasiak <epiotr@use.pl> 1.2.5-1
231- minor tweaking with library versioning
232
233* Sun Feb 4 2007 Piotr Eljasiak <epiotr@use.pl> 1.2.4-1
234- added libgsf dependencies
235
236* Tue Jan 30 2007 Piotr Eljasiak <epiotr@use.pl> 1.2.4-1
237- added build and runtime deps for python and gnome-python2-gnomevfs
238
239* Sat Jan 20 2007 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.2.3-5
240- Require meld (#225324)
241
242* Wed Jan 10 2007 Piotr Eljasiak <epiotr@use.pl> 1.2.4-1
243- removed unneeded .py files
244
245* Thu Dec 21 2006 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.2.3-2
246- Clean up.
247
248* Sun Dec 17 2006 Piotr Eljasiak <epiotr@use.pl> 1.2.4-1
249- use version requirements from configure.in
250- changed dependencies from glib to glib2
251
252* Fri Dec 15 2006 Stephanos Manos <stefmanos AT gmail DOT com> - 1.2.4-1
253- removed not needed .a files
254- added build and runtime deps for libexif id3lib
255
256* Tue Dec 12 2006 Stephanos Manos <stefmanos AT gmail DOT com> - 1.2.4-1
257- minor cleanups/fixes to make rpmlint silent
258       -changelog: entries starting with % (added a second %)
259       -changelog: replaced tabs with spaces
260       -descriptions: splitted in multiple lines
261       -summary: removed ending dot
262       -license: changed license-tag form GPL2 to GPL
263* Tue Nov 14 2006 Piotr Eljasiak <epiotr@use.pl>
264- fixed Source0 address
265
266* Mon Jul 17 2006 Piotr Eljasiak <epiotr@use.pl>
267- added glib dependencies
268
269* Sun May 14 2006 Stephanos Manos <stefmanos@gmail.com>
270- Fixed Scrollkeeper database update
271        -disabled scrollkeeper update from make
272        -added scrollkeeper-database-update in the %%post & %%postun section
273- Added %%post & %%postun entries for the desktop file
274- Added %%post & %%postun entries for the gtk+ icon cache file
275
276* Sun Apr 9 2006 Piotr Eljasiak <epiotr@use.pl>
277- minor cleanups
278
279* Sun Mar 5 2006 Piotr Eljasiak <epiotr@use.pl>
280- added OMF files
281
282* Mon Feb 13 2006 Piotr Eljasiak <epiotr@use.pl>
283- install gnome-commander icon to %%{_datadir}/pixmaps/
284- install gnome-commander.1* to %%{_mandir}/man1/
285
286* Sat Feb 11 2006 Piotr Eljasiak <epiotr@use.pl>
287- set default srcext to .bz2
288
289* Fri Jan 28 2005 Piotr Eljasiak <epiotr@use.pl>
290- fixed typo: rpm --> rpmbuild
291
292* Mon May 03 2004 Piotr Eljasiak <epiotr@use.pl>
293- converted spec file to utf-8
294- used RPM macros a bit more
295
296* Thu Jun 19 2003 Piotr Eljasiak <epiotr@use.pl>
297- added libraries
298
299* Tue Mar 25 2003 Piotr Eljasiak <epiotr@use.pl>
300- updated Sources
301
302* Mon Jan 20 2003 Piotr Eljasiak <epiotr@use.pl>
303- added build dependencies
304
305* Fri Jan 10 2003 Piotr Eljasiak <epiotr@use.pl>
306- added localization
307
308* Thu Jan 09 2003 Piotr Eljasiak <epiotr@use.pl>
309- added dependencies
310
311* Mon Jun 24 2002 Piotr Eljasiak <epiotr@use.pl>
312- more cleanup in install section
313
314* Sat Jun 15 2002 Piotr Eljasiak <epiotr@use.pl>
315- simplified install and files sections
316
317* Mon Jun 10 2002 Piotr Eljasiak <epiotr@use.pl>
318- .spec file is now generated from .spec.in
319
320* Mon Jun 10 2002 Marcus Bjurman <marbj499@student.liu.se>
321- The default icon for this project is now called gnome-commander.png
322  The xpm variant of the same icon is now also renamed in the same manner.
323
324* Sat Mar  9 2002 Marcus Bjurman <marbj499@student.liu.se>
325- Pumped up the version nr
326
327* Sun Nov  4 2001 Marcus Bjurman <marbj499@student.liu.se>
328- Initial build.
Note: See TracBrowser for help on using the repository browser.