source: projects/specs/trunk/g/gnome-commander/gnome-commander-vl.spec @ 8219

Revision 8219, 9.7 KB checked in by Takemikaduchi, 10 years ago (diff)

dia: fix bug
others: new upstream release

Line 
1%define        python_ver            2.7
2%define        exiv2_ver             0.23
3%define        taglib_ver            1.4
4%define        libgsf_ver            1.12.0
5%define        poppler_ver           0.14.2
6
7Name:          gnome-commander
8Summary:       A nice and fast file manager for the GNOME desktop
9Summary(pl):   Menadżer plików dla GNOME oparty o Norton Commander'a (TM)
10Summary(sv):   GNOME Commander är en snabb och smidig filhanderare för GNOME
11Version:       1.2.8.17
12Release:       1%{?_dist_release}
13
14Group:         User Interface/Desktops
15License:       GPLv2+
16URL:           http://www.nongnu.org/gcmd/
17Source0:       ftp://ftp.gnome.org/pub/GNOME/sources/%{name}/1.2/%{name}-%{version}.tar.xz
18
19Patch1:        gnome-commander-1.2.8.15-libgsf.patch
20
21BuildRoot:     %{_tmppath}/%{name}-%{version}-root
22
23BuildRequires: automake
24BuildRequires: flex
25BuildRequires: intltool >= 0.35.0
26BuildRequires: libtool
27BuildRequires: gnome-common
28BuildRequires: desktop-file-utils
29BuildRequires: scrollkeeper
30BuildRequires: gettext >= 0.10.36
31BuildRequires: glib2-devel >= 2.6.0
32BuildRequires: gtk2-devel >= 2.8.0
33BuildRequires: gnome-vfs2-devel >= 2.0.0
34BuildRequires: libgnomeui-devel >= 2.4.0
35BuildRequires: gnome-doc-utils >= 0.3.2
36BuildRequires: perl(XML::Parser)
37BuildRequires: libSM-devel
38BuildRequires: fontconfig-devel
39
40Requires:      glib2 >= 2.6.0
41Requires:      gtk2 >= 2.8.0
42Requires:      gnome-vfs2 >= 2.0.0
43Requires:      gnome-vfs2-smb >= 2.0.0
44Requires:      libgnomeui >= 2.4.0
45
46Requires:         meld
47Requires(post):   scrollkeeper
48Requires(postun): scrollkeeper
49
50BuildRequires:   python-devel >= %{python_ver}
51BuildRequires:   exiv2-devel >= %{exiv2_ver}
52BuildRequires:   taglib-devel >= %{taglib_ver}
53BuildRequires:   libgsf-devel >= %{libgsf_ver}
54BuildRequires:   poppler-devel >= %{poppler_ver}
55
56Requires:        python >= %{python_ver}
57Requires:        exiv2 >= %{exiv2_ver}
58Requires:        taglib >= %{taglib_ver}
59Requires:        libgsf >= %{libgsf_ver}
60Requires:        poppler >= %{poppler_ver}
61
62Vendor: Project Vine
63Distribution: Vine Linux
64
65%description
66GNOME Commander is a nice and fast file manager for the GNOME desktop.
67In addition to performing the basic file manager functions the program is
68also an FTP-client and it can browse SMB-networks.
69
70%prep
71%setup -q
72%patch1 -p1 -b .libgsf
73
74%build
75export CFLAGS="$RPM_OPT_FLAGS -Wno-deprecated-declarations"
76%configure \
77   --disable-scrollkeeper \
78   --enable-python
79%{__make} %{?_smp_mflags}
80
81%install
82%{__rm} -rf %{buildroot}
83%{__make} \
84   INSTALL="%{__install} -c -p" \
85   DESTDIR=%{buildroot} \
86   install
87
88desktop-file-install \
89   --delete-original \
90   --vendor '' \
91   --remove-category Application \
92   --dir %{buildroot}%{_datadir}/applications \
93   %{buildroot}%{_datadir}/applications/%{name}.desktop
94
95%{__rm} -f %{buildroot}%{_libdir}/%{name}/*.{a,la}
96%{__rm} -f %{buildroot}%{_libdir}/%{name}/*/*.{a,la,py}
97
98%find_lang %{name}
99
100%post
101scrollkeeper-update -q -o %{_datadir}/omf/%{name} || :
102
103%postun
104scrollkeeper-update -q || :
105
106%clean
107%{__rm} -rf %{buildroot}
108
109%files -f %{name}.lang
110%defattr(-,root,root,-)
111%doc AUTHORS BUGS ChangeLog COPYING INSTALL NEWS README TODO doc/*.txt
112
113%{_bindir}/*
114%{_libdir}/%{name}/
115%{_mandir}/man1/%{name}.1*
116
117%{_datadir}/applications/%{name}.desktop
118
119%{_datadir}/gnome/help/%{name}/
120%{_datadir}/omf/%{name}/
121
122%{_datadir}/pixmaps/%{name}.png
123%{_datadir}/pixmaps/%{name}/
124
125%changelog
126* Sat Jan 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.17-1
127- new upstream release
128
129* Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.16-1
130- new upstream release
131- remove Patch0 (gnome-commander-1.2.8.15-poppler-0.24.x.patch)
132- remove Patch2 (gnome-commander-1.2.8.15-gcc47.patch) from fedora
133
134* Wed Dec 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.15-7
135- rebuild with exiv2-0.24
136
137* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.15-6
138- rebuild with poppler-0.24.2
139- update Patch0 (gnome-commander-1.2.8.15-poppler-0.24.x.patch)
140- add Patch1 (gnome-commander-1.2.8.15-libgsf.patch)
141- add Patch2 (gnome-commander-1.2.8.15-gcc47.patch) from fedora
142
143* Sun Oct 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.15-5
144- rebuild with poppler-0.20.4
145- add Patch0 (gnome-commander-1.2.8.15-poppler-0.20.x.patch)
146
147* Sun Jul 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.15-4
148- rebuild with exiv2-0.23
149
150* Mon May 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.15-3
151- rebuild with exiv2-0.22
152
153* Sun Feb 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.15-2
154- rebuild with python-2.7.2
155
156* Wed Dec 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.15-1
157- new upstream release
158
159* Fri Oct 07 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.14-1
160- new upstream release
161
162* Sat Aug 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.13-1
163- new upstream release
164
165* Sun Aug  7 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.8.11-2
166- rebuilt with exiv2-0.21.1
167- added BR: fontconfig-devel
168
169* Sat May 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.11-1
170- new upstream release
171- change Group: User Interface/Desktops instead of Applications/File
172
173* Sat Mar 12 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.8.9-2
174- rebuilt with poppler-0.16.3
175
176* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.9-1
177- new upstream release
178
179* Wed Oct 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.8-1
180- new upstream release
181
182* Sun Jun 27 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.6-1
183- new upstream release
184
185* Wed May 05 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.8.5-2
186- rebuilt with exiv2-0.19
187
188* Sun Mar 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.5-1
189- Initial build for Vine Linux
190
191* Wed Jan 13 2010 Piotr Eljasiak <epiotr@use.pl>
192- added gnome-vfs2-smb dependency
193- replaced exiv2 with exiv2-libs dependency for FC>=8
194
195* Fri Oct 3 2008 Yuriy Penkin <yuriy.penkin@gmail.com>
196- changed dependencies for intltool to 0.35.0
197
198* Thu Aug 7 2008 Piotr Eljasiak <epiotr@use.pl>
199- added poppler dependencies
200
201* Fri Jul 11 2008 Piotr Eljasiak <epiotr@use.pl>
202 - added build deps
203
204* Fri Oct  5 2007 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.2.4-4
205- Drop yelp dependency
206
207* Wed Aug 22 2007 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.2.4-3.dist.2
208- Mass rebuild (buildID or binutils issue)
209
210* Fri Aug  3 2007 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.2.4-3.dist.1
211- License update
212
213* Wed Jul 18 2007 Piotr Eljasiak <epiotr@use.pl> 1.2.5-1
214 - replaced libexif and libiptcdata with exiv2 library
215
216* Tue Jul 10 2007 Piotr Eljasiak <epiotr@use.pl> 1.2.5-1
217- replaced id3lib with taglib dependencies
218
219* Sat Jun 16 2007 Dušan Hokův <dusan@mirc.cz> 1.2.5-1
220- added cs description
221
222* Mon Jun 11 2007 Piotr Eljasiak <epiotr@use.pl> 1.2.5-1
223- minor tweaking with library versioning
224
225* Sun Feb 4 2007 Piotr Eljasiak <epiotr@use.pl> 1.2.4-1
226- added libgsf dependencies
227
228* Tue Jan 30 2007 Piotr Eljasiak <epiotr@use.pl> 1.2.4-1
229- added build and runtime deps for python and gnome-python2-gnomevfs
230
231* Sat Jan 20 2007 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.2.3-5
232- Require meld (#225324)
233
234* Wed Jan 10 2007 Piotr Eljasiak <epiotr@use.pl> 1.2.4-1
235- removed unneeded .py files
236
237* Thu Dec 21 2006 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.2.3-2
238- Clean up.
239
240* Sun Dec 17 2006 Piotr Eljasiak <epiotr@use.pl> 1.2.4-1
241- use version requirements from configure.in
242- changed dependencies from glib to glib2
243
244* Fri Dec 15 2006 Stephanos Manos <stefmanos AT gmail DOT com> - 1.2.4-1
245- removed not needed .a files
246- added build and runtime deps for libexif id3lib
247
248* Tue Dec 12 2006 Stephanos Manos <stefmanos AT gmail DOT com> - 1.2.4-1
249- minor cleanups/fixes to make rpmlint silent
250       -changelog: entries starting with % (added a second %)
251       -changelog: replaced tabs with spaces
252       -descriptions: splitted in multiple lines
253       -summary: removed ending dot
254       -license: changed license-tag form GPL2 to GPL
255* Tue Nov 14 2006 Piotr Eljasiak <epiotr@use.pl>
256- fixed Source0 address
257
258* Mon Jul 17 2006 Piotr Eljasiak <epiotr@use.pl>
259- added glib dependencies
260
261* Sun May 14 2006 Stephanos Manos <stefmanos@gmail.com>
262- Fixed Scrollkeeper database update
263        -disabled scrollkeeper update from make
264        -added scrollkeeper-database-update in the %%post & %%postun section
265- Added %%post & %%postun entries for the desktop file
266- Added %%post & %%postun entries for the gtk+ icon cache file
267
268* Sun Apr 9 2006 Piotr Eljasiak <epiotr@use.pl>
269- minor cleanups
270
271* Sun Mar 5 2006 Piotr Eljasiak <epiotr@use.pl>
272- added OMF files
273
274* Mon Feb 13 2006 Piotr Eljasiak <epiotr@use.pl>
275- install gnome-commander icon to %%{_datadir}/pixmaps/
276- install gnome-commander.1* to %%{_mandir}/man1/
277
278* Sat Feb 11 2006 Piotr Eljasiak <epiotr@use.pl>
279- set default srcext to .bz2
280
281* Fri Jan 28 2005 Piotr Eljasiak <epiotr@use.pl>
282- fixed typo: rpm --> rpmbuild
283
284* Mon May 03 2004 Piotr Eljasiak <epiotr@use.pl>
285- converted spec file to utf-8
286- used RPM macros a bit more
287
288* Thu Jun 19 2003 Piotr Eljasiak <epiotr@use.pl>
289- added libraries
290
291* Tue Mar 25 2003 Piotr Eljasiak <epiotr@use.pl>
292- updated Sources
293
294* Mon Jan 20 2003 Piotr Eljasiak <epiotr@use.pl>
295- added build dependencies
296
297* Fri Jan 10 2003 Piotr Eljasiak <epiotr@use.pl>
298- added localization
299
300* Thu Jan 09 2003 Piotr Eljasiak <epiotr@use.pl>
301- added dependencies
302
303* Mon Jun 24 2002 Piotr Eljasiak <epiotr@use.pl>
304- more cleanup in install section
305
306* Sat Jun 15 2002 Piotr Eljasiak <epiotr@use.pl>
307- simplified install and files sections
308
309* Mon Jun 10 2002 Piotr Eljasiak <epiotr@use.pl>
310- .spec file is now generated from .spec.in
311
312* Mon Jun 10 2002 Marcus Bjurman <marbj499@student.liu.se>
313- The default icon for this project is now called gnome-commander.png
314  The xpm variant of the same icon is now also renamed in the same manner.
315
316* Sat Mar  9 2002 Marcus Bjurman <marbj499@student.liu.se>
317- Pumped up the version nr
318
319* Sun Nov  4 2001 Marcus Bjurman <marbj499@student.liu.se>
320- Initial build.
Note: See TracBrowser for help on using the repository browser.