source: projects/specs/trunk/g/gnome-commander/gnome-commander-vl.spec @ 8056

Revision 8056, 9.6 KB checked in by Takemikaduchi, 10 years ago (diff)

KDE-4.11.4
exiv2-0.24
wireshark-1.10.5, etc...

Line 
1%define        python_ver            2.7
2%define        exiv2_ver             0.23
3%define        taglib_ver            1.4
4%define        libgsf_ver            1.12.0
5%define        poppler_ver           0.14.2
6
7Name:          gnome-commander
8Summary:       A nice and fast file manager for the GNOME desktop
9Summary(pl):   Menadżer plików dla GNOME oparty o Norton Commander'a (TM)
10Summary(sv):   GNOME Commander är en snabb och smidig filhanderare för GNOME
11Version:       1.2.8.15
12Release:       7%{?_dist_release}
13
14Group:         User Interface/Desktops
15License:       GPLv2+
16URL:           http://www.nongnu.org/gcmd/
17Source0:       ftp://ftp.gnome.org/pub/GNOME/sources/%{name}/1.2/%{name}-%{version}.tar.xz
18
19Patch0:        gnome-commander-1.2.8.15-poppler-0.24.x.patch
20Patch1:        gnome-commander-1.2.8.15-libgsf.patch
21Patch2:        gnome-commander-1.2.8.15-gcc47.patch
22
23BuildRoot:     %{_tmppath}/%{name}-%{version}-root
24
25BuildRequires: automake
26BuildRequires: flex
27BuildRequires: intltool >= 0.35.0
28BuildRequires: libtool
29BuildRequires: gnome-common
30BuildRequires: desktop-file-utils
31BuildRequires: scrollkeeper
32BuildRequires: gettext >= 0.10.36
33BuildRequires: glib2-devel >= 2.6.0
34BuildRequires: gtk2-devel >= 2.8.0
35BuildRequires: gnome-vfs2-devel >= 2.0.0
36BuildRequires: libgnomeui-devel >= 2.4.0
37BuildRequires: gnome-doc-utils >= 0.3.2
38BuildRequires: perl(XML::Parser)
39BuildRequires: libSM-devel
40BuildRequires: fontconfig-devel
41
42Requires:      glib2 >= 2.6.0
43Requires:      gtk2 >= 2.8.0
44Requires:      gnome-vfs2 >= 2.0.0
45Requires:      gnome-vfs2-smb >= 2.0.0
46Requires:      libgnomeui >= 2.4.0
47
48Requires:         meld
49Requires(post):   scrollkeeper
50Requires(postun): scrollkeeper
51
52BuildRequires:   python-devel >= %{python_ver}
53BuildRequires:   exiv2-devel >= %{exiv2_ver}
54BuildRequires:   taglib-devel >= %{taglib_ver}
55BuildRequires:   libgsf-devel >= %{libgsf_ver}
56BuildRequires:   poppler-devel >= %{poppler_ver}
57
58Requires:        python >= %{python_ver}
59Requires:        exiv2 >= %{exiv2_ver}
60Requires:        taglib >= %{taglib_ver}
61Requires:        libgsf >= %{libgsf_ver}
62Requires:        poppler >= %{poppler_ver}
63
64Vendor: Project Vine
65Distribution: Vine Linux
66
67%description
68GNOME Commander is a nice and fast file manager for the GNOME desktop.
69In addition to performing the basic file manager functions the program is
70also an FTP-client and it can browse SMB-networks.
71
72%prep
73%setup -q
74%patch0 -p1 -b .poppler
75%patch1 -p1 -b .libgsf
76%patch2 -p1 -b .gcc
77
78%build
79export CFLAGS="$RPM_OPT_FLAGS -Wno-deprecated-declarations"
80%configure \
81   --disable-scrollkeeper \
82   --enable-python
83%{__make} %{?_smp_mflags}
84
85%install
86%{__rm} -rf %{buildroot}
87%{__make} \
88   INSTALL="%{__install} -c -p" \
89   DESTDIR=%{buildroot} \
90   install
91
92desktop-file-install \
93   --delete-original \
94   --vendor '' \
95   --remove-category Application \
96   --dir %{buildroot}%{_datadir}/applications \
97   %{buildroot}%{_datadir}/applications/%{name}.desktop
98
99%{__rm} -f %{buildroot}%{_libdir}/%{name}/*.{a,la}
100%{__rm} -f %{buildroot}%{_libdir}/%{name}/*/*.{a,la,py}
101
102%find_lang %{name}
103
104%post
105scrollkeeper-update -q -o %{_datadir}/omf/%{name} || :
106
107%postun
108scrollkeeper-update -q || :
109
110%clean
111%{__rm} -rf %{buildroot}
112
113%files -f %{name}.lang
114%defattr(-,root,root,-)
115%doc AUTHORS BUGS ChangeLog COPYING INSTALL NEWS README TODO doc/*.txt
116
117%{_bindir}/*
118%{_libdir}/%{name}/
119%{_mandir}/man1/%{name}.1*
120
121%{_datadir}/applications/%{name}.desktop
122
123%{_datadir}/gnome/help/%{name}/
124%{_datadir}/omf/%{name}/
125
126%{_datadir}/pixmaps/%{name}.png
127%{_datadir}/pixmaps/%{name}/
128
129%changelog
130* Wed Dec 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.15-7
131- rebuild with exiv2-0.24
132
133* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.15-6
134- rebuild with poppler-0.24.2
135- update Patch0 (gnome-commander-1.2.8.15-poppler-0.24.x.patch)
136- add Patch1 (gnome-commander-1.2.8.15-libgsf.patch)
137- add Patch2 (gnome-commander-1.2.8.15-gcc47.patch) from fedora
138
139* Sun Oct 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.15-5
140- rebuild with poppler-0.20.4
141- add Patch0 (gnome-commander-1.2.8.15-poppler-0.20.x.patch)
142
143* Sun Jul 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.15-4
144- rebuild with exiv2-0.23
145
146* Mon May 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.15-3
147- rebuild with exiv2-0.22
148
149* Sun Feb 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.15-2
150- rebuild with python-2.7.2
151
152* Wed Dec 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.15-1
153- new upstream release
154
155* Fri Oct 07 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.14-1
156- new upstream release
157
158* Sat Aug 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.13-1
159- new upstream release
160
161* Sun Aug  7 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.8.11-2
162- rebuilt with exiv2-0.21.1
163- added BR: fontconfig-devel
164
165* Sat May 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.11-1
166- new upstream release
167- change Group: User Interface/Desktops instead of Applications/File
168
169* Sat Mar 12 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.8.9-2
170- rebuilt with poppler-0.16.3
171
172* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.9-1
173- new upstream release
174
175* Wed Oct 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.8-1
176- new upstream release
177
178* Sun Jun 27 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.6-1
179- new upstream release
180
181* Wed May 05 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.8.5-2
182- rebuilt with exiv2-0.19
183
184* Sun Mar 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.5-1
185- Initial build for Vine Linux
186
187* Wed Jan 13 2010 Piotr Eljasiak <epiotr@use.pl>
188- added gnome-vfs2-smb dependency
189- replaced exiv2 with exiv2-libs dependency for FC>=8
190
191* Fri Oct 3 2008 Yuriy Penkin <yuriy.penkin@gmail.com>
192- changed dependencies for intltool to 0.35.0
193
194* Thu Aug 7 2008 Piotr Eljasiak <epiotr@use.pl>
195- added poppler dependencies
196
197* Fri Jul 11 2008 Piotr Eljasiak <epiotr@use.pl>
198 - added build deps
199
200* Fri Oct  5 2007 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.2.4-4
201- Drop yelp dependency
202
203* Wed Aug 22 2007 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.2.4-3.dist.2
204- Mass rebuild (buildID or binutils issue)
205
206* Fri Aug  3 2007 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.2.4-3.dist.1
207- License update
208
209* Wed Jul 18 2007 Piotr Eljasiak <epiotr@use.pl> 1.2.5-1
210 - replaced libexif and libiptcdata with exiv2 library
211
212* Tue Jul 10 2007 Piotr Eljasiak <epiotr@use.pl> 1.2.5-1
213- replaced id3lib with taglib dependencies
214
215* Sat Jun 16 2007 Dušan Hokův <dusan@mirc.cz> 1.2.5-1
216- added cs description
217
218* Mon Jun 11 2007 Piotr Eljasiak <epiotr@use.pl> 1.2.5-1
219- minor tweaking with library versioning
220
221* Sun Feb 4 2007 Piotr Eljasiak <epiotr@use.pl> 1.2.4-1
222- added libgsf dependencies
223
224* Tue Jan 30 2007 Piotr Eljasiak <epiotr@use.pl> 1.2.4-1
225- added build and runtime deps for python and gnome-python2-gnomevfs
226
227* Sat Jan 20 2007 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.2.3-5
228- Require meld (#225324)
229
230* Wed Jan 10 2007 Piotr Eljasiak <epiotr@use.pl> 1.2.4-1
231- removed unneeded .py files
232
233* Thu Dec 21 2006 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.2.3-2
234- Clean up.
235
236* Sun Dec 17 2006 Piotr Eljasiak <epiotr@use.pl> 1.2.4-1
237- use version requirements from configure.in
238- changed dependencies from glib to glib2
239
240* Fri Dec 15 2006 Stephanos Manos <stefmanos AT gmail DOT com> - 1.2.4-1
241- removed not needed .a files
242- added build and runtime deps for libexif id3lib
243
244* Tue Dec 12 2006 Stephanos Manos <stefmanos AT gmail DOT com> - 1.2.4-1
245- minor cleanups/fixes to make rpmlint silent
246       -changelog: entries starting with % (added a second %)
247       -changelog: replaced tabs with spaces
248       -descriptions: splitted in multiple lines
249       -summary: removed ending dot
250       -license: changed license-tag form GPL2 to GPL
251* Tue Nov 14 2006 Piotr Eljasiak <epiotr@use.pl>
252- fixed Source0 address
253
254* Mon Jul 17 2006 Piotr Eljasiak <epiotr@use.pl>
255- added glib dependencies
256
257* Sun May 14 2006 Stephanos Manos <stefmanos@gmail.com>
258- Fixed Scrollkeeper database update
259        -disabled scrollkeeper update from make
260        -added scrollkeeper-database-update in the %%post & %%postun section
261- Added %%post & %%postun entries for the desktop file
262- Added %%post & %%postun entries for the gtk+ icon cache file
263
264* Sun Apr 9 2006 Piotr Eljasiak <epiotr@use.pl>
265- minor cleanups
266
267* Sun Mar 5 2006 Piotr Eljasiak <epiotr@use.pl>
268- added OMF files
269
270* Mon Feb 13 2006 Piotr Eljasiak <epiotr@use.pl>
271- install gnome-commander icon to %%{_datadir}/pixmaps/
272- install gnome-commander.1* to %%{_mandir}/man1/
273
274* Sat Feb 11 2006 Piotr Eljasiak <epiotr@use.pl>
275- set default srcext to .bz2
276
277* Fri Jan 28 2005 Piotr Eljasiak <epiotr@use.pl>
278- fixed typo: rpm --> rpmbuild
279
280* Mon May 03 2004 Piotr Eljasiak <epiotr@use.pl>
281- converted spec file to utf-8
282- used RPM macros a bit more
283
284* Thu Jun 19 2003 Piotr Eljasiak <epiotr@use.pl>
285- added libraries
286
287* Tue Mar 25 2003 Piotr Eljasiak <epiotr@use.pl>
288- updated Sources
289
290* Mon Jan 20 2003 Piotr Eljasiak <epiotr@use.pl>
291- added build dependencies
292
293* Fri Jan 10 2003 Piotr Eljasiak <epiotr@use.pl>
294- added localization
295
296* Thu Jan 09 2003 Piotr Eljasiak <epiotr@use.pl>
297- added dependencies
298
299* Mon Jun 24 2002 Piotr Eljasiak <epiotr@use.pl>
300- more cleanup in install section
301
302* Sat Jun 15 2002 Piotr Eljasiak <epiotr@use.pl>
303- simplified install and files sections
304
305* Mon Jun 10 2002 Piotr Eljasiak <epiotr@use.pl>
306- .spec file is now generated from .spec.in
307
308* Mon Jun 10 2002 Marcus Bjurman <marbj499@student.liu.se>
309- The default icon for this project is now called gnome-commander.png
310  The xpm variant of the same icon is now also renamed in the same manner.
311
312* Sat Mar  9 2002 Marcus Bjurman <marbj499@student.liu.se>
313- Pumped up the version nr
314
315* Sun Nov  4 2001 Marcus Bjurman <marbj499@student.liu.se>
316- Initial build.
Note: See TracBrowser for help on using the repository browser.