source: projects/specs/trunk/g/gnome-commander/gnome-commander-vl.spec @ 4663

Revision 4663, 8.2 KB checked in by inagaki, 13 years ago (diff)

update: exiv2, libgexiv2. fotoxx, printoxx, gthumb, gnome-commander, strigi, shotwell, ufraw

Line 
1%define        python_ver            2.6
2%define        exiv2_ver             0.14
3%define        taglib_ver            1.4
4%define        libgsf_ver            1.12.0
5%define        poppler_ver           0.14.2
6
7Name:          gnome-commander
8Summary:       A nice and fast file manager for the GNOME desktop
9Summary(pl):   Menadżer plików dla GNOME oparty o Norton Commander'a (TM)
10Summary(sv):   GNOME Commander är en snabb och smidig filhanderare för GNOME
11Version:       1.2.8.11
12Release:       2%{?_dist_release}
13
14Group:         User Interface/Desktops
15License:       GPLv2+
16URL:           http://www.nongnu.org/gcmd/
17Source0:       ftp://ftp.gnome.org/pub/GNOME/sources/%{name}/1.2/%{name}-%{version}.tar.bz2
18BuildRoot:     %{_tmppath}/%{name}-%{version}-root
19
20BuildRequires: automake
21BuildRequires: flex
22BuildRequires: intltool >= 0.35.0
23BuildRequires: libtool
24BuildRequires: gnome-common
25BuildRequires: desktop-file-utils
26BuildRequires: scrollkeeper
27BuildRequires: gettext >= 0.10.36
28BuildRequires: glib2-devel >= 2.6.0
29BuildRequires: gtk2-devel >= 2.8.0
30BuildRequires: gnome-vfs2-devel >= 2.0.0
31BuildRequires: libgnomeui-devel >= 2.4.0
32BuildRequires: gnome-doc-utils >= 0.3.2
33BuildRequires: perl(XML::Parser)
34BuildRequires: libSM-devel
35BuildRequires: fontconfig-devel
36
37Requires:      glib2 >= 2.6.0
38Requires:      gtk2 >= 2.8.0
39Requires:      gnome-vfs2 >= 2.0.0
40Requires:      gnome-vfs2-smb >= 2.0.0
41Requires:      libgnomeui >= 2.4.0
42
43Requires:         meld
44Requires(post):   scrollkeeper
45Requires(postun): scrollkeeper
46
47BuildRequires:   python-devel >= %{python_ver}
48BuildRequires:   exiv2-devel >= %{exiv2_ver}
49BuildRequires:   taglib-devel >= %{taglib_ver}
50BuildRequires:   libgsf-devel >= %{libgsf_ver}
51BuildRequires:   poppler-devel >= %{poppler_ver}
52
53Requires:        python >= %{python_ver}
54Requires:        exiv2 >= %{exiv2_ver}
55Requires:        taglib >= %{taglib_ver}
56Requires:        libgsf >= %{libgsf_ver}
57Requires:        poppler >= %{poppler_ver}
58
59Vendor: Project Vine
60Distribution: Vine Linux
61
62%description
63GNOME Commander is a nice and fast file manager for the GNOME desktop.
64In addition to performing the basic file manager functions the program is
65also an FTP-client and it can browse SMB-networks.
66
67%prep
68%setup -q
69
70%build
71%configure \
72   --disable-scrollkeeper \
73   --enable-python
74%{__make} %{?_smp_mflags}
75
76%install
77%{__rm} -rf %{buildroot}
78%{__make} \
79   INSTALL="%{__install} -c -p" \
80   DESTDIR=%{buildroot} \
81   install
82
83desktop-file-install \
84   --delete-original \
85   --vendor '' \
86   --remove-category Application \
87   --dir %{buildroot}%{_datadir}/applications \
88   %{buildroot}%{_datadir}/applications/%{name}.desktop
89
90%{__rm} -f %{buildroot}%{_libdir}/%{name}/*.{a,la}
91%{__rm} -f %{buildroot}%{_libdir}/%{name}/*/*.{a,la,py}
92
93%find_lang %{name}
94
95%post
96scrollkeeper-update -q -o %{_datadir}/omf/%{name} || :
97
98%postun
99scrollkeeper-update -q || :
100
101%clean
102%{__rm} -rf %{buildroot}
103
104%files -f %{name}.lang
105%defattr(-,root,root,-)
106%doc AUTHORS BUGS ChangeLog COPYING INSTALL NEWS README TODO doc/*.txt
107
108%{_bindir}/*
109%{_libdir}/%{name}/
110%{_mandir}/man1/%{name}.1*
111
112%{_datadir}/applications/%{name}.desktop
113
114%{_datadir}/gnome/help/%{name}/
115%{_datadir}/omf/%{name}/
116
117%{_datadir}/pixmaps/%{name}.png
118%{_datadir}/pixmaps/%{name}/
119
120%changelog
121* Sun Aug  7 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.8.11-2
122- rebuilt with exiv2-0.21.1
123- added BR: fontconfig-devel
124
125* Sat May 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.11-1
126- new upstream release
127- change Group: User Interface/Desktops instead of Applications/File
128
129* Sat Mar 12 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.8.9-2
130- rebuilt with poppler-0.16.3
131
132* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.9-1
133- new upstream release
134
135* Wed Oct 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.8-1
136- new upstream release
137
138* Sun Jun 27 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.6-1
139- new upstream release
140
141* Wed May 05 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.8.5-2
142- rebuilt with exiv2-0.19
143
144* Sun Mar 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.5-1
145- Initial build for Vine Linux
146
147* Wed Jan 13 2010 Piotr Eljasiak <epiotr@use.pl>
148- added gnome-vfs2-smb dependency
149- replaced exiv2 with exiv2-libs dependency for FC>=8
150
151* Fri Oct 3 2008 Yuriy Penkin <yuriy.penkin@gmail.com>
152- changed dependencies for intltool to 0.35.0
153
154* Thu Aug 7 2008 Piotr Eljasiak <epiotr@use.pl>
155- added poppler dependencies
156
157* Fri Jul 11 2008 Piotr Eljasiak <epiotr@use.pl>
158 - added build deps
159
160* Fri Oct  5 2007 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.2.4-4
161- Drop yelp dependency
162
163* Wed Aug 22 2007 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.2.4-3.dist.2
164- Mass rebuild (buildID or binutils issue)
165
166* Fri Aug  3 2007 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.2.4-3.dist.1
167- License update
168
169* Wed Jul 18 2007 Piotr Eljasiak <epiotr@use.pl> 1.2.5-1
170 - replaced libexif and libiptcdata with exiv2 library
171
172* Tue Jul 10 2007 Piotr Eljasiak <epiotr@use.pl> 1.2.5-1
173- replaced id3lib with taglib dependencies
174
175* Sat Jun 16 2007 Dušan Hokův <dusan@mirc.cz> 1.2.5-1
176- added cs description
177
178* Mon Jun 11 2007 Piotr Eljasiak <epiotr@use.pl> 1.2.5-1
179- minor tweaking with library versioning
180
181* Sun Feb 4 2007 Piotr Eljasiak <epiotr@use.pl> 1.2.4-1
182- added libgsf dependencies
183
184* Wed Jan 30 2007 Piotr Eljasiak <epiotr@use.pl> 1.2.4-1
185- added build and runtime deps for python and gnome-python2-gnomevfs
186
187* Tue Jan 20 2007 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.2.3-5
188- Require meld (#225324)
189
190* Wed Jan 10 2007 Piotr Eljasiak <epiotr@use.pl> 1.2.4-1
191- removed unneeded .py files
192
193* Thu Dec 21 2006 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.2.3-2
194- Clean up.
195
196* Sun Dec 17 2006 Piotr Eljasiak <epiotr@use.pl> 1.2.4-1
197- use version requirements from configure.in
198- changed dependencies from glib to glib2
199
200* Fri Dec 15 2006 Stephanos Manos <stefmanos AT gmail DOT com> - 1.2.4-1
201- removed not needed .a files
202- added build and runtime deps for libexif id3lib
203
204* Tue Dec 12 2006 Stephanos Manos <stefmanos AT gmail DOT com> - 1.2.4-1
205- minor cleanups/fixes to make rpmlint silent
206       -changelog: entries starting with % (added a second %)
207       -changelog: replaced tabs with spaces
208       -descriptions: splitted in multiple lines
209       -summary: removed ending dot
210       -license: changed license-tag form GPL2 to GPL
211* Tue Nov 14 2006 Piotr Eljasiak <epiotr@use.pl>
212- fixed Source0 address
213
214* Mon Jul 17 2006 Piotr Eljasiak <epiotr@use.pl>
215- added glib dependencies
216
217* Sun May 14 2006 Stephanos Manos <stefmanos@gmail.com>
218- Fixed Scrollkeeper database update
219        -disabled scrollkeeper update from make
220        -added scrollkeeper-database-update in the %%post & %%postun section
221- Added %%post & %%postun entries for the desktop file
222- Added %%post & %%postun entries for the gtk+ icon cache file
223
224* Sun Apr 9 2006 Piotr Eljasiak <epiotr@use.pl>
225- minor cleanups
226
227* Thu Mar 5 2006 Piotr Eljasiak <epiotr@use.pl>
228- added OMF files
229
230* Mon Feb 13 2006 Piotr Eljasiak <epiotr@use.pl>
231- install gnome-commander icon to %%{_datadir}/pixmaps/
232- install gnome-commander.1* to %%{_mandir}/man1/
233
234* Sat Feb 11 2006 Piotr Eljasiak <epiotr@use.pl>
235- set default srcext to .bz2
236
237* Fri Jan 28 2005 Piotr Eljasiak <epiotr@use.pl>
238- fixed typo: rpm --> rpmbuild
239
240* Mon May 03 2004 Piotr Eljasiak <epiotr@use.pl>
241- converted spec file to utf-8
242- used RPM macros a bit more
243
244* Thu Jun 19 2003 Piotr Eljasiak <epiotr@use.pl>
245- added libraries
246
247* Tue Mar 25 2003 Piotr Eljasiak <epiotr@use.pl>
248- updated Sources
249
250* Mon Jan 20 2003 Piotr Eljasiak <epiotr@use.pl>
251- added build dependencies
252
253* Fri Jan 10 2003 Piotr Eljasiak <epiotr@use.pl>
254- added localization
255
256* Thu Jan 09 2003 Piotr Eljasiak <epiotr@use.pl>
257- added dependencies
258
259* Mon Jun 24 2002 Piotr Eljasiak <epiotr@use.pl>
260- more cleanup in install section
261
262* Sat Jun 15 2002 Piotr Eljasiak <epiotr@use.pl>
263- simplified install and files sections
264
265* Mon Jun 10 2002 Piotr Eljasiak <epiotr@use.pl>
266- .spec file is now generated from .spec.in
267
268* Mon Jun 10 2002 Marcus Bjurman <marbj499@student.liu.se>
269- The default icon for this project is now called gnome-commander.png
270  The xpm variant of the same icon is now also renamed in the same manner.
271
272* Sat Mar  9 2002 Marcus Bjurman <marbj499@student.liu.se>
273- Pumped up the version nr
274
275* Sun Nov  4 2001 Marcus Bjurman <marbj499@student.liu.se>
276- Initial build.
Note: See TracBrowser for help on using the repository browser.