source: projects/specs/trunk/g/gnome-commander/gnome-commander-vl.spec @ 2998

Revision 2998, 7.9 KB checked in by inagaki, 13 years ago (diff)

update: calibre, evince, epdfview, gimp, gambas{2,3}, gnome-commander, inkscape, poppler, pypopper, rcairo, ruby-gnome2, tracker

Line 
1%define        python_ver            2.6
2%define        exiv2_ver             0.14
3%define        taglib_ver            1.4
4%define        libgsf_ver            1.12.0
5%define        poppler_ver           0.14.2
6
7Name:          gnome-commander
8Summary:       A nice and fast file manager for the GNOME desktop
9Summary(pl):   Menadżer plików dla GNOME oparty o Norton Commander'a (TM)
10Summary(sv):   GNOME Commander är en snabb och smidig filhanderare för GNOME
11Version:       1.2.8.9
12Release:       2%{?_dist_release}
13
14Group:         Applications/File
15License:       GPLv2+
16URL:           http://www.nongnu.org/gcmd/
17Source0:       ftp://ftp.gnome.org/pub/GNOME/sources/%{name}/1.2/%{name}-%{version}.tar.bz2
18BuildRoot:     %{_tmppath}/%{name}-%{version}-root
19
20BuildRequires: automake
21BuildRequires: flex
22BuildRequires: intltool >= 0.35.0
23BuildRequires: libtool
24BuildRequires: gnome-common
25BuildRequires: desktop-file-utils
26BuildRequires: scrollkeeper
27BuildRequires: gettext >= 0.10.36
28BuildRequires: glib2-devel >= 2.6.0
29BuildRequires: gtk2-devel >= 2.8.0
30BuildRequires: gnome-vfs2-devel >= 2.0.0
31BuildRequires: libgnomeui-devel >= 2.4.0
32BuildRequires: gnome-doc-utils >= 0.3.2
33BuildRequires: perl(XML::Parser)
34BuildRequires: libSM-devel
35
36Requires:      glib2 >= 2.6.0
37Requires:      gtk2 >= 2.8.0
38Requires:      gnome-vfs2 >= 2.0.0
39Requires:      gnome-vfs2-smb >= 2.0.0
40Requires:      libgnomeui >= 2.4.0
41
42Requires:         meld
43Requires(post):   scrollkeeper
44Requires(postun): scrollkeeper
45
46BuildRequires:   python-devel >= %{python_ver}
47BuildRequires:   exiv2-devel >= %{exiv2_ver}
48BuildRequires:   taglib-devel >= %{taglib_ver}
49BuildRequires:   libgsf-devel >= %{libgsf_ver}
50BuildRequires:   poppler-devel >= %{poppler_ver}
51
52Requires:        python >= %{python_ver}
53Requires:        exiv2 >= %{exiv2_ver}
54Requires:        taglib >= %{taglib_ver}
55Requires:        libgsf >= %{libgsf_ver}
56Requires:        poppler >= %{poppler_ver}
57
58Vendor: Project Vine
59Distribution: Vine Linux
60
61%description
62GNOME Commander is a nice and fast file manager for the GNOME desktop.
63In addition to performing the basic file manager functions the program is
64also an FTP-client and it can browse SMB-networks.
65
66%prep
67%setup -q
68
69%build
70%configure \
71   --disable-scrollkeeper \
72   --enable-python
73%{__make} %{?_smp_mflags}
74
75%install
76%{__rm} -rf %{buildroot}
77%{__make} \
78   INSTALL="%{__install} -c -p" \
79   DESTDIR=%{buildroot} \
80   install
81
82desktop-file-install \
83   --delete-original \
84   --vendor '' \
85   --remove-category Application \
86   --dir %{buildroot}%{_datadir}/applications \
87   %{buildroot}%{_datadir}/applications/%{name}.desktop
88
89%{__rm} -f %{buildroot}%{_libdir}/%{name}/*.{a,la}
90%{__rm} -f %{buildroot}%{_libdir}/%{name}/*/*.{a,la,py}
91
92%find_lang %{name}
93
94%post
95scrollkeeper-update -q -o %{_datadir}/omf/%{name} || :
96
97%postun
98scrollkeeper-update -q || :
99
100%clean
101%{__rm} -rf %{buildroot}
102
103%files -f %{name}.lang
104%defattr(-,root,root,-)
105%doc AUTHORS BUGS ChangeLog COPYING INSTALL NEWS README TODO doc/*.txt
106
107%{_bindir}/*
108%{_libdir}/%{name}/
109%{_mandir}/man1/%{name}.1*
110
111%{_datadir}/applications/%{name}.desktop
112
113%{_datadir}/gnome/help/%{name}/
114%{_datadir}/omf/%{name}/
115
116%{_datadir}/pixmaps/%{name}.png
117%{_datadir}/pixmaps/%{name}/
118
119%changelog
120* Sat Mar 12 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.8.9-2
121- rebuilt with poppler-0.16.3
122
123* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.9-1
124- new upstream release
125
126* Wed Oct 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.8-1
127- new upstream release
128
129* Sun Jun 27 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.6-1
130- new upstream release
131
132* Wed May 05 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.8.5-2
133- rebuilt with exiv2-0.19
134
135* Sun Mar 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8.5-1
136- Initial build for Vine Linux
137
138* Wed Jan 13 2010 Piotr Eljasiak <epiotr@use.pl>
139- added gnome-vfs2-smb dependency
140- replaced exiv2 with exiv2-libs dependency for FC>=8
141
142* Fri Oct 3 2008 Yuriy Penkin <yuriy.penkin@gmail.com>
143- changed dependencies for intltool to 0.35.0
144
145* Thu Aug 7 2008 Piotr Eljasiak <epiotr@use.pl>
146- added poppler dependencies
147
148* Fri Jul 11 2008 Piotr Eljasiak <epiotr@use.pl>
149 - added build deps
150
151* Fri Oct  5 2007 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.2.4-4
152- Drop yelp dependency
153
154* Wed Aug 22 2007 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.2.4-3.dist.2
155- Mass rebuild (buildID or binutils issue)
156
157* Fri Aug  3 2007 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.2.4-3.dist.1
158- License update
159
160* Wed Jul 18 2007 Piotr Eljasiak <epiotr@use.pl> 1.2.5-1
161 - replaced libexif and libiptcdata with exiv2 library
162
163* Tue Jul 10 2007 Piotr Eljasiak <epiotr@use.pl> 1.2.5-1
164- replaced id3lib with taglib dependencies
165
166* Sat Jun 16 2007 Dušan Hokův <dusan@mirc.cz> 1.2.5-1
167- added cs description
168
169* Mon Jun 11 2007 Piotr Eljasiak <epiotr@use.pl> 1.2.5-1
170- minor tweaking with library versioning
171
172* Sun Feb 4 2007 Piotr Eljasiak <epiotr@use.pl> 1.2.4-1
173- added libgsf dependencies
174
175* Wed Jan 30 2007 Piotr Eljasiak <epiotr@use.pl> 1.2.4-1
176- added build and runtime deps for python and gnome-python2-gnomevfs
177
178* Tue Jan 20 2007 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.2.3-5
179- Require meld (#225324)
180
181* Wed Jan 10 2007 Piotr Eljasiak <epiotr@use.pl> 1.2.4-1
182- removed unneeded .py files
183
184* Thu Dec 21 2006 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.2.3-2
185- Clean up.
186
187* Sun Dec 17 2006 Piotr Eljasiak <epiotr@use.pl> 1.2.4-1
188- use version requirements from configure.in
189- changed dependencies from glib to glib2
190
191* Fri Dec 15 2006 Stephanos Manos <stefmanos AT gmail DOT com> - 1.2.4-1
192- removed not needed .a files
193- added build and runtime deps for libexif id3lib
194
195* Tue Dec 12 2006 Stephanos Manos <stefmanos AT gmail DOT com> - 1.2.4-1
196- minor cleanups/fixes to make rpmlint silent
197       -changelog: entries starting with % (added a second %)
198       -changelog: replaced tabs with spaces
199       -descriptions: splitted in multiple lines
200       -summary: removed ending dot
201       -license: changed license-tag form GPL2 to GPL
202* Tue Nov 14 2006 Piotr Eljasiak <epiotr@use.pl>
203- fixed Source0 address
204
205* Mon Jul 17 2006 Piotr Eljasiak <epiotr@use.pl>
206- added glib dependencies
207
208* Sun May 14 2006 Stephanos Manos <stefmanos@gmail.com>
209- Fixed Scrollkeeper database update
210        -disabled scrollkeeper update from make
211        -added scrollkeeper-database-update in the %%post & %%postun section
212- Added %%post & %%postun entries for the desktop file
213- Added %%post & %%postun entries for the gtk+ icon cache file
214
215* Sun Apr 9 2006 Piotr Eljasiak <epiotr@use.pl>
216- minor cleanups
217
218* Thu Mar 5 2006 Piotr Eljasiak <epiotr@use.pl>
219- added OMF files
220
221* Mon Feb 13 2006 Piotr Eljasiak <epiotr@use.pl>
222- install gnome-commander icon to %%{_datadir}/pixmaps/
223- install gnome-commander.1* to %%{_mandir}/man1/
224
225* Sat Feb 11 2006 Piotr Eljasiak <epiotr@use.pl>
226- set default srcext to .bz2
227
228* Fri Jan 28 2005 Piotr Eljasiak <epiotr@use.pl>
229- fixed typo: rpm --> rpmbuild
230
231* Mon May 03 2004 Piotr Eljasiak <epiotr@use.pl>
232- converted spec file to utf-8
233- used RPM macros a bit more
234
235* Thu Jun 19 2003 Piotr Eljasiak <epiotr@use.pl>
236- added libraries
237
238* Tue Mar 25 2003 Piotr Eljasiak <epiotr@use.pl>
239- updated Sources
240
241* Mon Jan 20 2003 Piotr Eljasiak <epiotr@use.pl>
242- added build dependencies
243
244* Fri Jan 10 2003 Piotr Eljasiak <epiotr@use.pl>
245- added localization
246
247* Thu Jan 09 2003 Piotr Eljasiak <epiotr@use.pl>
248- added dependencies
249
250* Mon Jun 24 2002 Piotr Eljasiak <epiotr@use.pl>
251- more cleanup in install section
252
253* Sat Jun 15 2002 Piotr Eljasiak <epiotr@use.pl>
254- simplified install and files sections
255
256* Mon Jun 10 2002 Piotr Eljasiak <epiotr@use.pl>
257- .spec file is now generated from .spec.in
258
259* Mon Jun 10 2002 Marcus Bjurman <marbj499@student.liu.se>
260- The default icon for this project is now called gnome-commander.png
261  The xpm variant of the same icon is now also renamed in the same manner.
262
263* Sat Mar  9 2002 Marcus Bjurman <marbj499@student.liu.se>
264- Pumped up the version nr
265
266* Sun Nov  4 2001 Marcus Bjurman <marbj499@student.liu.se>
267- Initial build.
Note: See TracBrowser for help on using the repository browser.