source: projects/specs/trunk/g/gnome-bluetooth/gnome-bluetooth-vl.spec @ 6401

Revision 6401, 12.5 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release

Line 
1Summary: GNOME Bluetooth Subsystem
2Summary(ja): GNOME Bluetooth サブシステム
3Name: gnome-bluetooth
4Version: 3.4.1
5Release: 1%{?_dist_release}
6License: GPLv2+
7Group: System Environment/Libraries
8URL: http://live.gnome.org/GnomeBluetooth
9Source0: http://ftp.gnome.org/pub/gnome/sources/gnome-bluetooth/3.4/%{name}-%{version}.tar.xz
10Source1: 61-gnome-bluetooth-rfkill.rules
11
12BuildRoot:      %{_tmppath}/%{name}-%{version}-root
13
14BuildRequires: bluez-libs-devel >= 2.8
15BuildRequires: libbonobo-devel >= 2.32.0
16BuildRequires: libbonoboui-devel >= 2.24.4
17BuildRequires: unique3-devel
18BuildRequires: libnotify-devel
19BuildRequires: nautilus-sendto-devel
20BuildRequires: gnome-doc-utils
21BuildRequires: intltool, automake, libtool, gettext
22
23Requires: %{name}-libs = %{version}-%{release}
24Requires: bluez >= 4.42
25Requires: obexd
26Requires(post): desktop-file-utils
27Requires(postun): desktop-file-utils
28ExcludeArch: s390 s390x
29
30## Patch1: gnome-bluetooth-0.8.0-desktop.patch
31
32Vendor: Project Vine
33Distribution: Vine Linux
34Packager: Takemikaduchi
35
36
37%description
38This package contains a library with widgets for Bluetooth applications.
39
40%description -l ja
41このパッケージには、 Bluetooth アプリケーションのためのウィジェットと
42ライブラリが含まれます。
43
44
45%package libs
46Summary: Libraries for applications, which use gnome-bluetooth
47Summary(ja):Gnome-bluetooth を使用するアプリケーション用ライブラリ
48Group: Development/Libraries
49
50%description libs
51This package contains the libraries for applications,
52which use gnome-bluetooth.
53
54%description libs -l ja
55このパッケージには Gnome-bluetoothを使用するアプリケーション用の
56ライブラリが含まれています。
57
58
59%package devel
60Summary: Files for the development of applications, which use gnome-bluetooth
61Summary(ja): Gnome-bluetoothを使用するアプリケーション開発用ファイル
62Group:          Development/Libraries
63License:        LGPLv2+
64Requires:       %{name}-libs = %{version}-%{release}
65Requires:       pkgconfig
66Requires:       gtk3-devel
67
68%description devel
69This package contains the files for the development of applications,
70which will use gnome-bluetooth.
71
72%description devel -l ja
73このパッケージにはGnome-bluetoothを使用するアプリケーションを
74開発するためのヘッダーファイルなどが含まれています(develパッケージ)
75
76
77%package -n     nautilus-sendto-gnome-bluetooth
78Summary:        Nautilus-sendto plugin for gnome-bluetooth
79Summary(ja):    gnome-bluetooth 用 nautilus-sendto プラグイン
80Group:          User Interface/Desktop
81License:        LGPLv2+
82Requires:       %{name}-libs = %{version}-%{release}
83Requires:       nautilus-sendto
84
85%description -n nautilus-sendto-gnome-bluetooth
86This package contains nautilus-sendto plugin for the gnome-bluetooth.
87
88%description -n nautilus-sendto-gnome-bluetooth -l ja
89このパッケージには gnome-bluetooth 用の nautilus-sendto プラグインが含まれています。
90
91
92%prep
93%setup -q -n gnome-bluetooth-%{version}
94
95
96%build
97%configure \
98        --disable-desktop-update \
99        --disable-icon-update \
100        --enable-nautilus-sendto \
101        --enable-introspection=yes
102make %{?_smp_mflags}
103
104
105%install
106rm -rf $RPM_BUILD_ROOT
107export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
108make DESTDIR=$RPM_BUILD_ROOT install
109
110# we do not want .la files
111rm -f $RPM_BUILD_ROOT%{_libdir}/gnome-vfs-2.0/modules/libbluetooth.*a
112rm -f $RPM_BUILD_ROOT%{_libdir}/libgnome-bluetooth.la
113rm -f $RPM_BUILD_ROOT/%{_libdir}/gnome-bluetooth/plugins/*.la
114rm -f $RPM_BUILD_ROOT/%{_libdir}/control-center-1/panels/*.la
115
116install -m0644 -D %{SOURCE1} $RPM_BUILD_ROOT/lib/udev/rules.d/61-gnome-bluetooth-rfkill.rules
117
118%find_lang gnome-bluetooth2
119%find_lang %{name} --with-gnome
120cat %{name}.lang >> gnome-bluetooth2.lang
121
122# save space by linking identical images in translated docs
123helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
124for f in $helpdir/C/figures/*.png; do
125  b="$(basename $f)"
126  for d in $helpdir/*; do
127    if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
128      g="$d/figures/$b"
129      if [ -f "$g" ]; then
130        if cmp -s $f $g; then
131          rm "$g"; ln -s "../../C/figures/$b" "$g"
132        fi
133      fi
134    fi
135  done
136done
137
138find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
139
140
141%clean
142rm -rf $RPM_BUILD_ROOT
143
144
145%post
146update-desktop-database -q
147
148%postun
149update-desktop-database -q
150if [ $1 -eq 0 ] ; then
151        touch --no-create %{_datadir}/icons/hicolor &>/dev/null
152        gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
153fi
154
155
156%post libs
157/sbin/ldconfig
158touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
159
160%posttrans libs
161gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
162
163%postun libs
164/sbin/ldconfig
165if [ $1 -eq 0 ] ; then
166        touch --no-create %{_datadir}/icons/hicolor &>/dev/null
167        gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
168fi
169o
170%postun -n nautilus-sendto-gnome-bluetooth
171if [ $1 -eq 0 ]; then
172  glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
173fi
174
175%posttrans -n nautilus-sendto-gnome-bluetooth
176glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
177
178
179%files -f %{name}.lang
180%defattr(-, root, root)
181%doc README NEWS COPYING
182%{_sysconfdir}/xdg/autostart/bluetooth-applet.desktop
183%{_bindir}/bluetooth-*
184%{_libdir}/gnome-bluetooth/
185%{_datadir}/applications/*.desktop
186%{_datadir}/gnome-bluetooth/
187%{_datadir}/locale/*
188%{_mandir}/man1/*
189/lib/udev/rules.d/61-gnome-bluetooth-rfkill.rules
190
191%files libs
192%defattr(-,root,root,-)
193%doc COPYING.LIB
194%{_libdir}/libgnome-bluetooth.so.*
195%{_libdir}/girepository-1.0/GnomeBluetooth-1.0.typelib
196%{_datadir}/icons/hicolor/*/apps/*
197%{_datadir}/icons/hicolor/*/status/*
198
199%files devel
200%defattr(-,root,root,-)
201%{_includedir}/gnome-bluetooth/
202%{_libdir}/libgnome-bluetooth.so
203%{_libdir}/pkgconfig/gnome-bluetooth-1.0.pc
204%{_datadir}/gir-1.0/GnomeBluetooth-1.0.gir
205%{_datadir}/gtk-doc/html/gnome-bluetooth/
206
207%files -n nautilus-sendto-gnome-bluetooth
208%defattr(-,root,root,-)
209%{_libdir}/nautilus-sendto/plugins/libnstbluetooth.so
210%{_datadir}/GConf/gsettings/gnome-bluetooth-nst
211%{_datadir}/glib-2.0/schemas/org.gnome.Bluetooth.nst.gschema.xml
212
213
214%changelog
215* Fri Jun 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
216- new upstream release
217- add BuildRequires: nautilus-sendto-devel
218- create nautilus-sendto-gnome-bluetooth package
219
220* Sun Apr 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.0-1
221- new upstream release
222- remove BuildRequires: GConf2-devel
223
224* Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
225- new upstream release
226
227* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
228- new upstream release
229
230* Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
231- new upstream release
232
233* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
234- new upstream release
235
236* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
237- new upstream release
238- change BuildRequires: unique3-devel instead of unique-devel
239- add BuildRequires: control-center-devel
240
241* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
242- new upstream release
243- remove BuildRequires: gir-repository-devel
244- add Requires(post) and Requires(postun): desktop-file-utils
245
246* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-2
247- rebuild with rpm-4.8.1 for pkg-config file
248
249* Wed Apr 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
250- new upstream release
251- add BuildRequires: gir-repository-devel
252- add configure option (--disable-nautilus-sendto)
253
254* Wed Dec 30 2009 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.6-1
255- new upstream release
256- merge spec file from FC package
257
258* Fri Oct 24  2008 Seiichirou Babasaki 0.11.0-6
259- Update to 0.11.0 (VineSeed)
260- added "# Maintainers: " comments.
261- changed UTF-8 encode at gnome-bluetooth.vsc.spec
262- FedoraCore - LOGS
263-- 0.11.0-5
264-- Rebuild against new bluez-libs
265-- 0.11.0-4
266-- Changed name of icon file(#444811)
267-- 0.11.0-3
268-- Remove gnome-obex-server, we should use gnome-user-share now
269-- 0.11.0-1
270-- gcc43 rebuild
271-- 0.11.0 - Update to 0.11.0
272-- 0.10.0 - Update to 0.10.0
273-- 0.9.1-4
274-- marked gnome-obex-server.schemas as config file
275-- changed upstream URL
276-- 0.9.1-3
277-- fixed wrong source URL
278-- 0.9.1-2
279-- rebuilt for F8
280-- changed license tag to GPLv2 and LGPLv2+
281-- 0.9.1-1
282-- Upgrade to 0.9.1 to fix a crasher in the server
283-- 0.9.0-1
284-- Update for 0.9.0
285-- Fix installation of the python bindings
286-- 0.8.0-4
287-- Remove unncessary gconfd killing from scripts (#224561)
288-- 0.8.0-3
289-- corrected BuildRoot
290-- smp flags added
291-- specfile cleanup
292-- fixed desktop file
293- Updated specfile
294
295* Fri Sep 26 2008 Seiichirou Babasaki 0.8.0-2
296- Updated specfile
297
298* Wed Jan 16 2008 Seiichirou Babasaki 0.8.0-1
299- Import gnome-bluetooth - Packager: Babasaki
300- Updated specfile (downgrade -> 0.8.0-0vl1)
301
302#----------------------------------------------------------------------------
303* Mon Nov 13 2006 Harald Hoyer <harald@redhat.com> - 0.8.0-1
304- version 0.8.0
305
306* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.7.0-10.1
307- rebuild
308
309* Wed Jun 14 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-10
310- bump for new openobex
311
312* Sun Jun 11 2006 Jesse Keating <jkeating@redhat.com> - 0.7.0-9
313- Missing automake, libtool, gettext BR
314
315* Sun Jun 11 2006 Jesse Keating <jkeating@redhat.com> - 0.7.0-6
316- Bump for new libbluetooth
317
318* Wed May 31 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-6
319- add dependency on bluez-utils, cosmetic tweaks (bug #190280)
320
321* Tue May 30 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-5
322- install schemata correctly (bug #193518)
323
324* Mon May 29 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-3
325- more build requires (bug #193374)
326
327* Mon Feb 27 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-2
328- pydir fixes for lib64
329
330* Thu Feb 16 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-1
331- version 0.7.0
332
333* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.6.0-2.2.1
334- bump again for double-long bug on ppc(64)
335
336* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.6.0-2.2
337- rebuilt for new gcc4.1 snapshot and glibc changes
338
339* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
340- rebuilt
341
342* Fri Oct 07 2005 Harald Hoyer <harald@redhat.com> - 0.6.0-2
343- Fix relative path for the icons in desktop files which no longer works
344  with the icon cache.
345
346* Wed Sep 28 2005 Harald Hoyer <harald@redhat.com> - 0.6.0-1
347- new version 0.6.0
348
349* Tue Aug 16 2005 Warren Togami <wtogami@redhat.com> 0.5.1-14
350- rebuild for new cairo
351
352* Thu Jul  7 2005 Matthias Saou <http://freshrpms.net/> 0.5.1-13
353- Minor spec file cleanups.
354- Fix relative path for the icons in desktop files which no longer works
355  with the icon cache.
356- Remove useless zero epochs.
357- Remove explicit python abi requirement, it's automatic for FC4 and up.
358
359* Thu Mar 31 2005 Harald Hoyer <harald@redhat.com> - 0.5.1-12
360- removed base requirement from libs
361
362* Tue Mar 29 2005 Warren Togami <wtogami@redhat.com> - 0.5.1-11
363- devel req glib2-devel libbtctl-devel for pkgconfig (#152488)
364
365* Wed Mar 02 2005 Harald Hoyer <harald@redhat.com>
366- rebuilt
367
368* Mon Feb 21 2005 Harald Hoyer <harald@redhat.com> - 0.5.1-9
369- added gnome hbox patch for bug rh#149215
370
371* Tue Dec 07 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-8
372- added requires for python-abi
373
374* Tue Dec 07 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-7
375- split package into app, libs and devel
376
377* Mon Oct 25 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-6
378- fixed again gnome-bluetooth-manager script for 64bit (bug 134864)
379
380* Fri Oct 08 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-5
381- buildrequire pygtk2-devel (bug 135032)
382- fixed gnome-bluetooth-manager script for 64bit (bug 134864)
383- fixed segfault on file receive (bug 133041)
384
385* Mon Sep 27 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-4
386- buildrequire libbtctl-devel
387- buildrequire openobex-devel >= 1.0.1
388- pythondir -> pyexecdir
389
390* Wed Jul 28 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-3
391- added build dependency for librsvg2-devel
392
393* Tue Jul 27 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-2
394- added pydir patch
395
396* Thu Jul 22 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-1
397- version 0.5.1
398
399* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
400- rebuilt
401
402* Tue May 25 2004 Harald Hoyer <harald@redhat.com> - 0.4.1-8
403- corrected BuildRequires
404
405* Wed Mar 10 2004 Harald Hoyer <harald@redhat.com> - 0.4.1-7
406- added EggToolBar patch for gcc34
407
408* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
409- rebuilt
410
411* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
412- rebuilt
413
414* Mon Jan 26 2004 Harald Hoyer <harald@redhat.de> 0.4.1-4
415- added autofoo patch
416
417* Thu Aug 28 2003 Harald Hoyer <harald@redhat.de> 0.4.1-3
418- add .so to gnome-vfs module, if libtool does not!
419
420* Thu Aug 07 2003 Harald Hoyer <harald@redhat.de> 0.4.1-2
421- call libtool finish
422
423* Wed Aug  6 2003 Harald Hoyer <harald@redhat.de> 0.4.1-1
424- new version 0.4.1
425
426* Wed Jun  5 2003 Harald Hoyer <harald@redhat.de> 0.4-1
427- initial RPM
428
429
Note: See TracBrowser for help on using the repository browser.