source: projects/specs/trunk/g/gnome-bluetooth/gnome-bluetooth-vl.spec @ 6011

Revision 6011, 12.2 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release

Line 
1Summary: GNOME Bluetooth Subsystem
2Summary(ja): GNOME Bluetooth サブシステム
3Name: gnome-bluetooth
4Version: 3.4.0
5Release: 1%{?_dist_release}
6License: GPLv2+
7Group: System Environment/Libraries
8URL: http://live.gnome.org/GnomeBluetooth
9Source0: http://ftp.gnome.org/pub/gnome/sources/gnome-bluetooth/3.4/%{name}-%{version}.tar.xz
10Source1: 61-gnome-bluetooth-rfkill.rules
11#----------------------------------------------------------------------------
12BuildRoot:      %{_tmppath}/%{name}-%{version}-root
13
14#----------------------------------------------------------------------------
15#BuildRequires: autoconf >= 2.57
16BuildRequires: bluez-libs-devel >= 2.8
17#BuildRequires: bluez-utils
18BuildRequires: libbonobo-devel >= 2.32.0
19BuildRequires: libbonoboui-devel >= 2.24.4
20BuildRequires: hal-devel
21BuildRequires: unique3-devel
22BuildRequires: libnotify-devel
23BuildRequires: gnome-doc-utils
24BuildRequires: intltool, automake, libtool, gettext
25
26Requires: %{name}-libs = %{version}-%{release}
27Requires: bluez >= 4.42
28Requires: obexd
29Requires(post): desktop-file-utils
30Requires(postun): desktop-file-utils
31ExcludeArch: s390 s390x
32
33## Patch1: gnome-bluetooth-0.8.0-desktop.patch
34
35Vendor: Project Vine
36Distribution: Vine Linux
37Packager: Takemikaduchi
38
39#----------------------------------------------------------------------------
40%description
41This package contains a library with widgets for Bluetooth applications.
42
43%description -l ja
44このパッケージには、 Bluetooth アプリケーションのためのウィジェットと
45ライブラリが含まれます。
46
47#----------------------------------------------------------------------------
48%package libs
49Summary: Libraries for applications, which use gnome-bluetooth
50Summary(ja):Gnome-bluetooth を使用するアプリケーション用ライブラリ
51Group: Development/Libraries
52
53%description libs
54This package contains the libraries for applications,
55which use gnome-bluetooth.
56
57%description libs -l ja
58このパッケージには Gnome-bluetoothを使用するアプリケーション用の
59ライブラリが含まれています。
60
61#----------------------------------------------------------------------------
62%package devel
63Summary: Files for the development of applications, which use gnome-bluetooth
64Summary(ja): Gnome-bluetoothを使用するアプリケーション開発用ファイル
65Group:          Development/Libraries
66License:        LGPLv2+
67Requires:       %{name}-libs = %{version}-%{release}
68Requires:       gtk-doc pkgconfig
69Requires:       glib2-devel
70Requires:       libbtctl-devel
71
72
73%description devel
74This package contains the files for the development of applications,
75which will use gnome-bluetooth.
76
77%description devel -l ja
78このパッケージにはGnome-bluetoothを使用するアプリケーションを
79開発するためのヘッダーファイルなどが含まれています(develパッケージ)
80
81#----------------------------------------------------------------------------
82
83%prep
84%setup -q -n gnome-bluetooth-%{version}
85
86## %patch1 -p1 -b .dfix
87
88%build
89%configure \
90        --disable-desktop-update \
91        --disable-icon-update \
92        --disable-nautilus-sendto \
93        --enable-introspection=yes
94make %{?_smp_mflags}
95
96#----------------------------------------------------------------------------
97%install
98rm -rf $RPM_BUILD_ROOT
99export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
100make DESTDIR=$RPM_BUILD_ROOT install
101
102# we do not want .la files
103rm -f $RPM_BUILD_ROOT%{_libdir}/gnome-vfs-2.0/modules/libbluetooth.*a
104rm -f $RPM_BUILD_ROOT%{_libdir}/libgnome-bluetooth.la
105rm -f $RPM_BUILD_ROOT/%{_libdir}/gnome-bluetooth/plugins/*.la
106rm -f $RPM_BUILD_ROOT/%{_libdir}/control-center-1/panels/*.la
107
108install -m0644 -D %{SOURCE1} $RPM_BUILD_ROOT/lib/udev/rules.d/61-gnome-bluetooth-rfkill.rules
109
110# Remove the gnome-obex-server
111# rm -rf $RPM_BUILD_ROOT%{_bindir}/ $RPM_BUILD_ROOT%{_datadir}/applications/ $RPM_BUILD_ROOT%{_sysconfdir}/
112
113%find_lang gnome-bluetooth2
114%find_lang %{name} --with-gnome
115cat %{name}.lang >> gnome-bluetooth2.lang
116
117# save space by linking identical images in translated docs
118helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
119for f in $helpdir/C/figures/*.png; do
120  b="$(basename $f)"
121  for d in $helpdir/*; do
122    if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
123      g="$d/figures/$b"
124      if [ -f "$g" ]; then
125        if cmp -s $f $g; then
126          rm "$g"; ln -s "../../C/figures/$b" "$g"
127        fi
128      fi
129    fi
130  done
131done
132
133%clean
134rm -rf $RPM_BUILD_ROOT
135
136%post
137update-desktop-database -q
138
139%postun
140update-desktop-database -q
141if [ $1 -eq 0 ] ; then
142        touch --no-create %{_datadir}/icons/hicolor &>/dev/null
143        gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
144fi
145
146%post libs
147/sbin/ldconfig
148touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
149
150%posttrans libs
151gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
152
153%postun libs
154/sbin/ldconfig
155if [ $1 -eq 0 ] ; then
156        touch --no-create %{_datadir}/icons/hicolor &>/dev/null
157        gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
158fi
159
160#----------------------------------------------------------------------------
161%files -f %{name}.lang
162%defattr(-, root, root)
163%doc README NEWS COPYING
164%{_sysconfdir}/xdg/autostart/bluetooth-applet.desktop
165%{_bindir}/bluetooth-*
166%{_libdir}/gnome-bluetooth/
167%{_datadir}/applications/*.desktop
168%{_datadir}/gnome-bluetooth/
169%{_datadir}/locale/*
170%{_mandir}/man1/*
171/lib/udev/rules.d/61-gnome-bluetooth-rfkill.rules
172
173%files libs
174%defattr(-,root,root,-)
175%doc COPYING.LIB
176%{_libdir}/libgnome-bluetooth.so.*
177%{_libdir}/girepository-1.0/GnomeBluetooth-1.0.typelib
178%{_datadir}/icons/hicolor/*/apps/*
179%{_datadir}/icons/hicolor/*/status/*
180
181%files devel
182%defattr(-,root,root,-)
183%{_includedir}/gnome-bluetooth/
184%{_libdir}/libgnome-bluetooth.so
185%{_libdir}/pkgconfig/gnome-bluetooth-1.0.pc
186%{_datadir}/gir-1.0/GnomeBluetooth-1.0.gir
187%{_datadir}/gtk-doc/html/gnome-bluetooth/
188
189#----------------------------------------------------------------------------
190%changelog
191* Sun Apr 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.0-1
192- new upstream release
193- remove BuildRequires: GConf2-devel
194
195* Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
196- new upstream release
197
198* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
199- new upstream release
200
201* Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
202- new upstream release
203
204* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
205- new upstream release
206
207* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
208- new upstream release
209- change BuildRequires: unique3-devel instead of unique-devel
210- add BuildRequires: control-center-devel
211
212* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
213- new upstream release
214- remove BuildRequires: gir-repository-devel
215- add Requires(post) and Requires(postun): desktop-file-utils
216
217* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-2
218- rebuild with rpm-4.8.1 for pkg-config file
219
220* Wed Apr 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
221- new upstream release
222- add BuildRequires: gir-repository-devel
223- add configure option (--disable-nautilus-sendto)
224
225* Wed Dec 30 2009 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.6-1
226- new upstream release
227- merge spec file from FC package
228
229* Fri Oct 24  2008 Seiichirou Babasaki 0.11.0-6
230- Update to 0.11.0 (VineSeed)
231- added "# Maintainers: " comments.
232- changed UTF-8 encode at gnome-bluetooth.vsc.spec
233- FedoraCore - LOGS
234-- 0.11.0-5
235-- Rebuild against new bluez-libs
236-- 0.11.0-4
237-- Changed name of icon file(#444811)
238-- 0.11.0-3
239-- Remove gnome-obex-server, we should use gnome-user-share now
240-- 0.11.0-1
241-- gcc43 rebuild
242-- 0.11.0 - Update to 0.11.0
243-- 0.10.0 - Update to 0.10.0
244-- 0.9.1-4
245-- marked gnome-obex-server.schemas as config file
246-- changed upstream URL
247-- 0.9.1-3
248-- fixed wrong source URL
249-- 0.9.1-2
250-- rebuilt for F8
251-- changed license tag to GPLv2 and LGPLv2+
252-- 0.9.1-1
253-- Upgrade to 0.9.1 to fix a crasher in the server
254-- 0.9.0-1
255-- Update for 0.9.0
256-- Fix installation of the python bindings
257-- 0.8.0-4
258-- Remove unncessary gconfd killing from scripts (#224561)
259-- 0.8.0-3
260-- corrected BuildRoot
261-- smp flags added
262-- specfile cleanup
263-- fixed desktop file
264- Updated specfile
265
266* Fri Sep 26 2008 Seiichirou Babasaki 0.8.0-2
267- Updated specfile
268
269* Wed Jan 16 2008 Seiichirou Babasaki 0.8.0-1
270- Import gnome-bluetooth - Packager: Babasaki
271- Updated specfile (downgrade -> 0.8.0-0vl1)
272
273#----------------------------------------------------------------------------
274* Mon Nov 13 2006 Harald Hoyer <harald@redhat.com> - 0.8.0-1
275- version 0.8.0
276
277* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.7.0-10.1
278- rebuild
279
280* Wed Jun 14 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-10
281- bump for new openobex
282
283* Sun Jun 11 2006 Jesse Keating <jkeating@redhat.com> - 0.7.0-9
284- Missing automake, libtool, gettext BR
285
286* Sun Jun 11 2006 Jesse Keating <jkeating@redhat.com> - 0.7.0-6
287- Bump for new libbluetooth
288
289* Wed May 31 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-6
290- add dependency on bluez-utils, cosmetic tweaks (bug #190280)
291
292* Tue May 30 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-5
293- install schemata correctly (bug #193518)
294
295* Mon May 29 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-3
296- more build requires (bug #193374)
297
298* Mon Feb 27 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-2
299- pydir fixes for lib64
300
301* Thu Feb 16 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-1
302- version 0.7.0
303
304* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.6.0-2.2.1
305- bump again for double-long bug on ppc(64)
306
307* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.6.0-2.2
308- rebuilt for new gcc4.1 snapshot and glibc changes
309
310* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
311- rebuilt
312
313* Fri Oct 07 2005 Harald Hoyer <harald@redhat.com> - 0.6.0-2
314- Fix relative path for the icons in desktop files which no longer works
315  with the icon cache.
316
317* Wed Sep 28 2005 Harald Hoyer <harald@redhat.com> - 0.6.0-1
318- new version 0.6.0
319
320* Tue Aug 16 2005 Warren Togami <wtogami@redhat.com> 0.5.1-14
321- rebuild for new cairo
322
323* Thu Jul  7 2005 Matthias Saou <http://freshrpms.net/> 0.5.1-13
324- Minor spec file cleanups.
325- Fix relative path for the icons in desktop files which no longer works
326  with the icon cache.
327- Remove useless zero epochs.
328- Remove explicit python abi requirement, it's automatic for FC4 and up.
329
330* Thu Mar 31 2005 Harald Hoyer <harald@redhat.com> - 0.5.1-12
331- removed base requirement from libs
332
333* Tue Mar 29 2005 Warren Togami <wtogami@redhat.com> - 0.5.1-11
334- devel req glib2-devel libbtctl-devel for pkgconfig (#152488)
335
336* Wed Mar 02 2005 Harald Hoyer <harald@redhat.com>
337- rebuilt
338
339* Mon Feb 21 2005 Harald Hoyer <harald@redhat.com> - 0.5.1-9
340- added gnome hbox patch for bug rh#149215
341
342* Tue Dec 07 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-8
343- added requires for python-abi
344
345* Tue Dec 07 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-7
346- split package into app, libs and devel
347
348* Mon Oct 25 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-6
349- fixed again gnome-bluetooth-manager script for 64bit (bug 134864)
350
351* Fri Oct 08 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-5
352- buildrequire pygtk2-devel (bug 135032)
353- fixed gnome-bluetooth-manager script for 64bit (bug 134864)
354- fixed segfault on file receive (bug 133041)
355
356* Mon Sep 27 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-4
357- buildrequire libbtctl-devel
358- buildrequire openobex-devel >= 1.0.1
359- pythondir -> pyexecdir
360
361* Wed Jul 28 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-3
362- added build dependency for librsvg2-devel
363
364* Tue Jul 27 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-2
365- added pydir patch
366
367* Thu Jul 22 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-1
368- version 0.5.1
369
370* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
371- rebuilt
372
373* Tue May 25 2004 Harald Hoyer <harald@redhat.com> - 0.4.1-8
374- corrected BuildRequires
375
376* Wed Mar 10 2004 Harald Hoyer <harald@redhat.com> - 0.4.1-7
377- added EggToolBar patch for gcc34
378
379* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
380- rebuilt
381
382* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
383- rebuilt
384
385* Mon Jan 26 2004 Harald Hoyer <harald@redhat.de> 0.4.1-4
386- added autofoo patch
387
388* Thu Aug 28 2003 Harald Hoyer <harald@redhat.de> 0.4.1-3
389- add .so to gnome-vfs module, if libtool does not!
390
391* Thu Aug 07 2003 Harald Hoyer <harald@redhat.de> 0.4.1-2
392- call libtool finish
393
394* Wed Aug  6 2003 Harald Hoyer <harald@redhat.de> 0.4.1-1
395- new version 0.4.1
396
397* Wed Jun  5 2003 Harald Hoyer <harald@redhat.de> 0.4-1
398- initial RPM
399
400
Note: See TracBrowser for help on using the repository browser.