source: projects/specs/trunk/g/gnome-bluetooth/gnome-bluetooth-vl.spec @ 4812

Revision 4812, 12.0 KB checked in by Takemikaduchi, 13 years ago (diff)

GNOME-3.1.92

Line 
1Summary: GNOME Bluetooth Subsystem
2Summary(ja): GNOME Bluetooth サブシステム
3Name: gnome-bluetooth
4Version: 3.1.92
5Release: 1%{?_dist_release}
6License: GPLv2+
7Group: System Environment/Libraries
8URL: http://live.gnome.org/GnomeBluetooth
9Source0: http://ftp.gnome.org/pub/gnome/sources/gnome-bluetooth/3.1/%{name}-%{version}.tar.xz
10Source1: 61-gnome-bluetooth-rfkill.rules
11#----------------------------------------------------------------------------
12BuildRoot:      %{_tmppath}/%{name}-%{version}-root
13
14#----------------------------------------------------------------------------
15#BuildRequires: autoconf >= 2.57
16BuildRequires: bluez-libs-devel >= 2.8
17#BuildRequires: bluez-utils
18BuildRequires: libbonobo-devel >= 2.32.0
19BuildRequires: libbonoboui-devel >= 2.24.4
20BuildRequires: GConf2-devel >= 2.32
21BuildRequires: hal-devel
22BuildRequires: unique3-devel
23BuildRequires: libnotify-devel
24BuildRequires: gnome-doc-utils
25BuildRequires: control-center-devel
26
27BuildRequires: intltool, automake, libtool, gettext
28Requires: %{name}-libs = %{version}-%{release}
29Requires(pre): GConf2
30Requires(post): GConf2
31Requires(preun): GConf2
32Requires: bluez >= 4.42
33Requires: obexd
34Requires(post): desktop-file-utils
35Requires(postun): desktop-file-utils
36ExcludeArch: s390 s390x
37
38## Patch1: gnome-bluetooth-0.8.0-desktop.patch
39
40Vendor: Project Vine
41Distribution: Vine Linux
42Packager: Takemikaduchi
43
44#----------------------------------------------------------------------------
45%description
46This package contains a library with widgets for Bluetooth applications.
47
48%description -l ja
49このパッケージには、 Bluetooth アプリケーションのためのウィジェットと
50ライブラリが含まれます。
51
52#----------------------------------------------------------------------------
53%package libs
54Summary: Libraries for applications, which use gnome-bluetooth
55Summary(ja):Gnome-bluetooth を使用するアプリケーション用ライブラリ
56Group: Development/Libraries
57
58%description libs
59This package contains the libraries for applications,
60which use gnome-bluetooth.
61
62%description libs -l ja
63このパッケージには Gnome-bluetoothを使用するアプリケーション用の
64ライブラリが含まれています。
65
66#----------------------------------------------------------------------------
67%package devel
68Summary: Files for the development of applications, which use gnome-bluetooth
69Summary(ja): Gnome-bluetoothを使用するアプリケーション開発用ファイル
70Group:          Development/Libraries
71License:        LGPLv2+
72Requires:       %{name}-libs = %{version}-%{release}
73Requires:       gtk-doc pkgconfig
74Requires:       glib2-devel
75Requires:       libbtctl-devel
76
77
78%description devel
79This package contains the files for the development of applications,
80which will use gnome-bluetooth.
81
82%description devel -l ja
83このパッケージにはGnome-bluetoothを使用するアプリケーションを
84開発するためのヘッダーファイルなどが含まれています(develパッケージ)
85
86#----------------------------------------------------------------------------
87
88%prep
89%setup -q -n gnome-bluetooth-%{version}
90
91## %patch1 -p1 -b .dfix
92
93%build
94%configure \
95        --disable-desktop-update \
96        --disable-icon-update \
97        --disable-nautilus-sendto \
98        --enable-introspection=yes
99make %{?_smp_mflags}
100
101#----------------------------------------------------------------------------
102%install
103rm -rf $RPM_BUILD_ROOT
104export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
105make DESTDIR=$RPM_BUILD_ROOT install
106
107# we do not want .la files
108rm -f $RPM_BUILD_ROOT%{_libdir}/gnome-vfs-2.0/modules/libbluetooth.*a
109rm -f $RPM_BUILD_ROOT%{_libdir}/libgnome-bluetooth.la
110rm -f $RPM_BUILD_ROOT/%{_libdir}/gnome-bluetooth/plugins/*.la
111rm -f $RPM_BUILD_ROOT/%{_libdir}/control-center-1/panels/*.la
112
113install -m0644 -D %{SOURCE1} $RPM_BUILD_ROOT/lib/udev/rules.d/61-gnome-bluetooth-rfkill.rules
114
115# Remove the gnome-obex-server
116# rm -rf $RPM_BUILD_ROOT%{_bindir}/ $RPM_BUILD_ROOT%{_datadir}/applications/ $RPM_BUILD_ROOT%{_sysconfdir}/
117
118%find_lang gnome-bluetooth2
119%find_lang %{name} --with-gnome
120cat %{name}.lang >> gnome-bluetooth2.lang
121
122# save space by linking identical images in translated docs
123helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
124for f in $helpdir/C/figures/*.png; do
125  b="$(basename $f)"
126  for d in $helpdir/*; do
127    if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
128      g="$d/figures/$b"
129      if [ -f "$g" ]; then
130        if cmp -s $f $g; then
131          rm "$g"; ln -s "../../C/figures/$b" "$g"
132        fi
133      fi
134    fi
135  done
136done
137
138%clean
139rm -rf $RPM_BUILD_ROOT
140
141%post
142update-desktop-database -q
143
144%postun
145update-desktop-database -q
146if [ $1 -eq 0 ] ; then
147        touch --no-create %{_datadir}/icons/hicolor &>/dev/null
148        gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
149fi
150
151%post libs
152/sbin/ldconfig
153touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
154
155%posttrans libs
156gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
157
158%postun libs
159/sbin/ldconfig
160if [ $1 -eq 0 ] ; then
161        touch --no-create %{_datadir}/icons/hicolor &>/dev/null
162        gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
163fi
164
165#----------------------------------------------------------------------------
166%files -f %{name}.lang
167%defattr(-, root, root)
168%doc README NEWS COPYING
169%{_sysconfdir}/xdg/autostart/bluetooth-applet.desktop
170%{_bindir}/bluetooth-*
171%{_libdir}/gnome-bluetooth/
172%{_libdir}/control-center-1/panels/libbluetooth.so
173%{_datadir}/applications/*.desktop
174%{_datadir}/gnome-bluetooth/
175%{_datadir}/locale/*
176%{_mandir}/man1/*
177/lib/udev/rules.d/61-gnome-bluetooth-rfkill.rules
178
179%files libs
180%defattr(-,root,root,-)
181%doc COPYING.LIB
182%{_libdir}/libgnome-bluetooth.so.*
183%{_libdir}/girepository-1.0/GnomeBluetooth-1.0.typelib
184%{_datadir}/icons/hicolor/*/apps/*
185%{_datadir}/icons/hicolor/*/status/*
186
187%files devel
188%defattr(-,root,root,-)
189%{_includedir}/gnome-bluetooth/
190%{_libdir}/libgnome-bluetooth.so
191%{_libdir}/pkgconfig/gnome-bluetooth-1.0.pc
192%{_datadir}/gir-1.0/GnomeBluetooth-1.0.gir
193%{_datadir}/gtk-doc/html/gnome-bluetooth/
194
195#----------------------------------------------------------------------------
196%changelog
197* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
198- new upstream release
199
200* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
201- new upstream release
202- change BuildRequires: unique3-devel instead of unique-devel
203- add BuildRequires: control-center-devel
204
205* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
206- new upstream release
207- remove BuildRequires: gir-repository-devel
208- add Requires(post) and Requires(postun): desktop-file-utils
209
210* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-2
211- rebuild with rpm-4.8.1 for pkg-config file
212
213* Wed Apr 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
214- new upstream release
215- add BuildRequires: gir-repository-devel
216- add configure option (--disable-nautilus-sendto)
217
218* Wed Dec 30 2009 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.6-1
219- new upstream release
220- merge spec file from FC package
221
222* Fri Oct 24  2008 Seiichirou Babasaki 0.11.0-6
223- Update to 0.11.0 (VineSeed)
224- added "# Maintainers: " comments.
225- changed UTF-8 encode at gnome-bluetooth.vsc.spec
226- FedoraCore - LOGS
227-- 0.11.0-5
228-- Rebuild against new bluez-libs
229-- 0.11.0-4
230-- Changed name of icon file(#444811)
231-- 0.11.0-3
232-- Remove gnome-obex-server, we should use gnome-user-share now
233-- 0.11.0-1
234-- gcc43 rebuild
235-- 0.11.0 - Update to 0.11.0
236-- 0.10.0 - Update to 0.10.0
237-- 0.9.1-4
238-- marked gnome-obex-server.schemas as config file
239-- changed upstream URL
240-- 0.9.1-3
241-- fixed wrong source URL
242-- 0.9.1-2
243-- rebuilt for F8
244-- changed license tag to GPLv2 and LGPLv2+
245-- 0.9.1-1
246-- Upgrade to 0.9.1 to fix a crasher in the server
247-- 0.9.0-1
248-- Update for 0.9.0
249-- Fix installation of the python bindings
250-- 0.8.0-4
251-- Remove unncessary gconfd killing from scripts (#224561)
252-- 0.8.0-3
253-- corrected BuildRoot
254-- smp flags added
255-- specfile cleanup
256-- fixed desktop file
257- Updated specfile
258
259* Fri Sep 26 2008 Seiichirou Babasaki 0.8.0-2
260- Updated specfile
261
262* Wed Jan 16 2008 Seiichirou Babasaki 0.8.0-1
263- Import gnome-bluetooth - Packager: Babasaki
264- Updated specfile (downgrade -> 0.8.0-0vl1)
265
266#----------------------------------------------------------------------------
267* Mon Nov 13 2006 Harald Hoyer <harald@redhat.com> - 0.8.0-1
268- version 0.8.0
269
270* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.7.0-10.1
271- rebuild
272
273* Wed Jun 14 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-10
274- bump for new openobex
275
276* Sun Jun 11 2006 Jesse Keating <jkeating@redhat.com> - 0.7.0-9
277- Missing automake, libtool, gettext BR
278
279* Sun Jun 11 2006 Jesse Keating <jkeating@redhat.com> - 0.7.0-6
280- Bump for new libbluetooth
281
282* Wed May 31 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-6
283- add dependency on bluez-utils, cosmetic tweaks (bug #190280)
284
285* Tue May 30 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-5
286- install schemata correctly (bug #193518)
287
288* Mon May 29 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-3
289- more build requires (bug #193374)
290
291* Mon Feb 27 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-2
292- pydir fixes for lib64
293
294* Thu Feb 16 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-1
295- version 0.7.0
296
297* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.6.0-2.2.1
298- bump again for double-long bug on ppc(64)
299
300* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.6.0-2.2
301- rebuilt for new gcc4.1 snapshot and glibc changes
302
303* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
304- rebuilt
305
306* Fri Oct 07 2005 Harald Hoyer <harald@redhat.com> - 0.6.0-2
307- Fix relative path for the icons in desktop files which no longer works
308  with the icon cache.
309
310* Wed Sep 28 2005 Harald Hoyer <harald@redhat.com> - 0.6.0-1
311- new version 0.6.0
312
313* Tue Aug 16 2005 Warren Togami <wtogami@redhat.com> 0.5.1-14
314- rebuild for new cairo
315
316* Thu Jul  7 2005 Matthias Saou <http://freshrpms.net/> 0.5.1-13
317- Minor spec file cleanups.
318- Fix relative path for the icons in desktop files which no longer works
319  with the icon cache.
320- Remove useless zero epochs.
321- Remove explicit python abi requirement, it's automatic for FC4 and up.
322
323* Thu Mar 31 2005 Harald Hoyer <harald@redhat.com> - 0.5.1-12
324- removed base requirement from libs
325
326* Tue Mar 29 2005 Warren Togami <wtogami@redhat.com> - 0.5.1-11
327- devel req glib2-devel libbtctl-devel for pkgconfig (#152488)
328
329* Wed Mar 02 2005 Harald Hoyer <harald@redhat.com>
330- rebuilt
331
332* Mon Feb 21 2005 Harald Hoyer <harald@redhat.com> - 0.5.1-9
333- added gnome hbox patch for bug rh#149215
334
335* Tue Dec 07 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-8
336- added requires for python-abi
337
338* Tue Dec 07 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-7
339- split package into app, libs and devel
340
341* Mon Oct 25 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-6
342- fixed again gnome-bluetooth-manager script for 64bit (bug 134864)
343
344* Fri Oct 08 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-5
345- buildrequire pygtk2-devel (bug 135032)
346- fixed gnome-bluetooth-manager script for 64bit (bug 134864)
347- fixed segfault on file receive (bug 133041)
348
349* Mon Sep 27 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-4
350- buildrequire libbtctl-devel
351- buildrequire openobex-devel >= 1.0.1
352- pythondir -> pyexecdir
353
354* Wed Jul 28 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-3
355- added build dependency for librsvg2-devel
356
357* Tue Jul 27 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-2
358- added pydir patch
359
360* Thu Jul 22 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-1
361- version 0.5.1
362
363* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
364- rebuilt
365
366* Tue May 25 2004 Harald Hoyer <harald@redhat.com> - 0.4.1-8
367- corrected BuildRequires
368
369* Wed Mar 10 2004 Harald Hoyer <harald@redhat.com> - 0.4.1-7
370- added EggToolBar patch for gcc34
371
372* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
373- rebuilt
374
375* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
376- rebuilt
377
378* Mon Jan 26 2004 Harald Hoyer <harald@redhat.de> 0.4.1-4
379- added autofoo patch
380
381* Thu Aug 28 2003 Harald Hoyer <harald@redhat.de> 0.4.1-3
382- add .so to gnome-vfs module, if libtool does not!
383
384* Thu Aug 07 2003 Harald Hoyer <harald@redhat.de> 0.4.1-2
385- call libtool finish
386
387* Wed Aug  6 2003 Harald Hoyer <harald@redhat.de> 0.4.1-1
388- new version 0.4.1
389
390* Wed Jun  5 2003 Harald Hoyer <harald@redhat.de> 0.4-1
391- initial RPM
392
393
Note: See TracBrowser for help on using the repository browser.