source: projects/specs/trunk/g/gnome-bluetooth/gnome-bluetooth-vl.spec @ 4616

Revision 4616, 11.9 KB checked in by Takemikaduchi, 13 years ago (diff)

X.Org, compiz, GNOME3, etc...

Line 
1Summary: GNOME Bluetooth Subsystem
2Summary(ja): GNOME Bluetooth サブシステム
3Name: gnome-bluetooth
4Version: 3.1.4
5Release: 1%{?_dist_release}
6License: GPLv2+
7Group: System Environment/Libraries
8URL: http://live.gnome.org/GnomeBluetooth
9Source0: http://ftp.gnome.org/pub/gnome/sources/gnome-bluetooth/3.1/%{name}-%{version}.tar.bz2
10Source1: 61-gnome-bluetooth-rfkill.rules
11#----------------------------------------------------------------------------
12BuildRoot:      %{_tmppath}/%{name}-%{version}-root
13
14#----------------------------------------------------------------------------
15#BuildRequires: autoconf >= 2.57
16BuildRequires: bluez-libs-devel >= 2.8
17#BuildRequires: bluez-utils
18BuildRequires: libbonobo-devel >= 2.32.0
19BuildRequires: libbonoboui-devel >= 2.24.4
20BuildRequires: GConf2-devel >= 2.32
21BuildRequires: hal-devel
22BuildRequires: unique3-devel
23BuildRequires: libnotify-devel
24BuildRequires: gnome-doc-utils
25BuildRequires: control-center-devel
26
27BuildRequires: intltool, automake, libtool, gettext
28Requires: %{name}-libs = %{version}-%{release}
29Requires(pre): GConf2
30Requires(post): GConf2
31Requires(preun): GConf2
32Requires: bluez >= 4.42
33Requires: obexd
34Requires(post): desktop-file-utils
35Requires(postun): desktop-file-utils
36ExcludeArch: s390 s390x
37
38## Patch1: gnome-bluetooth-0.8.0-desktop.patch
39
40Vendor: Project Vine
41Distribution: Vine Linux
42Packager: Takemikaduchi
43
44#----------------------------------------------------------------------------
45%description
46This package contains a library with widgets for Bluetooth applications.
47
48%description -l ja
49このパッケージには、 Bluetooth アプリケーションのためのウィジェットと
50ライブラリが含まれます。
51
52#----------------------------------------------------------------------------
53%package libs
54Summary: Libraries for applications, which use gnome-bluetooth
55Summary(ja):Gnome-bluetooth を使用するアプリケーション用ライブラリ
56Group: Development/Libraries
57
58%description libs
59This package contains the libraries for applications,
60which use gnome-bluetooth.
61
62%description libs -l ja
63このパッケージには Gnome-bluetoothを使用するアプリケーション用の
64ライブラリが含まれています。
65
66#----------------------------------------------------------------------------
67%package devel
68Summary: Files for the development of applications, which use gnome-bluetooth
69Summary(ja): Gnome-bluetoothを使用するアプリケーション開発用ファイル
70Group:          Development/Libraries
71License:        LGPLv2+
72Requires:       %{name}-libs = %{version}-%{release}
73Requires:       gtk-doc pkgconfig
74Requires:       glib2-devel
75Requires:       libbtctl-devel
76
77
78%description devel
79This package contains the files for the development of applications,
80which will use gnome-bluetooth.
81
82%description devel -l ja
83このパッケージにはGnome-bluetoothを使用するアプリケーションを
84開発するためのヘッダーファイルなどが含まれています(develパッケージ)
85
86#----------------------------------------------------------------------------
87
88%prep
89%setup -q -n gnome-bluetooth-%{version}
90
91## %patch1 -p1 -b .dfix
92
93%build
94%configure --disable-desktop-update --disable-icon-update --disable-nautilus-sendto --enable-introspection=yes
95make %{?_smp_mflags}
96
97#----------------------------------------------------------------------------
98%install
99rm -rf $RPM_BUILD_ROOT
100export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
101make DESTDIR=$RPM_BUILD_ROOT install
102
103# we do not want .la files
104rm -f $RPM_BUILD_ROOT%{_libdir}/gnome-vfs-2.0/modules/libbluetooth.*a
105rm -f $RPM_BUILD_ROOT%{_libdir}/libgnome-bluetooth.la
106rm -f $RPM_BUILD_ROOT/%{_libdir}/gnome-bluetooth/plugins/*.la
107rm -f $RPM_BUILD_ROOT/%{_libdir}/control-center-1/panels/*.la
108
109install -m0644 -D %{SOURCE1} $RPM_BUILD_ROOT/lib/udev/rules.d/61-gnome-bluetooth-rfkill.rules
110
111# Remove the gnome-obex-server
112# rm -rf $RPM_BUILD_ROOT%{_bindir}/ $RPM_BUILD_ROOT%{_datadir}/applications/ $RPM_BUILD_ROOT%{_sysconfdir}/
113
114%find_lang gnome-bluetooth2
115%find_lang %{name} --with-gnome
116cat %{name}.lang >> gnome-bluetooth2.lang
117
118# save space by linking identical images in translated docs
119helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
120for f in $helpdir/C/figures/*.png; do
121  b="$(basename $f)"
122  for d in $helpdir/*; do
123    if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
124      g="$d/figures/$b"
125      if [ -f "$g" ]; then
126        if cmp -s $f $g; then
127          rm "$g"; ln -s "../../C/figures/$b" "$g"
128        fi
129      fi
130    fi
131  done
132done
133
134%clean
135rm -rf $RPM_BUILD_ROOT
136
137%post
138update-desktop-database -q
139
140%postun
141update-desktop-database -q
142if [ $1 -eq 0 ] ; then
143        touch --no-create %{_datadir}/icons/hicolor &>/dev/null
144        gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
145fi
146
147%post libs
148/sbin/ldconfig
149touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
150
151%posttrans libs
152gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
153
154%postun libs
155/sbin/ldconfig
156if [ $1 -eq 0 ] ; then
157        touch --no-create %{_datadir}/icons/hicolor &>/dev/null
158        gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
159fi
160
161#----------------------------------------------------------------------------
162%files -f %{name}.lang
163%defattr(-, root, root)
164%doc README NEWS COPYING
165%{_sysconfdir}/xdg/autostart/bluetooth-applet.desktop
166%{_bindir}/bluetooth-*
167%{_libdir}/gnome-bluetooth/
168%{_libdir}/control-center-1/panels/libbluetooth.so
169%{_datadir}/applications/*.desktop
170%{_datadir}/gnome-bluetooth/
171%{_datadir}/locale/*
172%{_mandir}/man1/*
173/lib/udev/rules.d/61-gnome-bluetooth-rfkill.rules
174
175%files libs
176%defattr(-,root,root,-)
177%doc COPYING.LIB
178%{_libdir}/libgnome-bluetooth.so.*
179%{_libdir}/girepository-1.0/GnomeBluetooth-1.0.typelib
180%{_datadir}/icons/hicolor/*/apps/*
181%{_datadir}/icons/hicolor/*/status/*
182
183%files devel
184%defattr(-,root,root,-)
185%{_includedir}/gnome-bluetooth/
186%{_libdir}/libgnome-bluetooth.so
187%{_libdir}/pkgconfig/gnome-bluetooth-1.0.pc
188%{_datadir}/gir-1.0/GnomeBluetooth-1.0.gir
189%{_datadir}/gtk-doc/html/gnome-bluetooth/
190
191#----------------------------------------------------------------------------
192%changelog
193* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
194- new upstream release
195- change BuildRequires: unique3-devel instead of unique-devel
196- add BuildRequires: control-center-devel
197
198* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
199- new upstream release
200- remove BuildRequires: gir-repository-devel
201- add Requires(post) and Requires(postun): desktop-file-utils
202
203* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-2
204- rebuild with rpm-4.8.1 for pkg-config file
205
206* Wed Apr 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
207- new upstream release
208- add BuildRequires: gir-repository-devel
209- add configure option (--disable-nautilus-sendto)
210
211* Wed Dec 30 2009 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.6-1
212- new upstream release
213- merge spec file from FC package
214
215* Fri Oct 24  2008 Seiichirou Babasaki 0.11.0-6
216- Update to 0.11.0 (VineSeed)
217- added "# Maintainers: " comments.
218- changed UTF-8 encode at gnome-bluetooth.vsc.spec
219- FedoraCore - LOGS
220-- 0.11.0-5
221-- Rebuild against new bluez-libs
222-- 0.11.0-4
223-- Changed name of icon file(#444811)
224-- 0.11.0-3
225-- Remove gnome-obex-server, we should use gnome-user-share now
226-- 0.11.0-1
227-- gcc43 rebuild
228-- 0.11.0 - Update to 0.11.0
229-- 0.10.0 - Update to 0.10.0
230-- 0.9.1-4
231-- marked gnome-obex-server.schemas as config file
232-- changed upstream URL
233-- 0.9.1-3
234-- fixed wrong source URL
235-- 0.9.1-2
236-- rebuilt for F8
237-- changed license tag to GPLv2 and LGPLv2+
238-- 0.9.1-1
239-- Upgrade to 0.9.1 to fix a crasher in the server
240-- 0.9.0-1
241-- Update for 0.9.0
242-- Fix installation of the python bindings
243-- 0.8.0-4
244-- Remove unncessary gconfd killing from scripts (#224561)
245-- 0.8.0-3
246-- corrected BuildRoot
247-- smp flags added
248-- specfile cleanup
249-- fixed desktop file
250- Updated specfile
251
252* Fri Sep 26 2008 Seiichirou Babasaki 0.8.0-2
253- Updated specfile
254
255* Wed Jan 16 2008 Seiichirou Babasaki 0.8.0-1
256- Import gnome-bluetooth - Packager: Babasaki
257- Updated specfile (downgrade -> 0.8.0-0vl1)
258
259#----------------------------------------------------------------------------
260* Mon Nov 13 2006 Harald Hoyer <harald@redhat.com> - 0.8.0-1
261- version 0.8.0
262
263* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.7.0-10.1
264- rebuild
265
266* Wed Jun 14 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-10
267- bump for new openobex
268
269* Sun Jun 11 2006 Jesse Keating <jkeating@redhat.com> - 0.7.0-9
270- Missing automake, libtool, gettext BR
271
272* Sun Jun 11 2006 Jesse Keating <jkeating@redhat.com> - 0.7.0-6
273- Bump for new libbluetooth
274
275* Wed May 31 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-6
276- add dependency on bluez-utils, cosmetic tweaks (bug #190280)
277
278* Tue May 30 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-5
279- install schemata correctly (bug #193518)
280
281* Mon May 29 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-3
282- more build requires (bug #193374)
283
284* Mon Feb 27 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-2
285- pydir fixes for lib64
286
287* Thu Feb 16 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-1
288- version 0.7.0
289
290* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.6.0-2.2.1
291- bump again for double-long bug on ppc(64)
292
293* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.6.0-2.2
294- rebuilt for new gcc4.1 snapshot and glibc changes
295
296* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
297- rebuilt
298
299* Fri Oct 07 2005 Harald Hoyer <harald@redhat.com> - 0.6.0-2
300- Fix relative path for the icons in desktop files which no longer works
301  with the icon cache.
302
303* Wed Sep 28 2005 Harald Hoyer <harald@redhat.com> - 0.6.0-1
304- new version 0.6.0
305
306* Tue Aug 16 2005 Warren Togami <wtogami@redhat.com> 0.5.1-14
307- rebuild for new cairo
308
309* Thu Jul  7 2005 Matthias Saou <http://freshrpms.net/> 0.5.1-13
310- Minor spec file cleanups.
311- Fix relative path for the icons in desktop files which no longer works
312  with the icon cache.
313- Remove useless zero epochs.
314- Remove explicit python abi requirement, it's automatic for FC4 and up.
315
316* Thu Mar 31 2005 Harald Hoyer <harald@redhat.com> - 0.5.1-12
317- removed base requirement from libs
318
319* Tue Mar 29 2005 Warren Togami <wtogami@redhat.com> - 0.5.1-11
320- devel req glib2-devel libbtctl-devel for pkgconfig (#152488)
321
322* Wed Mar 02 2005 Harald Hoyer <harald@redhat.com>
323- rebuilt
324
325* Mon Feb 21 2005 Harald Hoyer <harald@redhat.com> - 0.5.1-9
326- added gnome hbox patch for bug rh#149215
327
328* Tue Dec 07 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-8
329- added requires for python-abi
330
331* Tue Dec 07 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-7
332- split package into app, libs and devel
333
334* Mon Oct 25 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-6
335- fixed again gnome-bluetooth-manager script for 64bit (bug 134864)
336
337* Fri Oct 08 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-5
338- buildrequire pygtk2-devel (bug 135032)
339- fixed gnome-bluetooth-manager script for 64bit (bug 134864)
340- fixed segfault on file receive (bug 133041)
341
342* Mon Sep 27 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-4
343- buildrequire libbtctl-devel
344- buildrequire openobex-devel >= 1.0.1
345- pythondir -> pyexecdir
346
347* Wed Jul 28 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-3
348- added build dependency for librsvg2-devel
349
350* Tue Jul 27 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-2
351- added pydir patch
352
353* Thu Jul 22 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-1
354- version 0.5.1
355
356* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
357- rebuilt
358
359* Tue May 25 2004 Harald Hoyer <harald@redhat.com> - 0.4.1-8
360- corrected BuildRequires
361
362* Wed Mar 10 2004 Harald Hoyer <harald@redhat.com> - 0.4.1-7
363- added EggToolBar patch for gcc34
364
365* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
366- rebuilt
367
368* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
369- rebuilt
370
371* Mon Jan 26 2004 Harald Hoyer <harald@redhat.de> 0.4.1-4
372- added autofoo patch
373
374* Thu Aug 28 2003 Harald Hoyer <harald@redhat.de> 0.4.1-3
375- add .so to gnome-vfs module, if libtool does not!
376
377* Thu Aug 07 2003 Harald Hoyer <harald@redhat.de> 0.4.1-2
378- call libtool finish
379
380* Wed Aug  6 2003 Harald Hoyer <harald@redhat.de> 0.4.1-1
381- new version 0.4.1
382
383* Wed Jun  5 2003 Harald Hoyer <harald@redhat.de> 0.4-1
384- initial RPM
385
386
Note: See TracBrowser for help on using the repository browser.