source: projects/specs/trunk/g/gnokii/gnokii-vl.spec @ 9138

Revision 9138, 15.7 KB checked in by inagaki, 9 years ago (diff)

2014-12-06 Ryoichi INAGAKI <ryo1@…>

  • gnokii, libpqxx: updated


Line 
1# TODO: merge patches upstream where applicable
2
3Name:           gnokii
4Version:        0.6.31
5Release:        1%{?_dist_release}
6Summary:        Linux/Unix tool suite for various mobile phones
7Summary(ja):    様々な携帯電話向けの Linux/Unix ツール集
8
9Group:          Applications/Communications
10License:        GPLv2+
11URL:            http://www.gnokii.org/
12Source0:        http://www.gnokii.org/download/gnokii/%{name}-%{version}.tar.bz2
13#----------------------------------------------------------------------------
14
15Source2:        gnokii-smsd.init
16Source3:        gnokii-smsd.sysconfig
17Source4:        gnokii-smsd.logrotate
18Source5:        gnokii-smsd2mail.sh
19Source6:        gnokii-smsd-README.smsd2mail
20
21# Patch to remove port locking and apply the system-wide /usr/sbin directory
22# to the path instead of the default /usr/local
23Patch1:         gnokii-config.patch
24
25#----------------------------------------------------------------------------
26
27BuildRoot:      %{_tmppath}/%{name}-%{version}-root
28
29#----------------------------------------------------------------------------
30
31BuildRequires:  flex
32BuildRequires:  gettext
33BuildRequires:  ImageMagick
34
35BuildRequires:  bluez-libs-devel
36BuildRequires:  desktop-file-utils
37BuildRequires:  gtk2-devel
38BuildRequires:  libusb-devel
39BuildRequires:  libmysqlclient-devel
40BuildRequires:  libpq-devel
41BuildRequires:  readline-devel
42BuildRequires:  pcsc-lite-devel
43BuildRequires:  sqlite3-devel
44BuildRequires:  zlib-devel
45
46BuildRequires:  libical-devel >= 0.24
47BuildRequires:  libXt-devel
48BuildRequires:  libXpm-devel
49
50BuildRequires:  perl(XML::Parser)
51Requires(pre):  %{_sbindir}/groupadd
52
53#----------------------------------------------------------------------------
54%description
55Gnokii provides tools and a user space driver for use with mobile
56phones under Linux, various unices and Win32. With gnokii you can do
57such things as make data calls, update your address book, change
58calendar entries, send and receive SMS messages and load ring tones
59depending on the phone you have.
60
61#----------------------------------------------------------------------------
62%package     -n xgnokii
63Summary:        Graphical Linux/Unix tool suite for various mobile phones
64Group:          Applications/Communications
65Requires:       %{name} = %{version}-%{release}
66
67%description -n xgnokii
68Xgnokii is graphical Linux/Unix tool suite for various mobile
69phones. It allows you to edit your contacts book, send/read SMS's
70from/in computer and more other features.
71
72#----------------------------------------------------------------------------
73%package        smsd
74Summary:        Gnokii SMS daemon
75Group:          System Environment/Daemons
76Requires:       %{name} = %{version}-%{release}
77Requires(pre):  %{_sbindir}/useradd
78Requires(post): /sbin/chkconfig
79Requires(preun): /sbin/chkconfig
80
81%description    smsd
82The Gnokii SMS daemon receives and sends SMS messages.
83
84#----------------------------------------------------------------------------
85%package        smsd-pgsql
86Summary:        PostgreSQL support for Gnokii SMS daemon
87Group:          System Environment/Daemons
88Requires:       %{name}-smsd = %{version}-%{release}
89Obsoletes:      %{name}-smsd-postgresql < 0.6.4-0.lvn.2
90
91%description    smsd-pgsql
92%{summary}.
93
94#----------------------------------------------------------------------------
95%package        smsd-mysql
96Summary:        MySQL support for Gnokii SMS daemon
97Group:          System Environment/Daemons
98Requires:       %{name}-smsd = %{version}-%{release}
99
100%description    smsd-mysql
101%{summary}.
102
103#----------------------------------------------------------------------------
104%package        devel
105Summary:        Gnokii development files
106Group:          Development/Libraries
107Requires:       %{name} = %{version}-%{release}
108Requires:       pkgconfig
109
110%description    devel
111%{summary}.
112
113
114#----------------------------------------------------------------------------
115%prep
116%setup -q
117%patch1 -p0
118install -pm 644 %{SOURCE5} smsd2mail.sh
119install -pm 644 %{SOURCE6} README.smsd2mail
120
121%build
122%configure --enable-security --disable-rpath --disable-static \
123                --enable-libical --with-x
124make %{?_smp_mflags}
125
126# xgnokii isn't built by the above make operation (Is it a bug?)
127make %{?_smp_mflags} -C xgnokii
128
129
130#----------------------------------------------------------------------------
131%install
132make install DESTDIR=$RPM_BUILD_ROOT
133make install DESTDIR=$RPM_BUILD_ROOT -C xgnokii
134
135# Rename smsd to gnokii-smsd
136mv $RPM_BUILD_ROOT%{_bindir}/{,gnokii-}smsd
137mv $RPM_BUILD_ROOT%{_mandir}/man8/{,gnokii-}smsd.8
138sed -i 's,smsd ,gnokii-smsd ,' $RPM_BUILD_ROOT%{_mandir}/man8/gnokii-smsd.8
139sed -i 's,smsd.,gnokii-smsd.,' $RPM_BUILD_ROOT%{_mandir}/man8/gnokii-smsd.8
140
141# Remove libtool droppings
142rm $RPM_BUILD_ROOT%{_libdir}{,/smsd}/lib*.la
143
144# Fix up the default desktop file
145desktop-file-install \
146  --delete-original \
147  --vendor "" \
148  --dir $RPM_BUILD_ROOT%{_datadir}/applications \
149  --mode 644 \
150  --add-category X-VineLinux \
151  $RPM_BUILD_ROOT%{_datadir}/applications/xgnokii.desktop
152
153# Convert the default icons to PNG
154install -dm 755 $RPM_BUILD_ROOT%{_datadir}/pixmaps
155convert Docs/sample/logo/gnokii.xpm \
156  $RPM_BUILD_ROOT%{_datadir}/pixmaps/xgnokii.png
157chmod 644 $RPM_BUILD_ROOT%{_datadir}/pixmaps/xgnokii.png
158
159# Install the configuration files
160install -Dpm 755 %{SOURCE2} $RPM_BUILD_ROOT%{_initrddir}/gnokii-smsd
161install -Dpm 640 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/gnokii-smsd
162install -Dpm 644 %{SOURCE4} \
163  $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/gnokii-smsd
164cp -a Docs/sample/gnokiirc $RPM_BUILD_ROOT%{_sysconfdir}/
165
166# Install the docs
167rm -rf temporary-gnokii-docs
168mkdir -p temporary-gnokii-docs/
169mv $RPM_BUILD_ROOT%{_datadir}/doc/gnokii/ temporary-gnokii-docs/
170
171%find_lang %{name}
172
173
174%clean
175rm -rf $RPM_BUILD_ROOT
176
177
178#----------------------------------------------------------------------------
179%pre
180%{_sbindir}/groupadd -r gnokii >/dev/null 2>&1 || :
181
182%pre smsd
183%{_sbindir}/useradd -r -M -d / -g gnokii \
184  -s /sbin/nologin -c "Gnokii system user" gnokii >/dev/null 2>&1 || :
185
186%post -p /sbin/ldconfig
187
188%postun -p /sbin/ldconfig
189
190%post smsd
191/sbin/chkconfig --add gnokii-smsd
192
193%preun smsd
194if [ $1 -eq 0 ] ; then
195  %{_initrddir}/gnokii-smsd stop >/dev/null 2>&1 || :
196  /sbin/chkconfig --del gnokii-smsd
197fi
198
199%postun smsd
200if [ $1 -ge 1 ] ; then
201  %{_initrddir}/gnokii-smsd try-restart >/dev/null 2>&1 || :
202fi
203
204
205#----------------------------------------------------------------------------
206%files -f %{name}.lang
207%defattr(-,root,root,-)
208%doc ChangeLog COPY* MAINTAINERS TODO temporary-gnokii-docs/*
209%config(noreplace) %{_sysconfdir}/gnokiirc
210%attr(4750,root,gnokii) %{_sbindir}/mgnokiidev
211%{_bindir}/gnokii
212%{_bindir}/sendsms
213%{_bindir}/gnokiid
214%{_libdir}/libgnokii.so.*
215%{_mandir}/man1/gnokii.1*
216%{_mandir}/man1/sendsms.1*
217%{_mandir}/man8/gnokiid.8*
218%{_mandir}/man8/mgnokiidev.8*
219
220%files -n xgnokii
221%defattr(-,root,root,-)
222%doc xgnokii/ChangeLog xgnokii/README.vcard
223%{_bindir}/xgnokii
224%{_datadir}/pixmaps/xgnokii.png
225%{_datadir}/applications/*xgnokii.desktop
226%{_mandir}/man1/xgnokii.1*
227
228%files smsd
229%defattr(-,root,root,-)
230%doc smsd/action smsd/ChangeLog smsd/README README.smsd2mail smsd2mail.sh
231%attr(-,gnokii,gnokii) %config(noreplace) %{_sysconfdir}/sysconfig/gnokii-smsd
232%config(noreplace) %{_sysconfdir}/logrotate.d/gnokii-smsd
233%{_initrddir}/gnokii-smsd
234%{_bindir}/gnokii-smsd
235%{_mandir}/man8/gnokii-smsd.8*
236%dir %{_libdir}/smsd/
237%{_libdir}/smsd/libsmsd_file.so
238%{_libdir}/smsd/libsmsd_sqlite.so
239
240%files smsd-pgsql
241%defattr(-,root,root,-)
242%doc smsd/sms.tables.pq.sql
243%{_libdir}/smsd/libsmsd_pq.so
244
245%files smsd-mysql
246%defattr(-,root,root,-)
247%doc smsd/sms.tables.mysql.sql
248%{_libdir}/smsd/libsmsd_mysql.so
249
250%files devel
251%defattr(-,root,root,-)
252%{_includedir}/gnokii*
253%{_libdir}/libgnokii.so
254%{_libdir}/pkgconfig/gnokii.pc
255%{_libdir}/pkgconfig/xgnokii.pc
256
257#----------------------------------------------------------------------------
258# Maintainers: babasaki@mindgear.org
259#
260#----------------------------------------------------------------------------
261%changelog
262* Mon Dec  1 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.6.31-1
263- new upstream release
264- updated Patch1
265- built with libmysqlclient 10.0.15 and libpq 9.3.4
266- updated BR for libmysqlclient-devel and libpq-devel
267- added BR: pcsc-lite-devel
268
269* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.30-1
270- new upstream release
271- remove Patch0
272- add BuildRequires: sqlite3-devel
273
274* Sun May 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.27-7
275- add BuildRequires: readline-devel
276
277* Tue Apr 12 2011 Shu KONNO <owa@bg.wakwak.com> 0.6.27-6
278- rebuilt with postgresql-9.0.3
279
280* Sun Oct 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.6.27-5
281- rebuilt with rpm-4.8.1 for pkg-config
282
283* Fri May 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.6.27-4
284- rebuilt with MySQL-5.1.34.
285
286* Mon Oct 27 2008 Seiichirou Babasaki - 0.6.27-3
287- Import gnokii - Packager: Babasaki
288- Updated specfile
289
290#----------------------------------------------------------------------------
291* Mon Oct 06 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.27-2
292- Fix htmlview patch
293
294* Mon Oct 06 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.27-1
295- Update to 0.6.27
296
297* Thu Sep 11 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.26-3
298- Rebuild
299
300* Thu Jun 19 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.26-2
301- Rebuild with libical support
302
303* Wed Jun 11 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.26-1
304- Update to 0.6.26
305
306* Fri May 23 2008 Robert Scheck <robert@fedoraproject.org> 0.6.25-2
307- Set empty --vendor rather none for using desktop-file-install
308- Fixed initscript as gnokii-smsd stays in /usr/bin not /usr/sbin
309
310* Mon May 19 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.25-1
311- Update to 0.6.25
312
313* Thu Mar 20 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.24-1
314- Update to 0.6.24
315
316* Mon Feb 11 2008 - Linus Walleij <triad@df.lth.se> - 0.6.22-3
317- Rebuild for GCC 4.3.
318
319* Thu Dec 6 2007 - Linus Walleij <triad@df.lth.se> - 0.6.22-2
320- Pick up new libssl .solib version dependency.
321
322* Thu Nov 29 2007 - Bastien Nocera <bnocera@redhat.com> - 0.6.22-1
323- Update to 0.6.22
324
325* Thu Nov 01 2007 - Bastien Nocera <bnocera@redhat.com> - 0.6.20-1
326- Update to 0.6.20
327
328* Sun Oct 28 2007 Jeremy Katz <katzj@redhat.com> - 0.6.18-3
329- Even better multilib fixing (#335161)
330
331* Tue Oct 23 2007 - Jeremy Katz <katzj@redhat.com> - 0.6.18-2
332- Quick fix to multilib conflict (#335161)
333
334* Fri Aug 17 2007 - Linus Walleij <triad@df.lth.se> - 0.6.18-1
335- New upstream release
336
337* Fri Aug 17 2007 - Linus Walleij <triad@df.lth.se> - 0.6.17-2
338- Update license field from GPL to GPLv2+
339
340* Wed Jul 04 2007 - Bastien Nocera <bnocera@redhat.com> - 0.6.17-1
341- New upstream release
342
343* Mon Jul 02 2007 - Bastien Nocera <bnocera@redhat.com> - 0.6.16-1
344- New upstream release
345- Update smsd name change patch
346- ppm2nokia, waitcall and todologo have moved to gnokii-extras, as per
347  upstream
348
349* Wed Dec 06 2006 Linus Walleij <triad@df.lth.se> - 0.6.14-3
350- Rebuild to pick up new libpq IF
351
352* Thu Oct 05 2006 Christian Iseli <Christian.Iseli@licr.org> 0.6.14-2
353 - rebuilt for unwind info generation, broken in gcc-4.1.1-21
354
355* Sat Sep 23 2006 Linus Walleij <triad@df.lth.se> - 0.6.14-1
356- New upstream release.
357
358* Tue Aug 29 2006 Linus Walleij <triad@df.lth.se> - 0.6.13-3
359- Rebuild for Fedora Extras 6.
360
361* Fri Aug 11 2006 Linus Walleij <triad@df.lth.se> - 0.6.13-2
362- Bump because tagged before committing sources and I just
363  dont know how the f* you delete a tag in CVS at the moment
364  and it does seem like a too big endavour to find out just
365  in order to have a nice release tag.
366
367* Thu Aug 10 2006 Linus Walleij <triad@df.lth.se> - 0.6.13-1
368- New upstream release.
369- New dependency on libusb for USB serial, DKU no longer needed/wanted
370  so now we have that troublesome issue resolved once and for all.
371- Remove patches to SQL files: these are now fixed upstream!
372
373* Mon Jun 12 2006 Linus Walleij <triad@df.lth.se> - 0.6.12-4
374- Rebuilding due to changed interface on libbluetooth.
375
376* Sun Apr 2 2006 Linus Walleij <triad@df.lth.se> - 0.6.12-4
377- Goofed up. Fixit it...
378
379* Sun Apr 2 2006 Linus Walleij <triad@df.lth.se> - 0.6.12-3
380- Post-import updates.
381
382* Thu Mar 31 2006 Linus Walleij <triad@df.lth.se> - 0.6.12-2
383- Updated after comments from Ville.
384
385* Thu Mar 16 2006 Linus Walleij <triad@df.lth.se> - 0.6.12-1
386- New upstream tarball
387
388* Wed Mar 8 2006 Linus Walleij <triad@df.lth.se> - 0.6.11-2
389- Updated after comments from Ville.
390
391* Sun Mar 5 2006 Linus Walleij <triad@df.lth.se> - 0.6.11-1
392- 0.6.11
393- Modified to drop into the Fedora Extras as the nice package it now is
394- Based work off Ville's good olde package
395
396* Sun Nov 13 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.6.10-0.lvn.1
397- 0.6.10.
398- Clean up pkgconfig file and -devel dependencies from bits needed only
399  for static libs.
400
401* Thu Nov  3 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.6.9-0.lvn.1
402- 0.6.9, desktop entry file included upstream.
403- Drop zero Epochs.
404
405* Sat Aug  6 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.8-0.lvn.1
406- 0.6.8.
407- Don't ship static libraries.
408- Rename smsd to gnokii-smsd to avoid conflicts with smstools.
409- Remove not included files instead of using %%exclude.
410
411* Sat Jun  4 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.7-0.lvn.2
412- BuildRequire openssl-devel to work around https://bugzilla.redhat.com/159569
413
414* Thu Jun  2 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.7-0.lvn.1
415- 0.6.7.
416- Build unconditionally with bluetooth support.
417
418* Mon May  2 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.5-0.lvn.1
419- 0.6.5.
420
421* Fri Nov  5 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.4-0.lvn.2
422- Rename -smsd-postgresql to -smsd-pgsql for consistency with other similar
423  packages in FC/Extras.
424
425* Fri Oct 22 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.4-0.lvn.1
426- Update to 0.6.4, perms and pgsql patches applied upstream.
427- Xgnokii help locale symlink hack no longer necessary.
428- Don't remove user/group on last erase, move smsd user to -smsd subpackage.
429- Add libical support (disabled), rebuild with "--with libical" to enable.
430
431* Mon Jul  5 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.3-0.lvn.1
432- Update to 0.6.3.
433
434* Sun Jun 20 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.1-0.lvn.4
435- Improve Xgnokii desktop entry according to GNOME HIG.
436
437* Sun Jun 13 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.1-0.lvn.3
438- Remove duplicate gettext build dependency (bug 95).
439
440* Sun Jun  6 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.1-0.lvn.2
441- Fix chown syntax in smsd init script.
442- Summary and description improvements.
443- Trim $RPM_OPT_FLAGS out from gnokii.pc.
444- Make -devel require XFree86-devel.
445
446* Sun Apr 18 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.1-0.lvn.1
447- Update to 0.6.1.
448
449* Thu Mar 18 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.0-0.lvn.2
450- Make -devel require pkgconfig.
451
452* Mon Feb 23 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.0-0.lvn.1
453- Update to 0.6.0.
454
455* Mon Feb  2 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.10-0.lvn.1
456- Update to 0.5.10.
457
458* Tue Jan 27 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.9-0.lvn.1
459- Update to 0.5.9.
460- Specfile cleanups, small init script enhancements.
461
462* Sat Dec 27 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.7-0.lvn.1
463- Update to 0.5.7.
464- Move smsd man page into -smsd subpackage.
465
466* Sat Nov 15 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.6-0.lvn.1
467- Update to 0.5.6.
468- Include sample action script for forwarding SMSD messages to mail.
469- s/fedora/livna/.
470- Specfile and init script cleanups.
471
472* Sat Jul 19 2003 Warren Togami <warren@togami.com> - 0:0.5.2-0.fdr.2
473- Disable smp flags to prevent build failure
474
475* Sun Jun 15 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.2-0.fdr.1
476- Update to 0.5.2.
477
478* Thu May 29 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.1-0.fdr.1
479- Update to 0.5.1.
480- Include init script, sysconfig and logrotate config for smsd.
481
482* Tue May 27 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.0-0.fdr.1
483- Update to 0.5.0.
484
485* Sun Nov  3 2002 Ville Skyttä <ville.skytta at iki.fi> 0.4.3-1cr
486- RedHat'ified PLD version.
Note: See TracBrowser for help on using the repository browser.