source: projects/specs/trunk/g/gnokii/gnokii-vl.spec @ 9376

Revision 9376, 16.1 KB checked in by inagaki, 9 years ago (diff)

2015-02-24 Ryoichi INAGAKI <ryo1@…>

  • evolution, evolution-data-server, gnokii, gnome-shell, kdepimlibs, kmymoney: rebuilt with libical
  • libical: updated


Line 
1# TODO: merge patches upstream where applicable
2
3Name:           gnokii
4Version:        0.6.31
5Release:        2%{?_dist_release}
6Summary:        Linux/Unix tool suite for various mobile phones
7Summary(ja):    様々な携帯電話向けの Linux/Unix ツール集
8
9Group:          Applications/Communications
10License:        GPLv2+
11URL:            http://www.gnokii.org/
12Source0:        http://www.gnokii.org/download/gnokii/%{name}-%{version}.tar.bz2
13#----------------------------------------------------------------------------
14
15Source2:        gnokii-smsd.init
16Source3:        gnokii-smsd.sysconfig
17Source4:        gnokii-smsd.logrotate
18Source5:        gnokii-smsd2mail.sh
19Source6:        gnokii-smsd-README.smsd2mail
20
21# Patch to remove port locking and apply the system-wide /usr/sbin directory
22# to the path instead of the default /usr/local
23Patch1:         gnokii-config.patch
24
25#----------------------------------------------------------------------------
26
27BuildRoot:      %{_tmppath}/%{name}-%{version}-root
28
29#----------------------------------------------------------------------------
30
31BuildRequires:  flex
32BuildRequires:  gettext
33BuildRequires:  ImageMagick
34
35BuildRequires:  bluez-libs-devel
36BuildRequires:  desktop-file-utils
37BuildRequires:  gtk2-devel
38BuildRequires:  libusb-devel
39BuildRequires:  libmysqlclient-devel
40BuildRequires:  libpq-devel
41BuildRequires:  readline-devel
42BuildRequires:  pcsc-lite-devel
43BuildRequires:  sqlite3-devel
44BuildRequires:  zlib-devel
45
46BuildRequires:  libical-devel >= 0.24
47BuildRequires:  libXt-devel
48BuildRequires:  libXpm-devel
49
50BuildRequires:  perl(XML::Parser)
51Requires(pre):  %{_sbindir}/groupadd
52
53#----------------------------------------------------------------------------
54%description
55Gnokii provides tools and a user space driver for use with mobile
56phones under Linux, various unices and Win32. With gnokii you can do
57such things as make data calls, update your address book, change
58calendar entries, send and receive SMS messages and load ring tones
59depending on the phone you have.
60
61#----------------------------------------------------------------------------
62%package     -n xgnokii
63Summary:        Graphical Linux/Unix tool suite for various mobile phones
64Summary(ja):    様々な携帯電話向けのグラフィカルな Linux/Unix ツール集
65Group:          Applications/Communications
66Requires:       %{name} = %{version}-%{release}
67
68%description -n xgnokii
69Xgnokii is graphical Linux/Unix tool suite for various mobile
70phones. It allows you to edit your contacts book, send/read SMS's
71from/in computer and more other features.
72
73#----------------------------------------------------------------------------
74%package        smsd
75Summary:        Gnokii SMS daemon
76Summary(ja):    Gnokii SMS デーモン
77Group:          System Environment/Daemons
78Requires:       %{name} = %{version}-%{release}
79Requires(pre):  %{_sbindir}/useradd
80Requires(post): /sbin/chkconfig
81Requires(preun): /sbin/chkconfig
82
83%description    smsd
84The Gnokii SMS daemon receives and sends SMS messages.
85
86#----------------------------------------------------------------------------
87%package        smsd-pgsql
88Summary:        PostgreSQL support for Gnokii SMS daemon
89Summary(ja):    Gnokii SMS デーモンの PostgreSQL サポート
90Group:          System Environment/Daemons
91Requires:       %{name}-smsd = %{version}-%{release}
92Obsoletes:      %{name}-smsd-postgresql < 0.6.4-0.lvn.2
93
94%description    smsd-pgsql
95%{summary}.
96
97#----------------------------------------------------------------------------
98%package        smsd-mysql
99Summary:        MySQL support for Gnokii SMS daemon
100Summary(ja):    Gnokii SMS デーモンの MySQL サポート
101Group:          System Environment/Daemons
102Requires:       %{name}-smsd = %{version}-%{release}
103
104%description    smsd-mysql
105%{summary}.
106
107#----------------------------------------------------------------------------
108%package        devel
109Summary:        Gnokii development files
110Summary(ja):    Gnokii の開発用ファイル
111Group:          Development/Libraries
112Requires:       %{name} = %{version}-%{release}
113Requires:       pkgconfig
114
115%description    devel
116%{summary}.
117
118
119#----------------------------------------------------------------------------
120%prep
121%setup -q
122%patch1 -p0
123install -pm 644 %{SOURCE5} smsd2mail.sh
124install -pm 644 %{SOURCE6} README.smsd2mail
125
126%build
127%configure --enable-security --disable-rpath --disable-static \
128                --enable-libical --with-x
129make %{?_smp_mflags}
130
131# xgnokii isn't built by the above make operation (Is it a bug?)
132make %{?_smp_mflags} -C xgnokii
133
134
135#----------------------------------------------------------------------------
136%install
137make install DESTDIR=$RPM_BUILD_ROOT
138make install DESTDIR=$RPM_BUILD_ROOT -C xgnokii
139
140# Rename smsd to gnokii-smsd
141mv $RPM_BUILD_ROOT%{_bindir}/{,gnokii-}smsd
142mv $RPM_BUILD_ROOT%{_mandir}/man8/{,gnokii-}smsd.8
143sed -i 's,smsd ,gnokii-smsd ,' $RPM_BUILD_ROOT%{_mandir}/man8/gnokii-smsd.8
144sed -i 's,smsd.,gnokii-smsd.,' $RPM_BUILD_ROOT%{_mandir}/man8/gnokii-smsd.8
145
146# Remove libtool droppings
147rm $RPM_BUILD_ROOT%{_libdir}{,/smsd}/lib*.la
148
149# Fix up the default desktop file
150desktop-file-install \
151  --delete-original \
152  --vendor "" \
153  --dir $RPM_BUILD_ROOT%{_datadir}/applications \
154  --mode 644 \
155  --add-category X-VineLinux \
156  $RPM_BUILD_ROOT%{_datadir}/applications/xgnokii.desktop
157
158# Convert the default icons to PNG
159install -dm 755 $RPM_BUILD_ROOT%{_datadir}/pixmaps
160convert Docs/sample/logo/gnokii.xpm \
161  $RPM_BUILD_ROOT%{_datadir}/pixmaps/xgnokii.png
162chmod 644 $RPM_BUILD_ROOT%{_datadir}/pixmaps/xgnokii.png
163
164# Install the configuration files
165install -Dpm 755 %{SOURCE2} $RPM_BUILD_ROOT%{_initrddir}/gnokii-smsd
166install -Dpm 640 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/gnokii-smsd
167install -Dpm 644 %{SOURCE4} \
168  $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/gnokii-smsd
169cp -a Docs/sample/gnokiirc $RPM_BUILD_ROOT%{_sysconfdir}/
170
171# Install the docs
172rm -rf temporary-gnokii-docs
173mkdir -p temporary-gnokii-docs/
174mv $RPM_BUILD_ROOT%{_datadir}/doc/gnokii/ temporary-gnokii-docs/
175
176%find_lang %{name}
177
178
179%clean
180rm -rf $RPM_BUILD_ROOT
181
182
183#----------------------------------------------------------------------------
184%pre
185%{_sbindir}/groupadd -r gnokii >/dev/null 2>&1 || :
186
187%pre smsd
188%{_sbindir}/useradd -r -M -d / -g gnokii \
189  -s /sbin/nologin -c "Gnokii system user" gnokii >/dev/null 2>&1 || :
190
191%post -p /sbin/ldconfig
192
193%postun -p /sbin/ldconfig
194
195%post smsd
196/sbin/chkconfig --add gnokii-smsd
197
198%preun smsd
199if [ $1 -eq 0 ] ; then
200  %{_initrddir}/gnokii-smsd stop >/dev/null 2>&1 || :
201  /sbin/chkconfig --del gnokii-smsd
202fi
203
204%postun smsd
205if [ $1 -ge 1 ] ; then
206  %{_initrddir}/gnokii-smsd try-restart >/dev/null 2>&1 || :
207fi
208
209
210#----------------------------------------------------------------------------
211%files -f %{name}.lang
212%defattr(-,root,root,-)
213%doc ChangeLog COPY* MAINTAINERS TODO temporary-gnokii-docs/*
214%config(noreplace) %{_sysconfdir}/gnokiirc
215%attr(4750,root,gnokii) %{_sbindir}/mgnokiidev
216%{_bindir}/gnokii
217%{_bindir}/sendsms
218%{_bindir}/gnokiid
219%{_libdir}/libgnokii.so.*
220%{_mandir}/man1/gnokii.1*
221%{_mandir}/man1/sendsms.1*
222%{_mandir}/man8/gnokiid.8*
223%{_mandir}/man8/mgnokiidev.8*
224
225%files -n xgnokii
226%defattr(-,root,root,-)
227%doc xgnokii/ChangeLog xgnokii/README.vcard
228%{_bindir}/xgnokii
229%{_datadir}/pixmaps/xgnokii.png
230%{_datadir}/applications/*xgnokii.desktop
231%{_mandir}/man1/xgnokii.1*
232
233%files smsd
234%defattr(-,root,root,-)
235%doc smsd/action smsd/ChangeLog smsd/README README.smsd2mail smsd2mail.sh
236%attr(-,gnokii,gnokii) %config(noreplace) %{_sysconfdir}/sysconfig/gnokii-smsd
237%config(noreplace) %{_sysconfdir}/logrotate.d/gnokii-smsd
238%{_initrddir}/gnokii-smsd
239%{_bindir}/gnokii-smsd
240%{_mandir}/man8/gnokii-smsd.8*
241%dir %{_libdir}/smsd/
242%{_libdir}/smsd/libsmsd_file.so
243%{_libdir}/smsd/libsmsd_sqlite.so
244
245%files smsd-pgsql
246%defattr(-,root,root,-)
247%doc smsd/sms.tables.pq.sql
248%{_libdir}/smsd/libsmsd_pq.so
249
250%files smsd-mysql
251%defattr(-,root,root,-)
252%doc smsd/sms.tables.mysql.sql
253%{_libdir}/smsd/libsmsd_mysql.so
254
255%files devel
256%defattr(-,root,root,-)
257%{_includedir}/gnokii*
258%{_libdir}/libgnokii.so
259%{_libdir}/pkgconfig/gnokii.pc
260%{_libdir}/pkgconfig/xgnokii.pc
261
262#----------------------------------------------------------------------------
263# Maintainers: babasaki@mindgear.org
264#
265#----------------------------------------------------------------------------
266%changelog
267* Mon Feb 23 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.6.31-2
268- rebuilt with libical 1.0.1
269
270* Mon Dec  1 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.6.31-1
271- new upstream release
272- updated Patch1
273- built with libmysqlclient 10.0.15 and libpq 9.3.4
274- updated BR for libmysqlclient-devel and libpq-devel
275- added BR: pcsc-lite-devel
276
277* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.30-1
278- new upstream release
279- remove Patch0
280- add BuildRequires: sqlite3-devel
281
282* Sun May 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.27-7
283- add BuildRequires: readline-devel
284
285* Tue Apr 12 2011 Shu KONNO <owa@bg.wakwak.com> 0.6.27-6
286- rebuilt with postgresql-9.0.3
287
288* Sun Oct 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.6.27-5
289- rebuilt with rpm-4.8.1 for pkg-config
290
291* Fri May 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.6.27-4
292- rebuilt with MySQL-5.1.34.
293
294* Mon Oct 27 2008 Seiichirou Babasaki - 0.6.27-3
295- Import gnokii - Packager: Babasaki
296- Updated specfile
297
298#----------------------------------------------------------------------------
299* Mon Oct 06 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.27-2
300- Fix htmlview patch
301
302* Mon Oct 06 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.27-1
303- Update to 0.6.27
304
305* Thu Sep 11 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.26-3
306- Rebuild
307
308* Thu Jun 19 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.26-2
309- Rebuild with libical support
310
311* Wed Jun 11 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.26-1
312- Update to 0.6.26
313
314* Fri May 23 2008 Robert Scheck <robert@fedoraproject.org> 0.6.25-2
315- Set empty --vendor rather none for using desktop-file-install
316- Fixed initscript as gnokii-smsd stays in /usr/bin not /usr/sbin
317
318* Mon May 19 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.25-1
319- Update to 0.6.25
320
321* Thu Mar 20 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.24-1
322- Update to 0.6.24
323
324* Mon Feb 11 2008 - Linus Walleij <triad@df.lth.se> - 0.6.22-3
325- Rebuild for GCC 4.3.
326
327* Thu Dec 6 2007 - Linus Walleij <triad@df.lth.se> - 0.6.22-2
328- Pick up new libssl .solib version dependency.
329
330* Thu Nov 29 2007 - Bastien Nocera <bnocera@redhat.com> - 0.6.22-1
331- Update to 0.6.22
332
333* Thu Nov 01 2007 - Bastien Nocera <bnocera@redhat.com> - 0.6.20-1
334- Update to 0.6.20
335
336* Sun Oct 28 2007 Jeremy Katz <katzj@redhat.com> - 0.6.18-3
337- Even better multilib fixing (#335161)
338
339* Tue Oct 23 2007 - Jeremy Katz <katzj@redhat.com> - 0.6.18-2
340- Quick fix to multilib conflict (#335161)
341
342* Fri Aug 17 2007 - Linus Walleij <triad@df.lth.se> - 0.6.18-1
343- New upstream release
344
345* Fri Aug 17 2007 - Linus Walleij <triad@df.lth.se> - 0.6.17-2
346- Update license field from GPL to GPLv2+
347
348* Wed Jul 04 2007 - Bastien Nocera <bnocera@redhat.com> - 0.6.17-1
349- New upstream release
350
351* Mon Jul 02 2007 - Bastien Nocera <bnocera@redhat.com> - 0.6.16-1
352- New upstream release
353- Update smsd name change patch
354- ppm2nokia, waitcall and todologo have moved to gnokii-extras, as per
355  upstream
356
357* Wed Dec 06 2006 Linus Walleij <triad@df.lth.se> - 0.6.14-3
358- Rebuild to pick up new libpq IF
359
360* Thu Oct 05 2006 Christian Iseli <Christian.Iseli@licr.org> 0.6.14-2
361 - rebuilt for unwind info generation, broken in gcc-4.1.1-21
362
363* Sat Sep 23 2006 Linus Walleij <triad@df.lth.se> - 0.6.14-1
364- New upstream release.
365
366* Tue Aug 29 2006 Linus Walleij <triad@df.lth.se> - 0.6.13-3
367- Rebuild for Fedora Extras 6.
368
369* Fri Aug 11 2006 Linus Walleij <triad@df.lth.se> - 0.6.13-2
370- Bump because tagged before committing sources and I just
371  dont know how the f* you delete a tag in CVS at the moment
372  and it does seem like a too big endavour to find out just
373  in order to have a nice release tag.
374
375* Thu Aug 10 2006 Linus Walleij <triad@df.lth.se> - 0.6.13-1
376- New upstream release.
377- New dependency on libusb for USB serial, DKU no longer needed/wanted
378  so now we have that troublesome issue resolved once and for all.
379- Remove patches to SQL files: these are now fixed upstream!
380
381* Mon Jun 12 2006 Linus Walleij <triad@df.lth.se> - 0.6.12-4
382- Rebuilding due to changed interface on libbluetooth.
383
384* Sun Apr 2 2006 Linus Walleij <triad@df.lth.se> - 0.6.12-4
385- Goofed up. Fixit it...
386
387* Sun Apr 2 2006 Linus Walleij <triad@df.lth.se> - 0.6.12-3
388- Post-import updates.
389
390* Thu Mar 31 2006 Linus Walleij <triad@df.lth.se> - 0.6.12-2
391- Updated after comments from Ville.
392
393* Thu Mar 16 2006 Linus Walleij <triad@df.lth.se> - 0.6.12-1
394- New upstream tarball
395
396* Wed Mar 8 2006 Linus Walleij <triad@df.lth.se> - 0.6.11-2
397- Updated after comments from Ville.
398
399* Sun Mar 5 2006 Linus Walleij <triad@df.lth.se> - 0.6.11-1
400- 0.6.11
401- Modified to drop into the Fedora Extras as the nice package it now is
402- Based work off Ville's good olde package
403
404* Sun Nov 13 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.6.10-0.lvn.1
405- 0.6.10.
406- Clean up pkgconfig file and -devel dependencies from bits needed only
407  for static libs.
408
409* Thu Nov  3 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.6.9-0.lvn.1
410- 0.6.9, desktop entry file included upstream.
411- Drop zero Epochs.
412
413* Sat Aug  6 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.8-0.lvn.1
414- 0.6.8.
415- Don't ship static libraries.
416- Rename smsd to gnokii-smsd to avoid conflicts with smstools.
417- Remove not included files instead of using %%exclude.
418
419* Sat Jun  4 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.7-0.lvn.2
420- BuildRequire openssl-devel to work around https://bugzilla.redhat.com/159569
421
422* Thu Jun  2 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.7-0.lvn.1
423- 0.6.7.
424- Build unconditionally with bluetooth support.
425
426* Mon May  2 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.5-0.lvn.1
427- 0.6.5.
428
429* Fri Nov  5 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.4-0.lvn.2
430- Rename -smsd-postgresql to -smsd-pgsql for consistency with other similar
431  packages in FC/Extras.
432
433* Fri Oct 22 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.4-0.lvn.1
434- Update to 0.6.4, perms and pgsql patches applied upstream.
435- Xgnokii help locale symlink hack no longer necessary.
436- Don't remove user/group on last erase, move smsd user to -smsd subpackage.
437- Add libical support (disabled), rebuild with "--with libical" to enable.
438
439* Mon Jul  5 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.3-0.lvn.1
440- Update to 0.6.3.
441
442* Sun Jun 20 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.1-0.lvn.4
443- Improve Xgnokii desktop entry according to GNOME HIG.
444
445* Sun Jun 13 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.1-0.lvn.3
446- Remove duplicate gettext build dependency (bug 95).
447
448* Sun Jun  6 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.1-0.lvn.2
449- Fix chown syntax in smsd init script.
450- Summary and description improvements.
451- Trim $RPM_OPT_FLAGS out from gnokii.pc.
452- Make -devel require XFree86-devel.
453
454* Sun Apr 18 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.1-0.lvn.1
455- Update to 0.6.1.
456
457* Thu Mar 18 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.0-0.lvn.2
458- Make -devel require pkgconfig.
459
460* Mon Feb 23 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.0-0.lvn.1
461- Update to 0.6.0.
462
463* Mon Feb  2 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.10-0.lvn.1
464- Update to 0.5.10.
465
466* Tue Jan 27 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.9-0.lvn.1
467- Update to 0.5.9.
468- Specfile cleanups, small init script enhancements.
469
470* Sat Dec 27 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.7-0.lvn.1
471- Update to 0.5.7.
472- Move smsd man page into -smsd subpackage.
473
474* Sat Nov 15 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.6-0.lvn.1
475- Update to 0.5.6.
476- Include sample action script for forwarding SMSD messages to mail.
477- s/fedora/livna/.
478- Specfile and init script cleanups.
479
480* Sat Jul 19 2003 Warren Togami <warren@togami.com> - 0:0.5.2-0.fdr.2
481- Disable smp flags to prevent build failure
482
483* Sun Jun 15 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.2-0.fdr.1
484- Update to 0.5.2.
485
486* Thu May 29 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.1-0.fdr.1
487- Update to 0.5.1.
488- Include init script, sysconfig and logrotate config for smsd.
489
490* Tue May 27 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.0-0.fdr.1
491- Update to 0.5.0.
492
493* Sun Nov  3 2002 Ville Skyttä <ville.skytta at iki.fi> 0.4.3-1cr
494- RedHat'ified PLD version.
Note: See TracBrowser for help on using the repository browser.