source: projects/specs/trunk/g/gnash/gnash-vl.spec @ 1919

Revision 1919, 17.7 KB checked in by owa, 14 years ago (diff)

rebuilt with rpm-4.8.1

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3# ghelp/omf/scrollkeeper support
4# not working as of version 0.8.7
5%define scrollkeeper 0
6
7# kde and klash support
8%define kde_support 0
9
10Name:           gnash
11Version:        0.8.7
12Release:        2%{?_dist_release}
13Summary:        GNU flash movie player
14
15Group:          Applications/Multimedia
16License:        GPLv3+
17URL:            http://www.gnu.org/software/gnash/
18Source0:        http://ftp.gnu.org/gnu/gnash/%{version}/%{name}-%{version}.tar.bz2
19Source1:        http://www.getgnash.org/gnash-splash.swf
20Source2:        gnash.desktop
21
22# register KComponentData properly in KDE 4 KPart
23Patch0:         gnash-0.8.3-fix-kde4-port.patch
24BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
25
26BuildRequires:  libxml2-devel libpng-devel libjpeg-devel libogg-devel
27BuildRequires:  libboost-devel curl-devel freetype-devel fontconfig-devel
28BuildRequires: libboost-date-time libboost-serialization libboost-thread
29BuildRequires:  SDL-devel
30BuildRequires:  agg-devel
31%if %{kde_support}
32#BuildRequires:  kde-filesystem
33BuildRequires:  kdelibs-devel
34%endif
35BuildRequires:  gtkglext-devel
36BuildRequires:  docbook2X
37#BuildRequires:  %{_bindir}/docbook2pdf
38BuildRequires:  gstreamer-devel >= 0.10%
39BuildRequires:  gstreamer-plugins-base-devel >= 0.10
40%if %{scrollkeeper}
41BuildRequires:  scrollkeeper
42%endif
43BuildRequires:  giflib-devel
44BuildRequires:  gettext
45BuildRequires:  desktop-file-utils
46BuildRequires:  speex-devel
47BuildRequires:  gstreamer-plugins-base-devel
48BuildRequires:  pygtk2-devel
49BuildRequires:  libtool-ltdl-devel
50BuildRequires(check): dejagnu
51
52%if %{scrollkeeper}
53Requires(post): scrollkeeper
54Requires(postun): scrollkeeper
55%endif
56Requires(post): /sbin/ldconfig
57Requires(postun): /sbin/ldconfig
58Requires(post): /sbin/install-info
59Requires(preun): /sbin/install-info
60
61%description
62Gnash is capable of reading up to SWF v9 files and opcodes, but primarily
63supports SWF v7, with better SWF v8 and v9 support under heavy development.
64Gnash includes initial parser support for SWF v8 and v9. Not all
65ActionScript 2 classes are implemented yet, but all of the most heavily
66used ones are. Many ActionScript 2 classes are partially implemented;
67there is support for all of the commonly used methods of each
68class.
69
70%package plugin
71Summary:   Web-client flash movie player plugin
72Requires:  %{name} = %{version}-%{release}
73# this doesn't prevent wrong dependencies, in case a package
74# provides %%{_libdir}/mozilla/plugins (like kdebase for konqueror)
75# and another unrelated webbrowser is installed, like w3m-el.
76# Moreover konqueror could provide webclient some day
77Requires:  %{_libdir}/mozilla/plugins webclient
78Group:     Applications/Internet
79
80%description plugin
81The gnash flash movie player plugin for firefox or mozilla.
82
83%if %{kde_support}
84%package klash
85Summary:   Konqueror flash movie player plugin
86Requires:  %{name} = %{version}-%{release}
87Group:     Applications/Multimedia
88
89%description klash
90The gnash flash movie player plugin for Konqueror.
91
92%endif
93
94%package cygnal
95Summary:   Streaming media server
96Requires:  %{name} = %{version}-%{release}
97Group:     Applications/Multimedia
98
99%description cygnal
100Cygnal is a streaming media server that's Flash aware.
101
102%package devel
103Summary:   Gnash header files
104Requires:  %{name} = %{version}-%{release}
105Group:     Development/Libraries
106
107%description devel
108Gnash header files can be used to write external Gnash extensions or to embed
109the Gnash GTK+ widget into a C/C++ application.
110
111%package -n python-gnash
112Summary:   Gnash Python bindings
113Requires:  %{name} = %{version}-%{release}
114Group:     Applications/Multimedia
115
116%description -n python-gnash
117Python bindings for the Gnash widget. Can be used to embed Gnash into any PyGTK
118application.
119
120%prep
121%setup -q
122%patch0 -p1 -b .fix-kde4
123%if %{kde_support}
124# Hack as autoreconf breaks build
125sed -i -e 's!kapp.h!kapplication.h!g' configure
126sed -i -e 's!libkdeui.la!libkdeui.so!g' configure
127# Currently kde4-gnash (from kde4 branch) links against various KDE libraries,
128# but only needs Qt -- remove the superfluous linkage
129sed -i -e 's!\$(KDE4_LIBS)!!g' gui/Makefile.in
130%endif
131# we don't want any builtin ltdl built, configure wants always either
132# ltdl-install or ltdl-convenience, hack that out
133sed -i -e 's/test x"\${enable_ltdl_convenience-no}" != xno/false/g' configure
134# and don't build the loader part of libltdl either
135sed -i -e 's/\$(LT_DLLOADERS)//g' libltdl/Makefile.in
136# link to the system libltdl instead of the bundled one
137# this is hardcoded in the makefiles, so --without-included-ltdl doesn't help
138sed -i -e 's!\$(top_builddir)/libltdl/libltdlc.la!-lltdl!g' \
139  */Makefile.in */*/Makefile.in
140# delete bundled libltdl stuff to make sure it's not used
141rm -f libltdl/*.[ch] libltdl/*/*.[ch]
142
143iconv -f latin1 -t utf8 < AUTHORS > AUTHORS.utf8
144touch -r AUTHORS AUTHORS.utf8
145mv AUTHORS.utf8 AUTHORS
146
147%build
148%configure --disable-static --with-npapi-plugindir=%{_libdir}/mozilla/plugins \
149  --enable-docbook --enable-ghelp --enable-media=GST \
150  --disable-dependency-tracking --disable-rpath \
151  --enable-cygnal \
152  --enable-sdkinstall \
153  --enable-python \
154%if %{kde_support}
155  --enable-gui=gtk,kde4,sdl,fb \
156  --with-kde4-prefix=%{_kde4_prefix} \
157  --with-kde4-lib=%{_kde4_libdir}/kde4/devel \
158  --with-kde4-incl=%{_kde4_includedir} \
159%else
160  --enable-gui=gtk,sdl,fb \
161%endif
162  --without-included-ltdl
163
164%if %{kde_support}
165# make sure the Qt 4 moc etc. tools are found
166export PATH=%{_qt4_prefix}/bin:$PATH
167#doesn't work currently: %%{?_smp_mflags}
168# override KDE4_LIBS because configure doesn't detect it properly
169make KDE4_LIBS='-L%{_kde4_libdir}/kde4/devel -lkparts -lkdeui -lkdecore'
170%else
171#doesn't work currently: %%{?_smp_mflags}
172make
173%endif
174
175%install
176rm -rf $RPM_BUILD_ROOT
177make install install-plugins \
178 DESTDIR=$RPM_BUILD_ROOT INSTALL='install -p' \
179%if %{kde_support}
180 KDE4_PLUGINDIR=%{_kde4_libdir}/kde4 \
181 KDE4_SERVICESDIR=%{_kde4_datadir}/kde4/services \
182 KDE4_CONFIGDIR=%{_kde4_configdir} \
183 KDE4_APPSDATADIR=%{_kde4_appsdir}/klash
184%endif
185
186rm $RPM_BUILD_ROOT%{_libdir}/gnash/*.la
187
188%if %{kde_support}
189# KDE 4 doesn't need the .la file anymore, thankfully
190rm $RPM_BUILD_ROOT%{_kde4_libdir}/kde4/libklashpart.la
191%endif
192
193rm -f $RPM_BUILD_ROOT%{_infodir}/dir
194
195rm -rf __dist_docs
196mkdir __dist_docs
197mv $RPM_BUILD_ROOT%{_datadir}/doc/gnash/* __dist_docs/
198rmdir $RPM_BUILD_ROOT%{_datadir}/doc/gnash
199
200cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/gnash/
201
202mkdir -p $RPM_BUILD_ROOT%{_libexecdir}
203# a wrapper to avoid gnash erroring out if there is no argument.
204# Instead open gnash-splash.swf.
205# this should not be needed in the next version.
206# FIXME: Do we still need this with 0.8.7?
207cat > $RPM_BUILD_ROOT%{_libexecdir}/gnash-wrapper << EOF
208#! /bin/sh
209if [ "z\$1" = 'z' ]; then
210 gnash %{_datadir}/gnash/gnash-splash.swf
211else
212 gnash "\$@"
213fi
214EOF
215
216chmod a+x $RPM_BUILD_ROOT%{_libexecdir}/gnash-wrapper
217
218sed -e 's;/usr/libexec;%{_libexecdir};' %{SOURCE2} > gnash.desktop
219mkdir -p $RPM_BUILD_ROOT%{_datadir}/applications
220desktop-file-install --vendor="fedora" \
221 --dir=$RPM_BUILD_ROOT%{_datadir}/applications/ \
222 gnash.desktop
223
224mkdir -p $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps
225cp -p ./gui/images/GnashG.png $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps
226
227%find_lang %{name}
228
229%clean
230rm -rf $RPM_BUILD_ROOT
231
232
233%post
234/sbin/ldconfig
235%if %{scrollkeeper}
236scrollkeeper-update -q -o %{_datadir}/omf/%{name} || :
237%endif
238/sbin/install-info %{_infodir}/gnash_ref.info %{_infodir}/dir || :
239/sbin/install-info %{_infodir}/gnash_user.info %{_infodir}/dir || :
240
241update-desktop-database &> /dev/null || :
242
243touch --no-create %{_datadir}/icons/hicolor
244if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
245  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
246fi
247
248
249%preun
250if [ $1 = 0 ]; then
251    /sbin/install-info --delete %{_infodir}/gnash_ref.info %{_infodir}/dir || :
252    /sbin/install-info --delete %{_infodir}/gnash_user.info %{_infodir}/dir || :
253fi
254
255%postun
256/sbin/ldconfig
257%if %{scrollkeeper}
258scrollkeeper-update -q || :
259%endif
260
261update-desktop-database &> /dev/null || :
262
263touch --no-create %{_datadir}/icons/hicolor
264if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
265  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
266fi
267
268
269%files -f %{name}.lang
270%defattr(-,root,root,-)
271%doc README AUTHORS COPYING NEWS
272%doc __dist_docs/*
273%config(noreplace) %{_sysconfdir}/gnashpluginrc
274%config(noreplace) %{_sysconfdir}/gnashrc
275%{_bindir}/dumpshm
276%{_bindir}/fb-gnash
277%{_bindir}/flvdumper
278%{_bindir}/gtk-gnash
279%{_bindir}/sdl-gnash
280%{_bindir}/soldumper
281%{_bindir}/gnash
282%{_bindir}/gprocessor
283%{_bindir}/findmicrophones
284%{_bindir}/findwebcams
285%dir %{_libdir}/gnash
286%{_libdir}/gnash/*.so*
287%{_mandir}/man1/gnash.1*
288%{_mandir}/man1/dumpshm.1*
289%{_mandir}/man1/gprocessor.1*
290%{_mandir}/man1/soldumper.1*
291%{_mandir}/man1/flvdumper.1*
292%{_mandir}/man1/findmicrophones.1*
293%{_mandir}/man1/findwebcams.1*
294%{_mandir}/man1/gtk-gnash.1*
295%{_infodir}/gnash*
296%{_datadir}/gnash/
297%{_datadir}/icons/hicolor/32x32/apps/*.png
298%{_datadir}/applications/*.desktop
299%{_libexecdir}/gnash-wrapper
300%if %{scrollkeeper}
301%{_datadir}/omf/gnash/
302%endif
303
304%files plugin
305%defattr(-,root,root,-)
306%{_libdir}/mozilla/plugins/libgnashplugin.so
307
308%if %{kde_support}
309%files klash
310%defattr(-,root,root,-)
311%{_kde4_bindir}/kde4-gnash
312%{_kde4_libdir}/kde4/libklashpart.so
313%{_kde4_appsdir}/klash/
314%{_kde4_datadir}/kde4/services/klash_part.desktop
315%{_mandir}/man1/kde4-gnash.1*
316%endif
317
318%files cygnal
319%defattr(-,root,root,-)
320%config(noreplace) %{_sysconfdir}/cygnalrc
321%{_bindir}/cygnal
322%{_mandir}/man1/cygnal.1*
323%{_mandir}/man1/rtmpget.1*
324%dir %{_libdir}/cygnal
325%{_libdir}/cygnal/plugins/*.so*
326
327%files devel
328%defattr(-,root,root,-)
329%{_includedir}/gnash/
330%{_libdir}/pkgconfig/gnash.pc
331
332%files -n python-gnash
333%defattr(-,root,root,-)
334%{python_sitearch}/gtk-2.0/*
335
336%changelog
337* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 0.8.7-2
338- rebuilt with rpm-4.8.1 for pkg-config
339
340* Wed Mar 17 2010 IWAI, Masaharu <iwai@alib.jp> 0.8.7-1
341- initial build for Vine Linux: based Fedora 0.8.7-1.fc14
342
343* Sat Feb 27 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.7-1
344- update to 0.8.7
345- make scrollkeeper a conditional (still disabled as it's not working)
346- drop gnash-0.8.3-manual.patch, should no longer be needed
347- drop gnash-0.8.6-python-install-dir.patch, fixed upstream
348
349* Fri Feb 12 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.6-13
350- delete bundled libltdl stuff to make sure it's not used
351
352* Thu Feb 11 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.6-12
353- don't build libltdlc.a
354
355* Thu Feb 11 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.6-11
356- --without-included-ltdl (CVE-2009-3736)
357
358* Fri Jan 22 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.6-10
359- Rebuild for new Boost (1.41.0)
360
361* Sat Jan 02 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.6-9
362- Add missing Epoch to Requires
363
364* Sat Jan 02 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.6-8
365- Install icon to the correct place (#551621)
366
367* Wed Dec 30 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-7
368- One more try at using the correct dir
369
370* Tue Dec 29 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-6
371- Patch was reversed
372
373* Tue Dec 29 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-5
374- Patch Makefile.in, not Makefile.am
375
376* Tue Dec 29 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-4
377- Pick up python modules from the right dir
378
379* Tue Dec 29 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-3
380- Install python modules in the right dir
381
382* Tue Dec 29 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-2
383- Add cygnal plugins
384
385* Tue Dec 29 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-1
386- Update to 0.8.6, increase epoch.
387
388* Thu Sep 10 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.8.20090910bzr11506
389- update to HEAD
390
391* Thu Sep 10 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.7.20090910bzr11505
392- update to HEAD
393
394* Mon Aug 10 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.9.0-0.6.20090809bzr11401
395- don't package headers in -widget, only in -devel (no duplicate files)
396- own %%{_includedir}/gnash/ in -devel
397- add missing %%defattr for -devel and -widget
398- make -devel and -widget require the main package (with exact VR)
399- fix -devel group and description
400- rename gnash-widget to python-gnash as per the naming guidelines
401
402* Sun Aug 09 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.9.0-0.5.20090809bzr11401
403- use %%{_includedir}, not %%{_prefix}/include
404
405* Sun Aug 09 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.4.20090809bzr11401
406- Install the python module in the sitearch dir
407
408* Sun Aug 09 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.3.20090809bzr11401
409- One more 64bit fix
410
411* Sun Aug 09 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.3.20090809bzr11400
412- Fix the packaging in 64bits
413
414* Sun Aug 09 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.2.20090809bzr11400
415- upload the .swf file
416
417* Sun Aug 09 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.1.20090809bzr11400
418- merge upstream changes into the spec
419
420* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.5-5
421- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
422
423* Fri May 22 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.5-4
424- rebuild for new Boost
425
426* Fri Mar 06 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.5-3
427- explicitly link the KlashPart against the libraries it uses
428
429* Fri Mar 06 2009 Jaroslav Reznik <jreznik@redhat.com> 0.8.5-2
430- add missing speex-devel and gstreamer-plugins-base-devel BR
431 
432* Fri Mar 06 2009 Jaroslav Reznik <jreznik@redhat.com> 0.8.5-1
433- update to 0.8.5
434- remove use_kde3_executable_hack
435- remove autoreconf
436
437* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> 0.8.4-7
438- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
439
440* Thu Dec 18 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.4-6
441- rebuild for new boost
442
443* Thu Nov 13 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.4-5
444- add missing portions of KDE 4 port from upstream kde4 branch
445
446* Thu Nov 13 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.4-4
447- add 3 more patches from bero to fix the KDE 4 viewer executable
448- disable use_kde3_executable hack
449
450* Sun Oct 19 2008 Patrice Dumas <pertusus@free.fr> 0.8.4-3
451- add a desktop file
452
453* Sat Oct 18 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.4-2
454- update KDE 4 patch (undo the backporting and use original patch)
455- patch to make autoreconf work
456- add missing BR giflib-devel, gettext
457- omit unrecognized --with-qtdir
458
459* Sat Oct 18 2008 Patrice Dumas <pertusus@free.fr> 0.8.4-1
460- update to 0.8.4
461
462* Thu Oct  4 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.3-6
463- use the KDE 3 executable with the KDE 4 KPart for now (making this conditional
464  so it can easily be disabled or removed once the KDE 4 executable is fixed)
465
466* Thu Oct  4 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.3-5
467- register KComponentData properly in KDE 4 KPart
468
469* Wed Oct  3 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.3-4
470- KDE 4 port of klash by Benjamin Wolsey and Bernhard Rosenkränzer
471
472* Fri Aug 29 2008 Michael Schwendt <mschwendt@fedoraproject.org> 0.8.3-3
473- include %%_libdir/gnash directory
474
475* Wed Jun 25 2008 Patrice Dumas <pertusus@free.fr> 0.8.3-2
476- add glib in the link, thanks Daniel Drake (#452767)
477
478* Sun Jun 22 2008 Patrice Dumas <pertusus@free.fr> 0.8.3-1
479- update to 0.8.3
480
481* Wed Apr  9 2008 Patrice Dumas <pertusus@free.fr> 0.8.2-3
482- ship libklashpart (#441601)
483
484* Mon Mar 10 2008 Patrice Dumas <pertusus@free.fr> 0.8.2-2
485- don't ship libltdl.so.3 (#436725)
486
487* Fri Mar  7 2008 Patrice Dumas <pertusus@free.fr> 0.8.2-1
488- update to 0.8.2
489
490* Sat Oct 27 2007 Patrice Dumas <pertusus@free.fr> 0.8.1-6
491- add patch from Martin Stransky to fix wrapped plugin #281061
492
493* Thu Sep 20 2007 Patrice Dumas <pertusus@free.fr> 0.8.1-5
494- info files are empty, don't install them
495
496* Thu Sep 20 2007 Patrice Dumas <pertusus@free.fr> 0.8.1-4
497- omf/scrollkeeper doc is broken, remove it
498
499* Fri Sep  7 2007 Patrice Dumas <pertusus@free.fr> 0.8.1-3
500- better documentation generation
501
502* Wed Sep  5 2007 Patrice Dumas <pertusus@free.fr> 0.8.1-2
503- update to 0.8.1
504- agg is now the default renderer
505
506* Fri Aug  3 2007 Patrice Dumas <pertusus@free.fr> 0.8.0-2
507- rebuild for boost soname change
508
509* Sun Jun 17 2007 Patrice Dumas <pertusus@free.fr> 0.8.0-1
510- update to 0.8.0
511
512* Wed May  9 2007 Patrice Dumas <pertusus@free.fr> 0.7.2-2
513- fix CVE-2007-2500 (fix 239213)
514
515* Sat Nov  6 2006 Patrice Dumas <pertusus@free.fr> 0.7.2-1
516- update for 0.7.2 release.
517
518* Thu Oct 05 2006 Christian Iseli <Christian.Iseli@licr.org> 0.7.1-9
519 - rebuilt for unwind info generation, broken in gcc-4.1.1-21
520
521* Sun Sep 24 2006 Patrice Dumas <pertusus@free.fr> 0.7.1-8
522- plugin requires %%{_libdir}/mozilla/plugins. Fix (incompletly and
523  temporarily, but there is no better solution yet) #207613
524
525* Sun Aug 27 2006 Patrice Dumas <pertusus@free.fr> - 0.7.1-7
526- add defattr for klash
527- add warnings in the description about stability
528
529* Mon Aug 21 2006 Patrice Dumas <pertusus@free.fr> - 0.7.1-6
530- remove superfluous buildrequires autoconf
531- rename last patch to gnash-plugin-tempfile-dir.patch
532- add README.fedora to plugin to explain tmpdirs
533
534* Wed Aug 16 2006 Jens Petersen <petersen@redhat.com> - 0.7.1-5
535- source qt.sh and configure --with-qtdir (Dominik Mierzejewski)
536- add plugin-tempfile-dir.patch for plugin to use a safe tempdir
537
538* Fri Jul 28 2006 Jens Petersen <petersen@redhat.com> - 0.7.1-4
539- buildrequire autotools (Michael Knox)
540
541* Fri Jun  2 2006 Patrice Dumas <pertusus@free.fr> - 0.7.1-3
542- add gnash-continue_on_info_install_error.patch to avoid
543- buildrequire libXmu-devel
544
545* Wed May 17 2006 Jens Petersen <petersen@redhat.com> - 0.7.1-2
546- configure with --disable-rpath
547- buildrequire docbook2X
548- remove devel files
549
550* Sun May  7 2006 Jens Petersen <petersen@redhat.com> - 0.7.1-1
551- update to 0.7.1 alpha release
552
553* Sat Apr  22 2006 Rob Savoye <rob@welcomehome.org> - 0.7-1
554- install the info file. Various tweaks for my system based on
555Patrice's latest patch,
556
557* Fri Feb  3 2006 Patrice Dumas <dumas@centre-cired.fr> - 0.7-1
558- initial packaging
Note: See TracBrowser for help on using the repository browser.