source: projects/specs/trunk/g/gmrun/gmrun-vl.spec @ 10129

Revision 10129, 4.3 KB checked in by ara_t, 8 years ago (diff)

Small GTK based 'Run application'

Line 
1%define pkg_name    gmrun
2%define pkg_version 0.9.2
3%define pkg_release 3%{?_dist_release}
4
5Summary: Small GTK based 'Run application'
6Name:    %{pkg_name}
7Version: %{pkg_version}
8Release: %{pkg_release}
9
10License: GPL2
11Group:   User Interface/X
12URL:     https://sourceforge.net/projects/gmrun/
13# URL:     https://github.com/rtyler/gmrun
14
15Source: %{name}-%{version}.tar.gz
16Patch0: ci_string.h.patch
17Patch1: prefs.cc.patch
18Patch2: gtkcompletionline.cc.patch
19
20BuildRoot:      %{_tmppath}/%{name}-root
21
22BuildRequires:  gtk2-devel
23BuildRequires:  popt-devel
24
25Vendor: Project Vine
26Distribution: Vine Linux
27# Packager: Mihai Bazon <mishoo@infoiasi.ro>
28Packager: ara_t
29
30
31%description
32Short GtkEntry for file autocompletion + main.cc that does the needed stuff
33for running programs.  This is intended as a replacement to grun, which
34(sorry) sucks.  The idea comes from the KDE Window Manager (ALT-F2 in KDE).
35Though, GNOME is better :)
36
37
38%prep
39%{__rm} -rf ${RPM_BUILD_ROOT}
40%setup -q
41%patch0 -p1
42%patch1 -p1
43%patch2 -p1
44
45%build
46%{configure}
47%{__make} %{?_smp_mflags}
48
49%install
50%{__rm} -rf ${RPM_BUILD_ROOT}
51%{__make} install-strip DESTDIR=${RPM_BUILD_ROOT}
52
53%clean
54%{__rm} -rf ${RPM_BUILD_ROOT}
55
56
57%files
58%defattr(-,root,root)
59%doc AUTHORS COPYING INSTALL README NEWS ChangeLog
60%{_bindir}/
61%{_datadir}/
62
63
64%changelog
65* Sun Apr 10 2016 Toshiaki Ara <ara_t@384.jp> 0.23.1-3
66- correct SPEC file
67
68* Mon Feb 29 2016 Toshiaki Ara <ara_t@384.jp> 0.23.1-2
69- change group to User Interface/X
70
71* Sun Feb 28 2016 Toshiaki Ara <ara_t@384.jp> 0.23.1-1
72- rebuild for Vine Linux
73- patch the difference with Commits on Sep 12, 2013
74
75* Sun Aug 03 2003 Mihai Bazon <mishoo@infoiasi.ro> 0.9-2
76- fixed a parsing bug in the "run command" function
77
78* Sun Jun 22 2003 Marius FERARU <altblue@n0i.net> 0.9-0.n0i
79- version 0.9
80
81* Sat Jun 14 2003 Marius FERARU <altblue@n0i.net> 0.8.1-1.n0i
82- rebuild on RHL9
83
84* Sat Aug 17 2002 Mihai Bazon <mishoo@infoiasi.ro>
85- Some bugs fixed, specifically the behavior of END/HOME keys (or C-E, C-A),
86  and the major one: you could not run a file that has an extension handler
87  with some other program than the extension handler :)
88
89* Fri Aug 16 2002 Mihai Bazon <mishoo@infoiasi.ro>
90- Fixed bug: filenames can now contain white spaces (will be backslash-ed)
91- New feature: can specify application handler per file extension, so you
92  can directly type the name of some .cpp file and emacs will show up :)
93  see config file for details.
94- New feature: can automatically simulate a TAB press after some timeout.
95  Check config file for details, key "TabTimeout" (0 to disable).
96- New feature: you can now always use "system" for running programs
97  (specify --enable-system at configure).
98
99* Fri Oct 19 2001 Mihai Bazon <mishoo@infoiasi.ro>
100- Fixed bug with sorting of completion list
101- Fixed bug with URL handling
102- New parameter: list of execs to be always run in terminal
103- New feature: last history line appears directly in edit line, selected
104
105* Wed Aug 01 2001 Mihai Bazon <mishoo@infoiasi.ro>
106- Programs are now executed using execv.  We don't use system anymore, thus
107  avoiding forking another shell.
108- gmrun.spec gets now generated automagically, at ./configure.
109
110* Sun Jul 22 2001 Mihai Bazon <mishoo@infoiasi.ro>
111- added "!" history backward search; like in bash, it finds the last command
112  which begins with the entered text.
113- CTRL-R / CTRL-S don't show two identical consecutive records.
114
115* Thu Jul 19 2001 Mihai Bazon <mishoo@infoiasi.ro>
116- added history search capabilities (CTRL-R / CTRL-S, like in bash / Emacs)
117- small bug fixes
118
119* Fri Jun 29 2001 Mihai Bazon <mishoo@infoiasi.ro>
120- history size configurable from config file
121- window appears directly where it should (no more flicker)
122
123* Wed May 14 2001 Mihai Bazon <mishoo@infoiasi.ro>
124- added default configuration file (goes to /usr/share/gmrun)
125
126* Wed May 07 2001 Marius Feraru <altblue@n0i.net>
127- updated to version 0.5.3 and took over to 0.5.31
128
129* Wed May 03 2001 Marius Feraru <altblue@n0i.net>
130- updated to version 0.2.5 and took over to 0.2.51:
131        * configuration file with 2 options for now:
132                'Terminal' and 'Width'
133        * added some more (and hopefully more useful) documentation:
134                README.hints, README.gmrunrc and README.icewm
135
136* Wed May 03 2001 Marius Feraru <altblue@n0i.net>
137- updated to version 0.2.2:
138        * Ctrl-Enter spawns a terminal
139
140* Wed May 02 2001 Marius Feraru <altblue@n0i.net>
141- initial RPM build
Note: See TracBrowser for help on using the repository browser.