source: projects/specs/trunk/g/gmrun/gmrun-vl.spec @ 10411

Revision 10411, 4.4 KB checked in by ara_t, 8 years ago (diff)

rebuild with gcc-5.4.0

Line 
1%define pkg_name    gmrun
2%define pkg_version 0.9.2
3%define pkg_release 4%{?_dist_release}
4
5Summary: Small GTK based 'Run application'
6Name:    %{pkg_name}
7Version: %{pkg_version}
8Release: %{pkg_release}
9
10License: GPL2
11Group:   User Interface/X
12URL:     https://sourceforge.net/projects/gmrun/
13# URL:     https://github.com/rtyler/gmrun
14
15Source: %{name}-%{version}.tar.gz
16Patch0: ci_string.h.patch
17Patch1: prefs.cc.patch
18Patch2: gtkcompletionline.cc.patch
19
20BuildRoot:      %{_tmppath}/%{name}-root
21
22BuildRequires:  gtk2-devel
23BuildRequires:  popt-devel
24
25Vendor: Project Vine
26Distribution: Vine Linux
27# Packager: Mihai Bazon <mishoo@infoiasi.ro>
28Packager: ara_t
29
30
31%description
32Short GtkEntry for file autocompletion + main.cc that does the needed stuff
33for running programs.  This is intended as a replacement to grun, which
34(sorry) sucks.  The idea comes from the KDE Window Manager (ALT-F2 in KDE).
35Though, GNOME is better :)
36
37
38%prep
39%{__rm} -rf ${RPM_BUILD_ROOT}
40%setup -q
41%patch0 -p1
42%patch1 -p1
43%patch2 -p1
44
45%build
46%{configure}
47%{__make} %{?_smp_mflags}
48
49%install
50%{__rm} -rf ${RPM_BUILD_ROOT}
51%{__make} install-strip DESTDIR=${RPM_BUILD_ROOT}
52
53%clean
54%{__rm} -rf ${RPM_BUILD_ROOT}
55
56
57%files
58%defattr(-,root,root)
59%doc AUTHORS COPYING INSTALL README NEWS ChangeLog
60%{_bindir}/
61%{_datadir}/
62
63
64%changelog
65* Sun May 15 2016 Toshiaki Ara <ara_t@384.jp> 0.23.1-4
66- rebuild with gcc-5.4.0
67
68* Sun Apr 10 2016 Toshiaki Ara <ara_t@384.jp> 0.23.1-3
69- correct SPEC file
70
71* Mon Feb 29 2016 Toshiaki Ara <ara_t@384.jp> 0.23.1-2
72- change group to User Interface/X
73
74* Sun Feb 28 2016 Toshiaki Ara <ara_t@384.jp> 0.23.1-1
75- rebuild for Vine Linux
76- patch the difference with Commits on Sep 12, 2013
77
78* Sun Aug 03 2003 Mihai Bazon <mishoo@infoiasi.ro> 0.9-2
79- fixed a parsing bug in the "run command" function
80
81* Sun Jun 22 2003 Marius FERARU <altblue@n0i.net> 0.9-0.n0i
82- version 0.9
83
84* Sat Jun 14 2003 Marius FERARU <altblue@n0i.net> 0.8.1-1.n0i
85- rebuild on RHL9
86
87* Sat Aug 17 2002 Mihai Bazon <mishoo@infoiasi.ro>
88- Some bugs fixed, specifically the behavior of END/HOME keys (or C-E, C-A),
89  and the major one: you could not run a file that has an extension handler
90  with some other program than the extension handler :)
91
92* Fri Aug 16 2002 Mihai Bazon <mishoo@infoiasi.ro>
93- Fixed bug: filenames can now contain white spaces (will be backslash-ed)
94- New feature: can specify application handler per file extension, so you
95  can directly type the name of some .cpp file and emacs will show up :)
96  see config file for details.
97- New feature: can automatically simulate a TAB press after some timeout.
98  Check config file for details, key "TabTimeout" (0 to disable).
99- New feature: you can now always use "system" for running programs
100  (specify --enable-system at configure).
101
102* Fri Oct 19 2001 Mihai Bazon <mishoo@infoiasi.ro>
103- Fixed bug with sorting of completion list
104- Fixed bug with URL handling
105- New parameter: list of execs to be always run in terminal
106- New feature: last history line appears directly in edit line, selected
107
108* Wed Aug 01 2001 Mihai Bazon <mishoo@infoiasi.ro>
109- Programs are now executed using execv.  We don't use system anymore, thus
110  avoiding forking another shell.
111- gmrun.spec gets now generated automagically, at ./configure.
112
113* Sun Jul 22 2001 Mihai Bazon <mishoo@infoiasi.ro>
114- added "!" history backward search; like in bash, it finds the last command
115  which begins with the entered text.
116- CTRL-R / CTRL-S don't show two identical consecutive records.
117
118* Thu Jul 19 2001 Mihai Bazon <mishoo@infoiasi.ro>
119- added history search capabilities (CTRL-R / CTRL-S, like in bash / Emacs)
120- small bug fixes
121
122* Fri Jun 29 2001 Mihai Bazon <mishoo@infoiasi.ro>
123- history size configurable from config file
124- window appears directly where it should (no more flicker)
125
126* Wed May 14 2001 Mihai Bazon <mishoo@infoiasi.ro>
127- added default configuration file (goes to /usr/share/gmrun)
128
129* Wed May 07 2001 Marius Feraru <altblue@n0i.net>
130- updated to version 0.5.3 and took over to 0.5.31
131
132* Wed May 03 2001 Marius Feraru <altblue@n0i.net>
133- updated to version 0.2.5 and took over to 0.2.51:
134        * configuration file with 2 options for now:
135                'Terminal' and 'Width'
136        * added some more (and hopefully more useful) documentation:
137                README.hints, README.gmrunrc and README.icewm
138
139* Wed May 03 2001 Marius Feraru <altblue@n0i.net>
140- updated to version 0.2.2:
141        * Ctrl-Enter spawns a terminal
142
143* Wed May 02 2001 Marius Feraru <altblue@n0i.net>
144- initial RPM build
Note: See TracBrowser for help on using the repository browser.