source: projects/specs/trunk/g/glib2/glib2-vl.spec @ 12057

Revision 12057, 22.8 KB checked in by tomop, 5 years ago (diff)

glib2-2.58.3-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define _unpackaged_files_terminate_build 1
3
4Summary: A library of handy utility functions.
5Name: glib2
6Version: 2.58.3
7Release: 1%{?_dist_release}
8License: LGPLv2+
9Group: System Environment/Libraries
10Source: http://ftp.gnome.org/pub/GNOME/sources/glib/2.48/glib-%{version}.tar.xz
11Source2: glib2.sh
12Source3: glib2.csh
13
14BuildRoot: %{_tmppath}/glib-%{version}-root
15
16BuildRequires: pkgconfig >= 0.14
17BuildRequires: dbus-devel
18BuildRequires: gamin-devel
19BuildRequires: libffi-devel
20BuildRequires: zlib-devel
21BuildRequires: python-devel
22BuildRequires: pcre-devel >= 8.13
23BuildRequires: libmount-devel
24BuildRequires: gtk-doc
25Obsoletes: glib-gtkbeta
26
27# for gio-querymodules
28Requires(post,postun): libffi
29
30URL: http://www.gtk.org
31
32Vendor: Project Vine
33Distribution: Vine Linux
34Packager: Daisuke SUZUKI <daisuke@linux.or.jp>
35
36%description
37GLib is the low-level core library that forms the basis
38for projects such as GTK+ and GNOME. It provides data structure
39handling for C, portability wrappers, and interfaces for such runtime
40functionality as an event loop, threads, dynamic loading, and an
41object system.
42
43This package provides version 2.48 of GLib.
44
45%package devel
46Summary: Development files for the GLib library
47Group: Development/Libraries
48Requires: %{name} = %{version}
49Requires: pkgconfig >= 0.14
50Requires: libffi-devel
51Requires: zlib-devel
52
53Obsoletes: glib-gtkbeta-devel
54Conflicts: glib-devel <= 1.2.8
55
56%description devel
57The glib-devel package includes the header files for
58version 2.48 of the GLib library.
59
60
61## to build compat32 for x86_64 architecture support
62%package -n compat32-%{name}
63Summary: A library of handy utility functions.
64Group: System Environment/Libraries
65
66%description -n compat32-%{name}
67GLib is the low-level core library that forms the basis
68for projects such as GTK+ and GNOME. It provides data structure
69handling for C, portability wrappers, and interfaces for such runtime
70functionality as an event loop, threads, dynamic loading, and an
71object system.
72
73This package provides version 2.48 of GLib.
74
75%package -n compat32-%{name}-devel
76Summary: Development files for the GLib library
77Group: Development/Libraries
78Requires: pkgconfig >= 0.14
79Requires: compat32-%{name} = %{version}
80
81Conflicts: glib-devel <= 1.2.8
82
83%description -n compat32-%{name}-devel
84The glib-devel package includes the header files for
85version 2.48 of the GLib library.
86
87
88%prep
89%setup -q -n glib-%{version}
90
91%build
92NOCONFIGURE=1 ./autogen.sh
93%configure --disable-selinux --enable-static --enable-systemtap
94make %{?_smp_mflags}
95
96%install
97rm -rf $RPM_BUILD_ROOT
98
99mkdir -p $RPM_BUILD_ROOT%{_bindir}
100make install DESTDIR=$RPM_BUILD_ROOT
101
102## glib2.sh and glib2.csh
103mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
104install -m 755 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
105install -m 755 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
106
107#mkdir -p $RPM_BUILD_ROOT%{python_sitearch}
108#ln -sf %{_libdir}/gdbus-2.0/codegen  $RPM_BUILD_ROOT%{python_sitearch}/codegen
109
110touch $RPM_BUILD_ROOT%{_libdir}/gio/modules/giomodule.cache
111
112rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
113rm -f $RPM_BUILD_ROOT%{_libdir}/gio/modules/lib*.{a,la}
114rm -f $RPM_BUILD_ROOT%{_libdir}/gio/modules/*.cache
115
116%find_lang glib20
117
118%clean
119rm -rf $RPM_BUILD_ROOT
120
121%post
122/sbin/ldconfig
123gio-querymodules %{_libdir}/gio/modules
124
125%postun
126/sbin/ldconfig
127gio-querymodules %{_libdir}/gio/modules
128
129%post -n compat32-%{name} -p /sbin/ldconfig
130
131%postun -n compat32-%{name} -p /sbin/ldconfig
132
133
134%files -f glib20.lang
135%defattr(-, root, root)
136%license COPYING
137%doc AUTHORS NEWS README*
138%{_bindir}/gapplication
139%{_bindir}/gdbus
140%{_bindir}/gio
141%{_bindir}/gio-launch-desktop
142%{_bindir}/gio-querymodules
143%{_bindir}/glib-compile-schemas
144%{_bindir}/gsettings
145%{_libdir}/libglib-2.0.so.*
146%{_libdir}/libgthread-2.0.so.*
147%{_libdir}/libgmodule-2.0.so.*
148%{_libdir}/libgobject-2.0.so.*
149%{_libdir}/libgio-2.0.so.*
150%{_libdir}/gio/modules/lib*.so
151%{_sysconfdir}/profile.d/*
152%dir %{_datadir}/bash-completion/completions
153%dir %{_datadir}/bash-completion
154%{_datadir}/bash-completion/completions/gapplication
155%{_datadir}/bash-completion/completions/gdbus
156%{_datadir}/bash-completion/completions/gio
157%{_datadir}/bash-completion/completions/gsettings
158
159%files devel
160%defattr(-, root, root)
161%{_bindir}/gdbus-codegen
162%{_bindir}/glib-compile-resources
163%{_bindir}/glib-genmarshal
164%{_bindir}/glib-gettextize
165%{_bindir}/glib-mkenums
166%{_bindir}/gobject-query
167%{_bindir}/gresource
168%{_bindir}/gtester
169%{_bindir}/gtester-report
170%{_libdir}/lib*.so
171%{_libdir}/lib*.a
172#%{_libdir}/gdbus-2.0/codegen/*
173%{_libdir}/glib-2.0
174%{_libdir}/pkgconfig/*
175#%{python_sitearch}/codegen
176%{_includedir}/*
177%{_datadir}/aclocal/*
178%{_datadir}/glib-2.0
179%{_datadir}/gettext/its/gschema.its
180%{_datadir}/gettext/its/gschema.loc
181#%doc %{_datadir}/gtk-doc/html/*
182%doc %{_mandir}/man1/*
183%{_datadir}/gdb/auto-load%{_libdir}/libglib-2.0.so.*-gdb.py*
184%{_datadir}/gdb/auto-load%{_libdir}/libgobject-2.0.so.*-gdb.py*
185%dir %{_datadir}/bash-completion/completions
186%dir %{_datadir}/bash-completion
187%{_datadir}/bash-completion/completions/gresource
188
189%if %{build_compat32}
190%files -n compat32-%{name}
191%defattr(-, root, root)
192%{_libdir}/libglib-2.0.so.*
193%{_libdir}/libgthread-2.0.so.*
194%{_libdir}/libgmodule-2.0.so.*
195%{_libdir}/libgobject-2.0.so.*
196%{_libdir}/libgio-2.0.so.*
197%{_libdir}/gio/modules/lib*.so
198
199%files -n compat32-%{name}-devel
200%defattr(-, root, root)
201%{_libdir}/lib*.so
202%{_libdir}/lib*.a
203%{_libdir}/glib-2.0
204%endif
205
206%changelog
207* Sat Apr 06 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.58.3-1
208- new upstream release.
209
210* Sat Dec 29 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.58.2-1
211- new upstream release.
212
213* Sat Jan 06 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.55.0-1
214- new upstream release.
215- dropped Patch0: fixed in upstream.
216- added BR:libmount-devel.
217
218* Thu Jul 14 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.48.1-1
219- new upstream release
220- add BuildRequires: pcre-devel
221
222* Sun May 08 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.46.2-2
223- add Requires: libffi
224
225* Fri Nov 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.46.2-1
226- new upstream release
227
228* Thu Oct 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.46.1-1
229- new upstream release
230
231* Thu May 14 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.44.1-1
232- new upstream release
233
234* Sat Mar 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.44.0-1
235- new upstream release
236
237* Sun Mar 08 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.42.2-1
238- new upstream release
239
240* Sun Nov 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.42.1-1
241- new upstream release
242
243* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.42.0-1
244- new upstream release
245
246* Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.0-2
247- rebuild with libffi-3.0.13
248
249* Fri Mar 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.0-1
250- new upstream release
251
252* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.38.2-1
253- new upstream release
254
255* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.38.1-1
256- new upstream release
257
258* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.4-1
259- new upstream release
260- remove Patch1 (glib-2.36.3-revert-g_file_set_contents.patch) from upstream
261
262* Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.3-1
263- new upstream release
264- add Patch1 (glib-2.36.3-revert-g_file_set_contents.patch) from upstream
265
266* Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.2-1
267- new upstream release
268
269* Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.1-1
270- new upstream release
271
272* Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.3-1
273- new upstream release
274
275* Sat Nov 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.2-1
276- new upstream release
277
278* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.1-1
279- new upstream release
280
281* Wed Sep 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.0-1
282- new upstream release
283
284* Mon Jul 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.4-1
285- new upstream release
286
287* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.3-1
288- new upstream release
289
290* Wed May 02 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
291- new upstream release
292
293* Sat Apr 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
294- new upstream release
295- add BuildRequires: python-devel
296- add Patch0 (glib-2.32.1-dconf-path.patch)
297
298* Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
299- new upstream release
300
301* Sun Oct 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
302- new upstream release
303
304* Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
305- new upstream release
306- add Requires: libffi-devel, zlib-devel (-devel sub package)
307
308* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.92-1
309- new upstream release
310
311* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.18-1
312- new upstream release
313- remove Patch0,1
314
315* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.16-1
316- new upstream release
317- Patch0: glib-2.29.16-fixes-bug-656387.patch
318- Patch1: glib-2.29.16-fixes-bug-656675.patch
319
320* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.14-1
321- new upstream release
322- add BuildRequires: libffi-devel, dbus-devel
323
324* Sat Jun 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.8-1
325- new upstream release
326
327* Fri Apr 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.6-1
328- new upstream release
329
330* Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.5-1
331- new upstream release
332
333* Wed Mar 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.4-1
334- new upstream release
335
336* Sat Mar 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.3-1
337- new upstream release
338
339* Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
340- new upstream release
341
342* Sat Feb 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.1-1
343- new upstream release
344
345* Sat Feb 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
346- new upstream release
347
348* Fri Dec 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.1-2
349- move the following files from glib2-devel to glib2 package
350   (gdbus, gio-querymodules, glib-compile-schemas, gsettings)
351
352* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.1-1
353- new upstream release
354
355* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.0-1
356- new upstream release
357- fix Source (add URL)
358- fix %files to add /etc/bash_completion.d files
359
360* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.24.2-2
361- build with rpm-4.8.1-1 for pkg-config file
362
363* Sat Aug 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.2-1
364- new upstream release
365
366* Tue May 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.1-1
367- new upstream release
368
369* Sun Mar 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.0-1
370- new upstream release
371- add BuildRequires: zlib-devel
372
373* Sun Mar 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.5-1
374- new upstream release
375
376* Mon Jan 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.4-1
377- new upstream release
378
379* Thu Jan 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.3-1
380- new upstream release
381
382* Sun Oct 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
383- new upstream release
384
385* Thu Sep 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.0-1
386- new upstream release
387
388* Mon Jun 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.4-1
389- new upstream release
390
391* Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.3-1
392- new upstream release
393
394* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.2-1
395- new upstream release
396
397* Sat Apr 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-1
398- new upstream release
399
400* Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.0-1
401- new upstream release
402
403* Sun Jan 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.4-1
404- new upstream release
405
406* Tue Nov 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.3-1
407- new upstream release
408
409* Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.2-1
410- new upstream release
411
412* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-1
413- new upstream release
414
415* Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-1
416- new upstream release
417
418* Mon Jul  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.4-1
419- new upstream release
420
421* Sat May 10 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.16.3-2
422- updated %%if %%{build_compat32} case related statements
423
424* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.3-1vl5
425- new upstream release
426- removed lib*.la files from devel package
427
428* Sun Apr  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.2-1vl5
429- new upstream release
430
431* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.1-1vl5
432- added %%{?_dist_release}
433- BuildRequires: gamin-devel
434
435* Tue Mar 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.1-0vl1
436- new upstream release
437
438* Thu Feb  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.6-0vl1
439- new upstream release
440
441* Wed Jan  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.5-0vl1
442- new upstream release
443
444* Wed Nov 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
445- new upstream release
446
447* Thu Oct 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.2-0vl1
448- new upstream release
449- removed BuildRequires: automake17
450
451* Thu Sep 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.1-0vl1
452- new upstream release
453
454* Sun Aug 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.0-0vl1
455- new upstream release
456
457* Wed Jul 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.13-0vl1
458- new upstream release
459
460* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.12-0vl2
461- rebuild with new environment
462
463* Thu May 03 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.12-0vl1
464- new upstream release
465
466* Thu Mar 15 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.11-0vl1
467- new upstream release
468
469* Mon Jan 08 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.7-0vl1
470- new upstream release
471
472* Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.6-0vl1
473- new upstream release
474
475* Thu Aug 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.3-0vl1
476- new upstream release
477
478* Wed Aug 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
479- new upstream release
480
481* Sat Aug 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
482- new upstream release
483
484* Mon Jun 26 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.10.3-0vl3
485- rebuild
486
487* Sun Jun 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.3-0vl2
488- update glib2.{sh,csh}
489  - add EUC-JP,CP932,UTF-8 to G_FILENAME_ENCODING
490
491* Fri Jun 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.3-0vl1
492- new upstream release
493
494* Sat Apr 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.2-0vl1
495- new upstream release
496
497* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
498- new upstream release
499
500* Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
501- new upstream release
502
503* Mon Feb 27 2006 Shu KONNO <owa@bg.wakwak.com> 2.8.6-0vl2
504- added compat32-* packages for x86_64 architecture support
505- chaged G_ATOMIC_X86_64 to I486 in config.h before making compat32
506
507* Sun Jan 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.6-0vl1
508- new upstream release
509
510* Thu Jan 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.5-0vl1
511- new upstream release
512
513* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.4-0vl1
514- new upstream release
515
516* Tue Sep 27 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl1
517- new upstream release
518
519* Tue Sep 20 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl3
520- fixed typo in glib2.csh
521
522* Sun Sep 18 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl2
523- update glib2.{sh,csh} to use G_FILENAME_ENCODING instead of
524  G_BROKEN_FILENAMES.
525
526* Wed Aug 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
527- new upstream release
528
529* Sat Aug 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.0-0vl1
530- new upstream release
531
532* Sat Aug 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.7-0vl1
533- new upstream release
534
535* Fri Aug 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.6-0vl1
536- new upstream release
537
538* Tue Aug 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.4-0vl1
539- new upstream release
540
541* Sun Jul 03 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.5-0vl1
542- new upstream release
543- add *.la to build arts (should be fixed in arts?)
544
545* Sat Apr 09 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.4-0vl1
546- new upstream release
547
548* Fri Mar 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.3-0vl1
549- new upstream release
550
551* Sat Feb 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.2-0vl1
552- new upstream release
553
554* Mon Jan 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-0vl1
555- new upstream release
556
557* Sat Dec 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.8-0vl1
558- new upstream release
559
560* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.7-0vl2
561- rebuilt
562
563* Mon Oct 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.7-0vl1
564- new upstream release
565
566* Sat Aug 14 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.6-0vl1
567- new upstream release
568
569* Sun Aug 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.5-0vl1
570- new upstream release
571
572* Fri Jul 16 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.4-0vl1
573- new upstream release
574
575* Sat Jun  5 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
576- new upstream release
577
578* Sat May  1 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
579- new upstream release
580
581* Thu Mar 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
582- new upstream release
583
584* Wed Dec 24 2003 Tomoya TAKA <taka@vinelinux.org> 2.2.3-0vl2
585- rebuild with new toolchain
586
587* Sat Aug 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3-0vl1
588- new upstream release
589
590* Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
591- new upstream release
592
593* Mon Feb 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
594- new upstream release
595
596* Wed Dec 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
597- new upstream release
598
599* Fri Dec 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
600- new upstream release
601- build for Vine Linux
602
603* Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
604- install glib2.sh and glib2.csh to set G_BROKEN_FILENAMES
605- blow away unpackaged files in install
606
607* Thu Aug  8 2002 Owen Taylor <otaylor@redhat.com>
608- Version 2.0.6
609- Remove fixed-ltmain.sh; shouldn't be needed any more.
610
611* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
612- automated rebuild
613
614* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
615- 2.0.4
616
617* Thu May 23 2002 Tim Powers <timp@redhat.com>
618- automated rebuild
619
620* Wed Apr 24 2002 Havoc Pennington <hp@redhat.com>
621 - rebuild in different environment
622
623* Mon Apr 15 2002 Owen Taylor <otaylor@redhat.com>
624- Fix missing .po files (#63336)
625
626* Wed Apr  3 2002 Alex Larsson <alexl@redhat.com>
627- Update to version 2.0.1
628
629* Fri Mar  8 2002 Owen Taylor <otaylor@redhat.com>
630- Version 2.0.0
631
632* Mon Feb 25 2002 Alex Larsson <alexl@redhat.com>
633- Update to 1.3.15
634
635* Thu Feb 21 2002 Alex Larsson <alexl@redhat.com>
636- Bump for rebuild
637
638* Mon Feb 18 2002 Alex Larsson <alexl@redhat.com>
639- Update to 1.3.14
640
641* Fri Feb 15 2002 Havoc Pennington <hp@redhat.com>
642- add horrible buildrequires hack
643
644* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
645- 1.3.13.91 cvs snap
646
647* Mon Feb 11 2002 Matt Wilson <msw@redhat.com>
648- rebuild from CVS snapshot
649- use setup -q
650
651* Thu Jan 31 2002 Jeremy Katz <katzj@redhat.com>
652- rebuild
653
654* Tue Jan 29 2002 Owen Taylor <otaylor@redhat.com>
655- 1.3.13
656
657* Tue Jan 22 2002 Havoc Pennington <hp@redhat.com>
658- attempting rebuild in rawhide
659
660* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
661- remove 64-bit patch now upstream, 1.3.12.90
662
663* Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
664- add some missing files to file list, langify
665
666* Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
667- add temporary patch to fix GTypeFundamentals on 64-bit
668
669* Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
670- Version 1.3.11
671
672* Thu Oct 25 2001 Owen Taylor <otaylor@redhat.com>
673- Version 1.3.10
674
675* Tue Sep 25 2001 Owen Taylor <otaylor@redhat.com>
676- Version 1.3.9
677
678* Wed Sep 19 2001 Owen Taylor <otaylor@redhat.com>
679- Version 1.3.8
680
681* Fri Jul 20 2001 Owen Taylor <otaylor@redhat.com>
682- Make -devel package require main package (#45388)
683- Fix description and summary
684- Configure with --disable-gtk-doc
685
686* Wed Jun 20 2001 Florian La Roche <Florian.LaRoche@redhat.de>
687- add some portability fixes needed at least on s390
688- copy config.{guess,sub} instead of calling libtoolize
689
690* Wed Jun 13 2001 Havoc Pennington <hp@redhat.com>
691- try a new glib tarball with Makefile changes to work around
692  libtool linking to installed .la files
693- make -devel require pkgconfig
694
695* Tue Jun 12 2001 Havoc Pennington <hp@redhat.com>
696- either libtool or the bad libtool hacks caused link
697  against glib-gobject 1.3.2, rebuild
698
699* Tue Jun 12 2001 Havoc Pennington <hp@redhat.com>
700- 1.3.6
701- bad libtool workarounds
702
703* Fri May 04 2001 Owen Taylor <otaylor@redhat.com>
704- 1.3.5, rename to glib2
705
706* Fri Nov 17 2000 Owen Taylor <otaylor@redhat.com>
707- Final 1.3.2
708
709* Mon Nov 13 2000 Owen Taylor <otaylor@redhat.com>
710- Version 1.3.2pre1
711- Remove pkgconfig
712
713* Sun Aug 13 2000 Owen Taylor <otaylor@redhat.com>
714- Call 1.3.1b instead of snap... the snap* naming doesn't
715  order correctly.
716
717* Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
718- new snapshot with fixed .pc files
719
720* Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
721- include .pc files in file list
722
723* Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
724- Include pkg-config
725- Upgrade to a glib CVS snapshot
726
727* Wed Jul 19 2000 Jakub Jelinek <jakub@redhat.com>
728- rebuild to cope with glibc locale binary incompatibility
729
730* Fri Jul 14 2000 Owen Taylor <otaylor@redhat.com>
731- Remove glib-config.1 manpage from build since
732  it conflicts with glib-devel. When we go to
733  glib glib1.2 setup, we should add it back
734
735* Fri Jul 07 2000 Owen Taylor <otaylor@redhat.com>
736- Version 1.3.1
737- Move back to standard %{prefix}
738
739* Thu Jun 8 2000 Owen Taylor <otaylor@redhat.com>
740- Rebuild in /opt/gtk-beta
741
742* Tue May 30 2000 Owen Taylor <otaylor@redhat.com>
743- New version (adds gobject)
744
745* Tue Apr 25 2000 Owen Taylor <otaylor@redhat.com>
746- Don't blow away /etc/ld.so.conf (sorry!)
747
748* Mon Apr 24 2000 Owen Taylor <otaylor@redhat.com>
749- Snapshot RPM for Pango testing
750
751* Fri Feb 04 2000 Owen Taylor <otaylor@redhat.com>
752- Added fixes from stable branch of CVS
753
754* Thu Oct 7  1999 Owen Taylor <otaylor@redhat.com>
755- version 1.2.6
756
757* Fri Sep 24 1999 Owen Taylor <otaylor@redhat.com>
758- version 1.2.5
759
760* Fri Sep 17 1999 Owen Taylor <otaylor@redhat.com>
761- version 1.2.4
762
763* Mon Jun 7 1999 Owen Taylor <otaylor@redhat.com>
764- version 1.2.3
765
766* Thu Mar 25 1999 Michael Fulbright <drmike@redhat.com>
767- version 1.2.1
768
769* Fri Feb 26 1999 Michael Fulbright <drmike@redhat.com>
770- Version 1.2
771
772* Thu Feb 25 1999 Michael Fulbright <drmike@redhat.com>
773- version 1.2.0pre1
774
775* Tue Feb 23 1999 Cristian Gafton <gafton@redhat.com>
776- new description tags
777
778* Sun Feb 21 1999 Michael Fulbright <drmike@redhat.com>
779- removed libtoolize from %build
780
781* Thu Feb 11 1999 Michael Fulbright <drmike@redhat.com>
782- added libgthread to file list
783
784* Fri Feb 05 1999 Michael Fulbright <drmike@redhat.com>
785- version 1.1.15
786
787* Wed Feb 03 1999 Michael Fulbright <drmike@redhat.com>
788- version 1.1.14
789
790* Mon Jan 18 1999 Michael Fulbright <drmike@redhat.com>
791- version 1.1.13
792
793* Wed Jan 06 1999 Michael Fulbright <drmike@redhat.com>
794- version 1.1.12
795
796* Wed Dec 16 1998 Michael Fulbright <drmike@redhat.com>
797- updated in preparation for the GNOME freeze
798
799* Mon Apr 13 1998 Marc Ewing <marc@redhat.com>
800- Split out glib package
801
Note: See TracBrowser for help on using the repository browser.