source: projects/specs/trunk/g/glib2/glib2-vl.spec @ 12310

Revision 12310, 23.2 KB checked in by tomop, 5 years ago (diff)

updated 18 packages

bind-9.11.12-1

bison-3.4.2-1

clisp-2.49.93-1

exiv2-0.27.2-1

firefox-68.2.0-1

galera-26.4.3-1

gcr-3.28.1-1

glib2-2.62.2-1

golang-1.13.4-1

incron-0.5.12-3

libgexiv2-0.12.0-1

libsecret-0.18.8-2

mariadb-10.4.10-1

perl-Bit-Vector-7.4-1

perl-Class-Accessor-0.51-1

seahorse-3.34-1

thunderbird-68.2.1-1

wireshark-3.0.6-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define _unpackaged_files_terminate_build 1
3
4Summary:        A library of handy utility functions.
5Name:           glib2
6Version:        2.62.2
7Release:        1%{?_dist_release}
8Group:          System Environment/Libraries
9
10Vendor:         Project Vine
11Distribution:   Vine Linux
12Packager:       Daisuke SUZUKI <daisuke@linux.or.jp>
13
14License:        LGPLv2+
15URL:            http://www.gtk.org
16%define         shortver %(echo %{version} | cut -d. -f1-2)
17Source:         https://download.gnome.org/sources/glib/%{shortver}/glib-%{version}.tar.xz
18Source2:        glib2.sh
19Source3:        glib2.csh
20
21BuildRoot:      %{_tmppath}/glib-%{version}-root
22
23BuildRequires: dbus-devel
24BuildRequires: docbook-style-xsl
25BuildRequires: gamin-devel
26BuildRequires: libattr-devel
27BuildRequires: libffi-devel
28BuildRequires: libmount-devel
29BuildRequires: libxslt
30BuildRequires: meson
31BuildRequires: pcre-devel >= 8.13
32BuildRequires: pkgconfig >= 0.14
33BuildRequires: python3-devel
34BuildRequires: zlib-devel
35Obsoletes: glib-gtkbeta
36
37# for gio-querymodules
38Requires(post,postun): libffi
39
40
41%description
42GLib is the low-level core library that forms the basis
43for projects such as GTK+ and GNOME. It provides data structure
44handling for C, portability wrappers, and interfaces for such runtime
45functionality as an event loop, threads, dynamic loading, and an
46object system.
47
48This package provides version %{shortver} of GLib.
49
50%package devel
51Summary: Development files for the GLib library
52Group: Development/Libraries
53Requires: %{name} = %{version}
54Requires: pkgconfig >= 0.14
55Requires: libffi-devel
56Requires: zlib-devel
57
58Obsoletes: glib-gtkbeta-devel
59Conflicts: glib-devel <= 1.2.8
60
61%description devel
62The glib-devel package includes the header files for
63version %{shortver} of the GLib library.
64
65
66## to build compat32 for x86_64 architecture support
67%package -n compat32-%{name}
68Summary: A library of handy utility functions.
69Group: System Environment/Libraries
70
71%description -n compat32-%{name}
72GLib is the low-level core library that forms the basis
73for projects such as GTK+ and GNOME. It provides data structure
74handling for C, portability wrappers, and interfaces for such runtime
75functionality as an event loop, threads, dynamic loading, and an
76object system.
77
78This package provides version %{shortver} of GLib.
79
80%package -n compat32-%{name}-devel
81Summary: Development files for the GLib library
82Group: Development/Libraries
83Requires: pkgconfig >= 0.14
84Requires: compat32-%{name} = %{version}
85
86Conflicts: glib-devel <= 1.2.8
87
88%description -n compat32-%{name}-devel
89The glib-devel package includes the header files for
90version %{shortver} of the GLib library.
91
92
93%prep
94%setup -q -n glib-%{version}
95
96%build
97%meson \
98        -Dselinux=disabled \
99        -Dman=true
100
101%meson_build
102
103%install
104rm -rf $RPM_BUILD_ROOT
105
106%meson_install
107
108## glib2.sh and glib2.csh
109mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
110install -m 755 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
111install -m 755 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
112
113#mkdir -p $RPM_BUILD_ROOT%{python_sitearch}
114#ln -sf %{_libdir}/gdbus-2.0/codegen  $RPM_BUILD_ROOT%{python_sitearch}/codegen
115
116mkdir -p $RPM_BUILD_ROOT%{_libdir}/gio/modules
117touch $RPM_BUILD_ROOT%{_libdir}/gio/modules/giomodule.cache
118
119rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
120rm -f $RPM_BUILD_ROOT%{_libdir}/gio/modules/lib*.{a,la}
121rm -f $RPM_BUILD_ROOT%{_libdir}/gio/modules/*.cache
122
123%find_lang glib20
124
125%clean
126rm -rf $RPM_BUILD_ROOT
127
128%post
129/sbin/ldconfig
130gio-querymodules %{_libdir}/gio/modules
131
132%postun
133/sbin/ldconfig
134gio-querymodules %{_libdir}/gio/modules
135
136%post -n compat32-%{name} -p /sbin/ldconfig
137
138%postun -n compat32-%{name} -p /sbin/ldconfig
139
140
141%files -f glib20.lang
142%defattr(-, root, root)
143%license COPYING
144%doc AUTHORS NEWS README*
145%{_bindir}/gapplication
146%{_bindir}/gdbus
147%{_bindir}/gio
148%{_bindir}/gio-launch-desktop
149%{_bindir}/gio-querymodules
150%{_bindir}/glib-compile-schemas
151%{_bindir}/gsettings
152%{_libdir}/libglib-2.0.so.*
153%{_libdir}/libgthread-2.0.so.*
154%{_libdir}/libgmodule-2.0.so.*
155%{_libdir}/libgobject-2.0.so.*
156%{_libdir}/libgio-2.0.so.*
157%dir %{_libdir}/gio
158%dir %{_libdir}/gio/modules
159#%{_libdir}/gio/modules/giomodule.cache
160#%{_libdir}/gio/modules/lib*.so
161%{_sysconfdir}/profile.d/*
162%dir %{_datadir}/bash-completion/completions
163%dir %{_datadir}/bash-completion
164%{_datadir}/bash-completion/completions/gapplication
165%{_datadir}/bash-completion/completions/gdbus
166%{_datadir}/bash-completion/completions/gio
167%{_datadir}/bash-completion/completions/gsettings
168
169%files devel
170%defattr(-, root, root)
171%{_bindir}/gdbus-codegen
172%{_bindir}/glib-compile-resources
173%{_bindir}/glib-genmarshal
174%{_bindir}/glib-gettextize
175%{_bindir}/glib-mkenums
176%{_bindir}/gobject-query
177%{_bindir}/gresource
178%{_bindir}/gtester
179%{_bindir}/gtester-report
180%{_libdir}/lib*.so
181#%{_libdir}/lib*.a
182#%{_libdir}/gdbus-2.0/codegen/*
183%{_libdir}/glib-2.0
184%{_libdir}/pkgconfig/*
185#%{python_sitearch}/codegen
186%{_includedir}/*
187%{_datadir}/aclocal/*
188%{_datadir}/glib-2.0
189%{_datadir}/gettext/its/gschema.its
190%{_datadir}/gettext/its/gschema.loc
191#%doc %{_datadir}/gtk-doc/html/*
192%doc %{_mandir}/man1/*
193%{_datadir}/gdb/auto-load%{_libdir}/libglib-2.0.so.*-gdb.py*
194%{_datadir}/gdb/auto-load%{_libdir}/libgobject-2.0.so.*-gdb.py*
195%dir %{_datadir}/bash-completion/completions
196%dir %{_datadir}/bash-completion
197%{_datadir}/bash-completion/completions/gresource
198
199%if %{build_compat32}
200%files -n compat32-%{name}
201%defattr(-, root, root)
202%{_libdir}/libglib-2.0.so.*
203%{_libdir}/libgthread-2.0.so.*
204%{_libdir}/libgmodule-2.0.so.*
205%{_libdir}/libgobject-2.0.so.*
206%{_libdir}/libgio-2.0.so.*
207%dir %{_libdir}/gio
208%dir %{_libdir}/gio/modules
209
210%files -n compat32-%{name}-devel
211%defattr(-, root, root)
212%{_libdir}/lib*.so
213%{_libdir}/glib-2.0
214%endif
215
216%changelog
217* Fri Nov 01 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.62.2-1
218- new upstream release.
219
220* Sat Apr 06 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.58.3-1
221- new upstream release.
222
223* Sat Dec 29 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.58.2-1
224- new upstream release.
225
226* Sat Jan 06 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.55.0-1
227- new upstream release.
228- dropped Patch0: fixed in upstream.
229- added BR:libmount-devel.
230
231* Thu Jul 14 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.48.1-1
232- new upstream release
233- add BuildRequires: pcre-devel
234
235* Sun May 08 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.46.2-2
236- add Requires: libffi
237
238* Fri Nov 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.46.2-1
239- new upstream release
240
241* Thu Oct 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.46.1-1
242- new upstream release
243
244* Thu May 14 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.44.1-1
245- new upstream release
246
247* Sat Mar 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.44.0-1
248- new upstream release
249
250* Sun Mar 08 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.42.2-1
251- new upstream release
252
253* Sun Nov 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.42.1-1
254- new upstream release
255
256* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.42.0-1
257- new upstream release
258
259* Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.0-2
260- rebuild with libffi-3.0.13
261
262* Fri Mar 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.0-1
263- new upstream release
264
265* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.38.2-1
266- new upstream release
267
268* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.38.1-1
269- new upstream release
270
271* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.4-1
272- new upstream release
273- remove Patch1 (glib-2.36.3-revert-g_file_set_contents.patch) from upstream
274
275* Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.3-1
276- new upstream release
277- add Patch1 (glib-2.36.3-revert-g_file_set_contents.patch) from upstream
278
279* Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.2-1
280- new upstream release
281
282* Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.1-1
283- new upstream release
284
285* Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.3-1
286- new upstream release
287
288* Sat Nov 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.2-1
289- new upstream release
290
291* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.1-1
292- new upstream release
293
294* Wed Sep 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.0-1
295- new upstream release
296
297* Mon Jul 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.4-1
298- new upstream release
299
300* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.3-1
301- new upstream release
302
303* Wed May 02 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
304- new upstream release
305
306* Sat Apr 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
307- new upstream release
308- add BuildRequires: python-devel
309- add Patch0 (glib-2.32.1-dconf-path.patch)
310
311* Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
312- new upstream release
313
314* Sun Oct 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
315- new upstream release
316
317* Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
318- new upstream release
319- add Requires: libffi-devel, zlib-devel (-devel sub package)
320
321* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.92-1
322- new upstream release
323
324* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.18-1
325- new upstream release
326- remove Patch0,1
327
328* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.16-1
329- new upstream release
330- Patch0: glib-2.29.16-fixes-bug-656387.patch
331- Patch1: glib-2.29.16-fixes-bug-656675.patch
332
333* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.14-1
334- new upstream release
335- add BuildRequires: libffi-devel, dbus-devel
336
337* Sat Jun 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.8-1
338- new upstream release
339
340* Fri Apr 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.6-1
341- new upstream release
342
343* Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.5-1
344- new upstream release
345
346* Wed Mar 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.4-1
347- new upstream release
348
349* Sat Mar 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.3-1
350- new upstream release
351
352* Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
353- new upstream release
354
355* Sat Feb 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.1-1
356- new upstream release
357
358* Sat Feb 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
359- new upstream release
360
361* Fri Dec 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.1-2
362- move the following files from glib2-devel to glib2 package
363   (gdbus, gio-querymodules, glib-compile-schemas, gsettings)
364
365* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.1-1
366- new upstream release
367
368* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.0-1
369- new upstream release
370- fix Source (add URL)
371- fix %files to add /etc/bash_completion.d files
372
373* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.24.2-2
374- build with rpm-4.8.1-1 for pkg-config file
375
376* Sat Aug 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.2-1
377- new upstream release
378
379* Tue May 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.1-1
380- new upstream release
381
382* Sun Mar 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.0-1
383- new upstream release
384- add BuildRequires: zlib-devel
385
386* Sun Mar 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.5-1
387- new upstream release
388
389* Mon Jan 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.4-1
390- new upstream release
391
392* Thu Jan 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.3-1
393- new upstream release
394
395* Sun Oct 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
396- new upstream release
397
398* Thu Sep 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.0-1
399- new upstream release
400
401* Mon Jun 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.4-1
402- new upstream release
403
404* Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.3-1
405- new upstream release
406
407* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.2-1
408- new upstream release
409
410* Sat Apr 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-1
411- new upstream release
412
413* Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.0-1
414- new upstream release
415
416* Sun Jan 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.4-1
417- new upstream release
418
419* Tue Nov 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.3-1
420- new upstream release
421
422* Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.2-1
423- new upstream release
424
425* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-1
426- new upstream release
427
428* Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-1
429- new upstream release
430
431* Mon Jul  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.4-1
432- new upstream release
433
434* Sat May 10 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.16.3-2
435- updated %%if %%{build_compat32} case related statements
436
437* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.3-1vl5
438- new upstream release
439- removed lib*.la files from devel package
440
441* Sun Apr  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.2-1vl5
442- new upstream release
443
444* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.1-1vl5
445- added %%{?_dist_release}
446- BuildRequires: gamin-devel
447
448* Tue Mar 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.1-0vl1
449- new upstream release
450
451* Thu Feb  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.6-0vl1
452- new upstream release
453
454* Wed Jan  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.5-0vl1
455- new upstream release
456
457* Wed Nov 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
458- new upstream release
459
460* Thu Oct 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.2-0vl1
461- new upstream release
462- removed BuildRequires: automake17
463
464* Thu Sep 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.1-0vl1
465- new upstream release
466
467* Sun Aug 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.0-0vl1
468- new upstream release
469
470* Wed Jul 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.13-0vl1
471- new upstream release
472
473* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.12-0vl2
474- rebuild with new environment
475
476* Thu May 03 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.12-0vl1
477- new upstream release
478
479* Thu Mar 15 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.11-0vl1
480- new upstream release
481
482* Mon Jan 08 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.7-0vl1
483- new upstream release
484
485* Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.6-0vl1
486- new upstream release
487
488* Thu Aug 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.3-0vl1
489- new upstream release
490
491* Wed Aug 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
492- new upstream release
493
494* Sat Aug 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
495- new upstream release
496
497* Mon Jun 26 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.10.3-0vl3
498- rebuild
499
500* Sun Jun 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.3-0vl2
501- update glib2.{sh,csh}
502  - add EUC-JP,CP932,UTF-8 to G_FILENAME_ENCODING
503
504* Fri Jun 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.3-0vl1
505- new upstream release
506
507* Sat Apr 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.2-0vl1
508- new upstream release
509
510* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
511- new upstream release
512
513* Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
514- new upstream release
515
516* Mon Feb 27 2006 Shu KONNO <owa@bg.wakwak.com> 2.8.6-0vl2
517- added compat32-* packages for x86_64 architecture support
518- chaged G_ATOMIC_X86_64 to I486 in config.h before making compat32
519
520* Sun Jan 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.6-0vl1
521- new upstream release
522
523* Thu Jan 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.5-0vl1
524- new upstream release
525
526* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.4-0vl1
527- new upstream release
528
529* Tue Sep 27 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl1
530- new upstream release
531
532* Tue Sep 20 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl3
533- fixed typo in glib2.csh
534
535* Sun Sep 18 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl2
536- update glib2.{sh,csh} to use G_FILENAME_ENCODING instead of
537  G_BROKEN_FILENAMES.
538
539* Wed Aug 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
540- new upstream release
541
542* Sat Aug 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.0-0vl1
543- new upstream release
544
545* Sat Aug 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.7-0vl1
546- new upstream release
547
548* Fri Aug 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.6-0vl1
549- new upstream release
550
551* Tue Aug 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.4-0vl1
552- new upstream release
553
554* Sun Jul 03 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.5-0vl1
555- new upstream release
556- add *.la to build arts (should be fixed in arts?)
557
558* Sat Apr 09 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.4-0vl1
559- new upstream release
560
561* Fri Mar 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.3-0vl1
562- new upstream release
563
564* Sat Feb 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.2-0vl1
565- new upstream release
566
567* Mon Jan 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-0vl1
568- new upstream release
569
570* Sat Dec 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.8-0vl1
571- new upstream release
572
573* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.7-0vl2
574- rebuilt
575
576* Mon Oct 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.7-0vl1
577- new upstream release
578
579* Sat Aug 14 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.6-0vl1
580- new upstream release
581
582* Sun Aug 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.5-0vl1
583- new upstream release
584
585* Fri Jul 16 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.4-0vl1
586- new upstream release
587
588* Sat Jun  5 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
589- new upstream release
590
591* Sat May  1 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
592- new upstream release
593
594* Thu Mar 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
595- new upstream release
596
597* Wed Dec 24 2003 Tomoya TAKA <taka@vinelinux.org> 2.2.3-0vl2
598- rebuild with new toolchain
599
600* Sat Aug 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3-0vl1
601- new upstream release
602
603* Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
604- new upstream release
605
606* Mon Feb 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
607- new upstream release
608
609* Wed Dec 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
610- new upstream release
611
612* Fri Dec 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
613- new upstream release
614- build for Vine Linux
615
616* Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
617- install glib2.sh and glib2.csh to set G_BROKEN_FILENAMES
618- blow away unpackaged files in install
619
620* Thu Aug  8 2002 Owen Taylor <otaylor@redhat.com>
621- Version 2.0.6
622- Remove fixed-ltmain.sh; shouldn't be needed any more.
623
624* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
625- automated rebuild
626
627* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
628- 2.0.4
629
630* Thu May 23 2002 Tim Powers <timp@redhat.com>
631- automated rebuild
632
633* Wed Apr 24 2002 Havoc Pennington <hp@redhat.com>
634 - rebuild in different environment
635
636* Mon Apr 15 2002 Owen Taylor <otaylor@redhat.com>
637- Fix missing .po files (#63336)
638
639* Wed Apr  3 2002 Alex Larsson <alexl@redhat.com>
640- Update to version 2.0.1
641
642* Fri Mar  8 2002 Owen Taylor <otaylor@redhat.com>
643- Version 2.0.0
644
645* Mon Feb 25 2002 Alex Larsson <alexl@redhat.com>
646- Update to 1.3.15
647
648* Thu Feb 21 2002 Alex Larsson <alexl@redhat.com>
649- Bump for rebuild
650
651* Mon Feb 18 2002 Alex Larsson <alexl@redhat.com>
652- Update to 1.3.14
653
654* Fri Feb 15 2002 Havoc Pennington <hp@redhat.com>
655- add horrible buildrequires hack
656
657* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
658- 1.3.13.91 cvs snap
659
660* Mon Feb 11 2002 Matt Wilson <msw@redhat.com>
661- rebuild from CVS snapshot
662- use setup -q
663
664* Thu Jan 31 2002 Jeremy Katz <katzj@redhat.com>
665- rebuild
666
667* Tue Jan 29 2002 Owen Taylor <otaylor@redhat.com>
668- 1.3.13
669
670* Tue Jan 22 2002 Havoc Pennington <hp@redhat.com>
671- attempting rebuild in rawhide
672
673* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
674- remove 64-bit patch now upstream, 1.3.12.90
675
676* Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
677- add some missing files to file list, langify
678
679* Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
680- add temporary patch to fix GTypeFundamentals on 64-bit
681
682* Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
683- Version 1.3.11
684
685* Thu Oct 25 2001 Owen Taylor <otaylor@redhat.com>
686- Version 1.3.10
687
688* Tue Sep 25 2001 Owen Taylor <otaylor@redhat.com>
689- Version 1.3.9
690
691* Wed Sep 19 2001 Owen Taylor <otaylor@redhat.com>
692- Version 1.3.8
693
694* Fri Jul 20 2001 Owen Taylor <otaylor@redhat.com>
695- Make -devel package require main package (#45388)
696- Fix description and summary
697- Configure with --disable-gtk-doc
698
699* Wed Jun 20 2001 Florian La Roche <Florian.LaRoche@redhat.de>
700- add some portability fixes needed at least on s390
701- copy config.{guess,sub} instead of calling libtoolize
702
703* Wed Jun 13 2001 Havoc Pennington <hp@redhat.com>
704- try a new glib tarball with Makefile changes to work around
705  libtool linking to installed .la files
706- make -devel require pkgconfig
707
708* Tue Jun 12 2001 Havoc Pennington <hp@redhat.com>
709- either libtool or the bad libtool hacks caused link
710  against glib-gobject 1.3.2, rebuild
711
712* Tue Jun 12 2001 Havoc Pennington <hp@redhat.com>
713- 1.3.6
714- bad libtool workarounds
715
716* Fri May 04 2001 Owen Taylor <otaylor@redhat.com>
717- 1.3.5, rename to glib2
718
719* Fri Nov 17 2000 Owen Taylor <otaylor@redhat.com>
720- Final 1.3.2
721
722* Mon Nov 13 2000 Owen Taylor <otaylor@redhat.com>
723- Version 1.3.2pre1
724- Remove pkgconfig
725
726* Sun Aug 13 2000 Owen Taylor <otaylor@redhat.com>
727- Call 1.3.1b instead of snap... the snap* naming doesn't
728  order correctly.
729
730* Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
731- new snapshot with fixed .pc files
732
733* Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
734- include .pc files in file list
735
736* Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
737- Include pkg-config
738- Upgrade to a glib CVS snapshot
739
740* Wed Jul 19 2000 Jakub Jelinek <jakub@redhat.com>
741- rebuild to cope with glibc locale binary incompatibility
742
743* Fri Jul 14 2000 Owen Taylor <otaylor@redhat.com>
744- Remove glib-config.1 manpage from build since
745  it conflicts with glib-devel. When we go to
746  glib glib1.2 setup, we should add it back
747
748* Fri Jul 07 2000 Owen Taylor <otaylor@redhat.com>
749- Version 1.3.1
750- Move back to standard %{prefix}
751
752* Thu Jun 8 2000 Owen Taylor <otaylor@redhat.com>
753- Rebuild in /opt/gtk-beta
754
755* Tue May 30 2000 Owen Taylor <otaylor@redhat.com>
756- New version (adds gobject)
757
758* Tue Apr 25 2000 Owen Taylor <otaylor@redhat.com>
759- Don't blow away /etc/ld.so.conf (sorry!)
760
761* Mon Apr 24 2000 Owen Taylor <otaylor@redhat.com>
762- Snapshot RPM for Pango testing
763
764* Fri Feb 04 2000 Owen Taylor <otaylor@redhat.com>
765- Added fixes from stable branch of CVS
766
767* Thu Oct 7  1999 Owen Taylor <otaylor@redhat.com>
768- version 1.2.6
769
770* Fri Sep 24 1999 Owen Taylor <otaylor@redhat.com>
771- version 1.2.5
772
773* Fri Sep 17 1999 Owen Taylor <otaylor@redhat.com>
774- version 1.2.4
775
776* Mon Jun 7 1999 Owen Taylor <otaylor@redhat.com>
777- version 1.2.3
778
779* Thu Mar 25 1999 Michael Fulbright <drmike@redhat.com>
780- version 1.2.1
781
782* Fri Feb 26 1999 Michael Fulbright <drmike@redhat.com>
783- Version 1.2
784
785* Thu Feb 25 1999 Michael Fulbright <drmike@redhat.com>
786- version 1.2.0pre1
787
788* Tue Feb 23 1999 Cristian Gafton <gafton@redhat.com>
789- new description tags
790
791* Sun Feb 21 1999 Michael Fulbright <drmike@redhat.com>
792- removed libtoolize from %build
793
794* Thu Feb 11 1999 Michael Fulbright <drmike@redhat.com>
795- added libgthread to file list
796
797* Fri Feb 05 1999 Michael Fulbright <drmike@redhat.com>
798- version 1.1.15
799
800* Wed Feb 03 1999 Michael Fulbright <drmike@redhat.com>
801- version 1.1.14
802
803* Mon Jan 18 1999 Michael Fulbright <drmike@redhat.com>
804- version 1.1.13
805
806* Wed Jan 06 1999 Michael Fulbright <drmike@redhat.com>
807- version 1.1.12
808
809* Wed Dec 16 1998 Michael Fulbright <drmike@redhat.com>
810- updated in preparation for the GNOME freeze
811
812* Mon Apr 13 1998 Marc Ewing <marc@redhat.com>
813- Split out glib package
814
Note: See TracBrowser for help on using the repository browser.