source: projects/specs/trunk/g/glib2/glib2-vl.spec @ 6951

Revision 6951, 20.2 KB checked in by Takemikaduchi, 12 years ago (diff)

GNOME-3.6.1

RevLine 
[6011]1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
[521]3%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
[4704]4
[521]5Summary: A library of handy utility functions.
6Name: glib2
[6951]7Version: 2.34.1
[2678]8Release: 1%{?_dist_release}
[521]9License: LGPLv2+
10Group: System Environment/Libraries
[6890]11Source: http://ftp.gnome.org/pub/GNOME/sources/glib/2.34/glib-%{version}.tar.xz
[521]12Source2: glib2.sh
13Source3: glib2.csh
[4616]14
[6078]15Patch0: glib-2.32.1-dconf-path.patch
16
[521]17BuildRoot: %{_tmppath}/glib-%{version}-root
[4616]18
[521]19BuildRequires: pkgconfig >= 0.14
[4616]20BuildRequires: dbus-devel
[521]21BuildRequires: gamin-devel
[4616]22BuildRequires: libffi-devel
23BuildRequires: zlib-devel
[6011]24BuildRequires: python-devel
[521]25BuildRequires: gtk-doc
26Obsoletes: glib-gtkbeta
27URL: http://www.gtk.org
28
29Vendor: Project Vine
30Distribution: Vine Linux
[2678]31Packager: Daisuke SUZUKI <daisuke@linux.or.jp>, Takemikaduchi
[521]32
33%description
34GLib is the low-level core library that forms the basis
35for projects such as GTK+ and GNOME. It provides data structure
36handling for C, portability wrappers, and interfaces for such runtime
37functionality as an event loop, threads, dynamic loading, and an
38object system.
39
[6890]40This package provides version 2.34 of GLib.
[521]41
42%package devel
43Summary: Development files for the GLib library
44Group: Development/Libraries
[4616]45Requires: %{name} = %{version}
46Requires: pkgconfig >= 0.14
[4850]47Requires: libffi-devel
48Requires: zlib-devel
[4616]49
[521]50Obsoletes: glib-gtkbeta-devel
51Conflicts: glib-devel <= 1.2.8
52
53%description devel
54The glib-devel package includes the header files for
[6890]55version 2.34 of the GLib library.
[521]56
57
58## to build compat32 for x86_64 architecture support
59%package -n compat32-%{name}
60Summary: A library of handy utility functions.
61Group: System Environment/Libraries
62
63%description -n compat32-%{name}
64GLib is the low-level core library that forms the basis
65for projects such as GTK+ and GNOME. It provides data structure
66handling for C, portability wrappers, and interfaces for such runtime
67functionality as an event loop, threads, dynamic loading, and an
68object system.
69
[6890]70This package provides version 2.34 of GLib.
[521]71
72%package -n compat32-%{name}-devel
73Summary: Development files for the GLib library
74Group: Development/Libraries
75Requires: pkgconfig >= 0.14
76Requires: compat32-%{name} = %{version}
[4616]77
[521]78Conflicts: glib-devel <= 1.2.8
79
80%description -n compat32-%{name}-devel
81The glib-devel package includes the header files for
[6890]82version 2.34 of the GLib library.
[521]83
84%prep
85%setup -q -n glib-%{version}
[6078]86%patch0 -p1
[521]87
88%build
[6078]89%configure --disable-selinux --enable-static --enable-systemtap
[521]90make %{?_smp_mflags}
91
92%install
93rm -rf $RPM_BUILD_ROOT
94
95mkdir -p $RPM_BUILD_ROOT%{_bindir}
[6078]96make install DESTDIR=$RPM_BUILD_ROOT
[521]97
98## glib2.sh and glib2.csh
99./mkinstalldirs $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
100install -m 755 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
101install -m 755 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
102
[6011]103mkdir -p $RPM_BUILD_ROOT%{python_sitearch}
104ln -sf %{_libdir}/gdbus-2.0/codegen  $RPM_BUILD_ROOT%{python_sitearch}/codegen
105
[6078]106touch $RPM_BUILD_ROOT%{_libdir}/gio/modules/giomodule.cache
107
[521]108rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
109rm -f $RPM_BUILD_ROOT%{_libdir}/gio/modules/lib*.{a,la}
[2041]110rm -f $RPM_BUILD_ROOT%{_libdir}/gio/modules/*.cache
[521]111
112%find_lang glib20
113
114%clean
115rm -rf $RPM_BUILD_ROOT
116
[6078]117%post
118/sbin/ldconfig
119gio-querymodules %{_libdir}/gio/modules
[521]120
[6078]121%postun
122/sbin/ldconfig
123gio-querymodules %{_libdir}/gio/modules
[521]124
125%post -n compat32-%{name} -p /sbin/ldconfig
126
127%postun -n compat32-%{name} -p /sbin/ldconfig
128
129
130%files -f glib20.lang
131%defattr(-, root, root)
132%doc AUTHORS COPYING ChangeLog NEWS README
[2323]133%{_bindir}/gdbus
134%{_bindir}/gio-querymodules
135%{_bindir}/glib-compile-schemas
136%{_bindir}/gsettings
[521]137%{_libdir}/libglib-2.0.so.*
138%{_libdir}/libgthread-2.0.so.*
139%{_libdir}/libgmodule-2.0.so.*
140%{_libdir}/libgobject-2.0.so.*
141%{_libdir}/libgio-2.0.so.*
142%{_libdir}/gio/modules/lib*.so
143%{_sysconfdir}/profile.d/*
[6581]144%{_datadir}/bash-completion/completions/gdbus
145%{_datadir}/bash-completion/completions/gsettings
[521]146
147%files devel
148%defattr(-, root, root)
[4616]149%{_bindir}/gdbus-codegen
[6011]150%{_bindir}/glib-compile-resources
[2323]151%{_bindir}/glib-genmarshal
152%{_bindir}/glib-gettextize
153%{_bindir}/glib-mkenums
154%{_bindir}/gobject-query
[6011]155%{_bindir}/gresource
[2323]156%{_bindir}/gtester
157%{_bindir}/gtester-report
[521]158%{_libdir}/lib*.so
159%{_libdir}/lib*.a
[6011]160%{_libdir}/gdbus-2.0/codegen/*
[521]161%{_libdir}/glib-2.0
[6011]162%{_libdir}/pkgconfig/*
163%{python_sitearch}/codegen
[521]164%{_includedir}/*
165%{_datadir}/aclocal/*
166%{_datadir}/glib-2.0
167%doc %{_datadir}/gtk-doc/html/*
168%doc %{_mandir}/man1/*
169%{_datadir}/gdb/auto-load%{_libdir}/libglib-2.0.so.*-gdb.py*
170%{_datadir}/gdb/auto-load%{_libdir}/libgobject-2.0.so.*-gdb.py*
[6581]171%{_datadir}/bash-completion/completions/gresource
[521]172
173%if %{build_compat32}
174%files -n compat32-%{name}
175%defattr(-, root, root)
176%{_libdir}/libglib-2.0.so.*
177%{_libdir}/libgthread-2.0.so.*
178%{_libdir}/libgmodule-2.0.so.*
179%{_libdir}/libgobject-2.0.so.*
180%{_libdir}/libgio-2.0.so.*
181%{_libdir}/gio/modules/lib*.so
182
183%files -n compat32-%{name}-devel
184%defattr(-, root, root)
185%{_libdir}/lib*.so
186%{_libdir}/lib*.a
187%{_libdir}/glib-2.0
188%endif
189
190%changelog
[6951]191* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.1-1
192- new upstream release
193
[6890]194* Wed Sep 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.0-1
195- new upstream release
196
[6581]197* Mon Jul 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.4-1
198- new upstream release
199
[6201]200* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.3-1
201- new upstream release
202
[6123]203* Wed May 02 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
204- new upstream release
205
[6011]206* Sat Apr 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
207- new upstream release
208- add BuildRequires: python-devel
[6078]209- add Patch0 (glib-2.32.1-dconf-path.patch)
[6011]210
[5168]211* Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
212- new upstream release
213
[5007]214* Sun Oct 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
215- new upstream release
216
[4850]217* Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
218- new upstream release
219- add Requires: libffi-devel, zlib-devel (-devel sub package)
220
[4812]221* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.92-1
222- new upstream release
223
[4704]224* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.18-1
225- new upstream release
226- remove Patch0,1
227
[4650]228* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.16-1
229- new upstream release
230- Patch0: glib-2.29.16-fixes-bug-656387.patch
231- Patch1: glib-2.29.16-fixes-bug-656675.patch
232
[4616]233* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.14-1
234- new upstream release
235- add BuildRequires: libffi-devel, dbus-devel
236
237* Sat Jun 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.8-1
238- new upstream release
239
[3685]240* Fri Apr 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.6-1
241- new upstream release
242
[3263]243* Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.5-1
244- new upstream release
245
[3079]246* Wed Mar 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.4-1
247- new upstream release
248
[3014]249* Sat Mar 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.3-1
250- new upstream release
251
[3003]252* Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
253- new upstream release
254
[2721]255* Sat Feb 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.1-1
256- new upstream release
257
[2678]258* Sat Feb 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
259- new upstream release
260
[2323]261* Fri Dec 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.1-2
262- move the following files from glib2-devel to glib2 package
263   (gdbus, gio-querymodules, glib-compile-schemas, gsettings)
264
[2219]265* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.1-1
266- new upstream release
267
[2041]268* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.0-1
269- new upstream release
270- fix Source (add URL)
271- fix %files to add /etc/bash_completion.d files
272
[1851]273* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.24.2-2
274- build with rpm-4.8.1-1 for pkg-config file
275
[1571]276* Sat Aug 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.2-1
277- new upstream release
278
[991]279* Tue May 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.1-1
280- new upstream release
281
[805]282* Sun Mar 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.0-1
283- new upstream release
284- add BuildRequires: zlib-devel
285
[697]286* Sun Mar 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.5-1
287- new upstream release
288
[521]289* Mon Jan 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.4-1
290- new upstream release
291
292* Thu Jan 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.3-1
293- new upstream release
294
295* Sun Oct 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
296- new upstream release
297
298* Thu Sep 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.0-1
299- new upstream release
300
301* Mon Jun 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.4-1
302- new upstream release
303
304* Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.3-1
305- new upstream release
306
307* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.2-1
308- new upstream release
309
310* Sat Apr 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-1
311- new upstream release
312
313* Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.0-1
314- new upstream release
315
316* Sun Jan 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.4-1
317- new upstream release
318
319* Tue Nov 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.3-1
320- new upstream release
321
322* Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.2-1
323- new upstream release
324
325* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-1
326- new upstream release
327
328* Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-1
329- new upstream release
330
331* Mon Jul  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.4-1
332- new upstream release
333
334* Sat May 10 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.16.3-2
335- updated %%if %%{build_compat32} case related statements
336
337* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.3-1vl5
338- new upstream release
339- removed lib*.la files from devel package
340
341* Sun Apr  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.2-1vl5
342- new upstream release
343
344* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.1-1vl5
345- added %%{?_dist_release}
346- BuildRequires: gamin-devel
347
348* Tue Mar 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.1-0vl1
349- new upstream release
350
351* Thu Feb  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.6-0vl1
352- new upstream release
353
354* Wed Jan  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.5-0vl1
355- new upstream release
356
357* Wed Nov 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
358- new upstream release
359
360* Thu Oct 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.2-0vl1
361- new upstream release
362- removed BuildRequires: automake17
363
364* Thu Sep 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.1-0vl1
365- new upstream release
366
367* Sun Aug 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.0-0vl1
368- new upstream release
369
370* Wed Jul 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.13-0vl1
371- new upstream release
372
373* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.12-0vl2
374- rebuild with new environment
375
376* Thu May 03 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.12-0vl1
377- new upstream release
378
379* Thu Mar 15 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.11-0vl1
380- new upstream release
381
382* Mon Jan 08 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.7-0vl1
383- new upstream release
384
385* Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.6-0vl1
386- new upstream release
387
388* Thu Aug 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.3-0vl1
389- new upstream release
390
391* Wed Aug 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
392- new upstream release
393
394* Sat Aug 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
395- new upstream release
396
397* Mon Jun 26 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.10.3-0vl3
398- rebuild
399
400* Sun Jun 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.3-0vl2
401- update glib2.{sh,csh}
402  - add EUC-JP,CP932,UTF-8 to G_FILENAME_ENCODING
403
404* Fri Jun 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.3-0vl1
405- new upstream release
406
407* Sat Apr 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.2-0vl1
408- new upstream release
409
410* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
411- new upstream release
412
413* Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
414- new upstream release
415
416* Mon Feb 27 2006 Shu KONNO <owa@bg.wakwak.com> 2.8.6-0vl2
417- added compat32-* packages for x86_64 architecture support
418- chaged G_ATOMIC_X86_64 to I486 in config.h before making compat32
419
420* Sun Jan 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.6-0vl1
421- new upstream release
422
423* Thu Jan 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.5-0vl1
424- new upstream release
425
426* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.4-0vl1
427- new upstream release
428
429* Tue Sep 27 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl1
430- new upstream release
431
432* Tue Sep 20 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl3
433- fixed typo in glib2.csh
434
435* Sun Sep 18 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl2
436- update glib2.{sh,csh} to use G_FILENAME_ENCODING instead of
437  G_BROKEN_FILENAMES.
438
439* Wed Aug 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
440- new upstream release
441
442* Sat Aug 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.0-0vl1
443- new upstream release
444
445* Sat Aug 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.7-0vl1
446- new upstream release
447
448* Fri Aug 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.6-0vl1
449- new upstream release
450
451* Tue Aug 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.4-0vl1
452- new upstream release
453
454* Sun Jul 03 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.5-0vl1
455- new upstream release
456- add *.la to build arts (should be fixed in arts?)
457
458* Sat Apr 09 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.4-0vl1
459- new upstream release
460
461* Fri Mar 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.3-0vl1
462- new upstream release
463
464* Sat Feb 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.2-0vl1
465- new upstream release
466
467* Mon Jan 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-0vl1
468- new upstream release
469
470* Sat Dec 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.8-0vl1
471- new upstream release
472
473* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.7-0vl2
474- rebuilt
475
476* Mon Oct 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.7-0vl1
477- new upstream release
478
479* Sat Aug 14 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.6-0vl1
480- new upstream release
481
482* Sun Aug 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.5-0vl1
483- new upstream release
484
485* Fri Jul 16 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.4-0vl1
486- new upstream release
487
488* Sat Jun  5 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
489- new upstream release
490
491* Sat May  1 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
492- new upstream release
493
494* Thu Mar 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
495- new upstream release
496
497* Wed Dec 24 2003 Tomoya TAKA <taka@vinelinux.org> 2.2.3-0vl2
498- rebuild with new toolchain
499
500* Sun Aug 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3-0vl1
501- new upstream release
502
503* Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
504- new upstream release
505
506* Mon Feb 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
507- new upstream release
508
509* Wed Dec 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
510- new upstream release
511
512* Fri Dec 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
513- new upstream release
514- build for Vine Linux
515
516* Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
517- install glib2.sh and glib2.csh to set G_BROKEN_FILENAMES
518- blow away unpackaged files in install
519
520* Thu Aug  8 2002 Owen Taylor <otaylor@redhat.com>
521- Version 2.0.6
522- Remove fixed-ltmain.sh; shouldn't be needed any more.
523
524* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
525- automated rebuild
526
527* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
528- 2.0.4
529
530* Thu May 23 2002 Tim Powers <timp@redhat.com>
531- automated rebuild
532
533* Wed Apr 24 2002 Havoc Pennington <hp@redhat.com>
534 - rebuild in different environment
535
536* Mon Apr 15 2002 Owen Taylor <otaylor@redhat.com>
537- Fix missing .po files (#63336)
538
539* Wed Apr  3 2002 Alex Larsson <alexl@redhat.com>
540- Update to version 2.0.1
541
542* Fri Mar  8 2002 Owen Taylor <otaylor@redhat.com>
543- Version 2.0.0
544
545* Mon Feb 25 2002 Alex Larsson <alexl@redhat.com>
546- Update to 1.3.15
547
548* Thu Feb 21 2002 Alex Larsson <alexl@redhat.com>
549- Bump for rebuild
550
551* Mon Feb 18 2002 Alex Larsson <alexl@redhat.com>
552- Update to 1.3.14
553
554* Fri Feb 15 2002 Havoc Pennington <hp@redhat.com>
555- add horrible buildrequires hack
556
557* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
558- 1.3.13.91 cvs snap
559
560* Mon Feb 11 2002 Matt Wilson <msw@redhat.com>
561- rebuild from CVS snapshot
562- use setup -q
563
564* Thu Jan 31 2002 Jeremy Katz <katzj@redhat.com>
565- rebuild
566
567* Tue Jan 29 2002 Owen Taylor <otaylor@redhat.com>
568- 1.3.13
569
570* Tue Jan 22 2002 Havoc Pennington <hp@redhat.com>
571- attempting rebuild in rawhide
572
573* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
574- remove 64-bit patch now upstream, 1.3.12.90
575
576* Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
577- add some missing files to file list, langify
578
579* Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
580- add temporary patch to fix GTypeFundamentals on 64-bit
581
582* Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
583- Version 1.3.11
584
585* Thu Oct 25 2001 Owen Taylor <otaylor@redhat.com>
586- Version 1.3.10
587
588* Tue Sep 25 2001 Owen Taylor <otaylor@redhat.com>
589- Version 1.3.9
590
591* Wed Sep 19 2001 Owen Taylor <otaylor@redhat.com>
592- Version 1.3.8
593
594* Fri Jul 20 2001 Owen Taylor <otaylor@redhat.com>
595- Make -devel package require main package (#45388)
596- Fix description and summary
597- Configure with --disable-gtk-doc
598
599* Wed Jun 20 2001 Florian La Roche <Florian.LaRoche@redhat.de>
600- add some portability fixes needed at least on s390
601- copy config.{guess,sub} instead of calling libtoolize
602
603* Wed Jun 13 2001 Havoc Pennington <hp@redhat.com>
604- try a new glib tarball with Makefile changes to work around
605  libtool linking to installed .la files
606- make -devel require pkgconfig
607
608* Tue Jun 12 2001 Havoc Pennington <hp@redhat.com>
609- either libtool or the bad libtool hacks caused link
610  against glib-gobject 1.3.2, rebuild
611
612* Tue Jun 12 2001 Havoc Pennington <hp@redhat.com>
613- 1.3.6
614- bad libtool workarounds
615
616* Fri May 04 2001 Owen Taylor <otaylor@redhat.com>
617- 1.3.5, rename to glib2
618
619* Fri Nov 17 2000 Owen Taylor <otaylor@redhat.com>
620- Final 1.3.2
621
622* Mon Nov 13 2000 Owen Taylor <otaylor@redhat.com>
623- Version 1.3.2pre1
624- Remove pkgconfig
625
626* Sun Aug 13 2000 Owen Taylor <otaylor@redhat.com>
627- Call 1.3.1b instead of snap... the snap* naming doesn't
628  order correctly.
629
630* Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
631- new snapshot with fixed .pc files
632
633* Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
634- include .pc files in file list
635
636* Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
637- Include pkg-config
638- Upgrade to a glib CVS snapshot
639
640* Wed Jul 19 2000 Jakub Jelinek <jakub@redhat.com>
641- rebuild to cope with glibc locale binary incompatibility
642
643* Fri Jul 14 2000 Owen Taylor <otaylor@redhat.com>
644- Remove glib-config.1 manpage from build since
645  it conflicts with glib-devel. When we go to
646  glib glib1.2 setup, we should add it back
647
648* Fri Jul 07 2000 Owen Taylor <otaylor@redhat.com>
649- Version 1.3.1
650- Move back to standard %{prefix}
651
652* Thu Jun 8 2000 Owen Taylor <otaylor@redhat.com>
653- Rebuild in /opt/gtk-beta
654
655* Tue May 30 2000 Owen Taylor <otaylor@redhat.com>
656- New version (adds gobject)
657
658* Wed Apr 25 2000 Owen Taylor <otaylor@redhat.com>
659- Don't blow away /etc/ld.so.conf (sorry!)
660
661* Tue Apr 24 2000 Owen Taylor <otaylor@redhat.com>
662- Snapshot RPM for Pango testing
663
664* Fri Feb 04 2000 Owen Taylor <otaylor@redhat.com>
665- Added fixes from stable branch of CVS
666
667* Thu Oct 7  1999 Owen Taylor <otaylor@redhat.com>
668- version 1.2.6
669
670* Fri Sep 24 1999 Owen Taylor <otaylor@redhat.com>
671- version 1.2.5
672
673* Fri Sep 17 1999 Owen Taylor <otaylor@redhat.com>
674- version 1.2.4
675
676* Mon Jun 7 1999 Owen Taylor <otaylor@redhat.com>
677- version 1.2.3
678
679* Thu Mar 25 1999 Michael Fulbright <drmike@redhat.com>
680- version 1.2.1
681
682* Fri Feb 26 1999 Michael Fulbright <drmike@redhat.com>
683- Version 1.2
684
685* Thu Feb 25 1999 Michael Fulbright <drmike@redhat.com>
686- version 1.2.0pre1
687
688* Tue Feb 23 1999 Cristian Gafton <gafton@redhat.com>
689- new description tags
690
691* Sun Feb 21 1999 Michael Fulbright <drmike@redhat.com>
692- removed libtoolize from %build
693
694* Thu Feb 11 1999 Michael Fulbright <drmike@redhat.com>
695- added libgthread to file list
696
697* Fri Feb 05 1999 Michael Fulbright <drmike@redhat.com>
698- version 1.1.15
699
700* Wed Feb 03 1999 Michael Fulbright <drmike@redhat.com>
701- version 1.1.14
702
703* Mon Jan 18 1999 Michael Fulbright <drmike@redhat.com>
704- version 1.1.13
705
706* Wed Jan 06 1999 Michael Fulbright <drmike@redhat.com>
707- version 1.1.12
708
709* Wed Dec 16 1998 Michael Fulbright <drmike@redhat.com>
710- updated in preparation for the GNOME freeze
711
712* Mon Apr 13 1998 Marc Ewing <marc@redhat.com>
713- Split out glib package
714
Note: See TracBrowser for help on using the repository browser.