source: projects/specs/trunk/g/glib2/glib2-vl.spec @ 6890

Revision 6890, 20.1 KB checked in by Takemikaduchi, 12 years ago (diff)

GNOME-3.6.0 & Cinnamon-1.6.1

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
4
5Summary: A library of handy utility functions.
6Name: glib2
7Version: 2.34.0
8Release: 1%{?_dist_release}
9License: LGPLv2+
10Group: System Environment/Libraries
11Source: http://ftp.gnome.org/pub/GNOME/sources/glib/2.34/glib-%{version}.tar.xz
12Source2: glib2.sh
13Source3: glib2.csh
14
15Patch0: glib-2.32.1-dconf-path.patch
16
17BuildRoot: %{_tmppath}/glib-%{version}-root
18
19BuildRequires: pkgconfig >= 0.14
20BuildRequires: dbus-devel
21BuildRequires: gamin-devel
22BuildRequires: libffi-devel
23BuildRequires: zlib-devel
24BuildRequires: python-devel
25BuildRequires: gtk-doc
26Obsoletes: glib-gtkbeta
27URL: http://www.gtk.org
28
29Vendor: Project Vine
30Distribution: Vine Linux
31Packager: Daisuke SUZUKI <daisuke@linux.or.jp>, Takemikaduchi
32
33%description
34GLib is the low-level core library that forms the basis
35for projects such as GTK+ and GNOME. It provides data structure
36handling for C, portability wrappers, and interfaces for such runtime
37functionality as an event loop, threads, dynamic loading, and an
38object system.
39
40This package provides version 2.34 of GLib.
41
42%package devel
43Summary: Development files for the GLib library
44Group: Development/Libraries
45Requires: %{name} = %{version}
46Requires: pkgconfig >= 0.14
47Requires: libffi-devel
48Requires: zlib-devel
49
50Obsoletes: glib-gtkbeta-devel
51Conflicts: glib-devel <= 1.2.8
52
53%description devel
54The glib-devel package includes the header files for
55version 2.34 of the GLib library.
56
57
58## to build compat32 for x86_64 architecture support
59%package -n compat32-%{name}
60Summary: A library of handy utility functions.
61Group: System Environment/Libraries
62
63%description -n compat32-%{name}
64GLib is the low-level core library that forms the basis
65for projects such as GTK+ and GNOME. It provides data structure
66handling for C, portability wrappers, and interfaces for such runtime
67functionality as an event loop, threads, dynamic loading, and an
68object system.
69
70This package provides version 2.34 of GLib.
71
72%package -n compat32-%{name}-devel
73Summary: Development files for the GLib library
74Group: Development/Libraries
75Requires: pkgconfig >= 0.14
76Requires: compat32-%{name} = %{version}
77
78Conflicts: glib-devel <= 1.2.8
79
80%description -n compat32-%{name}-devel
81The glib-devel package includes the header files for
82version 2.34 of the GLib library.
83
84%prep
85%setup -q -n glib-%{version}
86%patch0 -p1
87
88%build
89%configure --disable-selinux --enable-static --enable-systemtap
90make %{?_smp_mflags}
91
92%install
93rm -rf $RPM_BUILD_ROOT
94
95mkdir -p $RPM_BUILD_ROOT%{_bindir}
96make install DESTDIR=$RPM_BUILD_ROOT
97
98## glib2.sh and glib2.csh
99./mkinstalldirs $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
100install -m 755 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
101install -m 755 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
102
103mkdir -p $RPM_BUILD_ROOT%{python_sitearch}
104ln -sf %{_libdir}/gdbus-2.0/codegen  $RPM_BUILD_ROOT%{python_sitearch}/codegen
105
106touch $RPM_BUILD_ROOT%{_libdir}/gio/modules/giomodule.cache
107
108rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
109rm -f $RPM_BUILD_ROOT%{_libdir}/gio/modules/lib*.{a,la}
110rm -f $RPM_BUILD_ROOT%{_libdir}/gio/modules/*.cache
111
112%find_lang glib20
113
114%clean
115rm -rf $RPM_BUILD_ROOT
116
117%post
118/sbin/ldconfig
119gio-querymodules %{_libdir}/gio/modules
120
121%postun
122/sbin/ldconfig
123gio-querymodules %{_libdir}/gio/modules
124
125%post -n compat32-%{name} -p /sbin/ldconfig
126
127%postun -n compat32-%{name} -p /sbin/ldconfig
128
129
130%files -f glib20.lang
131%defattr(-, root, root)
132%doc AUTHORS COPYING ChangeLog NEWS README
133%{_bindir}/gdbus
134%{_bindir}/gio-querymodules
135%{_bindir}/glib-compile-schemas
136%{_bindir}/gsettings
137%{_libdir}/libglib-2.0.so.*
138%{_libdir}/libgthread-2.0.so.*
139%{_libdir}/libgmodule-2.0.so.*
140%{_libdir}/libgobject-2.0.so.*
141%{_libdir}/libgio-2.0.so.*
142%{_libdir}/gio/modules/lib*.so
143%{_sysconfdir}/profile.d/*
144%{_datadir}/bash-completion/completions/gdbus
145%{_datadir}/bash-completion/completions/gsettings
146
147%files devel
148%defattr(-, root, root)
149%{_bindir}/gdbus-codegen
150%{_bindir}/glib-compile-resources
151%{_bindir}/glib-genmarshal
152%{_bindir}/glib-gettextize
153%{_bindir}/glib-mkenums
154%{_bindir}/gobject-query
155%{_bindir}/gresource
156%{_bindir}/gtester
157%{_bindir}/gtester-report
158%{_libdir}/lib*.so
159%{_libdir}/lib*.a
160%{_libdir}/gdbus-2.0/codegen/*
161%{_libdir}/glib-2.0
162%{_libdir}/pkgconfig/*
163%{python_sitearch}/codegen
164%{_includedir}/*
165%{_datadir}/aclocal/*
166%{_datadir}/glib-2.0
167%doc %{_datadir}/gtk-doc/html/*
168%doc %{_mandir}/man1/*
169%{_datadir}/gdb/auto-load%{_libdir}/libglib-2.0.so.*-gdb.py*
170%{_datadir}/gdb/auto-load%{_libdir}/libgobject-2.0.so.*-gdb.py*
171%{_datadir}/bash-completion/completions/gresource
172
173%if %{build_compat32}
174%files -n compat32-%{name}
175%defattr(-, root, root)
176%{_libdir}/libglib-2.0.so.*
177%{_libdir}/libgthread-2.0.so.*
178%{_libdir}/libgmodule-2.0.so.*
179%{_libdir}/libgobject-2.0.so.*
180%{_libdir}/libgio-2.0.so.*
181%{_libdir}/gio/modules/lib*.so
182
183%files -n compat32-%{name}-devel
184%defattr(-, root, root)
185%{_libdir}/lib*.so
186%{_libdir}/lib*.a
187%{_libdir}/glib-2.0
188%endif
189
190%changelog
191* Wed Sep 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.0-1
192- new upstream release
193
194* Mon Jul 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.4-1
195- new upstream release
196
197* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.3-1
198- new upstream release
199
200* Wed May 02 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
201- new upstream release
202
203* Sat Apr 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
204- new upstream release
205- add BuildRequires: python-devel
206- add Patch0 (glib-2.32.1-dconf-path.patch)
207
208* Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
209- new upstream release
210
211* Sun Oct 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
212- new upstream release
213
214* Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
215- new upstream release
216- add Requires: libffi-devel, zlib-devel (-devel sub package)
217
218* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.92-1
219- new upstream release
220
221* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.18-1
222- new upstream release
223- remove Patch0,1
224
225* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.16-1
226- new upstream release
227- Patch0: glib-2.29.16-fixes-bug-656387.patch
228- Patch1: glib-2.29.16-fixes-bug-656675.patch
229
230* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.14-1
231- new upstream release
232- add BuildRequires: libffi-devel, dbus-devel
233
234* Sat Jun 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.8-1
235- new upstream release
236
237* Fri Apr 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.6-1
238- new upstream release
239
240* Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.5-1
241- new upstream release
242
243* Wed Mar 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.4-1
244- new upstream release
245
246* Sat Mar 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.3-1
247- new upstream release
248
249* Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
250- new upstream release
251
252* Sat Feb 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.1-1
253- new upstream release
254
255* Sat Feb 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
256- new upstream release
257
258* Fri Dec 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.1-2
259- move the following files from glib2-devel to glib2 package
260   (gdbus, gio-querymodules, glib-compile-schemas, gsettings)
261
262* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.1-1
263- new upstream release
264
265* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.0-1
266- new upstream release
267- fix Source (add URL)
268- fix %files to add /etc/bash_completion.d files
269
270* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.24.2-2
271- build with rpm-4.8.1-1 for pkg-config file
272
273* Sat Aug 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.2-1
274- new upstream release
275
276* Tue May 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.1-1
277- new upstream release
278
279* Sun Mar 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.0-1
280- new upstream release
281- add BuildRequires: zlib-devel
282
283* Sun Mar 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.5-1
284- new upstream release
285
286* Mon Jan 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.4-1
287- new upstream release
288
289* Thu Jan 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.3-1
290- new upstream release
291
292* Sun Oct 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
293- new upstream release
294
295* Thu Sep 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.0-1
296- new upstream release
297
298* Mon Jun 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.4-1
299- new upstream release
300
301* Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.3-1
302- new upstream release
303
304* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.2-1
305- new upstream release
306
307* Sat Apr 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-1
308- new upstream release
309
310* Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.0-1
311- new upstream release
312
313* Sun Jan 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.4-1
314- new upstream release
315
316* Tue Nov 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.3-1
317- new upstream release
318
319* Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.2-1
320- new upstream release
321
322* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-1
323- new upstream release
324
325* Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-1
326- new upstream release
327
328* Mon Jul  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.4-1
329- new upstream release
330
331* Sat May 10 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.16.3-2
332- updated %%if %%{build_compat32} case related statements
333
334* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.3-1vl5
335- new upstream release
336- removed lib*.la files from devel package
337
338* Sun Apr  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.2-1vl5
339- new upstream release
340
341* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.1-1vl5
342- added %%{?_dist_release}
343- BuildRequires: gamin-devel
344
345* Tue Mar 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.1-0vl1
346- new upstream release
347
348* Thu Feb  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.6-0vl1
349- new upstream release
350
351* Wed Jan  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.5-0vl1
352- new upstream release
353
354* Wed Nov 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
355- new upstream release
356
357* Thu Oct 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.2-0vl1
358- new upstream release
359- removed BuildRequires: automake17
360
361* Thu Sep 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.1-0vl1
362- new upstream release
363
364* Sun Aug 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.0-0vl1
365- new upstream release
366
367* Wed Jul 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.13-0vl1
368- new upstream release
369
370* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.12-0vl2
371- rebuild with new environment
372
373* Thu May 03 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.12-0vl1
374- new upstream release
375
376* Thu Mar 15 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.11-0vl1
377- new upstream release
378
379* Mon Jan 08 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.7-0vl1
380- new upstream release
381
382* Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.6-0vl1
383- new upstream release
384
385* Thu Aug 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.3-0vl1
386- new upstream release
387
388* Wed Aug 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
389- new upstream release
390
391* Sat Aug 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
392- new upstream release
393
394* Mon Jun 26 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.10.3-0vl3
395- rebuild
396
397* Sun Jun 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.3-0vl2
398- update glib2.{sh,csh}
399  - add EUC-JP,CP932,UTF-8 to G_FILENAME_ENCODING
400
401* Fri Jun 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.3-0vl1
402- new upstream release
403
404* Sat Apr 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.2-0vl1
405- new upstream release
406
407* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
408- new upstream release
409
410* Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
411- new upstream release
412
413* Mon Feb 27 2006 Shu KONNO <owa@bg.wakwak.com> 2.8.6-0vl2
414- added compat32-* packages for x86_64 architecture support
415- chaged G_ATOMIC_X86_64 to I486 in config.h before making compat32
416
417* Sun Jan 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.6-0vl1
418- new upstream release
419
420* Thu Jan 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.5-0vl1
421- new upstream release
422
423* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.4-0vl1
424- new upstream release
425
426* Tue Sep 27 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl1
427- new upstream release
428
429* Tue Sep 20 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl3
430- fixed typo in glib2.csh
431
432* Sun Sep 18 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl2
433- update glib2.{sh,csh} to use G_FILENAME_ENCODING instead of
434  G_BROKEN_FILENAMES.
435
436* Wed Aug 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
437- new upstream release
438
439* Sat Aug 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.0-0vl1
440- new upstream release
441
442* Sat Aug 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.7-0vl1
443- new upstream release
444
445* Fri Aug 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.6-0vl1
446- new upstream release
447
448* Tue Aug 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.4-0vl1
449- new upstream release
450
451* Sun Jul 03 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.5-0vl1
452- new upstream release
453- add *.la to build arts (should be fixed in arts?)
454
455* Sat Apr 09 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.4-0vl1
456- new upstream release
457
458* Fri Mar 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.3-0vl1
459- new upstream release
460
461* Sat Feb 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.2-0vl1
462- new upstream release
463
464* Mon Jan 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-0vl1
465- new upstream release
466
467* Sat Dec 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.8-0vl1
468- new upstream release
469
470* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.7-0vl2
471- rebuilt
472
473* Mon Oct 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.7-0vl1
474- new upstream release
475
476* Sat Aug 14 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.6-0vl1
477- new upstream release
478
479* Sun Aug 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.5-0vl1
480- new upstream release
481
482* Fri Jul 16 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.4-0vl1
483- new upstream release
484
485* Sat Jun  5 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
486- new upstream release
487
488* Sat May  1 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
489- new upstream release
490
491* Thu Mar 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
492- new upstream release
493
494* Wed Dec 24 2003 Tomoya TAKA <taka@vinelinux.org> 2.2.3-0vl2
495- rebuild with new toolchain
496
497* Sun Aug 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3-0vl1
498- new upstream release
499
500* Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
501- new upstream release
502
503* Mon Feb 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
504- new upstream release
505
506* Wed Dec 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
507- new upstream release
508
509* Fri Dec 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
510- new upstream release
511- build for Vine Linux
512
513* Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
514- install glib2.sh and glib2.csh to set G_BROKEN_FILENAMES
515- blow away unpackaged files in install
516
517* Thu Aug  8 2002 Owen Taylor <otaylor@redhat.com>
518- Version 2.0.6
519- Remove fixed-ltmain.sh; shouldn't be needed any more.
520
521* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
522- automated rebuild
523
524* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
525- 2.0.4
526
527* Thu May 23 2002 Tim Powers <timp@redhat.com>
528- automated rebuild
529
530* Wed Apr 24 2002 Havoc Pennington <hp@redhat.com>
531 - rebuild in different environment
532
533* Mon Apr 15 2002 Owen Taylor <otaylor@redhat.com>
534- Fix missing .po files (#63336)
535
536* Wed Apr  3 2002 Alex Larsson <alexl@redhat.com>
537- Update to version 2.0.1
538
539* Fri Mar  8 2002 Owen Taylor <otaylor@redhat.com>
540- Version 2.0.0
541
542* Mon Feb 25 2002 Alex Larsson <alexl@redhat.com>
543- Update to 1.3.15
544
545* Thu Feb 21 2002 Alex Larsson <alexl@redhat.com>
546- Bump for rebuild
547
548* Mon Feb 18 2002 Alex Larsson <alexl@redhat.com>
549- Update to 1.3.14
550
551* Fri Feb 15 2002 Havoc Pennington <hp@redhat.com>
552- add horrible buildrequires hack
553
554* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
555- 1.3.13.91 cvs snap
556
557* Mon Feb 11 2002 Matt Wilson <msw@redhat.com>
558- rebuild from CVS snapshot
559- use setup -q
560
561* Thu Jan 31 2002 Jeremy Katz <katzj@redhat.com>
562- rebuild
563
564* Tue Jan 29 2002 Owen Taylor <otaylor@redhat.com>
565- 1.3.13
566
567* Tue Jan 22 2002 Havoc Pennington <hp@redhat.com>
568- attempting rebuild in rawhide
569
570* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
571- remove 64-bit patch now upstream, 1.3.12.90
572
573* Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
574- add some missing files to file list, langify
575
576* Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
577- add temporary patch to fix GTypeFundamentals on 64-bit
578
579* Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
580- Version 1.3.11
581
582* Thu Oct 25 2001 Owen Taylor <otaylor@redhat.com>
583- Version 1.3.10
584
585* Tue Sep 25 2001 Owen Taylor <otaylor@redhat.com>
586- Version 1.3.9
587
588* Wed Sep 19 2001 Owen Taylor <otaylor@redhat.com>
589- Version 1.3.8
590
591* Fri Jul 20 2001 Owen Taylor <otaylor@redhat.com>
592- Make -devel package require main package (#45388)
593- Fix description and summary
594- Configure with --disable-gtk-doc
595
596* Wed Jun 20 2001 Florian La Roche <Florian.LaRoche@redhat.de>
597- add some portability fixes needed at least on s390
598- copy config.{guess,sub} instead of calling libtoolize
599
600* Wed Jun 13 2001 Havoc Pennington <hp@redhat.com>
601- try a new glib tarball with Makefile changes to work around
602  libtool linking to installed .la files
603- make -devel require pkgconfig
604
605* Tue Jun 12 2001 Havoc Pennington <hp@redhat.com>
606- either libtool or the bad libtool hacks caused link
607  against glib-gobject 1.3.2, rebuild
608
609* Tue Jun 12 2001 Havoc Pennington <hp@redhat.com>
610- 1.3.6
611- bad libtool workarounds
612
613* Fri May 04 2001 Owen Taylor <otaylor@redhat.com>
614- 1.3.5, rename to glib2
615
616* Fri Nov 17 2000 Owen Taylor <otaylor@redhat.com>
617- Final 1.3.2
618
619* Mon Nov 13 2000 Owen Taylor <otaylor@redhat.com>
620- Version 1.3.2pre1
621- Remove pkgconfig
622
623* Sun Aug 13 2000 Owen Taylor <otaylor@redhat.com>
624- Call 1.3.1b instead of snap... the snap* naming doesn't
625  order correctly.
626
627* Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
628- new snapshot with fixed .pc files
629
630* Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
631- include .pc files in file list
632
633* Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
634- Include pkg-config
635- Upgrade to a glib CVS snapshot
636
637* Wed Jul 19 2000 Jakub Jelinek <jakub@redhat.com>
638- rebuild to cope with glibc locale binary incompatibility
639
640* Fri Jul 14 2000 Owen Taylor <otaylor@redhat.com>
641- Remove glib-config.1 manpage from build since
642  it conflicts with glib-devel. When we go to
643  glib glib1.2 setup, we should add it back
644
645* Fri Jul 07 2000 Owen Taylor <otaylor@redhat.com>
646- Version 1.3.1
647- Move back to standard %{prefix}
648
649* Thu Jun 8 2000 Owen Taylor <otaylor@redhat.com>
650- Rebuild in /opt/gtk-beta
651
652* Tue May 30 2000 Owen Taylor <otaylor@redhat.com>
653- New version (adds gobject)
654
655* Wed Apr 25 2000 Owen Taylor <otaylor@redhat.com>
656- Don't blow away /etc/ld.so.conf (sorry!)
657
658* Tue Apr 24 2000 Owen Taylor <otaylor@redhat.com>
659- Snapshot RPM for Pango testing
660
661* Fri Feb 04 2000 Owen Taylor <otaylor@redhat.com>
662- Added fixes from stable branch of CVS
663
664* Thu Oct 7  1999 Owen Taylor <otaylor@redhat.com>
665- version 1.2.6
666
667* Fri Sep 24 1999 Owen Taylor <otaylor@redhat.com>
668- version 1.2.5
669
670* Fri Sep 17 1999 Owen Taylor <otaylor@redhat.com>
671- version 1.2.4
672
673* Mon Jun 7 1999 Owen Taylor <otaylor@redhat.com>
674- version 1.2.3
675
676* Thu Mar 25 1999 Michael Fulbright <drmike@redhat.com>
677- version 1.2.1
678
679* Fri Feb 26 1999 Michael Fulbright <drmike@redhat.com>
680- Version 1.2
681
682* Thu Feb 25 1999 Michael Fulbright <drmike@redhat.com>
683- version 1.2.0pre1
684
685* Tue Feb 23 1999 Cristian Gafton <gafton@redhat.com>
686- new description tags
687
688* Sun Feb 21 1999 Michael Fulbright <drmike@redhat.com>
689- removed libtoolize from %build
690
691* Thu Feb 11 1999 Michael Fulbright <drmike@redhat.com>
692- added libgthread to file list
693
694* Fri Feb 05 1999 Michael Fulbright <drmike@redhat.com>
695- version 1.1.15
696
697* Wed Feb 03 1999 Michael Fulbright <drmike@redhat.com>
698- version 1.1.14
699
700* Mon Jan 18 1999 Michael Fulbright <drmike@redhat.com>
701- version 1.1.13
702
703* Wed Jan 06 1999 Michael Fulbright <drmike@redhat.com>
704- version 1.1.12
705
706* Wed Dec 16 1998 Michael Fulbright <drmike@redhat.com>
707- updated in preparation for the GNOME freeze
708
709* Mon Apr 13 1998 Marc Ewing <marc@redhat.com>
710- Split out glib package
711
Note: See TracBrowser for help on using the repository browser.