source: projects/specs/trunk/g/glib2/glib2-vl.spec @ 6581

Revision 6581, 20.1 KB checked in by Takemikaduchi, 12 years ago (diff)

cogl: bug fix
others: new upstream release

RevLine 
[6011]1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
[521]3%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
[4704]4
[521]5Summary: A library of handy utility functions.
6Name: glib2
[6581]7Version: 2.32.4
[2678]8Release: 1%{?_dist_release}
[521]9License: LGPLv2+
10Group: System Environment/Libraries
[6011]11Source: http://ftp.gnome.org/pub/GNOME/sources/glib/2.32/glib-%{version}.tar.xz
[521]12Source2: glib2.sh
13Source3: glib2.csh
[4616]14
[6078]15Patch0: glib-2.32.1-dconf-path.patch
16
[521]17BuildRoot: %{_tmppath}/glib-%{version}-root
[4616]18
[521]19BuildRequires: pkgconfig >= 0.14
[4616]20BuildRequires: dbus-devel
[521]21BuildRequires: gamin-devel
[4616]22BuildRequires: libffi-devel
23BuildRequires: zlib-devel
[6011]24BuildRequires: python-devel
[521]25BuildRequires: gtk-doc
26Obsoletes: glib-gtkbeta
27URL: http://www.gtk.org
28
29Vendor: Project Vine
30Distribution: Vine Linux
[2678]31Packager: Daisuke SUZUKI <daisuke@linux.or.jp>, Takemikaduchi
[521]32
33%description
34GLib is the low-level core library that forms the basis
35for projects such as GTK+ and GNOME. It provides data structure
36handling for C, portability wrappers, and interfaces for such runtime
37functionality as an event loop, threads, dynamic loading, and an
38object system.
39
[6011]40This package provides version 2.32 of GLib.
[521]41
42%package devel
43Summary: Development files for the GLib library
44Group: Development/Libraries
[4616]45Requires: %{name} = %{version}
46Requires: pkgconfig >= 0.14
[4850]47Requires: libffi-devel
48Requires: zlib-devel
[4616]49
[521]50Obsoletes: glib-gtkbeta-devel
51Conflicts: glib-devel <= 1.2.8
52
53%description devel
54The glib-devel package includes the header files for
[6011]55version 2.32 of the GLib library.
[521]56
57
58## to build compat32 for x86_64 architecture support
59%package -n compat32-%{name}
60Summary: A library of handy utility functions.
61Group: System Environment/Libraries
62
63%description -n compat32-%{name}
64GLib is the low-level core library that forms the basis
65for projects such as GTK+ and GNOME. It provides data structure
66handling for C, portability wrappers, and interfaces for such runtime
67functionality as an event loop, threads, dynamic loading, and an
68object system.
69
[6011]70This package provides version 2.32 of GLib.
[521]71
72%package -n compat32-%{name}-devel
73Summary: Development files for the GLib library
74Group: Development/Libraries
75Requires: pkgconfig >= 0.14
76Requires: compat32-%{name} = %{version}
[4616]77
[521]78Conflicts: glib-devel <= 1.2.8
79
80%description -n compat32-%{name}-devel
81The glib-devel package includes the header files for
[6011]82version 2.32 of the GLib library.
[521]83
84%prep
85%setup -q -n glib-%{version}
[6078]86%patch0 -p1
[521]87
88%build
[6078]89%configure --disable-selinux --enable-static --enable-systemtap
[521]90make %{?_smp_mflags}
91
92%install
93rm -rf $RPM_BUILD_ROOT
94
95mkdir -p $RPM_BUILD_ROOT%{_bindir}
[6078]96make install DESTDIR=$RPM_BUILD_ROOT
[521]97
98## glib2.sh and glib2.csh
99./mkinstalldirs $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
100install -m 755 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
101install -m 755 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
102
[6011]103mkdir -p $RPM_BUILD_ROOT%{python_sitearch}
104ln -sf %{_libdir}/gdbus-2.0/codegen  $RPM_BUILD_ROOT%{python_sitearch}/codegen
105
[6078]106touch $RPM_BUILD_ROOT%{_libdir}/gio/modules/giomodule.cache
107
[521]108rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
109rm -f $RPM_BUILD_ROOT%{_libdir}/gio/modules/lib*.{a,la}
[2041]110rm -f $RPM_BUILD_ROOT%{_libdir}/gio/modules/*.cache
[521]111
112%find_lang glib20
113
114%clean
115rm -rf $RPM_BUILD_ROOT
116
[6078]117%post
118/sbin/ldconfig
119gio-querymodules %{_libdir}/gio/modules
[521]120
[6078]121%postun
122/sbin/ldconfig
123gio-querymodules %{_libdir}/gio/modules
[521]124
125%post -n compat32-%{name} -p /sbin/ldconfig
126
127%postun -n compat32-%{name} -p /sbin/ldconfig
128
129
130%files -f glib20.lang
131%defattr(-, root, root)
132%doc AUTHORS COPYING ChangeLog NEWS README
[2323]133%{_bindir}/gdbus
134%{_bindir}/gio-querymodules
135%{_bindir}/glib-compile-schemas
136%{_bindir}/gsettings
[521]137%{_libdir}/libglib-2.0.so.*
138%{_libdir}/libgthread-2.0.so.*
139%{_libdir}/libgmodule-2.0.so.*
140%{_libdir}/libgobject-2.0.so.*
141%{_libdir}/libgio-2.0.so.*
142%{_libdir}/gio/modules/lib*.so
143%{_sysconfdir}/profile.d/*
[6581]144%{_datadir}/bash-completion/completions/gdbus
145%{_datadir}/bash-completion/completions/gsettings
[521]146
147%files devel
148%defattr(-, root, root)
[4616]149%{_bindir}/gdbus-codegen
[6011]150%{_bindir}/glib-compile-resources
[2323]151%{_bindir}/glib-genmarshal
152%{_bindir}/glib-gettextize
153%{_bindir}/glib-mkenums
154%{_bindir}/gobject-query
[6011]155%{_bindir}/gresource
[2323]156%{_bindir}/gtester
157%{_bindir}/gtester-report
[521]158%{_libdir}/lib*.so
159%{_libdir}/lib*.a
[6011]160%{_libdir}/gdbus-2.0/codegen/*
[521]161%{_libdir}/glib-2.0
[6011]162%{_libdir}/pkgconfig/*
163%{python_sitearch}/codegen
[521]164%{_includedir}/*
165%{_datadir}/aclocal/*
166%{_datadir}/glib-2.0
167%doc %{_datadir}/gtk-doc/html/*
168%doc %{_mandir}/man1/*
169%{_datadir}/gdb/auto-load%{_libdir}/libglib-2.0.so.*-gdb.py*
170%{_datadir}/gdb/auto-load%{_libdir}/libgobject-2.0.so.*-gdb.py*
[6581]171%{_datadir}/bash-completion/completions/gresource
[521]172
173%if %{build_compat32}
174%files -n compat32-%{name}
175%defattr(-, root, root)
176%{_libdir}/libglib-2.0.so.*
177%{_libdir}/libgthread-2.0.so.*
178%{_libdir}/libgmodule-2.0.so.*
179%{_libdir}/libgobject-2.0.so.*
180%{_libdir}/libgio-2.0.so.*
181%{_libdir}/gio/modules/lib*.so
182
183%files -n compat32-%{name}-devel
184%defattr(-, root, root)
185%{_libdir}/lib*.so
186%{_libdir}/lib*.a
187%{_libdir}/glib-2.0
188%{_libdir}/pkgconfig/*
189%endif
190
191%changelog
[6581]192* Mon Jul 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.4-1
193- new upstream release
194
[6201]195* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.3-1
196- new upstream release
197
[6123]198* Wed May 02 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
199- new upstream release
200
[6011]201* Sat Apr 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
202- new upstream release
203- add BuildRequires: python-devel
[6078]204- add Patch0 (glib-2.32.1-dconf-path.patch)
[6011]205
[5168]206* Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
207- new upstream release
208
[5007]209* Sun Oct 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
210- new upstream release
211
[4850]212* Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
213- new upstream release
214- add Requires: libffi-devel, zlib-devel (-devel sub package)
215
[4812]216* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.92-1
217- new upstream release
218
[4704]219* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.18-1
220- new upstream release
221- remove Patch0,1
222
[4650]223* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.16-1
224- new upstream release
225- Patch0: glib-2.29.16-fixes-bug-656387.patch
226- Patch1: glib-2.29.16-fixes-bug-656675.patch
227
[4616]228* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.14-1
229- new upstream release
230- add BuildRequires: libffi-devel, dbus-devel
231
232* Sat Jun 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.8-1
233- new upstream release
234
[3685]235* Fri Apr 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.6-1
236- new upstream release
237
[3263]238* Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.5-1
239- new upstream release
240
[3079]241* Wed Mar 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.4-1
242- new upstream release
243
[3014]244* Sat Mar 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.3-1
245- new upstream release
246
[3003]247* Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
248- new upstream release
249
[2721]250* Sat Feb 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.1-1
251- new upstream release
252
[2678]253* Sat Feb 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
254- new upstream release
255
[2323]256* Fri Dec 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.1-2
257- move the following files from glib2-devel to glib2 package
258   (gdbus, gio-querymodules, glib-compile-schemas, gsettings)
259
[2219]260* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.1-1
261- new upstream release
262
[2041]263* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.0-1
264- new upstream release
265- fix Source (add URL)
266- fix %files to add /etc/bash_completion.d files
267
[1851]268* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.24.2-2
269- build with rpm-4.8.1-1 for pkg-config file
270
[1571]271* Sat Aug 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.2-1
272- new upstream release
273
[991]274* Tue May 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.1-1
275- new upstream release
276
[805]277* Sun Mar 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.0-1
278- new upstream release
279- add BuildRequires: zlib-devel
280
[697]281* Sun Mar 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.5-1
282- new upstream release
283
[521]284* Mon Jan 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.4-1
285- new upstream release
286
287* Thu Jan 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.3-1
288- new upstream release
289
290* Sun Oct 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
291- new upstream release
292
293* Thu Sep 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.0-1
294- new upstream release
295
296* Mon Jun 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.4-1
297- new upstream release
298
299* Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.3-1
300- new upstream release
301
302* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.2-1
303- new upstream release
304
305* Sat Apr 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-1
306- new upstream release
307
308* Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.0-1
309- new upstream release
310
311* Sun Jan 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.4-1
312- new upstream release
313
314* Tue Nov 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.3-1
315- new upstream release
316
317* Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.2-1
318- new upstream release
319
320* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-1
321- new upstream release
322
323* Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-1
324- new upstream release
325
326* Mon Jul  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.4-1
327- new upstream release
328
329* Sat May 10 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.16.3-2
330- updated %%if %%{build_compat32} case related statements
331
332* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.3-1vl5
333- new upstream release
334- removed lib*.la files from devel package
335
336* Sun Apr  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.2-1vl5
337- new upstream release
338
339* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.1-1vl5
340- added %%{?_dist_release}
341- BuildRequires: gamin-devel
342
343* Tue Mar 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.1-0vl1
344- new upstream release
345
346* Thu Feb  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.6-0vl1
347- new upstream release
348
349* Wed Jan  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.5-0vl1
350- new upstream release
351
352* Wed Nov 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
353- new upstream release
354
355* Thu Oct 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.2-0vl1
356- new upstream release
357- removed BuildRequires: automake17
358
359* Thu Sep 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.1-0vl1
360- new upstream release
361
362* Sun Aug 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.0-0vl1
363- new upstream release
364
365* Wed Jul 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.13-0vl1
366- new upstream release
367
368* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.12-0vl2
369- rebuild with new environment
370
371* Thu May 03 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.12-0vl1
372- new upstream release
373
374* Thu Mar 15 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.11-0vl1
375- new upstream release
376
377* Mon Jan 08 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.7-0vl1
378- new upstream release
379
380* Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.6-0vl1
381- new upstream release
382
383* Thu Aug 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.3-0vl1
384- new upstream release
385
386* Wed Aug 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
387- new upstream release
388
389* Sat Aug 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
390- new upstream release
391
392* Mon Jun 26 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.10.3-0vl3
393- rebuild
394
395* Sun Jun 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.3-0vl2
396- update glib2.{sh,csh}
397  - add EUC-JP,CP932,UTF-8 to G_FILENAME_ENCODING
398
399* Fri Jun 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.3-0vl1
400- new upstream release
401
402* Sat Apr 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.2-0vl1
403- new upstream release
404
405* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
406- new upstream release
407
408* Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
409- new upstream release
410
411* Mon Feb 27 2006 Shu KONNO <owa@bg.wakwak.com> 2.8.6-0vl2
412- added compat32-* packages for x86_64 architecture support
413- chaged G_ATOMIC_X86_64 to I486 in config.h before making compat32
414
415* Sun Jan 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.6-0vl1
416- new upstream release
417
418* Thu Jan 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.5-0vl1
419- new upstream release
420
421* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.4-0vl1
422- new upstream release
423
424* Tue Sep 27 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl1
425- new upstream release
426
427* Tue Sep 20 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl3
428- fixed typo in glib2.csh
429
430* Sun Sep 18 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl2
431- update glib2.{sh,csh} to use G_FILENAME_ENCODING instead of
432  G_BROKEN_FILENAMES.
433
434* Wed Aug 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
435- new upstream release
436
437* Sat Aug 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.0-0vl1
438- new upstream release
439
440* Sat Aug 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.7-0vl1
441- new upstream release
442
443* Fri Aug 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.6-0vl1
444- new upstream release
445
446* Tue Aug 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.4-0vl1
447- new upstream release
448
449* Sun Jul 03 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.5-0vl1
450- new upstream release
451- add *.la to build arts (should be fixed in arts?)
452
453* Sat Apr 09 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.4-0vl1
454- new upstream release
455
456* Fri Mar 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.3-0vl1
457- new upstream release
458
459* Sat Feb 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.2-0vl1
460- new upstream release
461
462* Mon Jan 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-0vl1
463- new upstream release
464
465* Sat Dec 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.8-0vl1
466- new upstream release
467
468* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.7-0vl2
469- rebuilt
470
471* Mon Oct 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.7-0vl1
472- new upstream release
473
474* Sat Aug 14 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.6-0vl1
475- new upstream release
476
477* Sun Aug 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.5-0vl1
478- new upstream release
479
480* Fri Jul 16 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.4-0vl1
481- new upstream release
482
483* Sat Jun  5 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
484- new upstream release
485
486* Sat May  1 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
487- new upstream release
488
489* Thu Mar 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
490- new upstream release
491
492* Wed Dec 24 2003 Tomoya TAKA <taka@vinelinux.org> 2.2.3-0vl2
493- rebuild with new toolchain
494
495* Sun Aug 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3-0vl1
496- new upstream release
497
498* Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
499- new upstream release
500
501* Mon Feb 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
502- new upstream release
503
504* Wed Dec 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
505- new upstream release
506
507* Fri Dec 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
508- new upstream release
509- build for Vine Linux
510
511* Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
512- install glib2.sh and glib2.csh to set G_BROKEN_FILENAMES
513- blow away unpackaged files in install
514
515* Thu Aug  8 2002 Owen Taylor <otaylor@redhat.com>
516- Version 2.0.6
517- Remove fixed-ltmain.sh; shouldn't be needed any more.
518
519* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
520- automated rebuild
521
522* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
523- 2.0.4
524
525* Thu May 23 2002 Tim Powers <timp@redhat.com>
526- automated rebuild
527
528* Wed Apr 24 2002 Havoc Pennington <hp@redhat.com>
529 - rebuild in different environment
530
531* Mon Apr 15 2002 Owen Taylor <otaylor@redhat.com>
532- Fix missing .po files (#63336)
533
534* Wed Apr  3 2002 Alex Larsson <alexl@redhat.com>
535- Update to version 2.0.1
536
537* Fri Mar  8 2002 Owen Taylor <otaylor@redhat.com>
538- Version 2.0.0
539
540* Mon Feb 25 2002 Alex Larsson <alexl@redhat.com>
541- Update to 1.3.15
542
543* Thu Feb 21 2002 Alex Larsson <alexl@redhat.com>
544- Bump for rebuild
545
546* Mon Feb 18 2002 Alex Larsson <alexl@redhat.com>
547- Update to 1.3.14
548
549* Fri Feb 15 2002 Havoc Pennington <hp@redhat.com>
550- add horrible buildrequires hack
551
552* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
553- 1.3.13.91 cvs snap
554
555* Mon Feb 11 2002 Matt Wilson <msw@redhat.com>
556- rebuild from CVS snapshot
557- use setup -q
558
559* Thu Jan 31 2002 Jeremy Katz <katzj@redhat.com>
560- rebuild
561
562* Tue Jan 29 2002 Owen Taylor <otaylor@redhat.com>
563- 1.3.13
564
565* Tue Jan 22 2002 Havoc Pennington <hp@redhat.com>
566- attempting rebuild in rawhide
567
568* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
569- remove 64-bit patch now upstream, 1.3.12.90
570
571* Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
572- add some missing files to file list, langify
573
574* Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
575- add temporary patch to fix GTypeFundamentals on 64-bit
576
577* Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
578- Version 1.3.11
579
580* Thu Oct 25 2001 Owen Taylor <otaylor@redhat.com>
581- Version 1.3.10
582
583* Tue Sep 25 2001 Owen Taylor <otaylor@redhat.com>
584- Version 1.3.9
585
586* Wed Sep 19 2001 Owen Taylor <otaylor@redhat.com>
587- Version 1.3.8
588
589* Fri Jul 20 2001 Owen Taylor <otaylor@redhat.com>
590- Make -devel package require main package (#45388)
591- Fix description and summary
592- Configure with --disable-gtk-doc
593
594* Wed Jun 20 2001 Florian La Roche <Florian.LaRoche@redhat.de>
595- add some portability fixes needed at least on s390
596- copy config.{guess,sub} instead of calling libtoolize
597
598* Wed Jun 13 2001 Havoc Pennington <hp@redhat.com>
599- try a new glib tarball with Makefile changes to work around
600  libtool linking to installed .la files
601- make -devel require pkgconfig
602
603* Tue Jun 12 2001 Havoc Pennington <hp@redhat.com>
604- either libtool or the bad libtool hacks caused link
605  against glib-gobject 1.3.2, rebuild
606
607* Tue Jun 12 2001 Havoc Pennington <hp@redhat.com>
608- 1.3.6
609- bad libtool workarounds
610
611* Fri May 04 2001 Owen Taylor <otaylor@redhat.com>
612- 1.3.5, rename to glib2
613
614* Fri Nov 17 2000 Owen Taylor <otaylor@redhat.com>
615- Final 1.3.2
616
617* Mon Nov 13 2000 Owen Taylor <otaylor@redhat.com>
618- Version 1.3.2pre1
619- Remove pkgconfig
620
621* Sun Aug 13 2000 Owen Taylor <otaylor@redhat.com>
622- Call 1.3.1b instead of snap... the snap* naming doesn't
623  order correctly.
624
625* Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
626- new snapshot with fixed .pc files
627
628* Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
629- include .pc files in file list
630
631* Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
632- Include pkg-config
633- Upgrade to a glib CVS snapshot
634
635* Wed Jul 19 2000 Jakub Jelinek <jakub@redhat.com>
636- rebuild to cope with glibc locale binary incompatibility
637
638* Fri Jul 14 2000 Owen Taylor <otaylor@redhat.com>
639- Remove glib-config.1 manpage from build since
640  it conflicts with glib-devel. When we go to
641  glib glib1.2 setup, we should add it back
642
643* Fri Jul 07 2000 Owen Taylor <otaylor@redhat.com>
644- Version 1.3.1
645- Move back to standard %{prefix}
646
647* Thu Jun 8 2000 Owen Taylor <otaylor@redhat.com>
648- Rebuild in /opt/gtk-beta
649
650* Tue May 30 2000 Owen Taylor <otaylor@redhat.com>
651- New version (adds gobject)
652
653* Wed Apr 25 2000 Owen Taylor <otaylor@redhat.com>
654- Don't blow away /etc/ld.so.conf (sorry!)
655
656* Tue Apr 24 2000 Owen Taylor <otaylor@redhat.com>
657- Snapshot RPM for Pango testing
658
659* Fri Feb 04 2000 Owen Taylor <otaylor@redhat.com>
660- Added fixes from stable branch of CVS
661
662* Thu Oct 7  1999 Owen Taylor <otaylor@redhat.com>
663- version 1.2.6
664
665* Fri Sep 24 1999 Owen Taylor <otaylor@redhat.com>
666- version 1.2.5
667
668* Fri Sep 17 1999 Owen Taylor <otaylor@redhat.com>
669- version 1.2.4
670
671* Mon Jun 7 1999 Owen Taylor <otaylor@redhat.com>
672- version 1.2.3
673
674* Thu Mar 25 1999 Michael Fulbright <drmike@redhat.com>
675- version 1.2.1
676
677* Fri Feb 26 1999 Michael Fulbright <drmike@redhat.com>
678- Version 1.2
679
680* Thu Feb 25 1999 Michael Fulbright <drmike@redhat.com>
681- version 1.2.0pre1
682
683* Tue Feb 23 1999 Cristian Gafton <gafton@redhat.com>
684- new description tags
685
686* Sun Feb 21 1999 Michael Fulbright <drmike@redhat.com>
687- removed libtoolize from %build
688
689* Thu Feb 11 1999 Michael Fulbright <drmike@redhat.com>
690- added libgthread to file list
691
692* Fri Feb 05 1999 Michael Fulbright <drmike@redhat.com>
693- version 1.1.15
694
695* Wed Feb 03 1999 Michael Fulbright <drmike@redhat.com>
696- version 1.1.14
697
698* Mon Jan 18 1999 Michael Fulbright <drmike@redhat.com>
699- version 1.1.13
700
701* Wed Jan 06 1999 Michael Fulbright <drmike@redhat.com>
702- version 1.1.12
703
704* Wed Dec 16 1998 Michael Fulbright <drmike@redhat.com>
705- updated in preparation for the GNOME freeze
706
707* Mon Apr 13 1998 Marc Ewing <marc@redhat.com>
708- Split out glib package
709
Note: See TracBrowser for help on using the repository browser.