source: projects/specs/trunk/g/glib2/glib2-vl.spec @ 3685

Revision 3685, 17.9 KB checked in by Takemikaduchi, 13 years ago (diff)

new upstream release

RevLine 
[521]1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2Summary: A library of handy utility functions.
3Name: glib2
[3685]4Version: 2.28.6
[2678]5Release: 1%{?_dist_release}
[521]6License: LGPLv2+
7Group: System Environment/Libraries
[2678]8Source: http://ftp.gnome.org/pub/GNOME/sources/glib/2.28/glib-%{version}.tar.bz2
[521]9Source2: glib2.sh
10Source3: glib2.csh
11BuildRoot: %{_tmppath}/glib-%{version}-root
12BuildRequires: pkgconfig >= 0.14
13BuildRequires: gamin-devel
14BuildRequires: gtk-doc
[805]15BuildRequires: zlib-devel
[521]16Obsoletes: glib-gtkbeta
17URL: http://www.gtk.org
18
19Vendor: Project Vine
20Distribution: Vine Linux
[2678]21Packager: Daisuke SUZUKI <daisuke@linux.or.jp>, Takemikaduchi
[521]22
23%description
24GLib is the low-level core library that forms the basis
25for projects such as GTK+ and GNOME. It provides data structure
26handling for C, portability wrappers, and interfaces for such runtime
27functionality as an event loop, threads, dynamic loading, and an
28object system.
29
[2678]30This package provides version 2.28 of GLib.
[521]31
32%package devel
33Summary: Development files for the GLib library
34Group: Development/Libraries
35Obsoletes: glib-gtkbeta-devel
36Requires: pkgconfig >= 0.14
37Requires: %{name} = %{version}
38Conflicts: glib-devel <= 1.2.8
39
40%description devel
41The glib-devel package includes the header files for
[2678]42version 2.28 of the GLib library.
[521]43
44
45## to build compat32 for x86_64 architecture support
46%package -n compat32-%{name}
47Summary: A library of handy utility functions.
48Group: System Environment/Libraries
49
50%description -n compat32-%{name}
51GLib is the low-level core library that forms the basis
52for projects such as GTK+ and GNOME. It provides data structure
53handling for C, portability wrappers, and interfaces for such runtime
54functionality as an event loop, threads, dynamic loading, and an
55object system.
56
[2678]57This package provides version 2.28 of GLib.
[521]58
59%package -n compat32-%{name}-devel
60Summary: Development files for the GLib library
61Group: Development/Libraries
62Requires: pkgconfig >= 0.14
63Requires: compat32-%{name} = %{version}
64Conflicts: glib-devel <= 1.2.8
65
66%description -n compat32-%{name}-devel
67The glib-devel package includes the header files for
[2678]68version 2.28 of the GLib library.
[521]69
70%prep
71%setup -q -n glib-%{version}
72
73%build
74%configure --disable-selinux --enable-static
75make %{?_smp_mflags}
76
77%install
78rm -rf $RPM_BUILD_ROOT
79
80mkdir -p $RPM_BUILD_ROOT%{_bindir}
81%makeinstall
82
83## glib2.sh and glib2.csh
84./mkinstalldirs $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
85install -m 755 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
86install -m 755 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
87
88rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
89rm -f $RPM_BUILD_ROOT%{_libdir}/gio/modules/lib*.{a,la}
[2041]90rm -f $RPM_BUILD_ROOT%{_libdir}/gio/modules/*.cache
[521]91
92%find_lang glib20
93
94%clean
95rm -rf $RPM_BUILD_ROOT
96
97%post -p /sbin/ldconfig
98
99%postun -p /sbin/ldconfig
100
101%post -n compat32-%{name} -p /sbin/ldconfig
102
103%postun -n compat32-%{name} -p /sbin/ldconfig
104
105
106%files -f glib20.lang
107%defattr(-, root, root)
108%doc AUTHORS COPYING ChangeLog NEWS README
[2323]109%{_bindir}/gdbus
110%{_bindir}/gio-querymodules
111%{_bindir}/glib-compile-schemas
112%{_bindir}/gsettings
[521]113%{_libdir}/libglib-2.0.so.*
114%{_libdir}/libgthread-2.0.so.*
115%{_libdir}/libgmodule-2.0.so.*
116%{_libdir}/libgobject-2.0.so.*
117%{_libdir}/libgio-2.0.so.*
118%{_libdir}/gio/modules/lib*.so
119%{_sysconfdir}/profile.d/*
[2041]120%{_sysconfdir}/bash_completion.d/*
[521]121
122%files devel
123%defattr(-, root, root)
[2323]124%{_bindir}/glib-genmarshal
125%{_bindir}/glib-gettextize
126%{_bindir}/glib-mkenums
127%{_bindir}/gobject-query
128%{_bindir}/gtester
129%{_bindir}/gtester-report
[521]130%{_libdir}/lib*.so
131%{_libdir}/lib*.a
132%{_libdir}/glib-2.0
133%{_includedir}/*
134%{_datadir}/aclocal/*
135%{_libdir}/pkgconfig/*
136%{_datadir}/glib-2.0
137%doc %{_datadir}/gtk-doc/html/*
138%doc %{_mandir}/man1/*
139%{_datadir}/gdb/auto-load%{_libdir}/libglib-2.0.so.*-gdb.py*
140%{_datadir}/gdb/auto-load%{_libdir}/libgobject-2.0.so.*-gdb.py*
141
142%if %{build_compat32}
143%files -n compat32-%{name}
144%defattr(-, root, root)
145%{_libdir}/libglib-2.0.so.*
146%{_libdir}/libgthread-2.0.so.*
147%{_libdir}/libgmodule-2.0.so.*
148%{_libdir}/libgobject-2.0.so.*
149%{_libdir}/libgio-2.0.so.*
150%{_libdir}/gio/modules/lib*.so
151
152%files -n compat32-%{name}-devel
153%defattr(-, root, root)
154%{_libdir}/lib*.so
155%{_libdir}/lib*.a
156%{_libdir}/glib-2.0
157%{_libdir}/pkgconfig/*
158%endif
159
160%changelog
[3685]161* Fri Apr 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.6-1
162- new upstream release
163
[3263]164* Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.5-1
165- new upstream release
166
[3079]167* Wed Mar 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.4-1
168- new upstream release
169
[3014]170* Sat Mar 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.3-1
171- new upstream release
172
[3003]173* Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
174- new upstream release
175
[2721]176* Sat Feb 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.1-1
177- new upstream release
178
[2678]179* Sat Feb 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
180- new upstream release
181
[2323]182* Fri Dec 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.1-2
183- move the following files from glib2-devel to glib2 package
184   (gdbus, gio-querymodules, glib-compile-schemas, gsettings)
185
[2219]186* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.1-1
187- new upstream release
188
[2041]189* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.0-1
190- new upstream release
191- fix Source (add URL)
192- fix %files to add /etc/bash_completion.d files
193
[1851]194* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.24.2-2
195- build with rpm-4.8.1-1 for pkg-config file
196
[1571]197* Sat Aug 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.2-1
198- new upstream release
199
[991]200* Tue May 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.1-1
201- new upstream release
202
[805]203* Sun Mar 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.0-1
204- new upstream release
205- add BuildRequires: zlib-devel
206
[697]207* Sun Mar 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.5-1
208- new upstream release
209
[521]210* Mon Jan 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.4-1
211- new upstream release
212
213* Thu Jan 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.3-1
214- new upstream release
215
216* Sun Oct 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
217- new upstream release
218
219* Thu Sep 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.0-1
220- new upstream release
221
222* Mon Jun 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.4-1
223- new upstream release
224
225* Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.3-1
226- new upstream release
227
228* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.2-1
229- new upstream release
230
231* Sat Apr 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-1
232- new upstream release
233
234* Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.0-1
235- new upstream release
236
237* Sun Jan 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.4-1
238- new upstream release
239
240* Tue Nov 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.3-1
241- new upstream release
242
243* Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.2-1
244- new upstream release
245
246* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-1
247- new upstream release
248
249* Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-1
250- new upstream release
251
252* Mon Jul  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.4-1
253- new upstream release
254
255* Sat May 10 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.16.3-2
256- updated %%if %%{build_compat32} case related statements
257
258* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.3-1vl5
259- new upstream release
260- removed lib*.la files from devel package
261
262* Sun Apr  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.2-1vl5
263- new upstream release
264
265* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.1-1vl5
266- added %%{?_dist_release}
267- BuildRequires: gamin-devel
268
269* Tue Mar 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.1-0vl1
270- new upstream release
271
272* Thu Feb  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.6-0vl1
273- new upstream release
274
275* Wed Jan  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.5-0vl1
276- new upstream release
277
278* Wed Nov 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
279- new upstream release
280
281* Thu Oct 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.2-0vl1
282- new upstream release
283- removed BuildRequires: automake17
284
285* Thu Sep 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.1-0vl1
286- new upstream release
287
288* Sun Aug 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.0-0vl1
289- new upstream release
290
291* Wed Jul 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.13-0vl1
292- new upstream release
293
294* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.12-0vl2
295- rebuild with new environment
296
297* Thu May 03 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.12-0vl1
298- new upstream release
299
300* Thu Mar 15 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.11-0vl1
301- new upstream release
302
303* Mon Jan 08 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.7-0vl1
304- new upstream release
305
306* Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.6-0vl1
307- new upstream release
308
309* Thu Aug 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.3-0vl1
310- new upstream release
311
312* Wed Aug 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
313- new upstream release
314
315* Sat Aug 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
316- new upstream release
317
318* Mon Jun 26 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.10.3-0vl3
319- rebuild
320
321* Sun Jun 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.3-0vl2
322- update glib2.{sh,csh}
323  - add EUC-JP,CP932,UTF-8 to G_FILENAME_ENCODING
324
325* Fri Jun 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.3-0vl1
326- new upstream release
327
328* Sat Apr 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.2-0vl1
329- new upstream release
330
331* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
332- new upstream release
333
334* Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
335- new upstream release
336
337* Mon Feb 27 2006 Shu KONNO <owa@bg.wakwak.com> 2.8.6-0vl2
338- added compat32-* packages for x86_64 architecture support
339- chaged G_ATOMIC_X86_64 to I486 in config.h before making compat32
340
341* Sun Jan 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.6-0vl1
342- new upstream release
343
344* Thu Jan 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.5-0vl1
345- new upstream release
346
347* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.4-0vl1
348- new upstream release
349
350* Tue Sep 27 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl1
351- new upstream release
352
353* Tue Sep 20 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl3
354- fixed typo in glib2.csh
355
356* Sun Sep 18 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl2
357- update glib2.{sh,csh} to use G_FILENAME_ENCODING instead of
358  G_BROKEN_FILENAMES.
359
360* Wed Aug 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
361- new upstream release
362
363* Sat Aug 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.0-0vl1
364- new upstream release
365
366* Sat Aug 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.7-0vl1
367- new upstream release
368
369* Fri Aug 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.6-0vl1
370- new upstream release
371
372* Tue Aug 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.4-0vl1
373- new upstream release
374
375* Sun Jul 03 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.5-0vl1
376- new upstream release
377- add *.la to build arts (should be fixed in arts?)
378
379* Sat Apr 09 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.4-0vl1
380- new upstream release
381
382* Fri Mar 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.3-0vl1
383- new upstream release
384
385* Sat Feb 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.2-0vl1
386- new upstream release
387
388* Mon Jan 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-0vl1
389- new upstream release
390
391* Sat Dec 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.8-0vl1
392- new upstream release
393
394* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.7-0vl2
395- rebuilt
396
397* Mon Oct 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.7-0vl1
398- new upstream release
399
400* Sat Aug 14 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.6-0vl1
401- new upstream release
402
403* Sun Aug 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.5-0vl1
404- new upstream release
405
406* Fri Jul 16 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.4-0vl1
407- new upstream release
408
409* Sat Jun  5 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
410- new upstream release
411
412* Sat May  1 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
413- new upstream release
414
415* Thu Mar 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
416- new upstream release
417
418* Wed Dec 24 2003 Tomoya TAKA <taka@vinelinux.org> 2.2.3-0vl2
419- rebuild with new toolchain
420
421* Sun Aug 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3-0vl1
422- new upstream release
423
424* Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
425- new upstream release
426
427* Mon Feb 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
428- new upstream release
429
430* Wed Dec 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
431- new upstream release
432
433* Fri Dec 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
434- new upstream release
435- build for Vine Linux
436
437* Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
438- install glib2.sh and glib2.csh to set G_BROKEN_FILENAMES
439- blow away unpackaged files in install
440
441* Thu Aug  8 2002 Owen Taylor <otaylor@redhat.com>
442- Version 2.0.6
443- Remove fixed-ltmain.sh; shouldn't be needed any more.
444
445* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
446- automated rebuild
447
448* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
449- 2.0.4
450
451* Thu May 23 2002 Tim Powers <timp@redhat.com>
452- automated rebuild
453
454* Wed Apr 24 2002 Havoc Pennington <hp@redhat.com>
455 - rebuild in different environment
456
457* Mon Apr 15 2002 Owen Taylor <otaylor@redhat.com>
458- Fix missing .po files (#63336)
459
460* Wed Apr  3 2002 Alex Larsson <alexl@redhat.com>
461- Update to version 2.0.1
462
463* Fri Mar  8 2002 Owen Taylor <otaylor@redhat.com>
464- Version 2.0.0
465
466* Mon Feb 25 2002 Alex Larsson <alexl@redhat.com>
467- Update to 1.3.15
468
469* Thu Feb 21 2002 Alex Larsson <alexl@redhat.com>
470- Bump for rebuild
471
472* Mon Feb 18 2002 Alex Larsson <alexl@redhat.com>
473- Update to 1.3.14
474
475* Fri Feb 15 2002 Havoc Pennington <hp@redhat.com>
476- add horrible buildrequires hack
477
478* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
479- 1.3.13.91 cvs snap
480
481* Mon Feb 11 2002 Matt Wilson <msw@redhat.com>
482- rebuild from CVS snapshot
483- use setup -q
484
485* Thu Jan 31 2002 Jeremy Katz <katzj@redhat.com>
486- rebuild
487
488* Tue Jan 29 2002 Owen Taylor <otaylor@redhat.com>
489- 1.3.13
490
491* Tue Jan 22 2002 Havoc Pennington <hp@redhat.com>
492- attempting rebuild in rawhide
493
494* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
495- remove 64-bit patch now upstream, 1.3.12.90
496
497* Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
498- add some missing files to file list, langify
499
500* Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
501- add temporary patch to fix GTypeFundamentals on 64-bit
502
503* Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
504- Version 1.3.11
505
506* Thu Oct 25 2001 Owen Taylor <otaylor@redhat.com>
507- Version 1.3.10
508
509* Tue Sep 25 2001 Owen Taylor <otaylor@redhat.com>
510- Version 1.3.9
511
512* Wed Sep 19 2001 Owen Taylor <otaylor@redhat.com>
513- Version 1.3.8
514
515* Fri Jul 20 2001 Owen Taylor <otaylor@redhat.com>
516- Make -devel package require main package (#45388)
517- Fix description and summary
518- Configure with --disable-gtk-doc
519
520* Wed Jun 20 2001 Florian La Roche <Florian.LaRoche@redhat.de>
521- add some portability fixes needed at least on s390
522- copy config.{guess,sub} instead of calling libtoolize
523
524* Wed Jun 13 2001 Havoc Pennington <hp@redhat.com>
525- try a new glib tarball with Makefile changes to work around
526  libtool linking to installed .la files
527- make -devel require pkgconfig
528
529* Tue Jun 12 2001 Havoc Pennington <hp@redhat.com>
530- either libtool or the bad libtool hacks caused link
531  against glib-gobject 1.3.2, rebuild
532
533* Tue Jun 12 2001 Havoc Pennington <hp@redhat.com>
534- 1.3.6
535- bad libtool workarounds
536
537* Fri May 04 2001 Owen Taylor <otaylor@redhat.com>
538- 1.3.5, rename to glib2
539
540* Fri Nov 17 2000 Owen Taylor <otaylor@redhat.com>
541- Final 1.3.2
542
543* Mon Nov 13 2000 Owen Taylor <otaylor@redhat.com>
544- Version 1.3.2pre1
545- Remove pkgconfig
546
547* Sun Aug 13 2000 Owen Taylor <otaylor@redhat.com>
548- Call 1.3.1b instead of snap... the snap* naming doesn't
549  order correctly.
550
551* Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
552- new snapshot with fixed .pc files
553
554* Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
555- include .pc files in file list
556
557* Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
558- Include pkg-config
559- Upgrade to a glib CVS snapshot
560
561* Wed Jul 19 2000 Jakub Jelinek <jakub@redhat.com>
562- rebuild to cope with glibc locale binary incompatibility
563
564* Fri Jul 14 2000 Owen Taylor <otaylor@redhat.com>
565- Remove glib-config.1 manpage from build since
566  it conflicts with glib-devel. When we go to
567  glib glib1.2 setup, we should add it back
568
569* Fri Jul 07 2000 Owen Taylor <otaylor@redhat.com>
570- Version 1.3.1
571- Move back to standard %{prefix}
572
573* Thu Jun 8 2000 Owen Taylor <otaylor@redhat.com>
574- Rebuild in /opt/gtk-beta
575
576* Tue May 30 2000 Owen Taylor <otaylor@redhat.com>
577- New version (adds gobject)
578
579* Wed Apr 25 2000 Owen Taylor <otaylor@redhat.com>
580- Don't blow away /etc/ld.so.conf (sorry!)
581
582* Tue Apr 24 2000 Owen Taylor <otaylor@redhat.com>
583- Snapshot RPM for Pango testing
584
585* Fri Feb 04 2000 Owen Taylor <otaylor@redhat.com>
586- Added fixes from stable branch of CVS
587
588* Thu Oct 7  1999 Owen Taylor <otaylor@redhat.com>
589- version 1.2.6
590
591* Fri Sep 24 1999 Owen Taylor <otaylor@redhat.com>
592- version 1.2.5
593
594* Fri Sep 17 1999 Owen Taylor <otaylor@redhat.com>
595- version 1.2.4
596
597* Mon Jun 7 1999 Owen Taylor <otaylor@redhat.com>
598- version 1.2.3
599
600* Thu Mar 25 1999 Michael Fulbright <drmike@redhat.com>
601- version 1.2.1
602
603* Fri Feb 26 1999 Michael Fulbright <drmike@redhat.com>
604- Version 1.2
605
606* Thu Feb 25 1999 Michael Fulbright <drmike@redhat.com>
607- version 1.2.0pre1
608
609* Tue Feb 23 1999 Cristian Gafton <gafton@redhat.com>
610- new description tags
611
612* Sun Feb 21 1999 Michael Fulbright <drmike@redhat.com>
613- removed libtoolize from %build
614
615* Thu Feb 11 1999 Michael Fulbright <drmike@redhat.com>
616- added libgthread to file list
617
618* Fri Feb 05 1999 Michael Fulbright <drmike@redhat.com>
619- version 1.1.15
620
621* Wed Feb 03 1999 Michael Fulbright <drmike@redhat.com>
622- version 1.1.14
623
624* Mon Jan 18 1999 Michael Fulbright <drmike@redhat.com>
625- version 1.1.13
626
627* Wed Jan 06 1999 Michael Fulbright <drmike@redhat.com>
628- version 1.1.12
629
630* Wed Dec 16 1998 Michael Fulbright <drmike@redhat.com>
631- updated in preparation for the GNOME freeze
632
633* Mon Apr 13 1998 Marc Ewing <marc@redhat.com>
634- Split out glib package
635
Note: See TracBrowser for help on using the repository browser.