source: projects/specs/trunk/g/glib/glib-vl.spec @ 9256

Revision 9256, 8.4 KB checked in by Takemikaduchi, 9 years ago (diff)

cpufrequtils,dev86,hdf5,irqbalance,openslp,pcmciautils: new upstream release
others: rebuild

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2# overwrite configure macro (remove --target option)
3%define configure CFLAGS="${CFLAGS:-%optflags}" ; export CFLAGS ; CXXFLAGS="${CXXFLAGS:-%optflags}" ; export CXXFLAGS ; FFLAGS="${FFLAGS:-%optflags}" ; export FFLAGS ; ./configure --host=%{_host} --build=%{_build} --program-prefix=%{?_program_prefix} --prefix=%{_prefix} --exec-prefix=%{_exec_prefix} --bindir=%{_bindir} --sbindir=%{_sbindir} --sysconfdir=%{_sysconfdir} --datadir=%{_datadir} --includedir=%{_includedir} --libdir=%{_libdir} --libexecdir=%{_libexecdir} --localstatedir=%{_localstatedir} --sharedstatedir=%{_sharedstatedir} --mandir=%{_mandir} --infodir=%{_infodir}
4
5Summary:        A library of handy utility functions.
6Summary(ja):    便利なユーティリティ関数ライブラリ
7Name:           glib
8Version:        1.2.10
9Release:        5%{?_dist_release}
10License:        LGPL
11Group:          System Environment/Libraries
12URL:            http://www.gtk.org
13Source:         ftp://ftp.gimp.org/pub/gtk/v1.2/%{name}-%{version}.tar.gz
14Patch1:         glib-1.2.10-isowarning.patch
15Patch2:         glib-1.2.10-gcc34.patch
16Patch3:         glib-1.2.10-config.sub-x86_64.patch
17BuildRoot:      %{_tmppath}/%{name}-%{version}-root
18
19%description
20Glib is a handy library of utility functions. This C
21library is designed to solve some portability problems
22and provide other useful functionality which most
23programs require.
24
25Glib is used by GDK, GTK+ and many applications.
26You should install Glib because many of your applications
27will depend on this library.
28
29This package rebuilds binaries with debug option.
30
31%description -l ja
32Glib は便利なユーティリティ関数ライブラリです。この C
33ライブラリはいくつかのよく遭遇する問題を解決し、多くの
34プログラムで必要な有用な機能を提供するために作られました。
35
36このパッケージでは debug option 付きで binary を 作成します。
37
38
39%package devel
40Summary: Libraries and header files for glib development
41Group: Development/Libraries
42Requires(post,preun): /sbin/install-info
43Requires:       %{name} = %{version}-%{release}
44
45%description devel
46Static libraries and header files for the support library for the GIMP's X
47libraries, which are available as public libraries.  GLIB includes generally
48useful data structures.
49
50%description devel -l ja
51GIMP の X ライブラリをサポートする静的関数およびヘッダファイルです。
52GLIB には使いやすいデータストラクチャーも含まれています。
53
54## to build compat32 for x86_64 architecture support
55%package -n compat32-%{name}
56Summary:        A library of handy utility functions.
57Group:          System Environment/Libraries
58Requires:       %{name} = %{version}-%{release}
59
60%description -n compat32-%{name}
61Glib is a handy library of utility functions. This C
62library is designed to solve some portability problems
63and provide other useful functionality which most
64programs require.
65
66%package -n compat32-%{name}-devel
67Summary: Libraries and header files for glib development
68Group: Development/Libraries
69Requires:       compat32-%{name} = %{version}-%{release}
70
71%description -n compat32-%{name}-devel
72Static libraries and header files for the support library for the GIMP's X
73libraries, which are available as public libraries.  GLIB includes generally
74useful data structures.
75
76
77%prep
78%setup -q
79%patch1 -p1 -b .isowarning
80%patch2 -p1 -b .gcc34
81%patch3 -p1 -b .config.sub
82
83
84%build
85%configure
86make %{?_smp_mflags}
87
88
89%install
90rm -rf ${RPM_BUILD_ROOT}
91make install DESTDIR=${RPM_BUILD_ROOT}
92
93rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
94rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.a
95rm -f $RPM_BUILD_ROOT%{_infodir}/dir
96
97# libgmodule-1.2.so.0* missing eXecute bit
98chmod -c a+x %{buildroot}%{_libdir}/lib*.so*
99
100#%find_lang %{name}
101
102%clean
103[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
104
105
106%post -p /sbin/ldconfig
107
108%postun -p /sbin/ldconfig
109
110
111%post devel
112/sbin/install-info %{_infodir}/glib.info* %{_infodir}/dir
113
114%preun devel
115if [ "$1" = 0 ]; then
116  /sbin/install-info --delete %{_infodir}/glib.info* %{_infodir}/dir
117fi
118
119%post -n compat32-%{name} -p /sbin/ldconfig
120
121%postun -n compat32-%{name} -p /sbin/ldconfig
122
123
124%files
125%defattr(-, root, root)
126%doc AUTHORS COPYING ChangeLog NEWS README
127%{_libdir}/libglib-1.2.so.*
128%{_libdir}/libgthread-1.2.so.*
129%{_libdir}/libgmodule-1.2.so.*
130
131%files devel
132%defattr(-, root, root)
133%{_bindir}/*
134%{_libdir}/lib*.so
135%{_libdir}/glib
136%{_libdir}/pkgconfig/*
137%{_includedir}/*
138%{_datadir}/aclocal/*
139%{_infodir}/*
140%{_mandir}/man1/*
141
142## to build compat32 for x86_64 architecture support
143%if %{build_compat32}
144%files -n compat32-%{name}
145%defattr(-, root, root)
146%{_libdir}/libglib-1.2.so.*
147%{_libdir}/libgthread-1.2.so.*
148%{_libdir}/libgmodule-1.2.so.*
149
150%files -n compat32-%{name}-devel
151%defattr(-, root, root)
152%{_libdir}/lib*.so
153%{_libdir}/glib
154%endif
155
156%changelog
157* Mon Jan 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.10-5
158- rebuild with VineSeed environment
159
160* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.10-4
161- rebuild with rpm-4.8.1 for pkg-config file
162
163* Mon May 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.10-3
164- spec in UTF-8
165
166* Sat May 10 2008 NAKAMURA Kenta <kenta@vinelinux.org> 1.2.10-2
167- updated %%if %%{build_compat32} case related statements
168
169* Tue May  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.10-1
170- applied new versioning policy
171- moved Requires(post,preun): /sbin/install-info to devel package
172
173* Fri Feb 10 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.10-0vl7
174- added compat32-* packages for x86_64 architecture support
175- added glib-1.2.10-config.sub-x86_64.patch
176
177* Tue Feb 07 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.10-0vl6
178- rebuild
179- disable %%find_lang macro
180- refine %%configure macro
181- add PreReq: ldconfig, install-info instead of /sbin/install-info
182
183* Wed Jul 07 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.10-0vl5
184- rebuilt
185- change from Copyright to License
186- add patch2
187- remove info/dir
188
189* Wed Dec 25 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.10-0vl4
190- rebuilt with new toolchain
191- TODO: we better remove info files when glib2 be ready to ship...
192
193* Thu Oct 11 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.2.10-0vl3
194- Applied RH patch (glib-1.2.10-isowarning.patch)
195  * Sat Jul 21 2001 Owen Taylor <otaylor@redhat.com>
196  - Add #pragma GCC system_header to supress warnings when in -pedantic
197    mode. (41271)
198- Added %%{_libdir}/pkgconfig to devel file list.
199
200* Sat Jul 14 2001 <sagami@vinelinux.org>
201- 1.2.10-0vl2: put %%patch0 at %%setup, not %%build. But already applied:-)
202
203* Tue Apr  3 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.2.10-0vl1
204- New upstream release.
205
206* Wed Mar  7 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.2.9-0vl1
207- New upstream release.
208
209* Mon Feb 05 2001 Lisa Sagami <czs14350@mb.infoweb.ne.jp>
210- 1.2.8-0vl2
211- fixed files section so as not to own mandir itself
212- use better macros
213
214* Mon May 29 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
215- updated to 1.2.8
216
217* Thu Feb 17 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
218- [glib-1.2.7-0vl1]
219
220* Mon Sep 27 1999 Jun Nishii <jun@flatout.org>
221- [glib-1.2.6-1]
222
223* Mon Sep 27 1999 Jun Nishii <jun@flatout.org>
224- [glib-1.2.5-1]
225
226* Tue Sep 7 1999 Yasuhide OOMORI <dasen@typhoon.co.jp>
227  [glib-1.2.4-2.1]
228- added debug option to CFLAG.
229
230* Mon Sep 6 1999 Yasuhide OOMORI <dasen@typhoon.co.jp>
231  [glib-1.2.4-2]
232- gzip info.
233
234* Fri Sep 3 1999 Yasuhide OOMORI <dasen@typhoon.co.jp>
235  [glib-1.2.4-1]
236- version 1.2.4.
237- bzip2 source.
238- info is installed in glib-devel.
239
240* Sat Aug 21 1999 Jun Nishii <jun@flatout.org>
241- added Japanese summary and description
242- build for Vine-1.9
243
244* Mon Jun 7 1999 Owen Taylor <otaylor@redhat.com>
245- version 1.2.3
246
247* Thu Mar 25 1999 Michael Fulbright <drmike@redhat.com>
248- version 1.2.1
249
250* Fri Feb 26 1999 Michael Fulbright <drmike@redhat.com>
251- Version 1.2
252
253* Thu Feb 25 1999 Michael Fulbright <drmike@redhat.com>
254- version 1.2.0pre1
255
256* Tue Feb 23 1999 Cristian Gafton <gafton@redhat.com>
257- new description tags
258
259* Sun Feb 21 1999 Michael Fulbright <drmike@redhat.com>
260- removed libtoolize from %build
261
262* Thu Feb 11 1999 Michael Fulbright <drmike@redhat.com>
263- added libgthread to file list
264
265* Fri Feb 05 1999 Michael Fulbright <drmike@redhat.com>
266- version 1.1.15
267
268* Wed Feb 03 1999 Michael Fulbright <drmike@redhat.com>
269- version 1.1.14
270
271* Mon Jan 18 1999 Michael Fulbright <drmike@redhat.com>
272- version 1.1.13
273
274* Wed Jan 06 1999 Michael Fulbright <drmike@redhat.com>
275- version 1.1.12
276
277* Wed Dec 16 1998 Michael Fulbright <drmike@redhat.com>
278- updated in preparation for the GNOME freeze
279
280* Mon Apr 13 1998 Marc Ewing <marc@redhat.com>
281- Split out glib package
282
Note: See TracBrowser for help on using the repository browser.