source: projects/specs/trunk/g/glib/glib-vl.spec @ 10524

Revision 10524, 8.5 KB checked in by Takemikaduchi, 8 years ago (diff)

glib: add patch
others: rebuild

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2# overwrite configure macro (remove --target option)
3%define configure CFLAGS="${CFLAGS:-%optflags}" ; export CFLAGS ; CXXFLAGS="${CXXFLAGS:-%optflags}" ; export CXXFLAGS ; FFLAGS="${FFLAGS:-%optflags}" ; export FFLAGS ; ./configure --host=%{_host} --build=%{_build} --program-prefix=%{?_program_prefix} --prefix=%{_prefix} --exec-prefix=%{_exec_prefix} --bindir=%{_bindir} --sbindir=%{_sbindir} --sysconfdir=%{_sysconfdir} --datadir=%{_datadir} --includedir=%{_includedir} --libdir=%{_libdir} --libexecdir=%{_libexecdir} --localstatedir=%{_localstatedir} --sharedstatedir=%{_sharedstatedir} --mandir=%{_mandir} --infodir=%{_infodir}
4
5Summary:        A library of handy utility functions.
6Summary(ja):    便利なユーティリティ関数ライブラリ
7Name:           glib
8Version:        1.2.10
9Release:        6%{?_dist_release}
10License:        LGPL
11Group:          System Environment/Libraries
12URL:            http://www.gtk.org
13Source:         ftp://ftp.gimp.org/pub/gtk/v1.2/%{name}-%{version}.tar.gz
14Patch1:         glib-1.2.10-isowarning.patch
15Patch2:         glib-1.2.10-gcc34.patch
16Patch3:         glib-1.2.10-config.sub-x86_64.patch
17Patch4:         glib-1.2.10-gcc5.patch
18BuildRoot:      %{_tmppath}/%{name}-%{version}-root
19
20%description
21Glib is a handy library of utility functions. This C
22library is designed to solve some portability problems
23and provide other useful functionality which most
24programs require.
25
26Glib is used by GDK, GTK+ and many applications.
27You should install Glib because many of your applications
28will depend on this library.
29
30This package rebuilds binaries with debug option.
31
32%description -l ja
33Glib は便利なユーティリティ関数ライブラリです。この C
34ライブラリはいくつかのよく遭遇する問題を解決し、多くの
35プログラムで必要な有用な機能を提供するために作られました。
36
37このパッケージでは debug option 付きで binary を 作成します。
38
39
40%package devel
41Summary: Libraries and header files for glib development
42Group: Development/Libraries
43Requires(post,preun): /sbin/install-info
44Requires:       %{name} = %{version}-%{release}
45
46%description devel
47Static libraries and header files for the support library for the GIMP's X
48libraries, which are available as public libraries.  GLIB includes generally
49useful data structures.
50
51%description devel -l ja
52GIMP の X ライブラリをサポートする静的関数およびヘッダファイルです。
53GLIB には使いやすいデータストラクチャーも含まれています。
54
55## to build compat32 for x86_64 architecture support
56%package -n compat32-%{name}
57Summary:        A library of handy utility functions.
58Group:          System Environment/Libraries
59Requires:       %{name} = %{version}-%{release}
60
61%description -n compat32-%{name}
62Glib is a handy library of utility functions. This C
63library is designed to solve some portability problems
64and provide other useful functionality which most
65programs require.
66
67%package -n compat32-%{name}-devel
68Summary: Libraries and header files for glib development
69Group: Development/Libraries
70Requires:       compat32-%{name} = %{version}-%{release}
71
72%description -n compat32-%{name}-devel
73Static libraries and header files for the support library for the GIMP's X
74libraries, which are available as public libraries.  GLIB includes generally
75useful data structures.
76
77
78%prep
79%setup -q
80%patch1 -p1 -b .isowarning
81%patch2 -p1 -b .gcc34
82%patch3 -p1 -b .config.sub
83%patch4 -p0 -b .gcc5
84
85
86%build
87%configure
88make %{?_smp_mflags}
89
90
91%install
92rm -rf ${RPM_BUILD_ROOT}
93make install DESTDIR=${RPM_BUILD_ROOT}
94
95rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
96rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.a
97rm -f $RPM_BUILD_ROOT%{_infodir}/dir
98
99# libgmodule-1.2.so.0* missing eXecute bit
100chmod -c a+x %{buildroot}%{_libdir}/lib*.so*
101
102#%find_lang %{name}
103
104%clean
105[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
106
107
108%post -p /sbin/ldconfig
109
110%postun -p /sbin/ldconfig
111
112
113%post devel
114/sbin/install-info %{_infodir}/glib.info* %{_infodir}/dir
115
116%preun devel
117if [ "$1" = 0 ]; then
118  /sbin/install-info --delete %{_infodir}/glib.info* %{_infodir}/dir
119fi
120
121%post -n compat32-%{name} -p /sbin/ldconfig
122
123%postun -n compat32-%{name} -p /sbin/ldconfig
124
125
126%files
127%defattr(-, root, root)
128%doc AUTHORS COPYING ChangeLog NEWS README
129%{_libdir}/libglib-1.2.so.*
130%{_libdir}/libgthread-1.2.so.*
131%{_libdir}/libgmodule-1.2.so.*
132
133%files devel
134%defattr(-, root, root)
135%{_bindir}/*
136%{_libdir}/lib*.so
137%{_libdir}/glib
138%{_libdir}/pkgconfig/*
139%{_includedir}/*
140%{_datadir}/aclocal/*
141%{_infodir}/*
142%{_mandir}/man1/*
143
144## to build compat32 for x86_64 architecture support
145%if %{build_compat32}
146%files -n compat32-%{name}
147%defattr(-, root, root)
148%{_libdir}/libglib-1.2.so.*
149%{_libdir}/libgthread-1.2.so.*
150%{_libdir}/libgmodule-1.2.so.*
151
152%files -n compat32-%{name}-devel
153%defattr(-, root, root)
154%{_libdir}/lib*.so
155%{_libdir}/glib
156%endif
157
158%changelog
159* Sun Jul 03 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.10-6
160- add Patch4 (glib-1.2.10-gcc5.patch) from fc
161
162* Mon Jan 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.10-5
163- rebuild with VineSeed environment
164
165* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.10-4
166- rebuild with rpm-4.8.1 for pkg-config file
167
168* Mon May 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.10-3
169- spec in UTF-8
170
171* Sat May 10 2008 NAKAMURA Kenta <kenta@vinelinux.org> 1.2.10-2
172- updated %%if %%{build_compat32} case related statements
173
174* Tue May  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.10-1
175- applied new versioning policy
176- moved Requires(post,preun): /sbin/install-info to devel package
177
178* Fri Feb 10 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.10-0vl7
179- added compat32-* packages for x86_64 architecture support
180- added glib-1.2.10-config.sub-x86_64.patch
181
182* Tue Feb 07 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.10-0vl6
183- rebuild
184- disable %%find_lang macro
185- refine %%configure macro
186- add PreReq: ldconfig, install-info instead of /sbin/install-info
187
188* Wed Jul 07 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.10-0vl5
189- rebuilt
190- change from Copyright to License
191- add patch2
192- remove info/dir
193
194* Wed Dec 25 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.10-0vl4
195- rebuilt with new toolchain
196- TODO: we better remove info files when glib2 be ready to ship...
197
198* Thu Oct 11 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.2.10-0vl3
199- Applied RH patch (glib-1.2.10-isowarning.patch)
200  * Sat Jul 21 2001 Owen Taylor <otaylor@redhat.com>
201  - Add #pragma GCC system_header to supress warnings when in -pedantic
202    mode. (41271)
203- Added %%{_libdir}/pkgconfig to devel file list.
204
205* Sat Jul 14 2001 <sagami@vinelinux.org>
206- 1.2.10-0vl2: put %%patch0 at %%setup, not %%build. But already applied:-)
207
208* Tue Apr  3 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.2.10-0vl1
209- New upstream release.
210
211* Wed Mar  7 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.2.9-0vl1
212- New upstream release.
213
214* Mon Feb 05 2001 Lisa Sagami <czs14350@mb.infoweb.ne.jp>
215- 1.2.8-0vl2
216- fixed files section so as not to own mandir itself
217- use better macros
218
219* Mon May 29 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
220- updated to 1.2.8
221
222* Thu Feb 17 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
223- [glib-1.2.7-0vl1]
224
225* Mon Sep 27 1999 Jun Nishii <jun@flatout.org>
226- [glib-1.2.6-1]
227
228* Mon Sep 27 1999 Jun Nishii <jun@flatout.org>
229- [glib-1.2.5-1]
230
231* Tue Sep 7 1999 Yasuhide OOMORI <dasen@typhoon.co.jp>
232  [glib-1.2.4-2.1]
233- added debug option to CFLAG.
234
235* Mon Sep 6 1999 Yasuhide OOMORI <dasen@typhoon.co.jp>
236  [glib-1.2.4-2]
237- gzip info.
238
239* Fri Sep 3 1999 Yasuhide OOMORI <dasen@typhoon.co.jp>
240  [glib-1.2.4-1]
241- version 1.2.4.
242- bzip2 source.
243- info is installed in glib-devel.
244
245* Sat Aug 21 1999 Jun Nishii <jun@flatout.org>
246- added Japanese summary and description
247- build for Vine-1.9
248
249* Mon Jun 7 1999 Owen Taylor <otaylor@redhat.com>
250- version 1.2.3
251
252* Thu Mar 25 1999 Michael Fulbright <drmike@redhat.com>
253- version 1.2.1
254
255* Fri Feb 26 1999 Michael Fulbright <drmike@redhat.com>
256- Version 1.2
257
258* Thu Feb 25 1999 Michael Fulbright <drmike@redhat.com>
259- version 1.2.0pre1
260
261* Tue Feb 23 1999 Cristian Gafton <gafton@redhat.com>
262- new description tags
263
264* Sun Feb 21 1999 Michael Fulbright <drmike@redhat.com>
265- removed libtoolize from %build
266
267* Thu Feb 11 1999 Michael Fulbright <drmike@redhat.com>
268- added libgthread to file list
269
270* Fri Feb 05 1999 Michael Fulbright <drmike@redhat.com>
271- version 1.1.15
272
273* Wed Feb 03 1999 Michael Fulbright <drmike@redhat.com>
274- version 1.1.14
275
276* Mon Jan 18 1999 Michael Fulbright <drmike@redhat.com>
277- version 1.1.13
278
279* Wed Jan 06 1999 Michael Fulbright <drmike@redhat.com>
280- version 1.1.12
281
282* Wed Dec 16 1998 Michael Fulbright <drmike@redhat.com>
283- updated in preparation for the GNOME freeze
284
285* Mon Apr 13 1998 Marc Ewing <marc@redhat.com>
286- Split out glib package
287
Note: See TracBrowser for help on using the repository browser.